Ubuntu

smarty should put files in /usr/share/php/smarty and not in smarty/libs

Reported by alexlehm on 2007-06-05
12
Affects Status Importance Assigned to Milestone
smarty (Debian)
Fix Released
Unknown
smarty (Ubuntu)
Low
Emmet Hikory

Bug Description

Binary package hint: smarty

when installing smarty on Ubunto 7.04, the library files are put into /usr/share/php/smarty/libs, consequently the script will have to use (if the include path is /usr/share/php)

require("smarty/libs/Smarty.class.php");

this is inconsistent with the install guide on smarty.php.net which suggests to put the files in (include_path)/Smarty without "libs".
I'm not sure about smarty/Smarty capitalization, but the libs dir should be definitely left out.

Related branches

Nathan Handler (nhandler) wrote :

For some reason, I'm having a difficult time building this package. Here is a patch that I think should get the lib files in the right folder. If someone could verify that it works, that would be great.

Emmet Hikory (persia) on 2007-06-09
Changed in smarty:
assignee: nobody → persia
importance: Undecided → Low
status: Unconfirmed → In Progress
Emmet Hikory (persia) wrote :

Thanks for your work on this bug. The debdiff is massive, and I don't understand the specific change from that patch. The version in the repositories built cleanly for me, but I didn't try applying the patch. Feel free to ask me via email, IRC, or jabber if you need specific help in getting a clean debdiff. I've unsubscribed ubuntu-universe-sponsors until a small, known working, debdiff can be prepared.

Changed in smarty:
assignee: persia → mrcheatr
status: In Progress → Needs Info
alexlehm (lehmann-arcor-so) wrote :

There is no actual diff at all, only since all files are moved from one directory from another, the diff includes all file contents

Emmet Hikory (persia) wrote :

OK. I understand. Thanks for the explanations. I'd like to request a smaller solution. Perhaps you could remove the "/libs/" from the install commands in debian/Makefile. This should accomplish the goal, with a significantly smaller (and easier to understand and maintain) debdiff.

t think we could modify the actual source of the program. I'll try that.
But I'm having a horrible time getting all the dependencies (and the
dependencies of the dependencies) to install. This means I can't
actually build the .deb file to test it.

Emmet Hikory wrote:
> OK. I understand. Thanks for the explanations. I'd like to request a
> smaller solution. Perhaps you could remove the "/libs/" from the
> install commands in debian/Makefile. This should accomplish the goal,
> with a significantly smaller (and easier to understand and maintain)
> debdiff.
>

Nathan Handler (nhandler) wrote :

This patch modifies the Makefile to get the lib files installed to the proper directory.

Changed in smarty:
assignee: mrcheatr → nobody
status: Needs Info → Confirmed
Emmet Hikory (persia) on 2007-06-09
Changed in smarty:
assignee: nobody → persia
status: Confirmed → In Progress
Emmet Hikory (persia) on 2007-06-09
Changed in smarty:
status: In Progress → Fix Committed
Nathan Handler (nhandler) wrote :

smarty (2.6.18-1ubuntu1) gutsy; urgency=low

  * Set Maintainer to Ubuntu MOTU Developers <email address hidden>
  * Modified Makefile so libs will be installed to correct directory (LP: #118793)

 -- Nathan Handler <email address hidden> Sat, 09 Jun 2007 08:20:06 -0500

Changed in smarty:
status: Fix Committed → Fix Released
alexlehm (lehmann-arcor-so) wrote :

a correction to the README.Debian to reflect the path

alexlehm (lehmann-arcor-so) wrote :

sorry

Raphaël Hertzog (hertzog) wrote :

Changing the path in ubuntu only was a serious mistake... it's good to fix bugs, but not to introduce gratuitous incompatibilities between Debian and Ubuntu.

If something had to be done, it should have been in Debian directly. Now you have a smarty-gettext package that is broken and several applications that work in Debian have to be customized in Ubuntu to match this change.

Mathieu Parent (sathieu) wrote :

Request to apply the same patch to ubuntu is at http://bugs.debian.org/514305

Changed in smarty (Debian):
status: Unknown → New
Changed in smarty (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.