Ubuntu

Don't install slocate by default on Desktops

Reported by Milan Bouchet-Valat on 2007-09-17
8
Affects Status Importance Assigned to Milestone
slocate (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: slocate

(Discussed here: https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2007-September/001646.html)

The slocate cron.daily job has long been an issue, making users ask why their computers were not responding or simply working hard without any explanation. This little 'bug' is giving a really bad impression to new users, making Ubuntu look 'Windows-like' (the worst for us), that is to say unstable and strange.

Having a look to Launchpad bug tracker, you can see that at least 5 open bugs refer to this problem, some proposing patches to make the issue less annoying. Those are:
Bug 134692 (with a committed patch, about using ionice to lessen the io usage of updatedb)
Bug 13671 (duplicate*, reporting ionice issues making previous patch almost unefficient)
Bug 133638 (about telling the user that the system is indexing files)
Bug 41742 (about a laptop not wanting to suspend when updatedb has automatically started)

And partly those, because bugs with slocate affect out-of-the-box users
that don't really need it:
Bug 113312 (about encrypted partition being indexed without notice from a newbie user)
Bug 74029 (about /mnt default indexation issues)

This bug should really be rapidly considered and solves by choosing a clear policy for Ubuntu. If we really want to keep the locate command working out-of-the-box in Ubuntu, we should find out ways of making updatedb run : 1) with low io and CPU priority 2) only when the user is not using his computer (just like Tracker will be doing by default in Gutsy).

Or we can consider using rlocate (http://rlocate.sourceforge.net/), which is a synchronized replacement for locate, keeping track of the filesystem updates when they are done.

We can also think (and this is my opinion ;-) ) that the locate command is only used by advanced users that know how to install slocate in two minutes, and thus that we don't need to install it by default. Newbies don't use locate in a terminal, but Tracker in GNOME. And we should remember that users are likely to use new background processes with Tracker or Beagle, that may even be installed by default. So the less are running, the better the system will work. Replacements like find can be used when necessary (eg for occasional remote help), though they are less efficient.

Scott Kitterman (kitterman) wrote :

This is a standard piece of Linux functionality. This sort of discussion should be addressed in a spec and decided by design and not just in a bug.

Milan Bouchet-Valat (nalimilan) wrote :

Sorry, I had forgotten to notice the ongoing discussion on ubuntu-devel-discuss. Fixed.

description: updated
sam tygier (samtygier) wrote :

i have a ubuntu minimal system without slocate, it seems that findutils does an updatedb daily. just removing slocate does not prevent indexing.

Timo Jyrinki (timo-jyrinki) wrote :

New discussion on ubuntu-devel-discuss starting from https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2008-January/002834.html

Btw, slocate is now properly separated from findutils in hardy.

Timmie (timmie) wrote :

I have read all comments in the both ML threads.

As being one of the submitters for the duplicate bug report would like to stress the following things:
* locate is a very useful tool for advanced users which can rapidly find where a certain configuration file, setting or programm documentation can be found.
* on desktop systems, nearly every user who does not use a terminal server for the whole family or office is his/her own administrator and therefore might need a powerful tool like locate
* the memory and hard disk blocking effects of the updatedb has incommodated me since I started to use linux (some 6 years ago) blocking my work every day for some 5-10 minutes. Remember that with increasing hard disk space there's even more to index...
* I was able to reduce the heavy load of rsnapshot just by using ionice
* Linus Torvals himself started an initiative for green computing meaning using processes that use less power and that don't get in the way of the user

=> summarising: let's come up with a smart and modern tool that retrains the functionality but is less blocking

Thanks everyone for your efforts addressing this.

Przemysław Kulczycki (azrael) wrote :

There is already an effort to put mlocate in main. Mlocate uses incremental database updates instead creating it from scratch. See bug #191775

description: updated
Colin Watson (cjwatson) wrote :

Once the metapackages get rebuilt, we'll be using mlocate in Hardy, which should clear this problem up.

Changed in slocate:
status: New → Fix Released
Przemysław Kulczycki (azrael) wrote :

Let's hope that mlocate won't fight for the disk as much as slocate (see bug #152051).

Milan Bouchet-Valat (nalimilan) wrote :

Very good indeed. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers