Ubuntu

sitecopy does not work with multiple sites in .sitecopyrc file

Reported by David Megginson on 2007-03-06
22
Affects Status Importance Assigned to Milestone
sitecopy (Debian)
Fix Released
Unknown
sitecopy (Ubuntu)
Undecided
Unassigned
Feisty
Medium
Unassigned

Bug Description

Binary package hint: sitecopy

In Feisty, sitecopy 0.16.3-6 (uploaded March 5) reads only the first site definition in .sitecopyrc and ignores the rest. The previous version correctly read all of the site definitions.

################################
# STEP 1
################################

I can confirm the bug here with an up-to-date Feisty.
I installed sitecopy and created this sample .sitecopyrc:

site site1
        server localhost
        remote /home/nico/lab/sitecopy/remote-site1
        local /home/nico/lab/sitecopy/local-site1
        username nico
site site2
        server localhost
        remote /home/nico/lab/sitecopy/remote-site2
        local /home/nico/lab/sitecopy/local-site2
        username nico

As you can see below, the behaviour is ok for site1, but buggy for site2:

$ sitecopy --init site1
sitecopy: Initializing site `site1' (on localhost in /home/nico/lab/sitecopy/remote-site1/)
sitecopy: All the files and directories are marked as NOT updated remotely.
$ sitecopy --init site2
sitecopy: No valid sites specified.
Try `sitecopy --help' for more information.

################################
# STEP 2
################################

I downloaded sitecopy from the original http://www.lyra.org/sitecopy/, I built it and tried it. It works well:

nico@aikawa:~/lab/sitecopy/sitecopy-0.16.3-orig$ ./sitecopy --init site1
sitecopy: Initializing site `site1' (on localhost in /home/nico/lab/sitecopy/remote-site1/)
sitecopy: All the files and directories are marked as NOT updated remotely.
nico@aikawa:~/lab/sitecopy/sitecopy-0.16.3-orig$ ./sitecopy --init site2
sitecopy: Initializing site `site2' (on localhost in /home/nico/lab/sitecopy/remote-site2/)
sitecopy: All the files and directories are marked as NOT updated remotely.

################################
# STEP 3
################################

So I thought: the bug has been introduced since 0.16.3, by the Ubuntu patch.
The file sitecopy_0.16.3.orig.tar.gz found on https://bugs.launchpad.net/ubuntu/+source/sitecopy/1:0.16.3-6 is strictly identical to the one that I used in STEP 2, found on the author's website.
I patched it with the diff sitecopy_0.16.3-6.diff.gz, built, and ran it, it works just as well:

nico@aikawa:~/lab/sitecopy/sitecopy-0.16.3$ ./sitecopy --init site1
sitecopy: Initializing site `site1' (on localhost in /home/nico/lab/sitecopy/remote-site1/)
sitecopy: All the files and directories are marked as NOT updated remotely.
nico@aikawa:~/lab/sitecopy/sitecopy-0.16.3$ ./sitecopy --init site2
sitecopy: Initializing site `site2' (on localhost in /home/nico/lab/sitecopy/remote-site2/)
sitecopy: All the files and directories are marked as NOT updated remotely.

################################
# Conclusion (or lack of)
################################

So I am really surprised, it seems to mean that the source does not correspond to what I got from APT ?

Confirming on the basis of that excellent investigation by Nicolas.
It could be simply that the official package needs to be rebuilt. Next step would be to try building the source with pbuilder (to see if it's a build-dep issue). You want to follow this through, Nicolas, or shall I grab it?

Changed in sitecopy:
status: Unconfirmed → Confirmed
Ondra (xorwen) wrote :

You have also my confirmation.

Hi all,

Sorry for the delay I was working in Malta, with no internet access.
I am now in Poland, on the internet a few minutes per day, so I can't do much :-(
Next week I will be back in France with a good connection, and I will be able to investigate a bit and try, but if anyone wants to follow this issue then please do, it is all for the better :-)

Good luck !

---
Nicolas
http://nrw.free.fr

edonia (uwe-ufritz) wrote :

I can confirm this bug. If I can help, please let me know.

Stefan (stefan-roellin) wrote :

Hi,

I can also confirm this bug. The problem seems to be the package build process: the provided patches in debian/patches are applied AFTER the sources are built. The attached patch solves this problem for me.

Changed in sitecopy:
status: Unknown → Fix Released
Christian Kujau (christiank) wrote :

AFAICS this is the same as #421606 in debian and got fixed in 0.16.3-8. Ubuntu/Feisty is still at 0.16.3-6.
The bug in debian has been tagged as "grave" - I'd consider a similiar severity for the ubuntu bug - can we assume that this will be fixed in feisty?

thank you for your time,
Christian.

Hallo,

keine Ahnung ob das noch in feisty gefixt wird, denke eher nicht. Ich
habe das selber gemacht, ist ja alles vorhanden, dann kann ich zumindest
das Programm benützen ;-)

Christian schrieb:
> AFAICS this is the same as #421606 in debian and got fixed in
> 0.16.3-8. Ubuntu/Feisty is still at 0.16.3-6. The bug in debian has
> been tagged as "grave" - I'd consider a similiar severity for the
> ubuntu bug - can we assume that this will be fixed in feisty?
>
> thank you for your time, Christian.
>

Mathias Gug (mathiaz) wrote :

Thanks taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Gutsy Gibbon.

If you need a fix for the bug in previous versions of Ubuntu, please follow the instructions for "How to request new packages" at https://help.ubuntu.com/community/UbuntuBackports#request-new-packages .

Changed in sitecopy:
status: Confirmed → Fix Released
Scott Kitterman (kitterman) wrote :

Actually, that's not correct. Backports is for new features, not bug fixing. This issue should be addresses through the SRU process. If one of the interested parties will prepare a debdiff for Feisty, I'll be glad to sponsor it. See https://wiki.ubuntu.com/MOTU/SRU for details.

I've opened a Feisty task for the bug. If someone can confrim this applies to Dapper/Edgy I'll open tasks for those releases too.

Changed in sitecopy:
importance: Undecided → Medium
status: New → Triaged

Please could someone mark this as Won't Fix for Feisty?

Hew McLachlan (hew) wrote :

Ubuntu Feisty Fawn is no longer supported, so a SRU will not be issued for this release. Marking Feisty as Won't Fix.

Changed in sitecopy:
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.