Doesn't set "duplex" driver flag

Bug #566759 reported by Mathias on 2010-04-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Simple Scan
Fix Released
Medium
Unassigned
simple-scan (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: simple-scan

Description: Ubuntu lucid (development branch)
Release: 10.04

I tried to do a duplex scan of a few documents using simple scan and my printers ADF (HP Officejet Pro L7590) but although I turned on the "Scanside: Front and Back" Option it didn't work for me. Only the front sides were scanned. If I use gscan2pdf or Xsane Duplex Scanning works well, so it seems to be a problem of simple scan.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: simple-scan 1.0.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon Apr 19 18:09:01 2010
DriverPackageVersions:
 libsane 1.0.20-13ubuntu2
 libsane-extras N/A
 hplip 3.10.2-2ubuntu2
 hpoj N/A
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
MachineType: Dell Inc. MP061
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=9616461a-0c75-4c00-97dd-d6d024eeee88 ro quiet splash
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
SimpleScanLog:

SourcePackage: simple-scan
dmi.bios.date: 06/27/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd06/27/2007:svnDellInc.:pnMP061:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MP061
dmi.sys.vendor: Dell Inc.

Mathias (mathias-gruber) wrote :
Robert Ancell (robert-ancell) wrote :

Hi Mathias,

Could you try the scan with simple-scan -d and attach the output here? Did this work in any previous versions of simple-scan?

Changed in simple-scan (Ubuntu):
status: New → Incomplete
Mathias (mathias-gruber) wrote :

Here is the output of simple-scan -d in a txt-file.

And i didn't try it with previous versions of simple-scan because i used XSane before upgrading to Ubuntu 10.04.

Robert Ancell (robert-ancell) wrote :

Problem fixed. This change will be in a stable update after Lucid is released.

Changed in simple-scan:
status: New → Fix Committed
importance: Undecided → Medium
summary: - simple scan no duplex scanning
+ Doesn't set "duplex" driver flag
Changed in simple-scan (Ubuntu):
status: Incomplete → Fix Committed
importance: Undecided → Medium
Changed in simple-scan (Ubuntu):
status: Fix Committed → Fix Released
Changed in simple-scan:
status: Fix Committed → Fix Released
Walther (hellsmurf) wrote :

I use Ubuntu 10.04(64 bit) and a hp officejet 8500 via Ethernet. Printing and scanning works pretty well. The only thing which is not running is duplex scanning(Got all packages up-to-date).

I atached a log with sudo simple-scan -d ->log.txt (With ->log.txt I have to reselect the scanner.)

Walther (hellsmurf) wrote :

PS: I use a wlan-router. Computer is connected over ethernet.

Walther (hellsmurf) wrote :

EDIT: OK, I am sorry. Got a HP Officejet Pro 8500 A909a. Thought it got DADF but this feature is only supported with the wlan version of the printer :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions