cannot download photos using shotwell via usb

Bug #1400470 reported by Nicolás Lichtmaier on 2014-12-08

This bug report will be marked for expiration in 56 days if no further activity occurs. (find out why)

This bug affects 30 people
Affects Status Importance Assigned to Milestone
shotwell (Ubuntu)

Bug Description

I get error message "Unable to fetch previews from the camera:
Could not claim the USB device (-53)" when I try to connect my camera and download photos to the PC using Shotwell. I have also installed gThumb and still same message.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu):
status: New → Confirmed
kenden (kenden) wrote :

Confirmed, this happens with my phone (Nexus 5) on Ubuntu 14.04 / Mint 17.1. Shotwell 0.18.0

Workaround, from:

"Shotwell is supposed to popup a dialog asking you to unmount, however there are cases where this doesn't work.
You may have to unmount the camera in Nautilus before starting Shotwell."

Unmounting in Nautilus before starting Shotwell works for me.

Adrian King (aking-il) wrote :

Same error message and workaround needed for

Ubuntu 14.10 64 bit
Shotwell 0.20.2
Samsung Galaxy s4

Bitterjug (bitterjug) wrote :

This is still affecting me today
Ubuntu 15.04, 64 bit
Shotwell 0.22.o
Samsung Galaxy Note III

Workaround : unmount in nautilus and re-start shotwell seems to be working.

Metta Crawler (metta-crawler) wrote :

For Android cameras you must also unlock the screen before it will talk to your computer.

ihoru (ihor-polyakov) wrote :

> Workaround : unmount in nautilus and re-start shotwell seems to be working.
Worked for me

Vincenzo Di Somma (vds) wrote :

Same error with:
Ubuntu 16.04 64 bit
Shotwell 0.22.0
Nexus 5x

The workaround works fine.

gadLinux (gad-aguilardelgado) wrote :

The situation got worse with 17.04 ubuntu.

The unmount trick doesn't work anymore and the camera/phone is left in strange status. I get "Can't lock camera. Unspecified error (-1)" If I unmount. I had to kill the gvfs process to be able access.

After killing

I got it working. but that's not the solution.

Geoffrey Pursell (geoffp) wrote :

I can't get the workaround to work at all with Ubuntu 16.10 and an iPhone 6+/iOS 10.3. I can't find any way at all to actually use Shotwell with my phone.

Simon P. (simpre) wrote :

I get the same error with Ubuntu 16.04.2 and my Moto G4 Play.

Alan Hayes (alanmodimages) wrote :

I tried the workaround on Ubunto Gnome 16.04 LTS. Did not work either. iPhone 7 Plus. When is going to be tackled?

peter (peter0829) on 2017-05-28
Changed in shotwell (Ubuntu):
status: Confirmed → Incomplete (kolkvdr) wrote :

solution #8 worked for me

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers