Shotwell doesn't respect 24-hour clock

Bug #1035067 reported by Benji on 2012-08-09
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
Shotwell
Fix Released
Medium
shotwell (Ubuntu)
Low
Unassigned

Bug Description

Here are my settings for "locale":
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE=de_DE.UTF-8
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE=de_DE.UTF-8
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_ALL=

The time should be displayed in a 24-hour time format. Other programs respect this issue. But shotwell only shows the am/pm time (12-hour time) in the picture information.

According to Bug 689055 (https://bugs.launchpad.net/ubuntu/+source/shotwell/+bug/689055) this bug should have been fixed in version 0.8. The current version in Ubuntu is 0.12.3. For me, the bug remains.

Lucas Beeler (lucas-yorba) wrote :

Hi Benji,

Is there any reason why you have a mixed-language environment on your computer? This is to say, your LANG environment variable specifies US English as your system language but you're using German numbers, dates, and times. Much more worryingly, your LC_MESSAGES environment variable is totally out of whack with all of your your other language collation (e.g. LC_xxx) variables. LC_MESSAGES specifies US English but all your other LC_xxx variables specify German. This is likely your problem.

Lucas

Adam Dingle (adam-yorba) wrote :

Thanks for the bug report. I think this is a bug: Shotwell should use LC_TIME to determine the time format used for displaying messages, independently of other environment variable settings. This bug is known upstream at

http://redmine.yorba.org/issues/2462

Benji (benjim) wrote :

Thank you Adam.

@Lucas: I like to have my programs and messages in "English" but with all units etc. should be in German, because I live there and like the metric system way better. :-) Which should be no problem, because that's what the different locales are for.

kroq-gar78 (kroq-gar78) on 2012-08-11
summary: - Shotwell doesn't use 24-hour clock
+ Shotwell doesn't respect 24-hour clock
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

is that still an issue in the current version?

Changed in shotwell (Ubuntu):
importance: Undecided → Low
Chris Wilson (notgary) on 2013-05-27
Changed in hundredpapercuts:
milestone: none → papercuts-s-shotwell
TomasHnyk (sup) wrote :

Yes, it is.

TomasHnyk (sup) wrote :

Oh no, actually it seems to be fixed.

Changed in shotwell (Ubuntu):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: New → Fix Released
Jim Nelson (yorba-jim) wrote :

I don't believe this bug has been fixed. See bug #1318847 and https://bugzilla.gnome.org/show_bug.cgi?id=716533.

Changed in shotwell (Ubuntu):
status: Fix Released → Triaged
Changed in shotwell:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in shotwell:
status: Confirmed → Incomplete
Christian González (droetker) wrote :

This bug is still present in 16.04.

Changed in shotwell:
status: Incomplete → Fix Released
Sebastien Bacher (seb128) wrote :
Changed in shotwell (Ubuntu):
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.