update-manager: missing dependency on libgtk2-perl for debconf frontend

Bug #1607929 reported by Alex Dehnert on 2016-07-29
66
This bug affects 21 people
Affects Status Importance Assigned to Milestone
shim-signed (Ubuntu)
High
Unassigned
update-manager (Ubuntu)
High
Brian Murray
Trusty
High
Brian Murray
Xenial
High
Brian Murray
Yakkety
High
Unassigned
Zesty
High
Brian Murray

Bug Description

[Impact]
update-manager is missing a recommends on libgtk2-perl which allows it to display debconf prompts. While we've fixed software-properties-gtk and gnome-software to depend / recommend libgk2-perl and this will resolve the issue for most installations it'd be best to fix update-manager too for all releases in case there is some installation situation where libgtk2-perl is missing.

[Test Case]
1) Uninstall libgtk2-perl - 'sudo apt-get remove libgtk2-perl'
2) Launch update-manager from a terminal
3) Observe the following message in the terminal:

debconf: unable to initialize frontend: Gnome
debconf: (Can't locate Gtk2.pm in @INC (you may need to install the Gtk2 module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 91.)
debconf: falling back to frontend: Dialog

[Regression Potential]
None - no really! We are just adding a recommends on another package.

Original Description
--------------------
I'm not really sure whether this is a bug; I think the install was hanging for a while, with a blank window displaying. I killed the install and it went away, but it's certainly plausible that this is due to something local, not a bug. Feel free to close this if nobody else is seeing it.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: shim-signed 1.17~14.04.1+0.8-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-85.129-generic 3.13.11-ckt36
Uname: Linux 3.13.0-85-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 2.14.1-0ubuntu3.21
Architecture: amd64
BootEFIContents:
 grub.cfg
 grubx64.efi
 MokManager.efi
 shimx64.efi
Date: Fri Jul 29 15:45:46 2016
DuplicateSignature: package:shim-signed:1.17~14.04.1+0.8-0ubuntu2:subprocess installed post-installation script was killed by signal (Terminated)
ErrorMessage: subprocess installed post-installation script was killed by signal (Terminated)
InstallationDate: Installed on 2014-05-23 (798 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
RelatedPackageVersions:
 dpkg 1.17.5ubuntu5.7
 apt 1.0.1ubuntu2.14SourcePackage: shim-signed
Title: package shim-signed 1.17~14.04.1+0.8-0ubuntu2 failed to install/upgrade: subprocess installed post-installation script was killed by signal (Terminated)
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Alex Dehnert (adehnert) wrote :
tags: removed: need-duplicate-check
Steve Langasek (vorlon) wrote :

The output in your dpkg upgrade log shows:

Processing triggers for shim-signed (1.17~14.04.1+0.8-0ubuntu2) ...
Use of uninitialized value $ret in string eq at /usr/share/perl5/Debconf/FrontEnd/Passthrough.pm line 212, <GEN0> line 22.
Use of uninitialized value $_[1] in join or string at /usr/share/perl5/Debconf/DbDriver/Stack.pm line 111, <GEN0> line 22.
Use of uninitialized value $_[1] in join or string at /usr/share/perl5/Debconf/DbDriver/Stack.pm line 111, <GEN0> line 22.
Use of uninitialized value $ret in string eq at /usr/share/perl5/Debconf/FrontEnd/Passthrough.pm line 212, <GEN0> line 29.
Use of uninitialized value $_[1] in join or string at /usr/share/perl5/Debconf/DbDriver/Stack.pm line 111, <GEN0> line 29.
[...]

This indicates a problem with the debconf prompting code. What program were you running to do the upgrade?

Changed in shim-signed (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) on 2016-08-02
summary: - package shim-signed 1.17~14.04.1+0.8-0ubuntu2 failed to install/upgrade:
- subprocess installed post-installation script was killed by signal
- (Terminated)
+ (debconf passthrough) package shim-signed 1.17~14.04.1+0.8-0ubuntu2
+ failed to install/upgrade: subprocess installed post-installation script
+ was killed by signal (Terminated)
Steve Langasek (vorlon) on 2016-08-02
Changed in shim-signed (Ubuntu):
importance: Undecided → High
Steve Langasek (vorlon) on 2016-08-02
summary: - (debconf passthrough) package shim-signed 1.17~14.04.1+0.8-0ubuntu2
- failed to install/upgrade: subprocess installed post-installation script
- was killed by signal (Terminated)
+ (trusty, debconf passthrough) package shim-signed
+ 1.17~14.04.1+0.8-0ubuntu2 failed to install/upgrade: subprocess
+ installed post-installation script was killed by signal (Terminated)

I think update-manager? One of the standard GUI updater things.

Here's a chunk of ps -AF --forest that might help:
alex 6365 1 0 84088 18916 2 Jul30 ? 00:00:00 /usr/bin/python /usr/lib/update-notifier/backend_helper.py show_updates
alex 6370 6365 0 173663 123028 2 Jul30 ? 00:00:11 \_ /usr/bin/python3 /usr/bin/update-manager --no-update
alex 7919 6370 0 17241 14224 2 Jul30 ? 00:00:00 \_ /usr/bin/perl -w /usr/bin/debconf-communicate
root 7180 1 0 76314 66688 2 Jul30 ? 00:00:04 /usr/bin/python3 /usr/sbin/aptd
root 7189 7180 0 76315 47888 3 Jul30 pts/3 01:13:37 \_ /usr/bin/python3 /usr/sbin/aptd
root 7916 7189 0 5261 10480 2 Jul30 pts/6 00:00:00 \_ /usr/bin/dpkg --status-fd 99 --configure shim-signed:amd64 dkms:all x11proto-randr-dev:all
root 7917 7916 0 17788 14340 0 Jul30 pts/6 00:00:00 \_ /usr/bin/perl -w /usr/share/debconf/frontend /var/lib/dpkg/info/shim-signed.postinst configure 1.17~14.04.1+0.8-0ubuntu2
--
[...]
alex 23733 1 0 84089 20524 3 20:54 ? 00:00:00 /usr/bin/python /usr/lib/update-notifier/backend_helper.py show_updates
alex 23738 23733 2 166574 182760 0 20:54 ? 00:00:02 \_ /usr/bin/python3 /usr/bin/update-manager --no-update

Steve Langasek (vorlon) on 2016-08-08
Changed in shim-signed (Ubuntu):
status: Incomplete → Triaged
Steve Langasek (vorlon) wrote :

This is related to bug #1679435 and bug #1679784. Since those bugs are fixed, this bug is effectively masked right now, but this package should still have proper depends/recommends so that it doesn't accidentally crop up again later.

summary: - (trusty, debconf passthrough) package shim-signed
- 1.17~14.04.1+0.8-0ubuntu2 failed to install/upgrade: subprocess
- installed post-installation script was killed by signal (Terminated)
+ update-manager: missing dependency on libgtk2-perl for debconf frontend
no longer affects: shim-signed (Ubuntu Zesty)
no longer affects: shim-signed (Ubuntu Trusty)
no longer affects: shim-signed (Ubuntu Xenial)
no longer affects: shim-signed (Ubuntu Yakkety)
Changed in update-manager (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in update-manager (Ubuntu Xenial):
status: New → Triaged
Changed in update-manager (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
Changed in update-manager (Ubuntu Xenial):
importance: Undecided → High
Changed in update-manager (Ubuntu Yakkety):
status: New → Triaged
importance: Undecided → High
Changed in update-manager (Ubuntu Zesty):
status: New → Triaged
importance: Undecided → High
Changed in update-manager (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu Yakkety):
status: Triaged → Won't Fix
Changed in update-manager (Ubuntu):
milestone: none → ubuntu-17.07
Brian Murray (brian-murray) wrote :

One way to get an error message out of update-manager about this is to remove libgtk2-perl, if it is already installed, and run update-manager via a terminal. When a package like software-properties-gtk is installed you'll see the following message in the terminal:

debconf: unable to initialize frontend: Gnome
debconf: (Can't locate Gtk2.pm in @INC (you may need to install the Gtk2 module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 91.)
debconf: falling back to frontend: Dialog

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:17.10.2

---------------
update-manager (1:17.10.2) artful; urgency=medium

  * Recommend libgtk2-perl be installed so we have a working debconf frontend.
    (LP: #1607929)

 -- Brian Murray <email address hidden> Tue, 18 Jul 2017 15:32:54 -0700

Changed in update-manager (Ubuntu):
status: In Progress → Fix Released
description: updated
Changed in update-manager (Ubuntu Trusty):
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu Zesty):
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu Trusty):
status: Triaged → In Progress
Changed in update-manager (Ubuntu Xenial):
status: Triaged → In Progress
Changed in update-manager (Ubuntu Zesty):
status: Triaged → In Progress

Hello Alex, or anyone else affected,

Accepted update-manager into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:16.04.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-manager (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in update-manager (Ubuntu Trusty):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Alex, or anyone else affected,

Accepted update-manager into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:0.196.24 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-manager (Ubuntu Zesty):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Alex, or anyone else affected,

Accepted update-manager into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:17.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

I removed the package libgtk2-perl from my testing system, then I installed the version of update-manager (17.04.5) from zesty-proposed. While the package was installing I observed libgtk2-perl also being installed. Additionally, when I ran the new version of update-manager I did not see any error messages about being unable to initialize the Gnome frontend.

tags: added: verification-done-zesty
Brian Murray (brian-murray) wrote :

I removed the package libgtk2-perl from my testing system, then I installed the version of update-manager (16.04.8) from xenial-proposed. While the package was installing I observed libgtk2-perl also being installed. Additionally, when I ran the new version of update-manager I did not see any error messages about being unable to initialize the Gnome frontend.

Brian Murray (brian-murray) wrote :

I removed the package libgtk2-perl from my testing system, then I installed the version of update-manager (1:0.196.24) from trusty-proposed. While the package was installing I observed libgtk2-perl also being installed. Additionally, when I ran the new version of update-manager I did not see any error messages about being unable to initialize the Gnome frontend.

tags: added: verification-done-trusty verification-done-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.196.24

---------------
update-manager (1:0.196.24) trusty-proposed; urgency=medium

  * Recommend libgtk2-perl be installed so we have a working debconf frontend.
    (LP: #1607929)

 -- Brian Murray <email address hidden> Mon, 24 Jul 2017 17:43:27 -0700

Changed in update-manager (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:16.04.8

---------------
update-manager (1:16.04.8) xenial; urgency=medium

  * Recommend libgtk2-perl be installed so we have a working debconf frontend.
    (LP: #1607929)

 -- Brian Murray <email address hidden> Mon, 24 Jul 2017 17:40:35 -0700

Changed in update-manager (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:17.04.5

---------------
update-manager (1:17.04.5) zesty; urgency=medium

  * Recommend libgtk2-perl be installed so we have a working debconf frontend.
    (LP: #1607929)

 -- Brian Murray <email address hidden> Mon, 24 Jul 2017 16:43:12 -0700

Changed in update-manager (Ubuntu Zesty):
status: Fix Committed → Fix Released
tags: added: id-59558f2e8009457ca9a91bae
Steve Langasek (vorlon) on 2017-11-06
Changed in shim-signed (Ubuntu):
status: Triaged → Confirmed
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers