sbd autopkgtest regresion

Bug #1837091 reported by Rafael David Tinoco on 2019-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sbd (Ubuntu)
Medium
Rafael David Tinoco

Bug Description

While proposed-migration shows us:

sbd (1.3.1-4 to 1.4.0-18-g5e3283c-1)
Maintainer: Debian HA Maintainers
Section: universe/misc
68 days old
autopkgtest for sbd/1.4.0-18-g5e3283c-1: amd64: Pass, arm64: Pass, armhf: Pass, i386: Pass, ppc64el: Pass, s390x: Pass
Invalidated by dependency
Depends: sbd pacemaker (not considered)
Not considered

previous rdependency triggered autopkgtests (corosync as trigger) reported:

autopkgtest for sbd/1.3.1-4: amd64: Ignored failure, arm64: Pass, armhf: Regression ♻ , i386: Regression ♻ , ppc64el: Pass, s390x: Pass

autopkgtest [19:17:07]: test corosync: [-----------------------
Job for corosync.service failed because the control process exited with error code.
See "systemctl status corosync.service" and "journalctl -xe" for details.
autopkgtest [19:17:09]: test corosync: -----------------------]
autopkgtest [19:17:13]: test corosync: - - - - - - - - - - results - - - - - - - - - -
corosync FAIL non-zero exit status 1

Investigate if its intermittent or not.

Changed in sbd (Ubuntu):
assignee: nobody → Rafael David Tinoco (rafaeldtinoco)
status: New → Confirmed
importance: Undecided → Medium

I did some combined triggers with the new corosync / pacemaker.
It is still failing (only on armhf btw).

You did some magic there:

sbd (1.3.1-4 to 1.4.0-18-g5e3283c-1)
Maintainer: Debian HA Maintainers
Section: universe/misc
90 days old
autopkgtest for sbd/1.4.0-18-g5e3283c-1: amd64: Pass, arm64: Pass, armhf: Pass, i386: Pass, ppc64el: Pass, s390x: Pass
Invalidated by dependency
Depends: sbd pacemaker (not considered)
Not considered

I guess this bug is "wont fix" now ?

Thanks!

With those new triggers we always see the service failing:

Setting up corosync (3.0.1-2ubuntu1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/corosync.service → /lib/systemd/system/corosync.service.
Job for corosync.service failed because the control process exited with error code.
See "systemctl status corosync.service" and "journalctl -xe" for details.
Setting up autopkgtest-satdep (0) ...
Processing triggers for systemd (240-6ubuntu9) ...
Processing triggers for libc-bin (2.29-0ubuntu3) ...
(Reading database ... 75495 files and directories currently installed.)
Removing autopkgtest-satdep (0) ...
autopkgtest [07:33:56]: test corosync: [-----------------------
Job for corosync.service failed because the control process exited with error code.
See "systemctl status corosync.service" and "journalctl -xe" for details.

Installing that on an armhf VM myself.

$ sudo apt install sdb corosync
...

Download full text (45.2 KiB)

This actually works just fine ...

ubuntu@eoan-armhf:~$ sudo apt update
Hit:1 http://ports.ubuntu.com/ubuntu-ports eoan InRelease
Hit:2 http://ports.ubuntu.com/ubuntu-ports eoan-updates InRelease
Hit:3 http://ports.ubuntu.com/ubuntu-ports eoan-backports InRelease
Get:4 http://ports.ubuntu.com/ubuntu-ports eoan-proposed InRelease [107 kB]
Hit:5 http://ports.ubuntu.com/ubuntu-ports eoan-security InRelease
Get:6 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/main armhf Packages [57.2 kB]
Get:7 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/main Translation-en [39.6 kB]
Get:8 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/main armhf c-n-f Metadata [1628 B]
Get:9 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/restricted Translation-en [624 B]
Get:10 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/restricted armhf c-n-f Metadata [116 B]
Get:11 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/universe armhf Packages [571 kB]
Get:12 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/universe Translation-en [365 kB]
Get:13 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/universe armhf c-n-f Metadata [3424 B]
Get:14 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/multiverse armhf Packages [2540 B]
Get:15 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/multiverse Translation-en [2688 B]
Get:16 http://ports.ubuntu.com/ubuntu-ports eoan-proposed/multiverse armhf c-n-f Metadata [164 B]
Fetched 1151 kB in 40s (29.0 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
48 packages can be upgraded. Run 'apt list --upgradable' to see them.
ubuntu@eoan-armhf:~$ sudo apt install sdb corosync
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  binfmt-support ca-certificates-mono cli-common libcfg7 libcmap4 libcorosync-common4
  libcpg4 libicsharpcode-nrefactory-cecil5.0-cil libicsharpcode-nrefactory-csharp5.0-cil
  libicsharpcode-nrefactory5.0-cil libknet1 libmono-btls-interface4.0-cil
  libmono-corlib4.5-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil libmono-posix4.0-cil
  libmono-security4.0-cil libmono-system-configuration4.0-cil libmono-system-core4.0-cil
  libmono-system-numerics4.0-cil libmono-system-security4.0-cil libmono-system-xml4.0-cil
  libmono-system4.0-cil libnspr4 libnss3 libqb0 libquorum5 libstatgrab10 libvotequorum8
  libxslt1.1 mono-4.0-gac mono-gac mono-runtime mono-runtime-common mono-runtime-sgen
  xsltproc
Suggested packages:
  libicsharpcode-nrefactory-ikvm5.0-cil libmono-i18n4.0-all libasound2 libgamin0 xdg-utils
  | libgnome2-0 | konqueror
The following NEW packages will be installed:
  binfmt-support ca-certificates-mono cli-common corosync libcfg7 libcmap4
  libcorosync-common4 libcpg4 libicsharpcode-nrefactory-cecil5.0-cil
  libicsharpcode-nrefactory-csharp5.0-cil libicsharpcode-nrefactory5.0-cil libknet1
  libmono-btls-interface4.0-cil libmono-corlib4.5-cil libmono-i18n-west4.0-cil
  libmono-i18n4.0-cil libmono-posix4.0-cil libmono-security4.0-cil
  libmono-system-configuration4.0-cil libmono-...

So after we now know that this would actually work we have to realize that this is just another case of failing on the armhf container (which Rafael already explained is the case).

Suggestion:
- fail-badtest this version
- submit to Debian to replace the isolation-container with isolation-machine

Actually since we upload a new version already, we can skip the badtest.
We block on others still, so it won't give us a speed bonus to resolve this.

Uploaded to Eoan with isolation-machine on the failing test.

Suggested to Debian as well in https://salsa.debian.org/ha-team/sbd/merge_requests/1

The upload worked and arm is fixed as expected.

This triggered an issue with both x86 tests, but that was expected as we have known that they only work if executred with the new pacemaker/corosync in proposed.
I have re-triggered those two to resolve as well.

corosync (in regard to sbd) is unblocked now.

looks like crmsh has a similar issue, I'm fixing it!

G.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sbd - 1.4.0-18-g5e3283c-1ubuntu1

---------------
sbd (1.4.0-18-g5e3283c-1ubuntu1) eoan; urgency=medium

  * d/t/control: corosync won't always start correctly in containers breaking
    the corosync test when the test dependencies are installed. Needs to be
    marked isolation-machine (LP: #1837091)

 -- Christian Ehrhardt <email address hidden> Fri, 09 Aug 2019 07:24:40 +0200

Changed in sbd (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers