Epson CX5900 scanner/printer scanner part not detected

Bug #72506 reported by Robin Sheat on 2006-11-20
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Undecided
Unassigned

Bug Description

The CX5900 when plugged in doesn't get the permissions appropriate to a scanner. The fix is to add this to /etc/udev/rules.d/45-libsane.rules:

# Epson CX-5900
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="082e", MODE="664", GROUP="scanner"

Rich Wales (richw) wrote :

Similar problem with the Epson Stylus CX7800 all-in-one -- SANE simply doesn't seem to know it's there. Adding a line to /etc/udev/rules.d/45-libsane.rules (vendor = 04b8, product = 081f), however, did NOT fix this problem for me, even after a system restart.

Rich Wales (richw) wrote :

I got my Epson Stylus CX7800 to scan after doing "sudo aptitude install libsane-extras". It's now recognized as a "Stylus CX7700/CX7800".

My system is a Ubuntu 7.04, in case it matters.

Tanker Bob (tankerbob) wrote :

Thanks, Rich. Adding libsane-extras worked for me as well with a CX7800 on Kubuntu 7.04! Selecting "CX7800" did not work, but selecting "Stylus CX7700/CX7800" worked fine.

Nick_Hill (nick-nickhill) wrote :

I had a similar problem with bug #67659 which appears to be fixed in Ubuntu Gutsy Gibbon tribe 2 + .

If Gutsy fixes this, perhaps we can close this too?

Nick_Hill (nick-nickhill) wrote :

It appears Gutsy Tribe 2 + fixes this bug.

Changed in sane-backends:
status: New → Fix Released
status: Fix Released → Fix Committed
Melissa Draper (melissa) wrote :

This is not yet fixed for the 5900.

Currently in tribe 3 (and updated further since), /etc/udev/rules.d/45-libsane.rules still lacks the following info:

# Epson CX-5900
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="082e", MODE="664", GROUP="scanner"

pelaodiego (sequefuiyo) wrote :

For me, worked:

1.- install libsane-extras (using sudo aptitude install libsane-extras) and sane-utils (using sudo aptitude install sane-utils, in super user mode, that is typing "sudo su" in a terminal).

2.- Then typing "sane-find-scanner" and look for a line like this "found USB scanner (vendor=0x04b8 [EPSON], product=0x082e [USB2.0 MFP(Hi-Speed)]) at libusb:002:008" so the scanner is there.

3.- Add the line

# Epson CX-5900
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="082e", MODE="664", GROUP="scanner"

** NOTE THAT THE SYSFS{idVendor} AND SYSFS{idProduct} MAY VARY DEPENDING ON YOUR CONFIGURATION **

to the file /etc/udev/rules.d/45-libsane.rules

4.- restart

5.- Then add "usb 0×04b8 0×082e" to the file /etc/sane.d/epson.conf where 0x04b8 are the SYSFS{idVendor} value and 0×082e the SYSFS{idProduct} value.

6.- Restart. (necessary? may not).

7.- Launching xsane.

done!...for me.

spinnekop (johan30) wrote :

Hi,

I checked all of this, and still my scanner cx5400 is not being detected.
in /etc/udev/rules.d/45-libsane.rules
# Epson CX-5400
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="0808", MODE="664", GROUP="scanner"

in /etc/sane.d/epson.conf
usb 0x4b8 0x808

libsane-extras and sane-utils has been installed.
sane-find-scanner gives output :
found USB scanner (vendor=0x04b8 [EPSON], product=0x0808 [USB MFP]) at libusb:001:002
and dmesg give me this after executing xscanimage :
root@gandalf:/etc/sane.d# dmesg | grep scan
[ 43.325616] usb-storage: waiting for device to settle before scanning
[ 43.325659] usb-storage: waiting for device to settle before scanning
[ 48.341130] usb-storage: device scan complete
[ 48.342414] usb-storage: device scan complete
[ 3472.902892] usb 1-2: usbfs: interface 1 claimed by usblp while 'xscanimage' sets config #1
[ 3472.945131] usb 1-2: usbfs: interface 1 claimed by usblp while 'xscanimage' sets config #1

Anybody has an idea ?
Greetz,

Still having issues with my Epson 4490 too, after upgrading from 7.04 to 7.10. It worked fine in 7.04.

I've installed the libsane-extras and sane-utils packages.

sane-find-scanner shows:
found USB scanner (vendor=0x04b8 [EPSON], product=0x0119 [EPSON Scanner]) at libusb:003:002

I added this to /etc/udev/rules.d/45-libsane.rules :
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="0119", MODE="664", GROUP="scanner"

I added this to /etc/sane.d/epson.conf :
usb 0×04b8 0x0119

Rebooted. Still no go. Any ideas or other info I can provide?

Thanks,
~Rick

Menno (m-tjoelker) wrote :

It is over a year ago, but maybe nevertheless useful for anyone.
To get another Epson scanner running, I had to add the path to the firmware in file /etc/sane.d/snapscan.conf.
In my case, the firmware file was called esfw41.bin. It was located at /usr/share/iscan, where it was placed by package iscan-plugin-gt-f500 from http://www.avasys.jp/english.
(Of course, for different models the firmware file will be different.)

jpxsat (jpxsat) wrote :

I'm experiencing huge difficulties with my cx7700 in ubuntu 10.04

First: I plugged the device, and the printer was detected within seconds.
Second: I tried to make the scanner work... device not detected.

I've installed the drivers from http://avasys.jp/eng/linux_driver/ and still nothing happens
Later i tried installing the sane extras, but didn't work neither

Finally i found this: http://reformedmusings.wordpress.com/2009/11/11/fixing-the-epson-scanner-in-ubuntu-karmic-9-10-issues/ in the hope it can help to debug this.

Alesh Slovak (alesh-slovak) wrote :

jpxsat, I am a developer on the Avasys drivers. It is more than likely that you are simply missing an entry in the udev rules for your scanner. If using our drivers, which do support your scanner, make sure to download and install both the iscan and iscan-data packages for your system. After installing the packages it is necessary to disconnect and reconnect your scanner if it was already connected to your computer.

jpxsat (jpxsat) wrote :

@Alesh Slovak

You're right, it works perfect: was trying to install some different package. Finally found the good ones and it works perfectly since then.
Many thanks! and sorry for the very-long delay in my response.

Robin Sheat, thank you for reporting this and helping make Ubuntu better.

As per https://wiki.ubuntu.com/Releases your version of Ubuntu is EOL.

If you have an issue in a supported release (ex. 16.04) please file a new report, and feel free to subscribe me to it.

Changed in sane-backends (Ubuntu):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers