Comment 22 for bug 229343

On Fri, Sep 11, 2009 at 4:04 PM, Jamie Strandboge <email address hidden> wrote:

> I had a similar issue, but did not resort to running saned as root.
> Instead, I did:
> $ sane-find-scanner
> ...
> found USB scanner (vendor=0x03f0 [HP], product=0x2a12 [Officejet J4500
> series]) at libusb:005:002
> ...
>
> Then I checked the permissions of the libusb:005:002 device:
> $ getfacl /dev/bus/usb/005/002
> getfacl: Removing leading '/' from absolute path names
> # file: dev/bus/usb/005/002
> # owner: lp
> # group: lp
> user::rw-
> group::rw-
> other::r--
>
> It was clear that saned needed to be in the 'lp' group. So I did:
> $ sudo adduser saned lp
>
> and it worked.
>

I don't think people are paying attention to the problem that others (like
me) have had which was temporarily solved by (post #4):

"I have to manually set permissions to the scanner device to be able to
allow remote users to use the scanner.

sudo chown root:saned /dev/bus/usb/001/002 && sudo chmod g+rw
/dev/bus/usb/001/002"

The problem was NOT that saned was not part of the lp group, but that saned
nor lp nor any other person had access to the device other than "root". The
permissions were originally root:root and needed to be changed to
root:saned. To make it worse, sane updates would reset the permissions to
the usb device making the scanner inaccessible again.