genesys_gl847 scanners produce a black band in scanned images on Ubuntu 17.10+, 18.04 LTS and 18.10 Cosmic cuttlefish

Bug #1731459 reported by dbazza on 2017-11-10
190
This bug affects 42 people
Affects Status Importance Assigned to Milestone
sane-backends
Fix Released
Unknown
sane-backends (Debian)
Confirmed
Unknown
sane-backends (Ubuntu)
Medium
Gunnar Hjalmarsson
Bionic
Medium
Unassigned
Disco
Medium
Unassigned

Bug Description

[Impact]

When using a Genesys GL847 scanner, the documents get disfigured by a discolored bar. The proposed uploads should fix the issue. They are available in this PPA:

https://launchpad.net/~gunnarhj/+archive/ubuntu/sane-backends

[Test case]

1. Install the libsane (libsane1 in bionic), libsane-common
   and sane-utils packages from {bionic,disco]-proposed.

2. Use an affected device to scan, and find that the issue is
   no longer present.

[Regression risk]

Upstream commit, focused bug fix => low regression risk

[Original description]

On Windows it works but on my Ubuntu 17.10, 18.04 and 18.10 I see a black band on scanned image. The scanner is Canon CanoScan LIDE100. Libsane version is 1.0.27-1~experimental2ubuntu1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sane-backends (Ubuntu):
status: New → Confirmed
eexcellent (handy-man) wrote :

Me too, works on Windows XP and Xubuntu 16.04. Not on Xubuntu 17.10 with libsane 1.0.27-1~experimental2ubuntu2.1

eexcellent (handy-man) wrote :

Here's the output of simple scan. (all front ends the same)

Duane Barry (duane-barry) wrote :

Workaround is to install sane-backends-1.0.25 from the sane Project Site.
This version seems to work properly with LiDE 200. I did not realise any side effects at the moment using 1.0.25.

I did some testing with different colours. Maybe this helps to pinpoint what's actually going wrong.

I also found an interesting correlation with this bug: https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1712997
The visual artefacts are very similar however they are not in a straight line and they happen with the old driver (1.0.25) which is otherwise fine.

What I wasn't able to confirm yet is if the current stable release of sane-backends 1.0.27 might fix this or not. There are many dependencies which make it impossible for me to replace libase1 with libsane. You can get it here if you are able to work around the dependency issue: https://launchpad.net/~rolfbensch/+archive/ubuntu/sane-release?field.series_filter=

btw: This also happens with CanoScan LiDE 200 btw. I marked the report for 200 as a duplicate of this report since yours was reported earlier.

Also I went through all changes made between 1.0.25 and 1.0.27 with regards to genesys in general and more specifically gl847 (which is the chip CanoScan LiDE 100 is using) looking for anything related to colour. The only thing I was able to find was this patch changing reallocation of gamma tables: https://anonscm.debian.org/cgit/sane/sane-backends.git/commit/backend/genesys.c?id=5edb87f9ac950473f8c3a57b4071c970887d8440

I'm no expert but this sounds promising and it's the best I can provide helping to fix this bug.

summary: - Black band in scanned images
+ On Ubuntu 17.10 genesys_gl847 scanners produce a black band in scanned
+ images.
summary: - On Ubuntu 17.10 genesys_gl847 scanners produce a black band in scanned
- images.
+ genesys_gl847 scanners produce a black band in scanned images on Ubuntu
+ 17.10

Very interesting fact:

I have two Canoscan LiDe 200 devices. One is showing the vertical bar on my Ubuntu 16.04/ libsane(1.0.27+git20180103-xenial0) the other one not.

Both are working fine under Windows 7.

Is there anything I can do or test to get more information for you?

teras (panayotis) wrote :

Sorry for double posting, just some demo images to present the problem.

Linux scan: https://i.stack.imgur.com/b3gij.jpg
OSX scan: https://i.stack.imgur.com/clWPg.jpg

Indeed it seems like a gamma error.

Saarloop (winfried100) wrote :

Since the update to ubuntu 17.10 the black vertical central line appears on my PC and Laptop with any scanning software independently of the configurations. The scanner works very well under Windows 10. I'm still waiting for a solution!

genti (pashol) wrote :

This is also reported on the SANE project bug report website, which includes the solution to fix this issue: https://alioth.debian.org/tracker/index.php?func=detail&aid=315752&group_id=30186&atid=410366

The root cause is a patch, that causes the issue in the first place

genti (pashol) wrote :

It is actually fixed now. If you build 1.0.27 from Git it'll be ok.

fermulator (fermulator) wrote :

@genti (pashol), are you sure it's fixed? I see no evidence of a fix according to history:
 * https://gitlab.com/sane-project/backends/commits/master/backend/genesys.c

Also, has anyone successfully worked around the problem?

In theory, if we rebuild from 1.0.25 git snapshot, it SHOULD resolve the problem;
https://help.ubuntu.com/community/CompileSaneFromSource

(gawd it's dumb why Ubuntu took into 1.0.27 experimental ...)

My steps were:
--

sudo apt-get install checkinstall libusb-dev build-essential libsane-dev libavahi-client-dev libavahi-glib-dev
cd ~/projects/_<somewhere you want a temp git clone to go...>
git clone git://anonscm.debian.org/collab-maint/sane-backends.git
cd sane-backends/
git checkout tags/upstream/1.0.25
./configure --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu --sysconfdir=/etc --localstatedir=/var BACKENDS="genesys" --
make
sudo checkinstall .

#@ (i named my package sane-git-1.0.25 for easy future removal)

$ dpkg --list | grep sane-git
ii sane-git-1.0.25 1.0.25-1 amd64 sane-backends

--
now, I'm not sure why, but it doens't show it actually installing the genesys library back-end ... bah .. just a bunch of docs!
, (something about the configure/make/install didn't quite go right I su ppose ..)

--
OK fine then ...
 (find the backend library it built...)

~/projects/sane-backends$ find . | grep libsane-genesys
./backend/.libs/libsane-genesys.lai
./backend/.libs/libsane-genesys.la
./backend/.libs/libsane-genesys.so
./backend/.libs/libsane-genesys.so.1
./backend/.libs/libsane-genesys.so.1.0.25 <<---- THIS!! we need it
./backend/libsane-genesys.la

$ cd /usr/lib/x86_64-linux-gnu/sane
$ sudo rm libsane-genesys.so libsane-genesys.so.1
$ sudo ln -s /home/fermulator/projects/sane-backends/backend/.libs/libsane-genesys.so.1.0.25
$ sudo ln -s /home/fermulator/projects/sane-backends/backend/.libs/libsane-genesys.so.1.0.25 libsane-genesys.so
$ sudo ln -s /home/fermulator/projects/sane-backends/backend/.libs/libsane-genesys.so.1.0.25 libsane-genesys.so.1

/usr/lib/x86_64-linux-gnu/sane$ ll | grep genesys
-rw-r--r-- 1 root root 867724 Oct 24 21:43 libsane-genesys.a
lrwxrwxrwx 1 root root 79 Mar 11 21:22 libsane-genesys.so -> /home/fermulator/projects/sane-backends/backend/.libs/libsane-genesys.so.1.0.25*
lrwxrwxrwx 1 root root 79 Mar 11 21:22 libsane-genesys.so.1 -> /home/fermulator/projects/sane-backends/backend/.libs/libsane-genesys.so.1.0.25*
lrwxrwxrwx 1 root root 79 Mar 11 21:22 libsane-genesys.so.1.0.25 -> /home/fermulator/projects/sane-backends/backend/.libs/libsane-genesys.so.1.0.25*
-rw-r--r-- 1 root root 537056 Oct 24 21:43 libsane-genesys.so.1.0.27

--

then unplug + replug scanner - BOOM FIXED (WORKAROUND)

--

whenever it _does_ finally get fixed, hopefully the next package installation will wipe my lib symlinks automatically

genti (pashol) wrote :

Yes, it's working for me with 1.0.27. I compiled from the same Git source like you. I own a CanoScan LIDE 200.

The problem was obviously the use of rewind instead of slow_back_home (see posted link). In the source I compiled it was using slow_back_home again at the very specific position mentioned in the link I posted earlier (somewhere around line 2069).

sane-config --version says that I have 1.0.27 installed.

Helmut Tischer (htischer) wrote :

@genti
On 16-Mar-2018 the last commit here was 9 months ago and this still shows the rewind:
https://gitlab.com/sane-project/backends/commits/master/backend/genesys.c
So, where did you commit your precious fix?
How to achieve that this fix gets picked up by future ubuntu updates and upgrades?

ramas (slocascio) wrote :

This bug is serious for me as I use my scanner everyday.

I am under Lubuntu 17.10.

For who like me cannot wait the official patch, can follow how I did solve:

1. get the source not from git but from the official package manager with command:
apt-get source libsane1
it did download and create the directory sane-backends-1.0.27/

2. modify the lines 2075-2077 of file sane-backends-1.0.27/backend/genesys.c into:
  if (dev->model->flags & GENESYS_FLAG_SHADING_REPARK && dev->model->cmd_set->slow_back_home)
    {
      status = dev->model->cmd_set->slow_back_home (dev, dev->model->flags );

3. build the dependencies with command:
 sudo apt-get build-dep libsane1

4. I had to copy the file /usr/share/aclocal/libtool.m4 into sane-backends-1.0.27/m4 as the build process complained it was missing

5. then build the fixed package with command:
  cd sane-backends-1.0.27
  dpkg-buildpackage -rfakeroot -uc -b

6. then install the updated package with command:
  cd ..
  sudo dpkg -i libsane1_1.0.27-1~experimental2ubuntu2.1_amd64.deb

7. I did restart my PC (but I do not know if this is necessary)

8. My simple-scan gui program did output a clean scan!!

reference here: https://askubuntu.com/questions/28372/how-do-i-get-and-modify-the-source-code-of-packages-installed-through-apt-get/28373#28373

Dirk Werner (geckpi) wrote :

@ramas

This worked out very nice for me with Ubuntu 17.10. Thanks for your work!

Alec B (castegere) wrote :

@ramas

Excellent instructions, worked perfectly for my Lide 200 flatbed.

In step 4, The missing m4 files don't need to be copied if you run ./configure first.

e.g.
sane-backends-1.0.27 $ ./configure --help

giuliano (syntaxb) wrote :

Excellent instructions, but too difficult for a newbe. May I hope that some official ubuntu update will fix the bug?

Ralef (ralef) wrote :

It is still the same problem under (x)ubuntu 18.04 and Scanlide 100.
libsane version is here 1.0.27-1.
The whole problem is very disappointing!

This problem has just arisen, with my Canon Lide 200, on a recently installed Ubuntu 18.04. The scanner worked fine with Ubuntu 16.04 and still works under Winblows.

Giovanni Pelosi (hute37-gmail) wrote :

same problem with

Package: libsane-common
Version: 1.0.27-1~experimental3ubuntu2

on

Ubuntu 18.04

Saarloop (winfried100) wrote :

Since ubuntu 17.10 I had always to switch to Windows 10 for using my Canon LIDE 100 because of the vertical central black line.
Before deciding to change finally my scanner, i looked again to this page and saw the remark of genti in date of 2018-03-07.
Under ubuntu 18.10 I realized the following steps without a new start:
   1) uninstall by synaptic: sane, xsane, xsane-common
   2) reinstall by synaptic: sane, xsane, xsane-common
Now my LIDE 100 is working fine using gscan2pdf without black line as the years before 17.04!
I don't know which of the three reinstalled applications resolved the problem.

Saarloop (winfried100) wrote :

I'm very sorry, but I was only lucky for about 10 correct clean scans after my above described reinstalling. Then the black line reappeared immediately after scan before the correction by the software (repositioning). So the result was always ok. But then I got two errors:
   1) Warning running unpaper: out of deviation range - NO ROTATION
   2) Error running unpaper: [image@0x561bb2222ea80] Using AVStream.codec to pass codec parameters
      to muxers is depreciated, use AVStream.codecpar unstead.
      [image@0x561bb2222ea80] Encoder did not produce proper pts, making some up.
The result of the scan was then shifted horizontally about 5 cm on my paper towards the left and this didn't move even changing all various parameters. The black line disappears but the page in not complete.
So for the moment I have to go back to Windows only for scanning.
There seems an error in unpaper, software applicated immediately after the scan, because I can see the original scan with black line just before.

giuliano (syntaxb) wrote :

After uninstalling from terminal sane, xsane, xsane-common and reinstalling them the black bar just became a coloured bar.

fermulator (fermulator) on 2018-08-12
summary: genesys_gl847 scanners produce a black band in scanned images on Ubuntu
- 17.10
+ 17.10+ (and 18.04 LTS)

how do we get this fixed upstream?
submitted: https://salsa.debian.org/debian/sane-backends/merge_requests/1

I accepted that Ubuntu 17.10 (non-LTS) had this bug, but it's still present in 18.04 (outrageous ;o) ... can we downgrade sane-backends on Ubuntu LTS?

--

repeating: (as per my workaround notes above
 -> https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1731459/comments/13

--

BAH;

 The alioth.debian.org service is discontinued. Its replacement is a GitLab instance at salsa.debian.org.

replace
 -> https://salsa.debian.org/debian/sane-backends
```
git clone https://salsa.debian.org/debian/sane-backends.git
```

--
ah, I see better workaround instructions since then;
 -> https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1731459/comments/16

--

information type: Public → Public Security
information type: Public Security → Public
fermulator (fermulator) wrote :

couldn't overwrite the existing

$ sudo dpkg -i libsane1_1.0.27-1~experimental3ubuntu2_amd64.deb
Selecting previously unselected package libsane1:amd64.
(Reading database ... 563959 files and directories currently installed.)
Preparing to unpack libsane1_1.0.27-1~experimental3ubuntu2_amd64.deb ...
Unpacking libsane1:amd64 (1.0.27-1~experimental3ubuntu2) over (1.0.27-1~experimental3ubuntu2) ...
dpkg: error processing archive libsane1_1.0.27-1~experimental3ubuntu2_amd64.deb (--install):
 trying to overwrite shared '/usr/share/doc/libsane1/changelog.Debian.gz', which is different from other instances of package libsane1:amd64
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for udev (237-3ubuntu10.3) ...
Errors were encountered while processing:
 libsane1_1.0.27-1~experimental3ubuntu2_amd64.deb

fermulator (fermulator) wrote :

(had to move the conflicting file)

fermulator (fermulator) wrote :

which is the correct project to submit this bug to upstream?

Yury Yatsynovich (y-v) wrote :

I've recently had the same problem of vertical black stripes on scans from my Canon imageCLASS MF244DW under Ubuntu 18.04.1. Compiling and installing sane-backends from https://github.com/kkaempf/sane-backends solved the problem.

The checkin comment refers to flags - does that mean that there's some
configuration that can be set for our scanners to avoid this behavior?

On Sun, Sep 30, 2018 at 8:05 AM fermulator <email address hidden>
wrote:

> Found one! upstream: https://gitlab.com/sane-project/backends/issues/7
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1731459
>
> Title:
> genesys_gl847 scanners produce a black band in scanned images on
> Ubuntu 17.10+ (and 18.04 LTS)
>
> Status in sane-backends package in Ubuntu:
> Confirmed
>
> Bug description:
> On Windows it works but on my Ubuntu 17.10 I see a black band on
> scanned image. The scanner is Canon CanoScan LIDE100. Libsane version
> is 1.0.27-1~experimental2ubuntu1
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1731459/+subscriptions
>

FYI, @ramas (slocascio), fermulator (fermulator) and Alec B (castegere) instructions - slightly updated and automated for Ubuntu 18.04.1 (libsane1_1.0.27-1~experimental3).

Also, I expanded the patch to test for both "slow_back_home" and "rewind", just in case it matters for some hardware.

--- cut here ---

# in Synaptic, Ubuntu Settings >> Repositories, enable "Source code"
apt-get source libsane1

# eyeball first
patch sane-backends-1.0.27/backend/genesys.c --dry-run < genesys.c.diff

# if the above was successful
patch sane-backends-1.0.27/backend/genesys.c < genesys.c.diff

sudo apt-get build-dep libsane1
cd sane-backends-1.0.27
./configure
sudo apt-get install fakeroot
dpkg-buildpackage -rfakeroot -uc -b
cd ..

sudo rm /usr/share/doc/libsane1/changelog.Debian.gz
sudo dpkg -i libsane1_1.0.27-1~experimental3ubuntu2_amd64.deb
# reboot

--- cut here ---

The attachment "genesys.c.diff" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
summary: genesys_gl847 scanners produce a black band in scanned images on Ubuntu
- 17.10+ (and 18.04 LTS)
+ 17.10+, 18.04 LTS and 18.10 Cosmic cutlefish
summary: genesys_gl847 scanners produce a black band in scanned images on Ubuntu
- 17.10+, 18.04 LTS and 18.10 Cosmic cutlefish
+ 17.10+, 18.04 LTS and 18.10 Cosmic cuttlefish
description: updated

Same problem in Ubuntu 18.10

Craig Gilding (slasherx2) wrote :

Also having the same problem. Compiling from git as per instructions didn't solve for me either. Not sure what I've done wrong

Gabriel N. (gary17) wrote :

Slightly updated patch instructions from above.

--- CUT HERE ---

sudo apt-get install dpkg-dev fakeroot

# in Synaptic, Ubuntu Settings >> Repositories, enable "Source code"
apt-get source libsane1

# eyeball first for any error messages
patch sane-backends-1.0.27/backend/genesys.c --dry-run < genesys.c.diff

# if the above was successful
patch sane-backends-1.0.27/backend/genesys.c < genesys.c.diff

sudo apt-get build-dep libsane1
cd sane-backends-1.0.27
./configure
dpkg-buildpackage -rfakeroot -uc -b
cd ..

sudo rm /usr/share/doc/libsane1/changelog.Debian.gz
sudo dpkg -i libsane1_1.0.27-1~experimental3ubuntu2_amd64.deb
# reboot

--- CUT HERE ---

Also:

- If any of the steps above fails, examine the entire output carefully line by line for error information about any possible missing packages, e.g. "Check if the 'dpkg-dev' package is installed". Simply use "sudo apt-get install <package>" to install anything that is missing.

- Unless you lock the libsane1 package in apt ("sudo apt-mark hold <package>") and in Synaptic (Synaptic >> Package >> Lock Version), your next automated or manual Ubuntu update might re-install the original, unpatched libsane1 package. Those two package maintenance systems use independent locking mechanisms that are not synchronized.

Kamrul Hasan (ntackbd) on 2019-01-04
affects: sane-backends (Ubuntu) → prj20071101
hector (hector-abella) wrote :

Hi everyone,

Same problem with Canoscan Lide 200 after updating to Ubuntu 18.04 (before it worked fine).

hector (hector-abella) wrote :

Same problem with CanoScan Lide 200 after upgrading to Ubuntu 18.04 (before it worked fine).

VasiliyTerkin (hein911) wrote :

Добрый день! У меня RICOH Aficio SP 100su, как мне это МФУ запустить на Mint 19.01!

David Förster (leicester86) wrote :

Hi guys

Same problem still exists here with CanoScan Lide 100 on Xubuntu 18.04. Will it be fixed in the near future or is patching on my own the only alternative?

Ralef (ralef) wrote :

Hi everyone,
I solved the problem for me very practicaly. I create a virtual machine (VirtualBox) with an xubuntu 16.04 to scan my documents. Yes ist takes more drivespeed then patching the code, but I think it is much easier then everything else.
It is a shame that older hardware is treated like this! The scanner is still absolutely sufficient for most of the uses!

fermulator (fermulator) wrote :

https://gitlab.com/sane-project/backends/issues/7 has been fixed!
Now to pull into ubuntu repos and backmerge fore LTS please.

fermulator (fermulator) wrote :

Also note:
https://gitlab.com/sane-project/backends/merge_requests/34#note_141760446
> applied the patches 4354fc7f to sane-backends_1.0.27-1~experimental3ubuntu2 (Ubuntu 18.04 LTS) to build the package for this distro.

, so perhaps that action is already done?

Roger (antarex882) wrote :

Adding this ppa should resolve the issue (as it includes the patch 4354fc7f):
ppa:rolfbensch/sane-git

Ralef (ralef) wrote :

This ppa didn't work for me. After the update I have still this black stripe in the scan. Scanner is a ScanLide 100.
Very disappointing.

Roger (antarex882) wrote :

And you are using one of the supported systems?
I am running Ubuntu 18.04 and the ppa does the trick when I am testing.

The PPA also worked for me (Ubuntu 18.04)

On Thu, Apr 4, 2019 at 10:50 AM Roger <email address hidden> wrote:

> And you are using one of the supported systems?
> I am running Ubuntu 18.04 and the ppa does the trick when I am testing.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1731459
>
> Title:
> genesys_gl847 scanners produce a black band in scanned images on
> Ubuntu 17.10+, 18.04 LTS and 18.10 Cosmic cuttlefish
>
> Status in prj20071101:
> Confirmed
>
> Bug description:
> On Windows it works but on my Ubuntu 17.10, 18.04 and 18.10 I see a
> black band on scanned image. The scanner is Canon CanoScan LIDE100.
> Libsane version is 1.0.27-1~experimental2ubuntu1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/prj20071101/+bug/1731459/+subscriptions
>

Ralef (ralef) wrote :

Hi, my system is a Xubuntu 18.10.
The weird thing is, now it works! I don't now why. I restarded the system several times before without success, but now, everything seems to be good!
Maybe beacause I always restarted with the scanner on the USB port..
After that I pluged out the scanner and waited several starts. When I read your message now, I pluged it in again and it worksnow! Thanks.

Simon Repp (simonrepp) wrote :

Unfortunately need to add that this issue persists for me in 19.04, in my case using a CanoScan Lide 200.

libsane version in my case is: 1.0.27-3.2ubuntu1

I tried updating to a patched version from the suggested ppa https://launchpad.net/~rolfbensch/+archive/ubuntu/sane-git, this seems like a viable option but anyhow I could not actually update from the ppa because of apparently unresolvable depdendencies in apt-get (running the update would at the same time require apt to remove certain ubuntu core packages, at least in my system constellation and I'm not going to try this).

Bottom line is I recommend anyone else affected to try updating from the ppa, and I'd be happy to see this bugfix picked up in the official ubuntu repositories sometime. :) thanks, appreciate everyone's efforts!

axion (bugzilla-axion) wrote :

Btw it's not a black band but an inverted band, that is everything in the path of the band is inverted in color.

affects: prj20071101 → sane-backends (Ubuntu)
description: updated
Changed in sane-backends (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: Confirmed → In Progress
Changed in sane-backends (Ubuntu Bionic):
importance: Undecided → Medium
status: New → In Progress
Changed in sane-backends (Ubuntu Disco):
importance: Undecided → Medium
status: New → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

Let's give it a try to get this fixed. I have put proposed uploads in a PPA, and asked for sponsorship to have them uploaded.

There is a but, though: I don't have an affected device, so I can't verify that the uploads fix the issue. The eoan upload will likely make it, but if the disco and bionic uploads won't get stuck in -proposed, some users who have access to an affected device need to help with the verification.

So your help will be needed. You'll get notified when it's time to verify.

CoderGuy (alec-bickerton) wrote :

I have a device, could you share a link to the PPA?

Gunnar Hjalmarsson (gunnarhj) wrote :

Sure. https://launchpad.net/~gunnarhj/+archive/ubuntu/sane-backends

(it's in the bug description too)

If you test from the PPA, it will need to be done later too (when it's in -proposed). Not saying it's unnecessary; on the contrary a pre-verification is very useful. If it would fail, we wouldn't need to bother any sponsor with uploading.

Simon Repp (simonrepp) wrote :

Hey Gunnar,

Thanks so much for picking this up! I attempted the mentioned pre-verification on a relatively fresh 19.04/Disco installation (specifically: one without any manual changes to the system-installed sane packages and repositories).

However I got an error that seems to be related to the ppa itself, not the patch per se. Any directions from here? Thanks!

-----------------------------

simon@interbliss:~$ sudo add-apt-repository ppa:gunnarhj/sane-backends
[sudo] password for simon:

 More info: https://launchpad.net/~gunnarhj/+archive/ubuntu/sane-backends
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 http://at.archive.ubuntu.com/ubuntu disco InRelease
Hit:2 http://at.archive.ubuntu.com/ubuntu disco-updates InRelease
Hit:3 https://deb.nodesource.com/node_12.x disco InRelease
Hit:4 http://at.archive.ubuntu.com/ubuntu disco-backports InRelease
Ign:5 http://ppa.launchpad.net/gunnarhj/sane-backends/ubuntu disco InRelease
Hit:6 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu disco InRelease
Hit:7 http://security.ubuntu.com/ubuntu disco-security InRelease
Err:8 http://ppa.launchpad.net/gunnarhj/sane-backends/ubuntu disco Release
  404 Not Found [IP: 91.189.95.83 80]
Hit:9 https://packagecloud.io/AtomEditor/atom/any any InRelease
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/gunnarhj/sane-backends/ubuntu disco Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Simon: That's because I had been lazy and not uploaded to disco (since it's identical with the package version in eoan). But I just uploaded to disco, so now (i.e. in a few minutes) you should be able to do:

sudo apt update

to fix it.

My apologies.

Simon Repp (simonrepp) wrote :

No worries :) I now retried and it worked perfectly - thanks!

More importantly I can confirm the update from your ppa solves the issue on Ubuntu 19.04 (I did before/after testing with a CanoScan LiDE 200).

I will gladly test again when required, thanks for the initiative!

Gunnar Hjalmarsson (gunnarhj) wrote :

@Simon: That's indeed good news. Then we know that this update will make a difference. Thanks!

CoderGuy (alec-bickerton) wrote :

@Gunnar,

I've just verified the package in the PPA and like Simon I can say that it resolves the issue on LiDE 200 devices. I made 10 scans and the bar was not present in any of the images.

Gunnar Hjalmarsson (gunnarhj) wrote :

@CoderGuy: Excellent!

Then we need a sponsor so this update can move forward. I'll try to ping someone on Monday, if nothing happens before then.

Ananth P (ananthp) wrote :

@gunnarhj I have `CanoScan LiDE 100` scanner with this problem on 18.04.3 LTS (bionic). I tried the above mentioned PPA. It does not solve the issue.

`libsane-common` version is `1.0.27-1~experimental3ubuntu2.2~ppa`. I see version `1.0.27-3.2...` for later ubuntu versions which is not available for bionic.

If the fix is posted in PPA for bionic, I can verify and provide the status here.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Ananth: That was disappointing, but thanks for letting us know. The version you mentioned for bionic has the very same patch as the disco and eoan versions, so the (attempt at a) fix is already in the PPA for bionic.

Simon's successful test was on 19.04.

@CoderGuy: Which Ubuntu version did you test on?

As regards LiDE 100 I see in the discussion on the upstream merge request that Jens Böttge explicitly confirmed that the patch worked when applied to the bionic version of sane-backends.

https://gitlab.com/sane-project/backends/merge_requests/34#note_141760446

Simon Repp (simonrepp) wrote :

@Ananth, @Gunnar: I wanted to cross-verify that the patch works for LiDE 200 on bionic 18.04.3 - To do this I booted from a fresh bionic live usb stick and installed the patch from ppa in the live session. However what I discovered is that this does not work on bionic AND also does not work on a disco live session (which I tried then too to make sure it is not a live session related issue).

Maybe you were already aware that testing it this way wouldn't work at all, but just for the record in case you weren't and so that everyone else knows that verifying this on a live session is (apparently) not possible.

I got these packages installed from ppa in the two live sessions just for reference/checking:
sane-utils/bionic,now 1.0.27-1~experimental3ubuntu2.2~ppa amd64 [installed, automatic]
sane-utils/disco,now 1.0.27-3.2ubuntu1.1~ppa amd64 [installed, automatic]

sponsored in bionic and disco, after removing "~ppa" from the changelog

and eoan, of course

CoderGuy (alec-bickerton) wrote :

@Gunnar,

I've tested on my main PC.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sane-backends - 1.0.27-3.2ubuntu2

---------------
sane-backends (1.0.27-3.2ubuntu2) eoan; urgency=medium

  * debian/patches/git-fix-discolored-bar-issue.patch:
    - Upstream commit to fix issue with discolored bar on Genesys GL847
      scanners (LP: #1731459).

 -- Gunnar Hjalmarsson <email address hidden> Thu, 08 Aug 2019 20:27:00 +0200

Changed in sane-backends (Ubuntu):
status: In Progress → Fix Released

Hello dbazza, or anyone else affected,

Accepted sane-backends into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sane-backends/1.0.27-3.2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in sane-backends (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Changed in sane-backends (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Steve Langasek (vorlon) wrote :

Hello dbazza, or anyone else affected,

Accepted sane-backends into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sane-backends/1.0.27-1~experimental3ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Gunnar Hjalmarsson (gunnarhj) wrote :

At last the change is in -proposed, so it's time for the real verification.

We need at least one positive verification for disco-proposed and one for bionic-proposed. I understand that @CoderGuy is on bionic and @Simon on disco. May I ask you guys to please test again, but this time with the packages from -proposed? (Needless to say, testing by other affected users works too.)

@Ananth, you never followed up. It would of course be best if the change made a difference for you too. OTOH, to be approved and thus moved to -updates, it's sufficient that the change has proved to address the bug for some users. We may of course not cause a regression, i.e. introduce some issue which wasn't there before, but I think the risk for that is very low.

Simon Repp (simonrepp) wrote :

@vorlon, @gunnarhj:

I added disco-proposed and downgraded the relevant packages to these versions:
---
libsane-common/disco-proposed,disco-proposed,now 1.0.27-3.2ubuntu1.1 all [installed,automatic]
libsane/disco-proposed,now 1.0.27-3.2ubuntu1.1 amd64 [installed]
sane-utils/disco-proposed,now 1.0.27-3.2ubuntu1.1 amd64 [installed,automatic]

Rebooting and then scanning a page on CanoScan LiDE 200 resulted in the expected result, an error-free scan. \o/

Therefore: Verified on disco.

Many thanks for your efforts!

tags: added: verification-done-disco
removed: verification-needed-disco
Ananth P (ananthp) wrote :

@gunnarhj I tested the ppa and bionic-propsed a machine with fresh clean install of bionic with CanoScan LIDE 100. The issue is *not* fixed on this machine.

Here are the details of my testing:

I switched back and forth between distro-default, ppa and bionic-proposed versions of libsane-common (and libsane1), restarted the machine etc.

PPA

After adding ppa, I run apt upgrade which updated these libsane-common, libsane1, sane-utils packages to

```
libsane-common/bionic,bionic,now 1.0.27-1~experimental3ubuntu2.2~ppa all [installed,automatic]
libsane1/bionic,now 1.0.27-1~experimental3ubuntu2.2~ppa amd64 [installed,automatic]
sane-utils/bionic,now 1.0.27-1~experimental3ubuntu2.2~ppa amd64 [installed,automatic]

```

I did a test scan. Colored bar still appeared. I restarted the system (or should I have restarted some sane service?). Tried scanning again. Issue still exists.

To go back to distro default, I removed the ppa and libsane-common. This removed a whole bunch of dependencies including ubuntu-desktop and simple-scan. Reinstalling ubuntu-desktop brought libsane-common etc back. Scanned a page again to see if there are any surprises. None. The problem still existed.

BIONIC-PROPOSED

I enabled bionic-proposed channel repo. It showed a whole bunch of updates. I had to pin the packages and install libsane-common/bionic-proposed and sane-utils/bionic-proposed.

package versions after this:
libsane-common/bionic-proposed,bionic-proposed,now 1.0.27-1~experimental3ubuntu2.2 all [installed]
libsane1/bionic-proposed,now 1.0.27-1~experimental3ubuntu2.2 amd64 [installed]
sane-utils/bionic-proposed,now 1.0.27-1~experimental3ubuntu2.2 amd64 [installed]

The problem persisted during immediate scan and after a restart.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for testing again, @Ananth. Then we'll have to notice that the fix does not help in all cases, unfortunately.

Assuming that the change doesn't make it worse for you somehow, and if @CoderGuy or someone else verifies it for 18.04, it will still be considered verified. Better improve it for some users than not at all.

I have no idea what needs to be done to make the bar disappear from your scans too. I simply applied an upstream commit which other users pointed at. Version 1.0.28 has been released upstream, and it's being worked on to package it for Debian/Ubuntu. Possibly it will include something that fixes it also for you. OTOH I don't think it will be easy to install 1.0.28 on bionic, but to test the new upstream an upgrade of Ubuntu will probably be preferable.

Ananth P (ananthp) wrote :

Thanks for your efforts @gunnarhj. I'm glad that the fix helps many users. If I come across any hack that solves the issue on my machine, I'll update here.

All autopkgtests for the newly accepted sane-backends (1.0.27-1~experimental3ubuntu2.2) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

colord/unknown (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#sane-backends

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

All autopkgtests for the newly accepted sane-backends (1.0.27-3.2ubuntu1.1) for disco have finished running.
The following regressions have been reported in tests triggered by the package:

libkf5sane/unknown (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/disco/update_excuses.html#sane-backends

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Changed in sane-backends:
status: Unknown → Fix Released
Roger (antarex882) wrote :

I had a major crash on mu Ubuntu Budgie system and had to reinstall using a Ubuntu Budgie 18.04.3 iso. I used the god old ppa from Rolf Bensch: ppa:rolfbensch/sane-git which again solved the problem on my Canon Lide 100 scanner. Version 1.0.28 of libsane seems to do the trick.

Changed in sane-backends (Debian):
status: Unknown → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

As regards the autopkgtest regression reports in comment #75 and #76:

colord has passed autopkgtest for bionic/armhf several times, the latest at 2019-08-23.

Likewise, libkf5sane has passed autopkgtest for disco/armhf several times, the latest at 2019-07-01.

Seems like simply re-running the tests might help. Can somebody in the SRU team please do that?

Gunnar Hjalmarsson (gunnarhj) wrote :

A week has soon passed since the new version was built in bionic-proposed, but no final verification yet. @CoderGuy, any chance that you can test the bionic-proposed packages? Anybody else?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sane-backends - 1.0.27-3.2ubuntu1.1

---------------
sane-backends (1.0.27-3.2ubuntu1.1) disco; urgency=medium

  * debian/patches/git-fix-discolored-bar-issue.patch:
    - Upstream commit to fix issue with discolored bar on Genesys GL847
      scanners (LP: #1731459).

 -- Gunnar Hjalmarsson <email address hidden> Thu, 08 Aug 2019 21:21:00 +0200

Changed in sane-backends (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for sane-backends has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

paul (paulgault-r) wrote :

my scanner = Canoscan LiDE 100
couldn't use this scanner on 18.04 at all without getting a thick black line in the output.
not a massive issue so far as it still worked ok on a 16.04 machine we've got.
After checking back into this conversation today i tried to scan again on 18.04, issue was not resolved but then i tried the ppa mentoned above in comment #77
sudo add-apt-repository ppa:rolfbensch/sane-git
sudo apt-get dist-upgrade
tried again and bingo! black line has gone.
Thank you to everyone involved!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.