package libsane1 1.0.27-1~experimental2ubuntu1: multiarch packages with differing files '/lib/udev/hwdb.d/20-sane.hwdb'

Bug #1725928 reported by MV on 2017-10-22
This bug affects 700 people
Affects Status Importance Assigned to Milestone
sane-backends (Debian)
Fix Released
Unknown
sane-backends (Ubuntu)
High
Unassigned

Bug Description

****************
From #3 comment below, to get a workaround, try:

sudo apt-get -o Dpkg::Options::="--force-overwrite" install --reinstall libsane1:i386 (or your real package name)

***************
Has been fixed with:

sane-backends (1.0.27-1~experimental3ubuntu2) bionic; urgency=medium

  * debian/rules: Drop timestamps from conflicting multiarch:same files
    hwdb.d/20-sane.hwdb and rules.d/60-libsane1.rules (closes: #880391)

 -- Adam Conrad <email address hidden> Sat, 03 Feb 2018 14:26:39 -0700
***************

apport error this morning.

ProblemType: Package
DistroRelease: Ubuntu 17.10
Package: libsane1 1.0.27-1~experimental2ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
Date: Sun Oct 22 09:37:46 2017
DuplicateSignature:
 package:libsane1:1.0.27-1~experimental2ubuntu1
 Unpacking libsane1:i386 (1.0.27-1~experimental2ubuntu1) ...
 dpkg: error processing archive /tmp/apt-dpkg-install-edJWJn/5-libsane1_1.0.27-1~experimental2ubuntu1_i386.deb (--unpack):
  trying to overwrite shared '/lib/udev/hwdb.d/20-sane.hwdb', which is different from other instances of package libsane1:i386
ErrorMessage: trying to overwrite shared '/lib/udev/hwdb.d/20-sane.hwdb', which is different from other instances of package libsane1:i386
InstallationDate: Installed on 2016-10-08 (378 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
Python3Details: /usr/bin/python3.6, Python 3.6.3, python3-minimal, 3.6.3-0ubuntu2
PythonDetails: /usr/bin/python2.7, Python 2.7.14, python-minimal, 2.7.14-2ubuntu1
RelatedPackageVersions:
 dpkg 1.18.24ubuntu1
 apt 1.5
SourcePackage: sane-backends
Title: package libsane1 1.0.27-1~experimental2ubuntu1 failed to install/upgrade: trying to overwrite shared '/lib/udev/hwdb.d/20-sane.hwdb', which is different from other instances of package libsane1:i386
UpgradeStatus: Upgraded to artful on 2017-10-20 (1 days ago)

MV (mvidal) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sane-backends (Ubuntu):
status: New → Confirmed
ChaiTan3 (chaitukca) wrote :

Using the following extra option in apt-get bypasses the problem.

-o Dpkg::Options::="--force-overwrite"

Lukas Mast (staggx) wrote :

@ChaiTan3 great, it's work

libsane1 is marked as "Multi-Arch: same", but the contents of /lib/udev/hwdb.d/20-sane.hwdb are different among architectures:

$ dpkg-deb --control /var/cache/apt/archives/libsane1_1.0.27-1~experimental2ubuntu1_amd64.deb amd64/
$ dpkg-deb --control /var/cache/apt/archives/libsane1_1.0.27-1~experimental2ubuntu1_i386.deb i386/
$ grep 20-sane.hwdb amd64/md5sums
822a0103c173599c49c01c41e7431450 lib/udev/hwdb.d/20-sane.hwdb
$ grep 20-sane.hwdb i386/md5sums
ed74da55eee3cbfee774e04f55669d28 lib/udev/hwdb.d/20-sane.hwdb

So, this is a bug in this package's packaging. I'll change the header to reflect this.

summary: - package libsane1 1.0.27-1~experimental2ubuntu1 failed to
- install/upgrade: trying to overwrite shared
- '/lib/udev/hwdb.d/20-sane.hwdb', which is different from other instances
- of package libsane1:i386
+ package libsane1 1.0.27-1~experimental2ubuntu1: multiarch packages with
+ differing files
Tom Rausner (tom-rausner) wrote :

please fix this. I'm very deep need of scanning abitity.

@tom-rausner: This should not affect your ability to scan. As long as libsane1:amd64 is installed (and it has to be installed otherwise this error won't be given), you should be able to scan using normal scanner application. (Unless you need a 32-bit driver, then you'll have to uninstall libsane1:amd64 and install libsane1:i386 along with i386 version of scanner application instead)

BTW, this seems to be reported at Debian's bugtracker already. However, as the version which this package in Ubuntu is based upon is in experimental, we'll have to see if this will be fixed anytime soon in Debian.

dino99 (9d9) on 2017-12-10
description: updated
Changed in sane-backends (Debian):
status: Unknown → New
Manfred Hampl (m-hampl) wrote :

In Ubuntu the differences in /lib/udev/hwdb.d/20-sane.hwdb from libsane1 1.0.27-1~experimental2ubuntu1 are

amd64:
# This file was automatically created based on description files (*.desc)
# by sane-desc 3.5 from sane-backends 1.0.27 on Fri Oct 27 06:58:13 2017
...

i386:
# This file was automatically created based on description files (*.desc)
# by sane-desc 3.5 from sane-backends 1.0.27 on Fri Oct 27 06:54:18 2017
...

In fact just the date/time information in the header comment differs, all other contents of the 20-sane.hwdb file are identical.

Arnoldus (arnoldus) wrote :

@ ChaiTan3 | 2017-10-23:
Tnx, worked!

dino99 (9d9) on 2018-01-26
description: updated

The Workaround in https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1725928/comments/3, explained in bug description works fine for me too. Thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unattended-upgrades (Ubuntu):
status: New → Confirmed
Joe Ferrari (almostamyth) wrote :

I got it straightened out folks. Thank you for the replies. I had to remove the previous version of Wine in order to install the newer version.

Changed in sane-backends (Ubuntu):
importance: Undecided → High
summary: package libsane1 1.0.27-1~experimental2ubuntu1: multiarch packages with
- differing files
+ differing files '/lib/udev/hwdb.d/20-sane.hwdb'
otec (otecasynove) on 2018-02-07
Changed in sane-backends (Ubuntu):
assignee: nobody → otec (otecasynove)
dino99 (9d9) on 2018-03-09
description: updated
Changed in sane-backends (Ubuntu):
assignee: otec (otecasynove) → nobody
Changed in unattended-upgrades (Ubuntu):
status: Confirmed → Invalid
Changed in unattended-upgrades (Ubuntu):
status: Invalid → Confirmed
dino99 (9d9) on 2018-03-18
no longer affects: unattended-upgrades (Ubuntu)
Cubic PPA (cubic-wizard) wrote :

I got this error on 64-bit machine, running Ubuntu 17.10, after I added i386 architecture and rebooted:

$ sudo dpkg --add-architecture i386

Changed in sane-backends (Debian):
status: New → Fix Committed
Rolf Leggewie (r0lf) wrote :

Closing as fixed in bionic

Changed in sane-backends (Ubuntu):
status: Confirmed → Fix Released
Changed in sane-backends (Debian):
status: Fix Committed → Fix Released
Laur (laufer07) on 2018-04-18
information type: Public → Public Security
information type: Public Security → Private Security
information type: Private Security → Public Security
information type: Public Security → Public

3Q

| |
邓寅
邮箱:waynesilver@163.com
|

签名由 网易邮箱大师 定制

在2018年05月01日 08:47,Seth Arnold 写道:
** Information type changed from Public Security to Public

--
You received this bug notification because you are subscribed to a
duplicate bug report (1730546).
https://bugs.launchpad.net/bugs/1725928

Title:
 package libsane1 1.0.27-1~experimental2ubuntu1: multiarch packages
 with differing files '/lib/udev/hwdb.d/20-sane.hwdb'

Status in sane-backends package in Ubuntu:
 Fix Released
Status in sane-backends package in Debian:
 Fix Released

Bug description:
 ****************
 From #3 comment below, to get a workaround, try:

 sudo apt-get -o Dpkg::Options::="--force-overwrite" install
 --reinstall libsane1:i386 (or your real package name)

 ***************
 Has been fixed with:

 sane-backends (1.0.27-1~experimental3ubuntu2) bionic; urgency=medium

   * debian/rules: Drop timestamps from conflicting multiarch:same files
     hwdb.d/20-sane.hwdb and rules.d/60-libsane1.rules (closes: #880391)

  -- Adam Conrad <email address hidden> Sat, 03 Feb 2018 14:26:39 -0700
 ***************

 apport error this morning.

 ProblemType: Package
 DistroRelease: Ubuntu 17.10
 Package: libsane1 1.0.27-1~experimental2ubuntu1
 ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
 Uname: Linux 4.13.0-16-generic x86_64
 NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
 ApportVersion: 2.20.7-0ubuntu3
 Architecture: amd64
 Date: Sun Oct 22 09:37:46 2017
 DuplicateSignature:
  package:libsane1:1.0.27-1~experimental2ubuntu1
  Unpacking libsane1:i386 (1.0.27-1~experimental2ubuntu1) ...
  dpkg: error processing archive /tmp/apt-dpkg-install-edJWJn/5-libsane1_1.0.27-1~experimental2ubuntu1_i386.deb (--unpack):
   trying to overwrite shared '/lib/udev/hwdb.d/20-sane.hwdb', which is different from other instances of package libsane1:i386
 ErrorMessage: trying to overwrite shared '/lib/udev/hwdb.d/20-sane.hwdb', which is different from other instances of package libsane1:i386
 InstallationDate: Installed on 2016-10-08 (378 days ago)
 InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
 Python3Details: /usr/bin/python3.6, Python 3.6.3, python3-minimal, 3.6.3-0ubuntu2
 PythonDetails: /usr/bin/python2.7, Python 2.7.14, python-minimal, 2.7.14-2ubuntu1
 RelatedPackageVersions:
  dpkg 1.18.24ubuntu1
  apt 1.5
 SourcePackage: sane-backends
 Title: package libsane1 1.0.27-1~experimental2ubuntu1 failed to install/upgrade: trying to overwrite shared '/lib/udev/hwdb.d/20-sane.hwdb', which is different from other instances of package libsane1:i386
 UpgradeStatus: Upgraded to artful on 2017-10-20 (1 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1725928/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.