Comment 12 for bug 1564778

Nish Aravamudan (nacc) wrote :

I setup a Trusty LXD, installed libsane and libsane-common and then manually updated source.list with the xenial repositories, including xenial-proposed. I then did `sudo apt-get update; sudo apt-get dist-upgrade` and the upgrade completed successfully (no error) with the following versions of libsane and libsane-common.

$ apt policy libsane libsane-common
libsane:
  Installed: 1.0.25+git20150528-1ubuntu2.16.04.1
  Candidate: 1.0.25+git20150528-1ubuntu2.16.04.1
  Version table:
 *** 1.0.25+git20150528-1ubuntu2.16.04.1 500
        500 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.25+git20150528-1ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages
libsane-common:
  Installed: 1.0.25+git20150528-1ubuntu2.16.04.1
  Candidate: 1.0.25+git20150528-1ubuntu2.16.04.1
  Version table:
 *** 1.0.25+git20150528-1ubuntu2.16.04.1 500
        500 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.25+git20150528-1ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages