Ubuntu

[Lucid] passwd reports a System Error when trying to change password

Reported by Philip Muškovac on 2010-03-28
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
High
Unassigned

Bug Description

I created a test user and wanted to change the password. What I got was:

# passwd test
passwd: System error
passwd: password unchanged

The strace output is attached.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: passwd 1:4.1.4.2-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-17-generic i686
Architecture: i386
Date: Sun Mar 28 13:27:24 2010
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: shadow

Philip Muškovac (yofel) wrote :
Ram Prasad (unixengineer) wrote :

Facing the same issue after upgrade to Ubuntu 10

$ sudo passwd myuser
passwd: System error
passwd: password unchanged

Johan (joh07) wrote :

The same problem here, also on Ubuntu Lucid. Eventually I also used usermod to unlock and clear (delete) the new user's password and make it usable with no password.

Philip Muškovac (yofel) on 2010-03-30
Changed in shadow (Ubuntu):
status: New → Confirmed
Milan Bouchet-Valat (nalimilan) wrote :

Same here. Using 'chpasswd' I get the same error, with a little more details:
> chpasswd: (user test) pam_chauthtok() failed, error:
> System Error

Changed in shadow (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High

The provided strace mentions windbind.

This looks to me as a duplicate of bug 546874.

Reporters: please check the resolution there.

affects: shadow (Ubuntu) → samba (Ubuntu)
Changed in samba (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers