Still unable to access unpassworded NTFS shares with 4.3.9 Fix

Bug #1579562 reported by Slee on 2016-05-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

original bug #1572876 was marked as fixed as it solved OP's issue, but it isn't working for me(and others reading through the comments)

Hello, I too was hit with this issue(https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1572876) on updating to 4.3.8, updated to 4.3.9 and still the same issue follows. Although my shares I'm trying to access aren't on another computer, but an external USB HDD on my router.

My external drive is NTFS with no password/share enabled, but in my router I set users' access(username/password) to access this external HDD. It worked fine prior to the 4.3.8 update, now when I try to access via Thunar, the login floater just keeps popping up not allowing me to access HDD.

I've even tried to set my user account in my router(HDD access) to match my Ubuntu account credentials, still fails.

I was on Xubuntu 14.04 when this update occurred, several days later I installed Xubuntu 16.04 and issue followed.

Thanks

Robie Basak (racb) on 2016-05-09
tags: added: regression-update
Marc Deslauriers (mdeslaur) wrote :

Perhaps your external drive doesn't support the ipc signing changes required to fix Badlock.

Could you try adding the following to your /etc/samba/smb.conf, in the [global] section, and then rebooting?:

client ipc signing = disabled

Slee (geo42) wrote :

Hi Marc, I added:
client ipc signing = disabled

directly under [global] in my smb.conf, rebooted as per your request, still same issue, I enter my credentials to access HDD and login floater just continues to popup.

Slee (geo42) wrote :

Hello again, is it possible it isn't a HDD issue, but Samba and my router's auth isn't working together? As I mentioned in main post, the HDD isn't shared or password protected, in my router's admin, I have to add users/passwords to access the HDD connected to router. Prior to the 4.3.8 update, I was able to access this HDD via Thunar over network, Thunar would prompt me to provide username/password to login and it worked.

Not sure if this really matters, just thought I'd point it out.

Thanks

Marc Deslauriers (mdeslaur) wrote :

Could you tell us what kind of router it is, in the off-chance that someone knows how to work around the issue?

Slee (geo42) wrote :

ASUS RT-AC66U

Screenshot of admin/samba/share in router:
http://storage8.static.itmages.com/i/16/0510/h_1462906652_6106863_d5be560ab6.jpeg

Marc Deslauriers (mdeslaur) wrote :

Could you try adding the following to your /etc/samba/smb.conf, in the [global] section, and then rebooting?:

client use spnego = no

Slee (geo42) wrote :

added new line, rebooted, login floater still pops up on each attempt to login

top of my [global]...

[global]
## As per Marc's request to see if ipc signing is the issue
client ipc signing = disabled
## 2nd request by Marc to try
client use spnego = no

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba (Ubuntu):
status: New → Confirmed
noisymime (josh-noisymime) wrote :

Am still seeing this issue on 14.04 as well. I logged bug #1582658 showing the samba log, which is giving the same error as in the original issue (bug #1572876).

I've also tried the 2 smb.conf options mentioned above by Marc, however neither resolved the issue.

Slee (geo42) wrote :

ok, seeing that the latest updates were causing problems with unpassworded NTFS shares...and the last update fixed it for some, my issue is still with accessing a drive on my router which is unpassworded ntfs.

I formatted a USB stick for ext3 and plugged it into the 2nd USB port on my router. The boxes I haven't updated to the past 2 previous updates can access it fine, this latest samba update(on this box) still won't connect to an ext3 formatted drive, so this issue(for external harddrives on routers) doesn't just affect just win shares

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers