Comment 39 for bug 1572876

Reinhard (reinhard-fink) wrote :

I am still blocked by the security-changes made in samba-4.3.8/9.

Here is an overview on my experience:

What was/is still WORKING:
Sambaserver (Ubuntu 11.10) with samba 3.5 works together with:
1. Windows 7 Clients in an NT-Domain
2. Ubuntu 14.04 Clients (samba 4.1.6) using
   "smbpasswd -D 10 -r smb01 -U teacher01" for password syncronisation.

BROCKEN on Ubuntu Client 14.04 and 16.04:
After update from samba 4.1.6 to 4.3.9 smbpasswd ... broken with:
Could not connect to machine <remotehost>: NT_STATUS_ACCESS_DENIED

What is WORKING in MY future network:
Sambaserver updated to 16.04 with samba 4.3.9 and Ubuntu 16.04 clients, then smbpasswd ... is OK.

BUT
this is NOT WORKING in MY future network:
1.
my standard user named "user" without an password (Flag [N ] in LDAP) can not access then new sambaserver.
that means: no NETLOGON, ..., but "user" can logged in and can even access a share on an other samba 4.1.6 server.
2.
other users with password, get all shares as expected BUT can not change their password.