libruby1.8: missing replaces/conflicts on rubyunit

Bug #14281 reported by Debian Bug Importer on 2005-03-20
4
Affects Status Importance Assigned to Milestone
ruby1.8 (Debian)
Fix Released
Unknown
ruby1.8 (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #300543 http://bugs.debian.org/300543

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #300543 http://bugs.debian.org/300543

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 20 Mar 2005 14:12:03 +0100
From: Yann Dirson <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: libruby1.8: missing replaces/conflicts on rubyunit

Package: libruby1.8
Version: 1.8.2-2
Severity: serious

Preparing to replace libruby1.8 1.8.2-2 (using .../libruby1.8_1.8.2-3_i38=
6.deb) ...
Unpacking replacement libruby1.8 ...
dpkg: error processing /var/cache/apt/archives/libruby1.8_1.8.2-3_i386.de=
b (--unpack):
 trying to overwrite `/usr/lib/ruby/1.8/rubyunit.rb', which is also in pa=
ckage rubyunit
dpkg-deb: subprocess paste killed by signal (Broken pipe)

Since rubyunit is not even in sarge any more, I suppose new ruby
packages should replace/conflict with it, to ensure its removal.

Currently it would break upgrades from woody when that package is
installed.

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i586)
Kernel: Linux 2.4.27-k6
Locale: LANG=3DC, LC_CTYPE=3Dfran=E7ais (charmap=3DISO-8859-1)

Versions of packages libruby1.8 depends on:
ii libc6 2.3.2.ds1-20 GNU C Library: Shared librar=
ies an

-- no debconf information

--=20
Yann Dirson <email address hidden> |
Debian-related: <email address hidden> | Support Debian GNU/Linux:
                                    | Freedom, Power, Stability, Gratis
     http://ydirson.free.fr/ | Check <http://www.debian.org/>

Yann Dirson wrote:
> Package: libruby1.8
> Version: 1.8.2-2
> Severity: serious
>
> Preparing to replace libruby1.8 1.8.2-2 (using .../libruby1.8_1.8.2-3_i386.deb) ...
> Unpacking replacement libruby1.8 ...
> dpkg: error processing /var/cache/apt/archives/libruby1.8_1.8.2-3_i386.deb (--unpack):
> trying to overwrite `/usr/lib/ruby/1.8/rubyunit.rb', which is also in package rubyunit
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
>
>
> Since rubyunit is not even in sarge any more, I suppose new ruby
> packages should replace/conflict with it, to ensure its removal.
>
> Currently it would break upgrades from woody when that package is
> installed.

Debian does not have "rubyunit for Ruby 1.8" package.

  $ auto-apt search rubyunit.rb
  usr/lib/ruby/1.8/rubyunit.rb interpreters/libtest-unit-ruby1.8
  usr/lib/ruby/1.6/rubyunit.rb interpreters/libtest-unit-ruby1.6,interpreters/rubyunit

(libruby1.8_1.8.2-3 replaces libtest-unit-ruby1.8.)

--
akira yamada <URL:http://arika.org>

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 21 Mar 2005 00:03:05 +0900
From: akira yamada <email address hidden>
To: Yann Dirson <email address hidden>, <email address hidden>
Subject: Re: Bug#300543: libruby1.8: missing replaces/conflicts on rubyunit

Yann Dirson wrote:
> Package: libruby1.8
> Version: 1.8.2-2
> Severity: serious
>
> Preparing to replace libruby1.8 1.8.2-2 (using .../libruby1.8_1.8.2-3_i386.deb) ...
> Unpacking replacement libruby1.8 ...
> dpkg: error processing /var/cache/apt/archives/libruby1.8_1.8.2-3_i386.deb (--unpack):
> trying to overwrite `/usr/lib/ruby/1.8/rubyunit.rb', which is also in package rubyunit
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
>
>
> Since rubyunit is not even in sarge any more, I suppose new ruby
> packages should replace/conflict with it, to ensure its removal.
>
> Currently it would break upgrades from woody when that package is
> installed.

Debian does not have "rubyunit for Ruby 1.8" package.

  $ auto-apt search rubyunit.rb
  usr/lib/ruby/1.8/rubyunit.rb interpreters/libtest-unit-ruby1.8
  usr/lib/ruby/1.6/rubyunit.rb interpreters/libtest-unit-ruby1.6,interpreters/rubyunit

(libruby1.8_1.8.2-3 replaces libtest-unit-ruby1.8.)

--
akira yamada <URL:http://arika.org>

Matt Zimmerman (mdz) wrote :

rubyunit has never been in any Ubuntu release

On Mon, Mar 21, 2005 at 12:03:05AM +0900, akira yamada wrote:
> Debian does not have "rubyunit for Ruby 1.8" package.

# apt-cache policy rubyunit
rubyunit:
  Installed: (none)
  Candidate: 0.5.2-2
  Version Table:
     0.5.2-2 0
        500 ftp://ftp.debian.org woody/main Packages

IIRC, it was -2.1 I had installed. Obviously it was not for 1.8, but
there was still a conflict.

--
Yann Dirson <email address hidden> |
Debian-related: <email address hidden> | Support Debian GNU/Linux:
                                    | Freedom, Power, Stability, Gratis
     http://ydirson.free.fr/ | Check <http://www.debian.org/>

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Tue, 22 Mar 2005 08:46:18 +0100
From: Yann Dirson <email address hidden>
To: akira yamada <email address hidden>
Cc: Yann Dirson <email address hidden>, <email address hidden>
Subject: Re: Bug#300543: libruby1.8: missing replaces/conflicts on rubyunit

On Mon, Mar 21, 2005 at 12:03:05AM +0900, akira yamada wrote:
> Debian does not have "rubyunit for Ruby 1.8" package.

# apt-cache policy rubyunit
rubyunit:
  Installed: (none)
  Candidate: 0.5.2-2
  Version Table:
     0.5.2-2 0
        500 ftp://ftp.debian.org woody/main Packages

IIRC, it was -2.1 I had installed. Obviously it was not for 1.8, but
there was still a conflict.

--
Yann Dirson <email address hidden> |
Debian-related: <email address hidden> | Support Debian GNU/Linux:
                                    | Freedom, Power, Stability, Gratis
     http://ydirson.free.fr/ | Check <http://www.debian.org/>

On Tue, Mar 22, 2005 at 08:46:18AM +0100, Yann Dirson wrote:
> On Mon, Mar 21, 2005 at 12:03:05AM +0900, akira yamada wrote:
> > Debian does not have "rubyunit for Ruby 1.8" package.
>
> # apt-cache policy rubyunit
> rubyunit:
> Installed: (none)
> Candidate: 0.5.2-2
> Version Table:
> 0.5.2-2 0
> 500 ftp://ftp.debian.org woody/main Packages
>
> IIRC, it was -2.1 I had installed. Obviously it was not for 1.8, but
> there was still a conflict.

As can be seen from
http://packages.qa.debian.org/r/rubyunit/news/1.html -2.1 was a NMU
for 1.8. It did not make it into a release, so maybe it is not worth
to add a conflict...

--
Yann Dirson <email address hidden> |
Debian-related: <email address hidden> | Support Debian GNU/Linux:
                                    | Freedom, Power, Stability, Gratis
     http://ydirson.free.fr/ | Check <http://www.debian.org/>

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Tue, 22 Mar 2005 20:55:34 +0100
From: Yann Dirson <email address hidden>
To: akira yamada <email address hidden>
Cc: Yann Dirson <email address hidden>, <email address hidden>
Subject: Re: Bug#300543: libruby1.8: missing replaces/conflicts on rubyunit

On Tue, Mar 22, 2005 at 08:46:18AM +0100, Yann Dirson wrote:
> On Mon, Mar 21, 2005 at 12:03:05AM +0900, akira yamada wrote:
> > Debian does not have "rubyunit for Ruby 1.8" package.
>
> # apt-cache policy rubyunit
> rubyunit:
> Installed: (none)
> Candidate: 0.5.2-2
> Version Table:
> 0.5.2-2 0
> 500 ftp://ftp.debian.org woody/main Packages
>
> IIRC, it was -2.1 I had installed. Obviously it was not for 1.8, but
> there was still a conflict.

As can be seen from
http://packages.qa.debian.org/r/rubyunit/news/1.html -2.1 was a NMU
for 1.8. It did not make it into a release, so maybe it is not worth
to add a conflict...

--
Yann Dirson <email address hidden> |
Debian-related: <email address hidden> | Support Debian GNU/Linux:
                                    | Freedom, Power, Stability, Gratis
     http://ydirson.free.fr/ | Check <http://www.debian.org/>

Yann Dirson wrote:
> As can be seen from
> http://packages.qa.debian.org/r/rubyunit/news/1.html -2.1 was a NMU
> for 1.8. It did not make it into a release, so maybe it is not worth
> to add a conflict...

rubyunit is already removed from testing/unstable.
(http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=224375&archive=yes)

And stable has rubyunit_0.5.2-2.
The version of rubyunit contains files only for ruby_1.6.

--
akira yamada <URL:http://arika.org>

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 23 Mar 2005 12:08:20 +0900
From: akira yamada <email address hidden>
To: Yann Dirson <email address hidden>
Cc: Yann Dirson <email address hidden>, <email address hidden>
Subject: Re: Bug#300543: libruby1.8: missing replaces/conflicts on rubyunit

Yann Dirson wrote:
> As can be seen from
> http://packages.qa.debian.org/r/rubyunit/news/1.html -2.1 was a NMU
> for 1.8. It did not make it into a release, so maybe it is not worth
> to add a conflict...

rubyunit is already removed from testing/unstable.
(http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=224375&archive=yes)

And stable has rubyunit_0.5.2-2.
The version of rubyunit contains files only for ruby_1.6.

--
akira yamada <URL:http://arika.org>

Changed in ruby1.8:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.