Rhythmbox writes wrong ID3 tags when multiple files are changed

Bug #996150 reported by Ralf Hersel on 2012-05-07
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
Baltix
High
Mantas Kriaučiūnas
rhythmbox (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Changing the ID3 tags (e.g. 'Title') of multiple files in Rhythmbox will write the first changed 'Title' to all subsequently changes files. How to reproduce:

1. Open Rhythmbox in Ubuntu 12.04
2. Select an Album or Artist with more than one song
3. Change the title of the first song (right click, preferences, change title, next or submit)
4. Change the title of the next song and so on
5. Open the folder for that Album in Nautilus and check the ID3 tags in the preferences of each file
6. Recognize that all changed titles have the title of the first changed song

Example
Before change:
Abba - blablub1
Abba - blablub2
Abba - blablub3

Change in Rhythmbox to:
Abba - Dancing Queen
Abba - Thank you for the music
Abba - Money Money Money

After change (in ID3 tags of the files):
Abba - Dancing Queen
Abba - Dancing Queen (although this is 'Thank you for the music')
Abba - Dancing Queen (although this is 'Money Money Money')

I could reproduce this error on 3 completely different PCs with completely different songs.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Mantas Kriaučiūnas (mantas) wrote :

Such important bugs shouldn't exist in LTS release, Rhythmbox changed Names, Artists and other track info in lots of my music files (ogg/vorbis) :( There are other bugreports about similar problems, see bug #1014643

Could you test if this bug exist in new rhythmbox 2.97 version? 2.97 fixes lots of bugs, which exists in 2.96, which is in Ubuntu 12.04 LTS.
You can install rhythmbox 2.97-1ubuntu1~precise1 from official gnome3-team repository ( ppa:gnome3-team/gnome3 ), see
https://launchpad.net/~gnome3-team/+archive/gnome3

Changed in baltix:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Mantas Kriaučiūnas (mantas)
Mantas Kriaučiūnas (mantas) wrote :

This bug should be fixed in Rhythmbox 2.97, see release notes (https://projects.gnome.org/rhythmbox/rhythmbox-2.97.news )

671840 - Fix setting multiple tags with different values, see gnome-bugs #671840 for more info.

Ubuntu developers, please upload Rhythmbox 2.97 into official precise-updates repository, current Rhythmbox 2.96 version contains lots of important dataloss and crash bugs :(

tags: added: dataloss
tags: added: regression-release
tags: added: precise
Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
importance: Undecided → Low
Changed in rhythmbox (Ubuntu Precise):
importance: Undecided → Low
status: New → Triaged

The importance of this bug for a LTS release shouldn't be set to "low". It takes a lot of time to correct the ID3 tags, the fastest way is probably to recover the files from a backup.

I'll try to upgrade to 2.97 from the PPA linked in here http://www.webupd8.org/2012/10/rhythmbox-298-released-install-it-in.html (they say 2.98 has another bug).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.