Ubuntu

shuffle doesn't work in queue

Reported by BigMc on 2007-03-30
72
This bug affects 9 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
Rhythmbox
Invalid
Wishlist
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

Today my rhythmbox was upgraded to 0.9.8 by feisty beta. Now when I play my queue, it doesn't matter if "shuffle" is pressed or not - the songs are played in the order they stand there. Pressing shuffle also doesn't change the order. When I delete all songs from the queue and play the library on shuffle that works fine. Before the upgrade I didn't have the problem.

EDIT:
To be precise, it was upgraded to 0.9.8-0ubuntu3. I don't know which version it was before, probably also a 0.9.8.

Steps to reproduce:
Put some songs into your queue and play them with shuffle turned on.

ProblemType: Bug
Architecture: i386
Date: Fri Mar 30 15:49:35 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.9.8-0ubuntu3
PackageArchitecture: i386
ProcCmdline: rhythmbox
ProcCwd: /home/tobi
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux tobi-laptop 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

BigMc (tobias-han) wrote :
BigMc (tobias-han) on 2007-03-30
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug. You can read http://bugzilla.gnome.org/show_bug.cgi?id=327254 upstream about this. That's not a bug, you use the queue to play songs in a determined order, you can use playlist if you want a randomly ordered queue

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Rejected
BigMc (tobias-han) wrote :

Ok, thanks, I didn't expect it to work this way. Now a "empty playlist" funktion would be useful for users, who use a playlist as "random queue". Like this I always have to delete and create new playlists.

Changed in rhythmbox:
status: Unknown → Rejected
Kevin J Brown (kevinlyfellow) wrote :

I was afraid that this bug was going to be called a feature :-(

BigMc (tobias-han) wrote :

There is also a mistake in the german translation, that confused me, but I don't know where to report it:
when you right-click a song, the field that adds the song to the queue is called "In die Wiedergabeliste aufnehmen" (Add to playlist) and not "In die Warteschlange aufnehmen" (Add to queue).

Mackenzie Morgan (maco.m) wrote :

There are still two usability bugs here, then.
1) The Shuffle and Repeat buttons should not even exist in Queue view if they can't be used, and they certainly shouldn't be able to be toggled. That is completely counter-intuitive
2) There should be a way for the user to pick a bunch of songs without the hassle of grabbing them in order or thinking about the order without having to make a playlist. Playlists are saved lists. If the user wants a "at this moment, I am in the mood for..." list that is *not* to be saved, there is no way to do this.

josu (josu-onandia) wrote :

I support 100% Mackenzie suggestion. There should be a button to do an immediate shuffle in the queue. I find this very simple and useful.

This bug has been sent upstream to GNOME, where we're sort of trying to
convince them that "it's a queue, it shouldn't be allowed to be
shuffled!" is extremely annoying to users that want songs to play only
once, in a random order, and then disappear...since playlists can't do
that "once, then disappear" thing. Can you pop your head in upstream
and add a "I want this too" comment?

Joel Möller (moller-joel) wrote :

Really annoying. With a playlist, there is no way to know whether or not I have heard a song, but if I had the ability to shuffle in the Play queue, I would. And its not like the original idea, with a no-chaotic queue disappears as it would still be possible not to use shuffle.

appi2012 (appi2012) wrote :

Instead of not adding the feature because it doesn't fit the name, change the name so it fits the feature. Development should not be stopped just because of what something is called.

Also, why can't a queue be shuffled?

Vish (vish) wrote :

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.

This is an app specific issue, Not a papercut.
A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Changed in hundredpapercuts:
status: New → Invalid
Mackenzie Morgan (maco.m) wrote :

By the way, you can right click on anything in the queue and choose "Shuffle Queue" ..at least in Karmic, and I think in Jaunty as well.

Changed in rhythmbox (Ubuntu):
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

don't reopen a bug with explanation

Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Invalid
Mackenzie Morgan (maco.m) wrote :

Sebastien means *without* explanation.

Changed in rhythmbox:
importance: Unknown → Wishlist
Chris Wilson (notgary) wrote :

Reopening as part of a review of closed paper cuts.

Changed in hundredpapercuts:
status: Invalid → New
Changed in rhythmbox (Ubuntu):
status: Invalid → New
Thomas Hotz (thotz) wrote :

Setting bug to confirmed because it affect multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed

still there in 13.04

Chris Wilson (notgary) on 2013-05-27
Changed in hundredpapercuts:
milestone: none → papercuts-s-rhythmbox
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.