rhythmbox tag editing has issues with gst0.10

Bug #8839 reported by ben9gn on 2004-10-06
88
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Wishlist
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

When you rt-click a track in the library and open the properties dialog there is
a space to rename the song, however it does not allow you to edit any of the
info (title, genre, album, track). This appears to be a permission issue.

http://bugzilla.gnome.org/show_bug.cgi?id=76524: http://bugzilla.gnome.org/show_bug.cgi?id=76524

Sebastien Bacher (seb128) wrote :

rhythmbox works with the file tags and the current is not able to change the
tags, so you can't edit the names.
upstreams are working on this feature and the tag edition should be support in
the next major branch

Sebastien Bacher (seb128) wrote :

Do you still have the issue? According to upstream too it works correctly

Alain Perry (alain-perry) wrote :

I do have the problem here with 0.9.2-0ubuntu4.
What I don't understand is that debian/rules for this version still has the
--enable-tag-writing.
But I still can't edit tags, though I'm pretty sure I was able to do it a few
days ago...

Sebastien Bacher (seb128) wrote :

what kind of files do you try to edit?

Ian Phillips (ianfp) wrote :

Hi there. I have the same problem using Rhythmbox 0.9.3.1 (from Dapper). I've tried editing tags for ogg vorbis and mp3s (ripped with Sound Juicer) and .m4a files (ripped with iTunes on Windows). Let me know if you need more info.

Sebastien Bacher (seb128) wrote :

The dapper package uses gst0.10 and the tag edition has issues due to some gstreamer bugs in fact

Changed in rhythmbox:
assignee: seb128 → desktop-bugs
status: Needs Info → Confirmed

tag editing should now work for ID3 / mp3 tags, in upstream cvs.

Tag editing for flac/ogg is still not working due to the required gstreamer element not being ported.

Changed in rhythmbox:
status: Unknown → In Progress
Changed in rhythmbox:
status: In Progress → Confirmed

The rhythmbox still doesn't work. The fields are now editable when you go to change song titles/artist/etc., and it works until you close rhythmbox. It appears that the changes aren't written to the file though, because the next time when you start rhythmbox all the songs are back in their original state.

I was renaming a Hall and Oates song when Edgy reported a crash. The Rhythmbox gui still was up and active, so it must be a backend process that crashed.

It didn't happen in all my MP3 files, but the hall and oats song has an ampersand "&" in the artist field "Daryl Hall & John Oates". I wonder if this is the cause.

I was retagging some of my MP3 files using UNICODE characters and Rhythmbox crashed. The metadata is for Tamil (a south Indian language) Songs. Prior to that the song meta-data was encoded using TSCII, which uses ASCII chars above 128 to represent Tamil characters. Using a TSCII font the TSCII encoded text can be rendered as Tamil characters. But unicode overcomes this problem, hence my reason to change.

So, English transliteration : "Aasai Aasaiyai" would be:
 in TSCII: "¬¨º ¬¨ºÂ¡ö"
 in Unicode: "ஆசை ஆசையாய்"

When I try and tag the file I get the following error:

  Error while saving song information retrieval
     Internal GStreamer problem; file a bug

 and the generated error report is attached.

I forgot to mention that like other users, even after the crash the main Rhythmbox GUI is active.

I did further tests. The problem does not occur when you tag all the ID tags in one go using UNICODE. But if you tag, lets say, Artist in Unicode and save it. Given that it did save without problems, you wouldn't be able to edit and save any more metadata for that file.

After further investigation, I found that Banshee doesn't suffer from this problem. It lets me add metadata in Unicode. After I save it Rhythmbox automatically loads the new metadata. This is just a workaround for now. But we would all like to have this fixed in Rhythmbox.

Rhythmbox developers might want to check the backend code of Banshee to see what is it that they are doing that is different to Rhythmbox, in terms of Unicode tag editing.

Banshee is using taglib-sharp to read the tags and may be that is why it can read the incorrectly encoded metadata. Apparently this is a known issue with gst0.10
as mentioned on Aaron Bockover's blog http://abock.org/2006/10/30/cracking-down-on-heap-abuse-part-2/

Sebastien Bacher (seb128) wrote :

Sarangan, your crash is a taglib bug, probably something like bug #61582

Sebastien, you may be right. I was editing the tags of few more files. This time the tags were all in English and normal ASCII encoding. Some of the file changes were saved and others weren't. That's when gstreamer crashed.

Thibault D (thibdrev) wrote :

error msg when trying to modify the tag of a song

Sebastien Bacher (seb128) wrote :

Thibault, your problem is a different one, that's a crash to taglib and known as bug #61582. If you are not sure of what you are doing better to open a new bug than commenting on a different bug which is confusing and make work harder for the bugsquad

Hi, GStreamer reportedly crashed but the bug reporting thing said that Rhythmbox crashed. I was editing an NSync song at the time. Just before editing 1 song, I edited 12 songs (all at once, changing the artist) without any problems. Crash dump attached.

Hi. I'm using Edgy and I tried editing the Genre of a particular mp3 and it fails with the error:

Error while saving song information
Internal GStreamer problem; file a bug

I tried again, and then the crash file creator popped up and said Rhythmbox had crashed (it didn't, but whatever) and it brought me to this page. I've attached the generated crash file.

Is this still relevant with Feisty ?

No this bug seems to be fixed in Fiesty / Rhythmbox 0.10.0 release. I can edit and save Mp3 metadata in UTF-8. Cheers for the bugfix.

Ok I will wait for others to confirm it's fixed, then I will update the status.

Seth Myers (sethfmyers) wrote :

i've recently upgraded to Fiesty & Rhythmbox 0.10.0 and the problem still appears to be relevant. though it was not a fresh install but a repository upgrade.

Ok, that should'nt change anything, I will wait for more feedback of other users.

maluze (justinthomas85) wrote :

I did a fresh resinatll, upgraded to Rhythmbox 0.11.0, and it appears to be having the same issues. I tried to edit the song tags for several mistagged songs, while a song is playing, and the song will will stop playing for a few seconds, and an error message will pop up saying: "Error while saving song information Internal GStreamer problem; file a bug"..

hotani (hotani) wrote :

unable to edit flac here. mp3 editing is fine.

hotani (hotani) wrote :

drat. A version might help. This is in rhythmbox 0.11.2 in Ubuntu Gutsy 7.10.

Anders Häggström (hagge) wrote :

I am also unable to edit tags in rhytmbox (v0.11.2, fresh Ubuntu Gutsy-intall).
I tried to edit mp3-files as well as lfac-.files. None of them worked.

If you need more information about my installation, just tell me what to post.

Changed in rhythmbox:
status: Confirmed → Triaged

I have the issue when trying to mass-edit tags (select several similar files and apply a tag to them).
If I edit them one after the other, it works fine (tested only on MP3 files).

version 0.11.2-0ubuntu4

Shirish Agarwal (shirishag75) wrote :

Its still is an issue in the .flac files. Not able to edit them. Have to go Nautilus> Properties to do the same. Not nice :(

Shirish Agarwal (shirishag75) wrote :

Oops, this is on Hardy Heron 0.11.4-0ubuntu4 , forgot to mention that detail

Nicole Ackerman (ackey) wrote :

Rhythmbox: 0.11.2
Kubuntu, 2.6.22-14-generic (previously Ubuntu gutsy, so all GNOME "stuff" is present)
(sorry if I shouldn't be bothering to post here if I'm running KDE)
Playing files mounted via sshfs/fuse (permissions are fine)

Can't edit mp3 tags, either multiple or individually. See the same message as everyone above.

Ubuntu 7.10, Rhythmbox 0.11.2
Cannot (mass-)edit FLAC tags, Quality column displays "unknown" for mp3 & flac.

Ubuntu 8.04 (Hardy), Rhythmbox 0.11.5

Also cannot (mass-)edit any FLAC tags in the properties window. Audio files are stored on a (FreeNAS) SMB share, which is write-able.

Scott Wegner (swegner) wrote :

I just briefly tried renaming some mp3 songs, and I seem to have this issue. Using stable Hardy with Rhythmbox 0.11.5

Roland Pinto (rjp) wrote :

yes i have this issue has well with mp3 not only hardy but also other distros like suse and arch.

hmich176 (hmich176) wrote :

Same issue here with FLACs. Any solution? I'm running 0.11.5 on Ubuntu 8.04.

Shirish Agarwal (shirishag75) wrote :

bumping this one up, would see if this is fixed in Intrepid or not as well.

Shirish Agarwal (shirishag75) wrote :

Atleast for 8.10 it appears to have been fixed as far as making tags are concerned, there are still issues however with the way rhythmbox tags them. It makes duplicates of albums, but that I guess is a different bug altogether.

Alvaro Kuolas (kuolas) wrote :

I've edited some MP3 tags in Rhythmbox and they apear Ok under Rhythmbox but with EasyTag and id3v2 does not appear any tag written. So, Where Rhythmbox saves this "tags"?

Lionel Dricot (ploum) wrote :

Tag editing is working fine for me with latest rhythmbox for Ogg and MP3.

I'm closing this bug. Feel free to open a new bug if you have a particular issue with tag editing. Please also add a way to reproduce the bug (attaching a particular file if needed). Thanks.

Changed in rhythmbox:
status: Triaged → Fix Released
Changed in rhythmbox:
status: Confirmed → Fix Released
Changed in rhythmbox:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.