Ubuntu

Importing a cd in rhythmbox does not work

Reported by Damiano Dallatana on 2007-01-08
30
Affects Status Importance Assigned to Milestone
Rhythmbox
Invalid
Undecided
Unassigned
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

steps to reproduce:
1. insert an audio cd into your cd-drive
2. open rhythmbox
3. go to your cd on the left panel
4. select "copy in your library" (do not know whether it says like that, in Italian is "Copia nella libreria"
5. nothing happens...

looking from the terminal, as I try to copy the cd in the library, rhythmbox reports an error:
(rhythmbox:8341): Rhythmbox-WARNING **: RBLibrarySource impl_paste called when gconf keys unset

and when I open rhythmbox from the terminal, it says
(rhythmbox:8341): Rhythmbox-WARNING **: Unable to start mDNS browsing: Il servizion MDNS non è in esecuzione
(translated: the MDNS service is not in execution)

Version informations:
rhythmbox 0.9.6 on Ubuntu Edgy Eft 6.10, it-IT l10n.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Could you run "rhythmbox -d" and note to the bug what is printed when you try to copy the CD?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Damiano Dallatana (damidalla) wrote :

When I click on the "copy cd" button (or whatever it says...), the bug is

(rhythmbox:12165): Rhythmbox-WARNING **: RBLibrarySource impl_paste called when gconf keys unset

Sebastien Bacher (seb128) wrote :

"rhythmbox -d" should print a lot of thing, there is nothing else about the problem?

Damiano Dallatana (damidalla) wrote :

"rhythmbox -d" prints out too many things.
I just tried again saving everything on a .txt file.
The only strange thing I found that _could_ be related to this is:

[free_dbus_error] rb-generic-player-source.c:716: finding audio player udi: dbus error: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_571_ide_0_0

However, I attach a .tar.gz archive containing the whole log file (originally 1.8 MB). The only action I tried was opening the cd and trying to copy it...

(obviously, I am at your disposal for anything you could need...)

Sebastien Bacher (seb128) wrote :

Thank you for the log, I've forwarded the bug upstream: http://bugzilla.gnome.org/show_bug.cgi?id=396094

Changed in rhythmbox:
importance: Undecided → Low
status: Needs Info → Confirmed
Changed in rhythmbox:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

comment from upstream:

"this:

Rhythmbox-WARNING **: RBLibrarySource impl_paste called when gconf keys unset

means that the library location is not set. We could certainly handle this
case better."

Does it work if you set a library directory?

Damiano Dallatana (damidalla) wrote :

yes, the only problem was the unset library directory.
So, it is not a bug. But it could be handled really better by rhythmbox!

Thank you very much indeed, sebastien! consider yourself hugged...

Changed in rhythmbox:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

do you still get the issue in hardy or intrepid?

Changed in rhythmbox:
status: Confirmed → Triaged

I no longer have a Ubuntu system...

On Wed, Oct 29, 2008 at 9:41 AM, Sebastien Bacher <email address hidden> wrote:
> do you still get the issue in hardy or intrepid?
>
> ** Changed in: rhythmbox (Ubuntu)
> Status: Confirmed => Triaged
>
> --
> Importing a cd in rhythmbox does not work
> https://bugs.launchpad.net/bugs/78431
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Changed in rhythmbox:
importance: Unknown → Medium
Thomas Hotz (thotz) wrote :

> I no longer have a Ubuntu system...

So I close the bug. Thank you for making Ubuntu better!

Changed in rhythmbox (Ubuntu):
status: Triaged → Invalid
Thomas Hotz (thotz) wrote :

Oh, haven't looked at the duplicates? Can somebody confirm this bug please?

Changed in rhythmbox (Ubuntu):
status: Invalid → Incomplete
Thomas Hotz (thotz) on 2013-05-01
Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Changed in rhythmbox:
importance: Medium → Undecided
status: Confirmed → New
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.