rhythmbox crashed with SIGSEGV in rb_ipod_db_get_mount_path()

Bug #549287 reported by Charles Southerland on 2010-03-27
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: rhythmbox

Upgraded a fresh install of 9.10 to 10.04 Beta 1 (x86 desktop) to test support for a new 5th gen ipod nano. A few minutes after initializing the new ipod in rhythmbox (version 0.12.7git20100325-0ubuntu1), I right clicked on the IPOD entry (in the left panel of rhythmbox) and clicked on properties, and then rhythmbox crashed after a few moments (maybe a second or two on this older laptop). I started rhythmbox a few more times to see if the results were consistent, and every time I clicked on properties, rhythmbox would consistently crash in this manner. If you have any more questions, please let me know so I can get back to you ASAP (I know those of you working on 10.04 must be on a tight schedule, so I would like to help however I can).

Here are a few version numbers that might help:
ubuntu 10.04 Beta 1
linux 2.6.32.17-generic
rhythmbox 0.12.7git20100325-0ubuntu1
libgpod4 0.7.92-0ubuntu1
libplist1 1.1-1ubuntu1

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Fri Mar 26 20:04:43 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: rhythmbox 0.12.7git20100325-0ubuntu1
ProcCmdline: rhythmbox /media/IPOD
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
SegvAnalysis:
 Segfault happened at: 0x122c8f6 <rb_ipod_db_get_mount_path+38>: mov (%eax),%eax
 PC (0x0122c8f6) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 rb_ipod_db_get_mount_path ()
 ?? () from /usr/lib/rhythmbox/plugins/ipod/libipod.so
 ?? () from /usr/lib/rhythmbox/plugins/ipod/libipod.so
 rb_media_player_source_show_properties ()
 ?? () from /usr/lib/rhythmbox/plugins/ipod/libipod.so
Title: rhythmbox crashed with SIGSEGV in rb_ipod_db_get_mount_path()
Uname: Linux 2.6.32-17-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Charles Southerland (proidiot) wrote :
description: updated

StacktraceTop:
 rb_ipod_db_get_mount_path (ipod_db=0x0) at rb-ipod-db.c:892
 get_mount_point (source=0x9e22008) at rb-ipod-source.c:1825
 impl_get_capacity (source=0x9e22008)
 rb_media_player_source_show_properties (source=0x9e22008)
 rb_ipod_plugin_cmd_properties (action=0x961fd68,

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Pedro Villavicencio (pedro) wrote :

trace is good enough, but i'd like to ask you if this is still reproducible with rhythmbox 0.12.8 ? may you please test the same and comment back? Thanks in advance.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Charles Southerland (proidiot) wrote :

Before I do anything else, I want to let you know what I've done.

I later tried plugging this iPod Nano 5g back into my 9.10 box, thinking that I would check to see if I could get the latest gtkpod compiled from source to work with it (in case the problem was upstream). However, when I plugged this iPod back into the 9.10 box after having "initialized" it on the 10.04 box, it no longer appeared.

Then, it what must have been a total lapse of sanity, I had a friend of mine plug it into his Windows box with iTunes, as I had read somewhere online that doing so "fixes" the filesystem layout in the iPod Nano 5g, at which point it can be used with the upstream libgpod. After plugging the iPod back into the 9.10 box, it still isn't recognized (I didn't bother to finish installing the upstream libgpod). However, now when I plug this iPod into my 10.04 box, the error does not occur. When dragging and dropping music files into the iPod before did nothing, I assumed that this was not valid behavior. However, this also works now.

This leads me to believe that this problem may have been an issue with the "initialization" process for the iPod Nano 5g.

I apologize for dropping the ball on this... is there anything I can do to salvage the situation? Resetting didn't seem to have any effect...

I have to same problem know with Rhythmbox 0.12.8
and I have seen this guy has the problem as well:
http://ubuntuforums.org/showthread.php?t=1498607
and this guy has the solution:
http://wolfs-ubuntu.blogspot.com/2010/06/ipod-nano-5g-on-lucid.html
but it is still a bug in Rhythmbox I guess so i'm marking New.

My problem came about after a Rhythmbox crash that corrupted the iPod. Then I tried removing the FXX where X's are numbers from the Music directory because the ipod couldn't recognize the music anymore. That must mean that I am in the uninitalized state again.

Changed in rhythmbox (Ubuntu):
status: Incomplete → New
redrick (antonluneyv) wrote :

I've had this problem too but after re-initializing IPod(Shuffle, 2nd gen) in windows iTunes, it is gone. Right now I'm on Rhythmbox 0.13.1 and it's not reproducible anymore.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. A new version of Rhythmbox is available on Maverick and we are wondering if this bug is still an issue for you with that version? Could you please test and comment back? Thanks in advance.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for rhythmbox (Ubuntu) because there has been no activity for 60 days.]

Changed in rhythmbox (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers