"Party mode" ununderstandable and undocumented

Bug #329389 reported by era on 2009-02-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
Rhythmbox
Confirmed
Medium
rhythmbox (Ubuntu)
Low
Unassigned
Nominated for Precise by Alberto Salvia Novella
Nominated for Trusty by Alberto Salvia Novella
Nominated for Vivid by Alberto Salvia Novella
Nominated for Wily by Alberto Salvia Novella
Nominated for Xenial by Alberto Salvia Novella
Nominated for Yakkety by Alberto Salvia Novella

Bug Description

Binary package hint: rhythmbox

The manual does not explain what "party mode" is. The status bar help text is not helpful at all; when you hover the cursor over the Party Mode menu entry, it laconically says "Change the status of the party mode". (Is that even English?)

I was scared that it would ruin all my playlists and send my email address to the spammers, but I tried it anyway. It seems to toggle a full-screen view. Then why is it not called "Full Screen"? Does it do something more?

The top Google hit http://ubuntuforums.org/showthread.php?t=694932 seems inconclusive to me. Does Party mode involve changes in how the play queue can be manipulated and/or how the computer can be used?

Minimal fix:
 * Describe Party Mode in the on-line help

Bonus points:
 * Improve the Status bar help text

vnix$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10

vnix$ apt-cache policy rhythmbox
rhythmbox:
  Installed: 0.11.6svn20081008-0ubuntu4.2
  Candidate: 0.11.6svn20081008-0ubuntu4.2
  Version table:
 *** 0.11.6svn20081008-0ubuntu4.2 0
        500 http://fi.archive.ubuntu.com intrepid-updates/main Packages
        100 /var/lib/dpkg/status
     0.11.6svn20081008-0ubuntu4 0
        500 http://fi.archive.ubuntu.com intrepid/main Packages

Pedro Villavicencio (pedro) wrote :

marking this as bitesize, patches are welcome. And this also needs to be send upstream by someone interested on that, leaving an upstream task open as well.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Johnathon (kirrus) wrote :

Linking new upstream bug report

Changed in rhythmbox:
importance: Undecided → Unknown
status: New → Unknown
Changed in rhythmbox:
status: Confirmed → Triaged
Changed in rhythmbox:
status: Unknown → New
MrPaul (paul-campbell) wrote :

The attached patch should solve this.

I have identified the behaviour of Party mode from the code and documented it accordingly.

MrPaul (paul-campbell) wrote :

As per Wiki: Bugs/HowToFix

Changed in rhythmbox:
assignee: desktop-bugs → nobody
status: Triaged → Confirmed
era (era) wrote :

@MrPaul: shouldn't the patch be submitted to the upstream bug report rather than here?

Sebastien Bacher (seb128) wrote :

right, thanks for your work but the change is not distribution specific and should be sent to bugzilla too

Changed in rhythmbox (Ubuntu):
assignee: nobody → desktop-bugs
status: Confirmed → Triaged
Ekaterina G. Potapova (egeomar) wrote :

@MrPaul: thanks for your work but the Ubuntu documentation group is working on editing the whole Rhythmbox manual, so you you can contact me about working together.

David Futcher (bobbo) on 2010-06-08
tags: added: patch-forwarded-upstream
Changed in rhythmbox:
importance: Unknown → Medium
Chris Wilson (notgary) wrote :

This is an old bug report. How's the manual entry for Party Mode looking in 12.04/12.10?

Changed in hundredpapercuts:
milestone: none → raring-round-1
Chris Wilson (notgary) on 2012-10-23
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Israel Dahl (israeldahl) wrote :

In the manual the Key Shortcuts says F11 is for Full screen, but there is no entry in the manual like the above patch submitted by Mr. Paul. Searching for 'Party Mode' produces no results. It might be nice is party mode came with visualizations, too.

Changed in hundredpapercuts:
status: New → Confirmed
Chris Wilson (notgary) on 2012-10-24
Changed in hundredpapercuts:
importance: Undecided → Low
Chris Wilson (notgary) wrote :

Comment from the developer:

"I think calling it 'ununderstandable' is a bit of a stretch, and I
don't think documenting it will help. I'm really not sure what to do
about party mode."

This makes the problem hard to define, so I'm going to close the paper cut task for now.

Changed in hundredpapercuts:
status: Confirmed → Invalid
importance: Low → Undecided
assignee: Papercuts Ninja (papercuts-ninja) → nobody
milestone: raring-round-1 → none
Israel Dahl (israeldahl) wrote :

Still missing in 13.04.
Really chaning the phrase "Party Mode" to "Fullscreen" would eliminate the problem.
Party Mode is gibberish. A fullscreen app is how we used to use apps back in the day.... and it wasn't always a party. Or is the TTY a terminal "Party Mode"? Really Fullscreen describes it MUCH more clearly.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/329389

tags: added: package-qa-testing
Cody Smith (cody.smith) on 2014-02-05
Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Cody Smith (cody.smith)
Cody Smith (cody.smith) on 2014-02-05
Changed in rhythmbox (Ubuntu):
assignee: Cody Smith (cody.smith) → nobody

I'm on 15.10 and this still hasn't been addressed. On a regular size window, it's now called full screen, but when in full screen to toggle back to a custom size, the option is still labeled party mode.

Changed in rhythmbox (Ubuntu):
assignee: nobody → Vamshi Balanaga (vamrocks602)
tags: added: wily
Changed in hundredpapercuts:
importance: Undecided → Low
status: Invalid → Triaged
tags: added: precise trusty
tags: added: vivid
tags: added: xenial
Changed in rhythmbox:
status: New → Confirmed
Changed in rhythmbox (Ubuntu):
assignee: Vamshi Balanaga (vamrocks602) → nobody

In 16.10 View -> Full screen takes me to Full screen mode where Settings(icon) -> View has Party Mode toggled off. Clicking on it takes me to normal view. I think it needs to be fixed. In Full screen Party Mode(whatever it is meant for) should be toggled on because clicking on it doesn't toggle it on but takes me to normal view.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.