crashed while listening to a mp3 podcast

Bug #276603 reported by Bradley Peters on 2008-10-01
204
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Critical
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs
Intrepid
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

$ lsb_release -rd
Description: Ubuntu intrepid (development branch)
Release: 8.10

$ apt-cache policy rhythmbox
rhythmbox:
  Installed: 0.11.6svn20080916-0ubuntu1
  Candidate: 0.11.6svn20080916-0ubuntu1
  Version table:
 *** 0.11.6svn20080916-0ubuntu1 0
        500 http://ca.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

I was listening to an MP3 (downloaded podcast) in Rhythmbox. The program froze and stopped playing the track. After a short time (not sure exactly, but less than a minute) it crashed (window disappeared) and the crash report window came up. There are some podcasts configured and so the program was likely downloading at the same time (I didn't directly observe this, but my connection is slow so Rhythmbox usually is doing that).

In case it is relevant I also have the Fluendo Playback Pack from the Canonical Store installed.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.11.6svn20080916-0ubuntu1
ProcAttrCurrent: unconfined
ProcCmdline: rhythmbox
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 g_type_check_instance_cast ()
 ?? ()
 ?? () from /usr/lib/libglib-2.0.so.0
 start_thread () from /lib/tls/i686/cmov/libpthread.so.0
 clone () from /lib/tls/i686/cmov/libc.so.6
Title: rhythmbox crashed with SIGSEGV in g_type_check_instance_cast()
Uname: Linux 2.6.27-4-generic i686
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

StacktraceTop:IA__g_type_check_instance_cast (type_instance=0x2f6d6f63,
podcast_download_thread (data=0x99eccd8)
g_thread_create_proxy (data=0x9fb7900)
start_thread () from /lib/tls/i686/cmov/libpthread.so.0
clone () from /lib/tls/i686/cmov/libc.so.6

Changed in rhythmbox:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=554556

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: New → Triaged
Changed in rhythmbox:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

this bug has been fixed upstream, thanks for reporting.

Changed in rhythmbox:
status: Triaged → Fix Committed
Martin Olsson (mnemo) wrote :

If somebody is really annoyed by this bug and don't want to wait for jaunty (or a SRU which i'm not sure will happen)... I'm attaching a patch created from the upstream bugfix that Jonathan Matthew did. Below are some rough steps on how this patch can be applied locally:

mkdir rb
cd rb
apt-get source rhythmbox
patch -p1 < /path/to/rb_kiev.patch
cd rhythmbox-0.11.6svn20081008
sudo apt-get build-dep rhythmbox
fakeroot debian/rules binary
cd ..
sudo dpkg -i rhythmbox_0.11.6svn20081008-0ubuntu4.2_amd64.deb
#### eller i386 in the end if you have 32-bit ubuntu

James Lewis (james-fsck) wrote :

Hmm, doesn't seem that that can easily be done on a vanilla install, I get "Build dependencies could not be satisfied."..

I'd be surprised if this isn't considered worth releasing as an update... it's the default music player in the distro, so it's easily in the top 5 or 10 applications used on the end user desktop, and this bug basically makes podcasts completely unusable!

Can it really be OK to wait 4 months for 9.04?

Changed in rhythmbox:
status: New → Fix Released
petski (petski) wrote :

I've used Launchpad's PPA to build a new (intrepid) version of the rhythmbox package. It's actually just a copy of the current package in intrepid + rb_kiev.patch (See mnemo's comment)

The debdiff is attached.

If you suffer from this bug, please see if the new version makes a difference and add a comment to this bugreport afterwards (for the quick ones among you, it could take a short while before the package

$ sudo sh -c 'echo deb http://ppa.launchpad.net/petski/ubuntu intrepid main > /etc/apt/sources.list.d/LP276603.list'
$ sudo sh -c 'echo deb-src http://ppa.launchpad.net/petski/ubuntu intrepid main >> /etc/apt/sources.list.d/LP276603.list'
$ sudo apt-get update
$ sudo apt-get upgrade # Ignore warning about the unauthenticated rhythmbox package

Restart rhythmbox (if needed) and see if it makes a difference.

To revert the changes you've made:

$ sudo rm -f /etc/apt/sources.list.d/LP276603.list
$ sudo apt-get update
$ sudo apt-get install 'rhythmbox=0.11.6svn20081008-0ubuntu4.2'

HTH

Martin Olsson (mnemo) wrote :

Thanks petski

Martin Olsson (mnemo) wrote :

By the way James, regarding the build dependencies: you can always install the build dependencies for any package using "sudo apt-get build-dep PACKAGE_NAME". I should have included "sudo apt-get build-dep rhythmbox" after the apt-get source step above.

Sebastien Bacher (seb128) wrote :

This update fixes the issue

 rhythmbox (0.11.6svn20090108-0ubuntu1) jaunty; urgency=low
 .
   * New svn update
   * debian/control.in:
     - updated gtk requirement
   * debian/patches/90_correct_cd_recording.patch,
     debian/patches/90_upstream_change_correct_cd_copy_naming.patch,
     debian/patches/91_upstream_fix_mtp_transfer.patch,
     debian/patches/92_upstream_change_correct_player_listing.patch,
     debian/patches/93_upstream_change_no_crossfading_locking.patch:
     - the changes are in the new version
   * debian/patches/01_lpi.patch:
     - new version update
   * debian/patches/02_autoconf.patch:
     - new version update

Changed in rhythmbox:
status: Fix Committed → Fix Released
James Lewis (james-fsck) wrote :

Thanks for the comment regarding installing build dependencies... not really an Ubuntu/Debian user primarily, but I have to say that I've tried a lot of distributions, and Ubuntu is the first that has kept me away from Slack, and I'm really impressed with the way Ubuntu has made a well built distribution and managed to make it user friendly enough for casual computer users at the same time... As of the last few patches, I'm really thinking that 9.04 will be outstanding, just need to make people aware of it and Linux can overtake MAC on the desktop... :)

In any case, the patch posted above by petski does resolve the issue with podcast downloads causing segfault, so this seems to be a big step forwards, thanks very much for doing this!

I have to say that there is still a minor issue with the file lists stopping updating and being corrupted when scrolling if they are open when it downloads more than 1 podcast, but that is a minor irritation rather than a show stopper, because usually you'd never have this screen open for an extended period.... would anyone be interested in a screenshot of what I mean?... is this somthing that should have a separate (and far less critical) bug listed?

markofealing (mark-ferns16) wrote :

Thanks petski, you fix has resolved the problem.

petski (petski) wrote :

SRU:

Impact: Program crashes
Resolution in development branch: sofware synced with upstream (https://launchpad.net/ubuntu/+source/rhythmbox)
Patch: Attached to this bug (http://launchpadlibrarian.net/20995317/rhythmbox_lp276603.debdiff)
Instructions to reproduce: See description of this bug and it's duplicates
Justification: crashing application, obviously safe patch

petski (petski) wrote :

Subscribed ubuntu-main-sponsors as advised in #ubuntu-devel, could one of you please upload this to intrepid-proposed?

Gijutsu (gijutsu) wrote :

The package released by petski worked for me as well

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Confirmed
petski (petski) wrote :

New debdiff as requested by seb128

Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in rhythmbox:
status: Confirmed → Fix Committed
petski (petski) wrote :

And for those who have added my PPA, please remove it using the following command:

sudo rm -f /etc/apt/sources.list.d/LP276603.list

Duane Hinnen (duanedesign) wrote :

I downloaded the rhythmbox package from pettski's repository aprox. 3 weeks ago. I was very happy to find that my previous problem (Bug #289738 marked as a dup of this bug) had gone away. So far so good, thank you everyone who helped to resolve this bug. I am so happy to have my Rhythmbox back. :)

petski (petski) wrote :

:) Happy to help :)

We're currently in the phase that a new package of rhythmbox is about to be distributed to everyone running Intrepid. The only thing is that the archive admins want to be sure that this new package works as expected. If you guys are positive about the new package, everybody can have their Rhythmbox back in just a couple of days :). The new package is slightly different than mine, but the results should be that same.

So, martin, jona, markofealing, duanedesign and everyone else who is reading this: I would really appreciate it if you would (re-)test the "new" package, which is currently in the "-proposed" pocket.So, please:

- sudo rm -f /etc/apt/sources.list.d/LP276603.list
- Follow instruction on https://wiki.ubuntu.com/Testing/EnableProposed
- sudo apt-get update
- sudo apt-get upgrade
- Make sure that at the end the command "dpkg-query -l rhythmbox" will give "0.11.6svn20081008-0ubuntu4.3" (_NOT_ "0.11.6svn20081008-0ubuntu4.3~ppa1").
- Let us know if rhythmbox works as expected

Best regards

Derek White (d-man97) wrote :

Was this supposed to fix the problems with rhythmbox when downloading multiple podcasts and gvfsd-http eats memory, too?

petski (petski) wrote :

As far as I know, it only resolves #276603

You can always find the changelog for a certain package at https://launchpad.net/ubuntu/+source/rhythmbox (in this case)

Duane Hinnen (duanedesign) wrote :

Petski,
I followed your instructions on your post dated 2009-01-29. I have been running the new package for aprox a week now and my rhythmbox is working great!
Dh

Martin Olsson (mnemo) wrote :

Derek,

the gvfs-http leak you mention is not fixed by this SRU but it has been fixed upstream already so it will be fixed in jaunty for sure. The patch that fixes the gvfs-http memory leak is available here:
http://launchpadlibrarian.net/20351735/gvfs_leak_fix.patch

Indeed you can use the same repro steps as on this bug to trigger the leak. If you download 20 podcasts of 2MB each you're likely to see 40MB leaked memory in the gvfs-http process (check VIRT/RES columns in "top" for example).

Martin Olsson (mnemo) wrote :

petski,

I just ran the repro again on my intrepid box to make sure it still repros and it did. After that I enabled -proposed and I installed your updated package and ran the repro again and now the bug is gone.

I'm not a big rhythmbox user myself so I won't do any extensive testing like duanedesign did, but I can assert that the bugfix is working on my system for sure. I think it can be safely moved from -proposed to a real update.

Derek White (d-man97) wrote :

Thanks for that information.
I don't want to wait for jaunty; so, I guess I'll learn the nifty patch program.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.11.6svn20081008-0ubuntu4.3

---------------
rhythmbox (0.11.6svn20081008-0ubuntu4.3) intrepid-proposed; urgency=low

  * debian/patches/94_upstream_fix_close_and_unref_streams.patch
    - Closing the streams (and unref them) before emitting the
      error/complete status (LP: #276603).

 -- Patrick Kuijvenhoven <email address hidden> Tue, 27 Jan 2009 23:49:09 +0100

Changed in rhythmbox:
status: Fix Committed → Fix Released
Changed in rhythmbox:
status: Fix Released → Incomplete
Changed in rhythmbox (Ubuntu):
status: Fix Released → Confirmed
Changed in rhythmbox (Ubuntu Intrepid):
status: Fix Released → New
Steve Langasek (vorlon) wrote :

don't change bug states without explanation.

Changed in rhythmbox:
status: Incomplete → Fix Released
Changed in rhythmbox (Ubuntu Intrepid):
status: New → Fix Released
Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
Changed in rhythmbox:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.