Manually adding stream in the form of shoutcast playlist (.pls) doesn't work

Bug #14953 reported by Eduardo Silva on 2005-04-04
16
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Sebastien Bacher

Bug Description

Could rhythmbox directly read the playlist file by which most audio
streams are anounced on the web?

Rythmbox can't understand adresses of playlists, so for each radio I
want to add to rhythmbox, I have to save and open the file, to copy the
address. For example:

Website gives me :http://acamar.org:8000/listen.pls
I download file "listen.pls" which contains the address the app
understands:

[playlist]
NumberOfEntries=1
File1=http://acamar.org:8000/

This would really help the ease of adding radio streams to rhythmbox,
specially to users who don't know.

Subject: rhythmbox: fails to read playlist of streams
Package: rhythmbox
Version: 0.8.8-7ubuntu3
Severity: normal
Distribution: Debian 3.1
Version: GNOME2.10.0 0.8.8
Gnome-Distributor: Ubuntu
Component: iradio

Sebastien Bacher (seb128) wrote :

do you use hoary? that works fine here, clicking on the pls link with epiphany
opens to open it launchs rhythmbox and start playing the radio ... what does it
do for you?

Sebastien Bacher (seb128) wrote :

*** Bug 16646 has been marked as a duplicate of this bug. ***

Eduardo Silva (jobezone) wrote :

(In reply to comment #1)
> do you use hoary? that works fine here, clicking on the pls link with epiphany
> opens to open it launchs rhythmbox and start playing the radio ... what does it
> do for you?

I just tried it with Firefox and it works when I click on the .pls link, and
plays almost imediately!... Sorry, I never tried this, as I thought this
probably wouldn't work.So it's nice.

What I did, and didn't(doesn't still) work, was copy the
http://acamar.org:8000/listen.pls adress, go to rhythmbox, New Internet Radio
station, and place this in the adress. When double-clicking to play the station,
rhythmbox says it's buffering and won't start playing the stream.

Since there is a New Internet Radio Station button on rhythmbox, I assume most
users will use the .pls or other formats(.m3u).
But I got it working easily now, thanks.

Oddly, it's working for me now too. I don't remember anything changing between
this week and last, except that I just caught up on a lot of security updates (I
had misconfigured /etc/apt/sources.list).

Sebastien Bacher (seb128) wrote :

I'm closing it since it works. Feel free to reopen if you get the issue again.

Eduardo Silva (jobezone) wrote :

Sorry for re-opening this bug, but rhythmbox still can't read radio streams in
the shoutcast format .pls when manually adding as a radio station. I've changed
the name of the bug, because of this.

To Reproduce:

Choose "New Internet Radio Station"
Paste this link into Location: http://sc1.magnatune.com:8002/listen.pls or any
other .pls shoutcast link you have.
Double-click the newly created entry.

What it does:

Bottom right says "Buffering..." and the activity bar moves to infinity. The
stream never starts playing.
If, instead, you directly click on this, or any other .pls link on a website, it
can be opened and correctly played by rythmbox.

What it should do:
It should correctly play the stream, just the same as if it was clicked on a
website.

Eduardo Silva (jobezone) wrote :

Following the same steps as the previous comment, but adding instead a .m3u link
works (for example, http://www.radioparadise.com/musiclinks/rp_32.m3u ).

Sebastien Bacher (seb128) wrote :

This works fine with rhythmbox 0.9.2 for me, I'm closing the bug. Feel free to
reopen if you still get the issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.