Rhythmbox:Error while saving song information:Internal GStreamer problem

Bug #123460 reported by joji on 2007-07-02
110
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Expired
Wishlist
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Rhythmbox:Error while saving song information:Internal GStreamer problem

ProblemType: Bug
Architecture: i386
Date: Mon Jul 2 10:10:28 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.10.0-0ubuntu2
PackageArchitecture: i386
ProcCmdline: rhythmbox
ProcCwd: /home/yoj
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux beeyatch 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

joji (joji-tribeofe) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug. Does it happen with any song? What did you do to trigger the bug?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete

> Thank you for your bug. Does it happen with any song? What did you do to
> trigger the bug?
>
> ** Changed in: rhythmbox (Ubuntu)
> Importance: Undecided => Low
> Assignee: (unassigned) => Ubuntu Desktop Bugs
> Status: New => Incomplete
>
> --
> Rhythmbox:Error while saving song information:Internal GStreamer problem
>
>>>>>>>>>Hi!
I was trying to go thru my collection and change multiple songs' info via
"properties"...specifically, i was trying to rename artists' names::ie
i have David Bowie and david bowie. i was trying to put them together in
the same artist category when i received this error.

Sebastien Bacher (seb128) wrote :

Could you run "rhythmbox -d" and note error printed when that happens?

joji (joji-tribeofe) wrote :

> Could you run "rhythmbox -d" and note error printed when that happens?
>
> --
> Rhythmbox:Error while saving song information:Internal GStreamer problem
> https://bugs.launchpad.net/bugs/123460
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>>>>i am a little new.
i'll be happy to, but you'll have to send me the script i need to get so
far as to run that.
i assume i use my terminal: then what's next?
i'll happily paste on the error and send it thru to you.
cheers

Sebastien Bacher (seb128) wrote :

open a command line window and write "rhythmbox -d" to it

Pedro Villavicencio (pedro) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in rhythmbox:
status: Incomplete → Invalid
Edenguy (edenguy17) wrote :

I've got the same problem, it seems to work completely random as sometimes it IS possible to properly change the track information but then after a couple of minutes it suddenly changes back and gives the 'GStreamer Internal error" warning. It's also like this when changing genre or album in more than one track - some tracks change, some don't.

After writing rythmbox -d in the console I got this:

mp@mp-desktop:~$ rhythmbox -d
(18:20:36) [0x80f4028] [rb_debug_init_match] rb-debug.c:141: Debugging enabled
(18:20:36) [0x80f4028] [main] main.c:206: initializing Rhythmbox 0.10.0
(18:20:36) [0x80f4028] [rb_threads_init] rb-util.c:460: GMutex isn't recursive
(18:20:36) [0x80f4028] [main] main.c:215: going to create DBus object
(18:20:36) [0x80f4028] [main] main.c:402: THE END

I don't really understand this but I hope the topic gets reopened, this problem is pretty irritating.

greetings
MP

Antonio Cono (tblu) wrote :

(14:48:26) [0x6c9500] [rb_debug_init_match] rb-debug.c:153: Debugging enabled
(14:48:26) [0x6c9500] [main] main.c:171: initializing Rhythmbox 0.11.2
(14:48:26) [0x6c9500] [rb_threads_init] rb-util.c:460: GMutex isn't recursive
(14:48:26) [0x6c9500] [main] main.c:179: going to create DBus object
(14:48:26) [0x6c9500] [main] main.c:322: THE END

I got the same problem and getting the same information.

I hope it can help!
Greetings
Antonio Cono

Sebastien Bacher (seb128) wrote :

There is no indication you get the same bug, you should open a new one with detailled informations and steps to trigger the bug if that's still happening on gutsy

joji (joji-tribeofe) wrote :

sorry to get lost there sebastian, i went away for a bit.
let's see if it can work: here's the results of rythmbox -d you had asked for

(21:44:53) [0x80f4028] [rb_debug_init_match] rb-debug.c:141: Debugging enabled
(21:44:53) [0x80f4028] [main] main.c:206: initializing Rhythmbox 0.10.0
(21:44:53) [0x80f4028] [rb_threads_init] rb-util.c:460: GMutex isn't recursive
(21:44:53) [0x80f4028] [main] main.c:215: going to create DBus object
(21:44:53) [0x80f4028] [main] main.c:402: THE END

and yes the error happens consistently when changing multiple song info. the error msg comes up usually 5-10 seconds after closing the dialog box.

cheers!
joji

Dennis (dennis-u) wrote :

hello all together,

havin' the same problem. I imported all my songs per smb from a NAS and can't change mp3 tag information. After some seconds all (one file, two files, multiple files) changes are reset to previous. Can't remember that it works before.
Using Rythmbox 0.11.2 and Ubuntu Gutsy Gibbon.

Debug information:
(01:25:22) [0x80fb408] [rb_debug_init_match] rb-debug.c:153: Debugging enabled
(01:25:22) [0x80fb408] [main] main.c:171: initializing Rhythmbox 0.11.2
(01:25:22) [0x80fb408] [rb_threads_init] rb-util.c:460: GMutex isn't recursive
(01:25:22) [0x80fb408] [main] main.c:179: going to create DBus object
(01:25:22) [0x80fb408] [main] main.c:322: THE END

Hope this is usefull. If more information are required please tell me.

pyutaros (pyutaros) wrote :

Also receiving same error. Here is the Rhythmbox -d output.

(11:31:11) [0x80fb408] [rb_debug_init_match] rb-debug.c:153: Debugging enabled
(11:31:11) [0x80fb408] [main] main.c:171: initializing Rhythmbox 0.11.2
(11:31:11) [0x80fb408] [rb_threads_init] rb-util.c:460: GMutex isn't recursive
(11:31:11) [0x80fb408] [main] main.c:179: going to create DBus object
(11:31:11) [0x80fb408] [main] main.c:322: THE END

Let me know if more info is needed.

pyutaros (pyutaros) wrote :
Download full text (27.3 KiB)

Here's some output from when the error actually happens.

(20:15:55) [0x805eed8] [rb_metadata_bus_handler] rb-metadata-gst.c:860: message of type 64
(20:15:55) [0x805eed8] [rb_metadata_bus_handler] rb-metadata-gst.c:860: message of type 64
(20:15:55) [0x805eed8] [rb_metadata_bus_handler] rb-metadata-gst.c:860: message of type 64
(20:15:55) [0x805eed8] [rb_metadata_bus_handler] rb-metadata-gst.c:860: message of type 64
(20:15:55) [0x805eed8] [rb_metadata_bus_handler] rb-metadata-gst.c:860: message of type 64
(20:15:55) [0x805eed8] [rb_metadata_bus_handler] rb-metadata-gst.c:860: message of type 64
(20:15:55) [0x805eed8] [rb_metadata_bus_handler] rb-metadata-gst.c:860: message of type 64
(20:15:55) [0x805eed8] [rb_metadata_bus_handler] rb-metadata-gst.c:860: message of type 64
(20:15:55) [0x805eed8] [rb_metadata_load] rb-metadata-gst.c:1018: gone to PAUSED for smb://delerium%3Bshannon@filez/music/Redistribute/Aphex%20Twin/(1995)%20Donkey%20Rhubarb/01%20-%20donkey%20rhubarb.mp3
(20:15:55) [0x805eed8] [rb_metadata_load] rb-metadata-gst.c:1035: duration query succeeded
(20:15:55) [0x805eed8] [rb_metadata_load] rb-metadata-gst.c:1122: successfully read metadata for smb://delerium%3Bshannon@filez/music/Redistribute/Aphex%20Twin/(1995)%20Donkey%20Rhubarb/01%20-%20donkey%20rhubarb.mp3
(20:15:55) [0x805eed8] [rb_metadata_dbus_load] rb-metadata-dbus-service.c:127: metadata load finished; mimetype = application/x-id3
(20:15:55) [0x805eed8] [rb_metadata_dbus_add_to_message] rb-metadata-dbus.c:75: opening container type {uv}
(20:15:55) [0x987f020] [rb_metadata_load] rb-metadata-dbus-client.c:409: got mimetype: application/x-id3
(20:15:55) [0x80fb408] [rhythmdb_process_one_event] rhythmdb.c:2010: processing RHYTHMDB_EVENT_METADATA_LOAD
(20:15:55) [0x80fb408] [rhythmdb_property_model_delete_prop] rhythmdb-property-model.c:661: deleting "Electronica & Dance": refcount: 344
(20:15:55) [0x80fb408] [rhythmdb_property_model_insert] rhythmdb-property-model.c:600: adding "Electronica & Dance": refcount 344
(20:15:55) [0x80fb408] [rhythmdb_property_model_delete_prop] rhythmdb-property-model.c:661: deleting "Aphex Twin": refcount: 143
(20:15:55) [0x80fb408] [rhythmdb_property_model_insert] rhythmdb-property-model.c:600: adding "Aphex Twin": refcount 143
(20:15:55) [0x80fb408] [rhythmdb_property_model_delete_prop] rhythmdb-property-model.c:661: deleting "Donkey Rhubarb": refcount: 4
(20:15:55) [0x80fb408] [rhythmdb_property_model_insert] rhythmdb-property-model.c:600: adding "Donkey Rhubarb": refcount 4
(20:15:55) [0x80fb408] [rb_entry_view_rows_reordered_cb] rb-entry-view.c:1760: rows reordered
(20:15:56) [0x80fb408] [window_focus_cb] rb-mmkeys-plugin.c:117: window got focus, re-grabbing media keys
(20:16:06) [0x80fb408] [window_focus_cb] rb-mmkeys-plugin.c:117: window got focus, re-grabbing media keys
(20:16:20) [0x80fb408] [rb_shell_quit] rb-shell.c:2461: Quitting
(20:16:20) [0x80fb408] [rb_shell_player_set_playing_source_internal] rb-shell-player.c:2732: setting playing source to (nil)
(20:16:20) [0x80fb408] [rb_shell_player_stop] rb-shell-player.c:2800: stopping
(20:16:20) [0x80fb408] [rb_shell_player_sync_with_source] rb-shell-player.c:2563: playing source: (nil...

pyutaros (pyutaros) wrote :

There were further comments, yet this hasn't been looked into.

Changed in rhythmbox:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

There's no indication of the error on the logs.

Changed in rhythmbox:
status: New → Incomplete
pyutaros (pyutaros) wrote :

I believe there has been a communication breakdown here. Please explain with as much clarity and granularity as possible:
1) EXACTLY what process should be used to capture the error output.
2) EXACTLY what portion of the log you need to see posted here.
3) EXACTLY what else users experiencing this problem should be looking for. (This error has begun popping up every couple of minutes on my 7.10 machine.)
Thanks

Changed in rhythmbox:
status: Incomplete → New
pyutaros (pyutaros) wrote :

Is it possible this problem is not related to Rhythmbox and needs to be reported to the GStreamer team? If so, who are they, and how would one go about reporting it? Sorry for being so persistent about this, but this problem is really annoying and is preventing me from using Rhythmbox in any practical fashion.

pyutaros (pyutaros) wrote :

I managed to find the cause of my problem. I had "Watch my library for new files" selected in preferences. I'm not sure whether the samba share was the problem, or whether it was the fact that I have many files in my directory that are not music files and hence have no ID3 information (specifically the album art Windows creates for music files and the thumbs.db windows creates for thumbnails in a directory). Either way, turning this option off seems to give me a workaround for this issue. The problem could likely be resolved if you could create a filter that ignores files of certain types. Hope this helps others who are having this issue.

Kjell Braden (afflux) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Hardy Heron. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at [WWW] http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in rhythmbox:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in rhythmbox:
status: Incomplete → Invalid
Ville Ranki (ville-ranki) wrote :

This bug still exists in Intrepid. Maybe playing from gvfs share could be the common cause. I have 500 gigs of music mounted over fuse/sftp and rhythmbox pops up this dialog several times when it scans the share for changed files.

Can this bug be reopened or should i re-create it? I can repeat the problem and take logs if still needed.

Ville Ranki (ville-ranki) wrote :

Here's a log:

WARN rb_media_renderer Nov 28 18:53:26 elapsed_changed <rb.ShellPlayer object at 0xa760324 (RBShellPlayer at 0x9a28060)> 81L (coherence/MediaPlayer.py:155)
WARN rb_media_renderer Nov 28 18:53:26 update_position 81L 189 (coherence/MediaPlayer.py:183)
(18:53:26) [0xb967ca0] [kill_metadata_service] rb-metadata-dbus-client.c:147: closing dbus connection
(18:53:26) [0xb967ca0] [kill_metadata_service] rb-metadata-dbus-client.c:157: killing child process
(18:53:26) [0xb967ca0] [kill_metadata_service] rb-metadata-dbus-client.c:164: closing metadata child process stdout pipe
(18:53:26) [0xb967ca0] [default_sync_metadata] rhythmdb.c:4350: error saving metadata for file:///home/xxx/siilo/Sound/0-ALL-AND-EVERYTHING/Hypocrisy/Penetralia/Jesus%20Fall.mp3: Internal GStreamer problem; file a bug; reloading metadata to revert
(18:53:26) [0xb967ca0] [action_thread_main] rhythmdb.c:2716: executing RHYTHMDB_ACTION_LOAD for "file:///home/xxx/siilo/Sound/0-ALL-AND-EVERYTHING/Hypocrisy/Penetralia/Jesus%20Fall.mp3"

Btw i've got UPnP plugin installed, if it matters..

Ville Ranki (ville-ranki) wrote :

Bug still exists on Intrepid and is reproducable. It makes rhythmbox unusable. I can provide any extra inforimation if needed.

Changed in rhythmbox:
status: Invalid → New

bug still exists but THe problem Im having is if there are any other files NOT related to mpg, ogg, flac etc, there is an import error listed. It seems on my machine, windoze adds other files eg. thumbs.db, desktop.ini, thumbnail.info
Rhythmbox should ignore these files as there not music sources

Ville Ranki (ville-ranki) wrote :

It's obvious it should ignore them. Typically users including me have a lot of non-audio files (thumbs.db, cover jpg's, etc) in their audio directory.

Miss bliss (joylearns) wrote :

How do I make the error while saving song information Internal GStreamer problem; file a bug, go away?

I tried writing "rhythmbox -d" command line and this is what it said.

(17:50:08) [0x80dc408] [rb_debug_init_match] rb-debug.c:153: Debugging enabled
(17:50:08) [0x80dc408] [main] main.c:184: initializing Rhythmbox 0.11.5
(17:50:08) [0x80dc408] [rb_threads_init] rb-util.c:460: GMutex isn't recursive
(17:50:08) [0x80dc408] [main] main.c:192: going to create DBus object
(17:50:08) [0x80dc408] [main] main.c:346: THE END

Lionel Dricot (ploum) wrote :

I don't really understand this bug report but could someone report it upstream on http://bugzilla.gnome.org ? It's likely an upstream issue. Please describe an easy way to reproduce this problem.

Ville Ranki (ville-ranki) wrote :

I haven't seen this problem any more on Intrepid for a while. Has it been fixed or does someone still have it?

It seems to be fixed. I didnt realize the package had been updated. Now
I have 0.11.5

On Wed, 2009-03-11 at 13:00 +0000, Ville Ranki wrote:

> I haven't seen this problem any more on Intrepid for a while. Has it
> been fixed or does someone still have it?
>

It seems to be fixed, The package seems to have been updated as I now
have 0.11.5

On Wed, 2009-03-11 at 11:10 +0000, Lionel Dricot wrote:

> I don't really understand this bug report but could someone report it
> upstream on http://bugzilla.gnome.org ? It's likely an upstream issue.
> Please describe an easy way to reproduce this problem.
>

jeret (korisvalmentaja) wrote :

I just got the error msg again, when I opened Rhythmbox. My version is 0.11.6.
Error messages (4 of them) appeared right after startup, having displayed the library contents.
Couldn't reproduce the error with -d option, though.
I have my music stored on a network share which is permanently mounted, which might be useful info.

For a laugh and a half, I decided to delete everything in Rhythmbox and
rescan the music folder
AND I can reproduce the problem again. For every file that isn't music,
i.e.: thumbs.db, 2bthumbnail.info, desktop.ini, *.txt, lyrics.pdf, I get
an 'Import error' and each one says 'internal GStreamer problem:file a
bug'. and every folder/album has some of these
I have music on a local drive and a network drive, same problem
Ive got rhythmbox version 0.11.5

On Wed, 2009-03-11 at 16:52 +0000, jeret wrote:

> I just got the error msg again, when I opened Rhythmbox. My version is 0.11.6.
> Error messages (4 of them) appeared right after startup, having displayed the library contents.
> Couldn't reproduce the error with -d option, though.
> I have my music stored on a network share which is permanently mounted, which might be useful info.
>

Ernst (ernst-blaauw) wrote :

I'm running Rhythmbox 0.11.6, I cannot reproduce this problem (which I had before). For me, it seems to be solved. (However, I'm not using Rhythmbox anymore, but Foobar and Amarok. Maybe the problem did not pop up during testing)

Per Ångström (autark) wrote :
Download full text (4.9 KiB)

Rhythmbox 0.12.0/Ubuntu 9.04

I can easily recreate this problem: I only need to edit the metadata of a few files in my collection of classical FLAC files. Some changes will go through but some will not, and Rhythmbox will display a title-less dialog about an internal GStreamer problem. If I look closely in the file system, I will find some left-over hidden temporary files that are playable but truncated near the end, one for each failed edit.

I have a few observations:

- Whenever a metadata-change operation fails, the error message will appear after *15 seconds*. I think there is a timeout somewhere that arbitrarily concludes that the operation fails after that time. This might explain why I have been unable to recreate the problem when I have copied parts of collection to my internal drive, which is my faster than the drive that has the collection. It might also explain why some edits go through and others not: if the file is large it takes longer to rewrite.

- Rhythmbox will not wait for the edits to have effect before rescanning the collection. Since Rhytmhbox doesn't wait for the result of the metadata change, it looks like the operation succeeded with a spurious error indication. It is not until the collection is reloaded that it it obvious that the operation failed. And the user's storage space will be eaten by large hidden temporary files.

Following is some debug output. Note the *15-second gap* between the start of the operation and the detection of the error:

(10:24:22) [0xbf4700] [rb_metadata_save] rb-metadata-gst.c:1300: saving metadata for uri: file:///media/Passport/musik/klassiskt/Mahler%20-%20Sinfonie%20Nr.9%20-%20Polish%20National%20Radio%20Symphony%20Orchestra/Mahler%20-%20Symphony%20%239%20-%201-01%20-%20Mvt%201%20-%20Andante%20comodo.flac
(10:24:22) [0xbf4700] [rb_metadata_save] rb-metadata-gst.c:1303: temporary file name prefix: file:///media/Passport/musik/klassiskt/Mahler%20-%20Sinfonie%20Nr.9%20-%20Polish%20National%20Radio%20Symphony%20Orchestra/.Mahler%20-%20Symphony%20%239%20-%201-01%20-%20Mvt%201%20-%20Andante%20comodo.flac
[snipped]
(10:24:22) [0xbf4700] [rb_metadata_bus_handler] rb-metadata-gst.c:946: message of type state-changed from pipeline
(10:24:22) [0xbf4700] [rb_metadata_gst_load_tag] rb-metadata-gst.c:663: uri: file:///media/Passport/musik/klassiskt/Mahler%20-%20Sinfonie%20Nr.9%20-%20Polish%20National%20Radio%20Symphony%20Orchestra/Mahler%20-%20Symphony%20%239%20-%201-01%20-%20Mvt%201%20-%20Andante%20comodo.flac tag: artist
(10:24:22) [0xbf4700] [rb_metadata_gst_load_tag] rb-metadata-gst.c:663: uri: file:///media/Passport/musik/klassiskt/Mahler%20-%20Sinfonie%20Nr.9%20-%20Polish%20National%20Radio%20Symphony%20Orchestra/Mahler%20-%20Symphony%20%239%20-%201-01%20-%20Mvt%201%20-%20Andante%20comodo.flac tag: album
(10:24:22) [0xbf4700] [rb_metadata_gst_load_tag] rb-metadata-gst.c:716: Got shorter duplicate tag
(10:24:22) [0xbf4700] [rb_metadata_gst_load_tag] rb-metadata-gst.c:663: uri: file:///media/Passport/musik/klassiskt/Mahler%20-%20Sinfonie%20Nr.9%20-%20Polish%20National%20Radio%20Symphony%20Orchestra/Mahler%20-%20Symphony%20%239%20-%201-01%20-%20Mvt%201%20-%20Andante%20comodo.flac tag: title
(...

Read more...

Per Ångström (autark) wrote :

I have found it! Look at the following lines from rb-metadata-dbus-service.c:

#define ATTENTION_SPAN 30
...
electromagnetic_shotgun (gpointer data)
{
        ServiceData *c = (ServiceData *)data;
        GTime now = time(NULL);
        int idle = now - c->last_active;

        /* quit if we haven't done anything for a while */
        if (idle > ATTENTION_SPAN) {
                rb_debug ("shutting down (%ds idle)", idle);
                g_main_loop_quit (c->loop);
        }

        return TRUE;
}
...
        if (!svc.external)
                g_timeout_add_seconds (ATTENTION_SPAN / 2, (GSourceFunc) electromagnetic_shotgun, &svc);

No wonder all lengthy operations are cut off after 15 seconds!

Another observation: It seems that metadata-change operations are quicker and thus less error-prone when only a small collection is loaded. This suggests that the metadata-change background operation is hindered by Rhythmbox rescanning the collection while the operation is in progress.

Per Ångström (autark) wrote :

I will file an upstream bug report.

Per Ångström (autark) wrote :

http://bugzilla.gnome.org/show_bug.cgi?id=577433 "metadata-dbus operations arbitrarily cut off after 15 seconds"

Andreas Moog (ampelbein) wrote :

Thanks for linking upstream.

Changed in rhythmbox (Ubuntu):
status: New → Triaged
Ville Ranki (ville-ranki) wrote :

I got too annoyed because of this not being fixed and did a quick hack for myself.

I commented out the line 320 in metadata/rb-metadata-dbus-client.c:

  g_set_error (error,
        RB_METADATA_ERROR,
        RB_METADATA_ERROR_INTERNAL,
        _("Internal GStreamer problem; file a bug"));

Now rb doesn't bitch about this and is usable once again. I attached a fixed build.

Enjoy.

Per Ångström (autark) wrote :

Are you sure this will not only suppress the error message? I think the 15-second timeout I found actually kills the metadata operation prematurely. You cannot trust the metadata displayed by Rhythmbox after a metadata operation, since Rhythmbox will update its display immediately without waiting for the operation to finish.

Ville Ranki (ville-ranki) wrote :

I'm not 100% sure what this change does as i haven't studied the source code more deeply. After the change RB seems to be running just fine though.

Everyone should understand that my fix just disables the error dialog, not the original bug that causes it.

Changed in rhythmbox:
status: Unknown → New
Per Ångström (autark) wrote :

I found another timeout in addition to the one I discovered earlier. I have uploaded a patch to the Rhythmbox Bugzilla which increases these timeouts considerably. The patch fixes the problems for me and it's very low-risk.

Per Ångström (autark) wrote :

Rhythmbox has rejected my patch and will not do anything about the bug (which is still unconfirmed), unless someone comes up with a more sophisticated solution. In other words, this will probably never be fixed. Sorry!

Yassen (yassen-jason-todorov) wrote :

Well I personally find this very annoying - and it has been a carried problem since at least 7.10.

Ville Ranki (ville-ranki) wrote :

Could Per's patch be included in Ubuntu version of Rhythmbox? I think it's really weird that Ubuntu's default desktop's default music player can have showstopper bugs like this.

nomnex (nomnex) wrote :
Download full text (14.9 KiB)

I have exactly the same problem anytime I Alt+Return to edit a song's metadata (mainly .mp3)

Rhythmbox 12
GStreamer

Message Error while saving song information
Internal GStremer problem, file a bug

rhythmbox -d

(rhythmbox-metadata:4505): GStreamer-CRITICAL **: gst_tag_get_type: assertion `info != NULL' failed

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.20.1/gobject/gtype.c:3940: type id `0' is invalid

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.20.1/gobject/gvalue.c:192: cannot initialize GValue with type `(null)', this type has no GTypeValueTable implementation

(rhythmbox-metadata:4505): GLib-GObject-CRITICAL **: g_value_transform: assertion `G_IS_VALUE (dest_value)' failed

(rhythmbox-metadata:4505): GLib-GObject-CRITICAL **: g_value_unset: assertion `G_IS_VALUE (value)' failed

(rhythmbox-metadata:4505): GStreamer-CRITICAL **: gst_tag_get_type: assertion `info != NULL' failed

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.20.1/gobject/gtype.c:3940: type id `0' is invalid

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.20.1/gobject/gvalue.c:192: cannot initialize GValue with type `(null)', this type has no GTypeValueTable implementation

(rhythmbox-metadata:4505): GLib-GObject-CRITICAL **: g_value_transform: assertion `G_IS_VALUE (dest_value)' failed

(rhythmbox-metadata:4505): GLib-GObject-CRITICAL **: g_value_unset: assertion `G_IS_VALUE (value)' failed

(rhythmbox-metadata:4505): GStreamer-CRITICAL **: gst_tag_get_type: assertion `info != NULL' failed

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.20.1/gobject/gtype.c:3940: type id `0' is invalid

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.20.1/gobject/gvalue.c:192: cannot initialize GValue with type `(null)', this type has no GTypeValueTable implementation

(rhythmbox-metadata:4505): GLib-GObject-CRITICAL **: g_value_transform: assertion `G_IS_VALUE (dest_value)' failed

(rhythmbox-metadata:4505): GLib-GObject-CRITICAL **: g_value_unset: assertion `G_IS_VALUE (value)' failed

(rhythmbox-metadata:4505): GStreamer-CRITICAL **: gst_tag_get_type: assertion `info != NULL' failed

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.20.1/gobject/gtype.c:3940: type id `0' is invalid

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

(rhythmbox-metadata:4505): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.20.1/gobject/gvalue.c:192: cannot initialize GValue with type `(null)', this type has no GTypeValueTable implementation

(rhythmbox-metadata:4505): GLib-GObject-CRITICAL **: g_value_transform: assertion `G_IS_VALU...

nomnex (nomnex) wrote :

Edit: writing tags on large mp3 (I use DJ sets ~110 MB) is a fairly long process. I have only used RB for a few hours, but anytime I tried to tag/modify the tags of a .mp3 file, RB is kinda of freezing after a few seconds of disk activity; then the error message pops-up. I guess Per Ångström made his point: No wonder all lengthy operations are cut off after 15 seconds!

I see that as a serious bug. Thanks

Davide Saurino (dsaurino) wrote :

I have the same bug, my music library is in a local directory mounted through smbfs. I'm able to change id3 info but I get the error message for each song I'm going to modify.

Miguel Gaspar (ghaspias) wrote :

This behaviour is still a problem for me (in Ubuntu 9.10).
The timeout Per Ångström refers to has been (reluctantly) changed upstream to 120 seconds (after strenuous efforts from Per Ångström - great work!), but if you happen to have a slow wi-fi (as a result of a long broken rtl8187 driver in Ubuntu, as I have), and have full-cd audio files in a remote share, this will probably bite you.
I don't think this is such a rare scenario as not to deserve attention.
So, I sugest that when changing metadata, the dialog should be left open while 'applying' changes, and leave to the user the decision to abort if it takes too long.

voltaire (frivo) wrote :

I had a Rhythmbox opened in a background window and as I was editing tags with EasyTag, It crashed Rhythmbox and since then whenever I want to open it there a fairly long delay and it comes with the pop-up: Error while saving song information. Internal GStreamer problem; file a bug.

I am using Ubuntu 10.04.

voltaire (frivo) wrote :

A re-install of rhythmbox didn't help but removing the xml file rhythmdb.xml (~/.local/share/rhythmbox/rhythmdb.xml) helped me start the application again (after which it re-scans the music database automatically).

jtrottier (trottier-james) wrote :

Same Exact issue as voltaire.
When trying to re-open, Rhythmbox stops at rhythmdb.c:2635: processing RHYTHMDB_EVENT_METADATA_LOAD
Have to kill process "rhythmbox-metadata" (as it doesn't stop when rhythmbox crashes) from system-monitor to get it to load and start functioning again.
Also, I have auto-rescan set to update my music library and use a lot of FLAC files.
Also caused miro to freeze.

Hugo Hidalgo (hydrodelta) wrote :

Same problem here as Voltaire with Ubuntu 10.04 and Rhythmbox 0.12.8.

It seemed frozen for a while, but after a long delay it allowed me to close the error message window and then after another long delay another one appeared (again frozen for a while and then let me close the window and so on). After about 20 minutes it finished the process and I unmarked the "Watch my library for new files" option in the preferences. I logged out, and restarted rhythmbox. This time was really frozen. I erased the file ~/.local/share/rhythmbox/rhythmdb.xml as suggested by Voltaire and restarted the program. Added all my libraries again and closed. Logged out and logged in and restarted rhythmbox. I seems to be working fine now (but of course it won't look for new songs).

ad7u (calebeskurdal) wrote :

I am experiencing this bug in 10.04. Closing rhythmbox-metadata from the System Monitor seems to have got rid of the error box.

Leeteq.XV (leeteq) wrote :

In my case, it seems to mostly (or "only"?) happen when I select several songs tagged with "Unknown". I can update others (multiple songs) just fine as long as they are not in the Unknown genre.

Leeteq.XV (leeteq) wrote :

(using updated Ubuntu 10.04 LTS)

Changed in rhythmbox:
importance: Unknown → Wishlist
Changed in rhythmbox:
status: New → Confirmed
Changed in rhythmbox:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.