ipod: album art not added unless the file is playing

Bug #117583 reported by Nicolò Chieffo on 2007-05-29
38
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Wishlist
Sebastien Bacher

Bug Description

Binary package hint: rhythmbox

rhythmbox 0.11.0-0ubuntu1

I've just dragged a song to the ipod, but its cover art, which was available in rhythmbox, is not available when using the ipod.
This only happens if the file was not playing in the moment I copied it. If it was playing the artwork is copied

Sebastien Bacher (seb128) wrote :

Thank you for your bug. The gutsy version has code for that, it just require to be built with a newer libgpod version

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: Unconfirmed → Fix Committed
Changed in rhythmbox:
status: Unknown → Fix Released

I also would like to see an option to download new cover arts for my
ipod, like in itunes... is it possible?

Now rhythmbox has been built with libgpod2 but this feature is still missing

Sebastien Bacher (seb128) wrote :

I've just tried and that works fine on my gutsy. What ipod model do you use? Did you try with several songs? Do you have a local covert of one downloaded automatically? Could you run rhythmbox -d and look if there is any error when you dnd the track?

Changed in rhythmbox:
status: Fix Committed → Incomplete

Ipod nano black, old model, 4GB.
I tried with several songs!
I don't know what does "local cover" mean... I have every cover in
.gnome2/rhythmbox/covers and they were downloaded

starting rhythmbox -d there is no reference of "art" or "cover" when
dragging the file to the ipod.

which .c file is the responsable of putting the art to the ipod?

Nicolò Chieffo (yelo3) wrote :

also lyrics are not added. Should I open a new bug or it is just part
of the same code block of this bug?

you can look in plugins/ipod/rb-ipod-source.c request_artwork() and artwork_notify_cb() and plugins/ipod/rb-ipod-db.c rb_ipod_db_set_thumbnail_internal()

The lyric seems to be a different request, feel free to open an another bug if there is not already one opened

maybe to have the artwork it is needed in the file's metadata, instead
of in the local cache?

what do you mean? it works automatically, the cover is downloaded from the net and copied on the ipod with the track

Ok if it is like you said, In my case it does not work. Is there a way
to know if my ipod is recognized as artwork-capable?
Thank you

the ipod nano can display artwork, where do you try to see it on the player? Could you try to copy a track using gtkpod?

Sebastien, could you please post here the debugging messages that I
should see if the artwork is copied?
Thank you very much

Nicolò Chieffo (yelo3) wrote :

To see the artwork you have to start playing a song and then hit twice
the "middle" button
starting gtkpod I see this error:

iTunesDB '/media/YELO3/iPod_Control/iTunes/iTunesDB' does not match
checksum in extended information file
'/media/YELO3/iPod_Control/iTunes/iTunesDB.ext'
gtkpod will try to match the information using SHA1 checksums. This
may take a long time.

maybe this could be the problem... but it does not do any fix.
From gtkpod I can download directly a cover art from an already
present song. This does not work either!

Nicolò Chieffo (yelo3) wrote :

I've just resetted the ipod from itunes. But rhythmbox still does not
add the art, also with the new 0.11.2

The previous error always happens when a file is added from rhythmbox.

There is debug message about the artwork when it's copied no, I've tried with an another song and it worked fine also. Does transfering artwork using itunes work correctly? I'll try to ask upstream if they have some ideas on the issue

Sebastien Bacher (seb128) wrote :

could you run "ldd $(which rhythmbox)" and copy that to a comment? what architecture do you use?

Sebastien Bacher (seb128) wrote :

what version of libgpod2 is installed?

Nicolò Chieffo (yelo3) wrote :

Yes, itunes can transfer artwork well.
Anyway I will try again with itunes soon
libgpod2 0.5.2-2

Sebastien Bacher (seb128) wrote :

What about "ldd /usr/lib/rhythmbox/plugins/ipod/libipod.so"?

from windows now. iTunes can still transfer artwork.

Sebastien Bacher (seb128) wrote :

marking New for now

Changed in rhythmbox:
status: Incomplete → New
Dan Bishop (danbishop) wrote :

I have a green ipod nano (2nd generation) and I also get no album art transferred. All my album art resides in the correct folders titled ".folder.jpg" and rhythmbox detects it perfectly. It does not sync it to the ipod however, whether the track is playing or not.

I have attached output of the above command. I use AMD64 but only recently switched and this wasn't working on i386 either...

Nicholas Gee (nicholas-gee) wrote :

I have an ipod video 60gb with the same problem. Artwork in the folder titled cover.png. Rhythmbox loads it fine when playing the track but doesn't transfer the art to the ipod unless I'm actually playing the song in rhythmbox as I transfer; and even then it only transfers art for that song on the album and no others.

Pedro Villavicencio (pedro) wrote :

That's works fine for me in Gutsy and Hardy with a 30gb iPod video, is this still an issue for you?

Ross Burton (ross) wrote :

I'm hitting this bug, with Rhythmbox from Debian Unstable (rhythmbox 0.10.1-1+b2, libgpod3 0.6.0-3) and an iPod Classic. All album artwork is in ~/.rhythmbox and appears in the Rhythmbox UI, but none is transferred to the iPod.

Nicolò Chieffo (yelo3) wrote :

I'm still having this issue, after a clean install of hardy alpha 5

Everthon Valadão (valadao) wrote :

yes! I finally got the cover art working (on gtkpod) by compiling the libgpod 0.6.0 with PIXBUF installed...
I guess it would work on Rhythmbox too, so I put the download/install script below so you guys could fix it too:

apt-get -y install libgpod2 libgpod-common libgpod-dev libmp4v2-0 libgdk-pixbuf2 libgdk-pixbuf-dev
cd /tmp
wget -c http://ufpr.dl.sourceforge.net/sourceforge/gtkpod/libgpod-0.6.0.tar.gz
tar -zxvf libgpod-0.6.0.tar.gz
cd libgpod-0.6.0
./configure
make
sudo make install
sudo rm /usr/lib/libgpod.so.2.0.0
sudo rm /usr/lib/libgpod.so.2
sudo ln -s /usr/local/lib/libgpod.so.3 /usr/lib/libgpod.so.3
sudo ln -s /usr/local/lib/libgpod.so.3 /usr/lib/libgpod.so.2

can this fix be ported to ubuntu?

I'm in hardy right now, and this is the situation:
the ipod plugin /usr/lib/rhythmbox/plugins/ipod/libipod.so depends on libgpod3.
ldd on /usr/lib/libgpod.so.3 shows this:
[...]
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb7e78000)
[...]

so the version in hardy is compiled with pixbuf, but it's not working,

Sebastien Bacher (seb128) wrote :

the hardy works correctly when you have played the song in the library to get the artwork before copying

Not working in my case... I have my library with cover.jpg in every
album directory, but the coverart is not copied

that might depend of the ipod model then, needs to be debugged by somebody having access to such hardware, I tried using automatically downloaded covers in rhythbox and not local images though

can you try with cover.jpg?
How can I debug it? Is it enough to run rhythmbox -d?

I tested it with downloaded covers, and it works. Very sad! I'm changing the description accordingly to this

Changed in rhythmbox:
status: New → Confirmed
description: updated

I've understood what triggers the artwork to be copied: the file must be playing in the moment it is copied to the ipod. In this case it copies cover.jpg too.
This bug is also valid (in my case) if the artwork is downloaded

description: updated
Changed in rhythmbox:
status: Unknown → New

I confirm this bug on a fully updated hardy 64bit.

Jonas H (jonash) wrote :

I confirm this bug on hardy x86 and Ipod Nano 1st generation.

Changed in rhythmbox:
status: Confirmed → Triaged
Stéphane Maniaci (stephh) wrote :

I can confirm this on latest Hardy x86_64 and Ipod Nano 4th generation.

I can also confirm it for both 32 or 64-bit systems... too bad!

Jonas H (jonash) wrote :

This bug sucks °-°

Nevertheless it seems to work properly with Banshee...

Pedro Villavicencio (pedro) wrote :

that's a really useful comment, please only comment on the bug if you have more information that can be useful for the report to get it fixed otherwise Please don't do it. thanks.

Here there is a patch which seems to solve the problem but I haven't tried it.

http://bugzilla.gnome.org/show_bug.cgi?id=529873

The patch solves the problem for me. It can be simply installed without the need to recompile anything since the plugin is in Python.

Instructions here: http://bugzilla.gnome.org/show_bug.cgi?id=529873#c5

Tom Wright (twright-tdw) wrote :

i can confirm that the patch works for the ipod nano 3rd gen

I can confirm the bug using rhythmbox 0.11.6svn20080903-0ubuntu2 (intrepid source compiled under hardy). The behavior is exactly the same as rhythmbox 0.11.5 available in standard hardy. While I haven't looked at the patch referred by Christian Apolloni, I found my way out for the moment: when all the songs are transferred to the ipod, just play a song from each album on the ipod (that can be done by double-clicking on the name of the album via the library browser in rhythbmox) and wait for the album art to appear. It will then be tranfered to the ipod.

john (hellandbarrenjoy) wrote :

[quote]I found my way out for the moment: when all the songs are transferred to the ipod, just play a song from each album on the ipod (that can be done by double-clicking on the name of the album via the library browser in rhythbmox) and wait for the album art to appear. It will then be tranfered to the ipod.[/quote]

jesus christ. with a 160gb almost full, this sounds tedious...

Le jeudi 18 septembre 2008 à 05:59 +0000, john a écrit :
> [quote]I found my way out for the moment: when all the songs are
> transferred to the ipod, just play a song from each album on the ipod
> (that can be done by double-clicking on the name of the album via the
> library browser in rhythbmox) and wait for the album art to appear. It
> will then be tranfered to the ipod.[/quote]
>
> jesus christ. with a 160gb almost full, this sounds tedious...
>
Well... on my 4GB iPod nano, it's not that long... ok, so let's look at
that patch, then...

Matti Pöllä (mpo) wrote :

3rd gen ipod nano: bug confirmed, patch working
4rd gen ipod nano: bug confirmed, patch not working

peter76 (pf-moll) wrote :

When I use Jean's trick to play a song on my iPod 4G, album art is put on my iPod, but not with the right album...
Should I file another bug about this?

Changed in rhythmbox:
assignee: desktop-bugs → seb128
Changed in rhythmbox:
status: New → Fix Released
Pedro Villavicencio (pedro) wrote :

this ha been fixed upstream now.

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the new version is in karmic now

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.