package resolvconf 1.78ubuntu1 failed to install/upgrade: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1

Bug #1536335 reported by Nicolas DERIVE on 2016-01-20
132
This bug affects 25 people
Affects Status Importance Assigned to Milestone
resolvconf (Ubuntu)
Critical
Martin Pitt

Bug Description

Upgrading from 14.04LTS to 16.04LTS (Xenial), I got this upgrade error.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: resolvconf 1.78ubuntu1
ProcVersionSignature: Ubuntu 4.3.0-6.17-generic 4.3.3
Uname: Linux 4.3.0-6-generic x86_64
ApportVersion: 2.19.3-0ubuntu3
Architecture: amd64
Date: Wed Jan 20 19:57:02 2016
ErrorMessage: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
InstallationDate: Installed on 2014-10-05 (472 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1
 apt 1.1.10
SourcePackage: resolvconf
Title: package resolvconf 1.78ubuntu1 failed to install/upgrade: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
UpgradeStatus: Upgraded to xenial on 2016-01-20 (0 days ago)

Nicolas DERIVE (kalon33) wrote :
Steve Langasek (vorlon) on 2016-01-20
Changed in resolvconf (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
Martin Pitt (pitti) wrote :

I tried to reproduce this with a 14.04 → 16.04 upgrade in several scenarios, but I can't yet. Nicolas, do you actually use ifupdown on this system, i. e. can you please attach your /etc/network/interfaces and /etc/network/interfaces.d/* ?

Even if I remove "eth0" from /etc/network/interfaces, 14.04's resolvconf still creates /run/resolvconf/interfaces/ (it will be empty then). This happens both in the upstart job (/etc/init/resolvconf.conf) and in the systemd service (/lib/systemd/system/resolvconf.service). So it appears to me that resolvconf was never started before you started the upgrade even.

Did you do anything to disable resolvconf in 14.04?

I suppose we could guard against this by teaching resolvconf to mkdir the runtime directory on resolvconf --enable-updates, instead of in the init scripts. But that doesn't help to understand what went wrong on your system.

Thanks!

On Thu, Jan 21, 2016 at 10:01:57AM -0000, Martin Pitt wrote:
> I tried to reproduce this with a 14.04 → 16.04 upgrade in several
> scenarios, but I can't yet. Nicolas, do you actually use ifupdown on
> this system, i. e. can you please attach your /etc/network/interfaces
> and /etc/network/interfaces.d/* ?

> Even if I remove "eth0" from /etc/network/interfaces, 14.04's
> resolvconf still creates /run/resolvconf/interfaces/ (it will be empty
> then). This happens both in the upstart job (/etc/init/resolvconf.conf)
> and in the systemd service (/lib/systemd/system/resolvconf.service). So
> it appears to me that resolvconf was never started before you started
> the upgrade even.

And what happens if resolvconf is upgraded inside a chroot, where services
are not started?

Steve Langasek [2016-01-21 16:59 -0000]:
> And what happens if resolvconf is upgraded inside a chroot, where services
> are not started?

I tried that too and couldn't reproduce the failure --
/run/resolvconf/interfaces is created in a schroot anyway.

Nicolas DERIVE (kalon33) wrote :

Martin, here is the file. I have nothing in /etc/network/interfaces.d/.

Nicolas DERIVE (kalon33) wrote :

And to answer your question, no, I didn't alter resolvconf behavior when running 14.04. When forcing a "dpkg --configure -a", and then a "apt-get -f install", it seems to fix that problem and I have a properly running system.

I tried to upgrade another computer from 15.10 and didn't encounter that problem, I got systemd upgrade error BTW, but it was fixed by the automatic "dpkg --configure -a" run at the end.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in resolvconf (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

multiple reports; marking critical as this breaks dist upgrades.

Changed in resolvconf (Ubuntu):
importance: High → Critical
Željko Jagušt (zeljko-jagust) wrote :

I did a strace on "resolvconf -a eth0.inet" and from the result, an interface file in /run/resolvconf/interface is not generated:

stat("/run/resolvconf/interface", {st_mode=S_IFDIR|0755, st_size=40, ...}) = 0
chdir("/run/resolvconf/interface") = 0
stat("eth0.inet", 0x7ffd99e45550) = -1 ENOENT (No such file or directory)

Thanks. I think this is my firmware file for the wireless lan.

I am trying to update or use a different firmware for this.

On Thu, Feb 11, 2016 at 12:57 PM, Željko Jagušt <email address hidden>
wrote:

> I did a strace on "resolvconf -a eth0.inet" and from the result, an
> interface file in /run/resolvconf/interface is not generated:
>
> stat("/run/resolvconf/interface", {st_mode=S_IFDIR|0755, st_size=40, ...})
> = 0
> chdir("/run/resolvconf/interface") = 0
> stat("eth0.inet", 0x7ffd99e45550) = -1 ENOENT (No such file or
> directory)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1542884).
> https://bugs.launchpad.net/bugs/1536335
>
> Title:
> package resolvconf 1.78ubuntu1 failed to install/upgrade: le sous-
> processus script post-installation installé a retourné une erreur de
> sortie d'état 1
>
> Status in resolvconf package in Ubuntu:
> Confirmed
>
> Bug description:
> Upgrading from 14.04LTS to 16.04LTS (Xenial), I got this upgrade
> error.
>
> ProblemType: Package
> DistroRelease: Ubuntu 16.04
> Package: resolvconf 1.78ubuntu1
> ProcVersionSignature: Ubuntu 4.3.0-6.17-generic 4.3.3
> Uname: Linux 4.3.0-6-generic x86_64
> ApportVersion: 2.19.3-0ubuntu3
> Architecture: amd64
> Date: Wed Jan 20 19:57:02 2016
> ErrorMessage: le sous-processus script post-installation installé a
> retourné une erreur de sortie d'état 1
> InstallationDate: Installed on 2014-10-05 (472 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> (20140417)
> PackageArchitecture: all
> RelatedPackageVersions:
> dpkg 1.18.4ubuntu1
> apt 1.1.10
> SourcePackage: resolvconf
> Title: package resolvconf 1.78ubuntu1 failed to install/upgrade: le
> sous-processus script post-installation installé a retourné une erreur de
> sortie d'état 1
> UpgradeStatus: Upgraded to xenial on 2016-01-20 (0 days ago)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/resolvconf/+bug/1536335/+subscriptions
>

Rishi Banerjee [2016-02-11 7:52 -0000]:
> I am trying to update or use a different firmware for this.

This isn't firmware related at all, so please don't try and break your
wifi card :-)

Martin Pitt (pitti) on 2016-02-29
Changed in resolvconf (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package resolvconf - 1.78ubuntu2

---------------
resolvconf (1.78ubuntu2) xenial; urgency=medium

  [ Thomas Hood ]
  * Drop obsolete versioned dependencies. (Closes: #804976)
    (Taken from Debian packaging git)

  [ Martin Pitt ]
  * bin/resolvconf: Create runtime dir if it does not exist. In some upgrade
    scenarios resolvconf gets called before the postinst or init scripts get
    run. (LP: #1536335)

 -- Martin Pitt <email address hidden> Mon, 29 Feb 2016 08:39:56 +0100

Changed in resolvconf (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers