Ubuntu

[SRU] Mouse Wheel does not work in RDP/VNC (12.04)

Reported by Hannes Erven on 2012-03-12
236
This bug affects 46 people
Affects Status Importance Assigned to Milestone
remmina
Unknown
Unknown
remmina (Ubuntu)
Medium
Mathieu Trudel-Lapierre
Precise
Medium
Mathieu Trudel-Lapierre

Bug Description

[Impact]
Medium frequency of occurence, but this patch satisfies the expectation of users to be able to scroll windows in the same way used as outside a remote session. Based on the number of people affected and subscribers, This is an common expectation.
Also this is a regression, since it worked in previous versions of Remmina.

[Development Fix]
Small patch written by Jean-Louis Dupond, integrated upstream. See https://github.com/FreeRDP/Remmina/commit/fe1b698e4a6bba7783edcb3d0431e6acb24323f4. Simply implements the missing event.

[Stable Fix]
See "Development Fix".

[Test Case]
1) Connect to a RDP or VNC -enabled system; open a window where scrolling would be necessary.
2) Attempt to scroll the window via a mouse scrolling wheel, or touchpad scrolling region.

[Regression Potential]
Minimal; affects remmina only. This is limited to the scrolling behavior for the GDK_SCROLL_SMOOTH event, which was missing. Possible regression would be the lack of support of that event (so equivalent to not patching).

-----

Issue: Scrolling/Mouse Wheel does not work in Remmina (for both VNC & RDP plugins)
The patch is already applied upstream: https://github.com/FreeRDP/Remmina/commit/fe1b698e4a6bba7783edcb3d0431e6acb24323f4
Its a quite small patch. We just needed to implement SCROLL_SMOOTH.

Testing the fix is easy.
Without patch: unable to scroll with mousewheel in rdp or vnc connections
After patching: we can now scroll in vnc & rdp

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in remmina (Ubuntu):
status: New → Confirmed
Nate Carlson (natecarlson) wrote :

Upgraded from Oneiric to Precise today; Remmina plus plugin versions are now 1.0.0-1ubuntu5. In this version, scrolling no longer works for me; it worked fine in Oneiric. I dropped back to Oneiric versions, and that works fine.. after adding oneiric sources to apt, ran:

sudo apt-get install libfreerdp-dev=0.8.2-2build1 libfreerdp-plugins-standard=0.8.2-2build1 remmina=0.9.3-2 remmina-plugin-nx=0.9.2-2 remmina-plugin-rdp=0.9.2-2 remmina-plugin-telepathy=0.9.2-2 remmina-plugin-vnc=0.9.2-2

1of16 (1of16) wrote :

is there a fix?

WillieStylez (williestylez) wrote :

Can someone point us in the right direction of a fix, or a step by step of what Nate did. I tried adding an Oneiric source to Software Center, but I am not sure I know what I am doing there. I saw in a thread where you may need to reload apt to get new sources to work, but it didn't offer any commands to do that. when I try to get "help" from command, it says I need install apt! :-( Pretty frustrating. Any help would be appreciated.

sunweb (sunweb-a) wrote :

to WillieStylez

Make the file executable and click on it
or
open it in text editor and copy paste line by line in terminal

Jérôme Poulin (jeromepoulin) wrote :

I noticed yesterday when you have a large display, the wheel scrolls the display. It seems intercepted by the remmina's GTK interface.

Jean-Louis Dupond (dupondje) wrote :

GDK_SCROLL_SMOOTH got added into GDK, but this is not supported in Remmina atm.
Getting a patch ready, and asking for SRU.

Changed in remmina (Ubuntu):
assignee: nobody → Jean-Louis Dupond (dupondje)
Jean-Louis Dupond (dupondje) wrote :

The attached patch fixes the Scroll issue in Remmina.

The patch implements the GDK_SCROLL_SMOOTH event.
Which was just ignored before. (Only GDK_SCROLL_UP/DOWN was used).

This exact same code has also been added upstream:
https://github.com/FreeRDP/Remmina/commit/1aebfc027507607d5f061ba9072eb952e07214d1

Which means next Remmina release we can drop this patch.

summary: - Mouse Wheel does not work in RDP (12.04)
+ [SRU] Mouse Wheel does not work in RDP (12.04)
summary: - [SRU] Mouse Wheel does not work in RDP (12.04)
+ [SRU] Mouse Wheel does not work in RDP/VNC (12.04)

Jean-Louis,

At first glance your patch looks good. Unfortunately, I can't test it just now but I will be able to in a few hours, at which point I'll be happy to sponsor the package.

In the meantime, could you take a look at https://wiki.ubuntu.com/StableReleaseUpdates#Procedure and add the necessary information to this bug's description for the SRU? Thanks!

Changed in remmina (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: Jean-Louis Dupond (dupondje) → Mathieu Trudel-Lapierre (mathieu-tl)

I was able to succesfully scroll in RDP, but not in VNC. Jean-Louis, can you explain what I'm doing wrong in testing this? ;)

Jean-Louis Dupond (dupondje) wrote :

Attached an improved patch. This also fixes scrolling in VNC plugin.

sunweb (sunweb-a) wrote :

Thats great news.
Will it be updated in repository soon ? If not, could you tell how to apply the patch ?

Indeed, I can verify it works properly now.

Upstream has committed the initial changes:
https://github.com/FreeRDP/Remmina/commit/fe1b698e4a6bba7783edcb3d0431e6acb24323f4 , the others to be committed shortly.

description: updated
description: updated
description: updated

Hello Hannes, or anyone else affected,

Accepted remmina into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in remmina (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Hannes Erven (hannes-erven) wrote :

Thank you Martin and everyone else involved - I can confirm the bug is fixed in 1.0.0.1-ubuntu6 .

tags: added: verification-done
removed: verification-needed
Changed in remmina (Ubuntu):
status: Fix Committed → Fix Released

Hi all, I'm using lubuntu (Ubuntu 12.04 LTS) I just upgraded my OS and I'm facing excatly the problem described in the ticket.
I downloaded the scroll.patch file and tried to run it, unfortunately I got this error message:

      diff: remmina-1.0.0/debian/changelog: File o directory non esistente (file or directory doesn't exist)
      diff: remmina-1.0.0/debian/changelog: File o directory non esistente (file or directory doesn't exist)
      ./scroll.patch: riga 2: ---: comando non trovato (row 2 command not found)
      ./scroll.patch: riga 3: +++: comando non trovato (row 3 command not found)
      ./scroll.patch: riga 4: @@: comando non trovato (row 4 command not found)
      ./scroll.patch: riga 5: errore di sintassi vicino al token non atteso "1.0.0-1ubuntu6" (syntax error next to unattended token "1.0.0-1ubuntu6")
      ./scroll.patch: riga 5: `+remmina (1.0.0-1ubuntu6) precise-proposed; urgency=low' (row 5 ...)

Can anybody help me and give me the proper procedure to apply the patch?
Thank you very much in advance.
Maurizio

Jean-Louis Dupond (dupondje) wrote :

Hi!

You need to enable proposed (https://wiki.ubuntu.com/Testing/EnableProposed).
Then you will get an update of Remmina with the scroll patch included.

No need you need to build/patch the package yourself.

Thank you very much Jean-Louis, I followed your suggestion, now the patch is working.

rs232 (vincenco) wrote :

The update definitely fixed the scrolling issue. I followed Jean-Louis advice.

Unfortunately, the cut and paste still doesn't work.

alex (alejandro-garcia-lopez) wrote :

Same here, successfully updated remmina with the patch (through the precise proposed repo) and scrolling has been fixed but still no copy/paste.

Sorinello (sorinello) wrote :

Any idea when this wil lbe available in Ubuntu 12.04 as an official update ?

I enabled "proposed" like Jean mentioned, and after doing so, I did received an update that got the scroll-wheel working (thank you), but (along with that update) I had to update 117 other proposed packages (having nothing to do with this bug), that I would have rather not updated, until they were "approved" (not just "proposed"). There is no granulartiy; "proposed" is all packages or no packages (it seems).

So as Sorinello was asking, I'd like to know when this fix will become an official update.

Thanks again for the fix. Now if we can get "cut and paste" (to remote desktops) working, I'll be completely content:
https://bugs.launchpad.net/bugs/937522

Hannes Erven (hannes-erven) wrote :

In Synaptic, you can filter the packages you'd like to upgrade easily - even with (or: especially when) "proposed" enabled.
I even deactivated proposed again after updating only remmina - even that way the updated version persisted.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package remmina - 1.0.0-1ubuntu6

---------------
remmina (1.0.0-1ubuntu6) precise-proposed; urgency=low

  * debian/patches/scroll_smooth.patch: fix scrolling with GDK_SCROLL_SMOOTH
    (LP: #952964).
 -- Jean-Louis Dupond <email address hidden> Sun, 22 Apr 2012 23:10:05 +0200

Changed in remmina (Ubuntu Precise):
status: Fix Committed → Fix Released
rs232 (vincenco) wrote :

The scrollwheel issue appears to be fixed. Thanks so much! Also the cut and paste is fixed with a new ppa over here:
https://bugs.launchpad.net/ubuntu/+source/remmina/+bug/937522

Tomas Cassidy (tomas-cassidy) wrote :

I'm still seeing this bug in the latest remmina package on Ubuntu 12.04. Scrolling with the mouse wheel doesn't work in a RDP session to a Windows 7 or Windows Server 2008 machine. It is working in VNC.

$ apt-cache policy remmina
remmina:
  Installed: 1.0.0-1ubuntu6.1
  Candidate: 1.0.0-1ubuntu6.1
  Version table:
 *** 1.0.0-1ubuntu6.1 0
        500 http://au.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.0-1ubuntu5 0
        500 http://au.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.