CAPS LOCK desactivate and up/down arrows are insane in TSE connexion

Bug #458976 reported by David VANTYGHEM on 2009-10-23
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rdesktop (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by David VANTYGHEM
Nominated for Karmic by David VANTYGHEM

Bug Description

Binary package hint: yelp

I connect to a Windows 2003 server with TSE, using rdesktop under Ubuntu 9.04.

I first had a problem with the numerical keypad that didn't work. I unactivated "Controlling mouse with the numerical keypad" in the keyboard configuration menu. Now, it's OK.

Then a second problem : Caps Lock doesn't work. I replace "Caps_Lock 0x0 inhibit" by "Caps_Lock 0x03 In /usr/share/rdesktop/keymaps) and now it's OK.

But I still have got 2 other problems :
- The up and down arrows sometimes become insane in one of my software (CEGID ERP), about 5-6 lines are passed instead of one, when choosing a line in a list, with this software CEGID. Particularly when it's the first or the last line showed in the screen. Perhaps the problem is the same with others softwares but I did not found at this moment.
 - When CAPS LOCK is activated, sometimes big letters become small letters, particularly after using the numerical pad. But the CAPS LOCK led is still lighting. And the opposite phenomenon occurs : CAPS LOCK LED switched off, small letters become big letters.

I don't have this problem with a Debian client PC and the same rdesktop "common" and "fr" configuration files (in /usr/share/rdesktop/keymaps). I'm using rdesktop 1.6.0-2, tsclient 0.150-1, grdesktop... The 2 bugs are always here.

I think there's no relation between these two bugs and rdesktop but I can't find the solution.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/yelp
Package: yelp 2.25.1-0ubuntu5
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.28-16-generic i686

I found that in fact, changing “Caps_Lock 0×0 inhibit” to “Caps_Lock 0×3a capslock” was a wrong solution (see http://linuxsagas.wordpress.com/2009/01/17/ubuntu-intrepid-woes-keyboard/ ). This is the cause of the inversion of CAPS LOCK. For example, press :
a CAPS LOCK a 5 (or another numpad key) CAPS LOCK a 5 a
-> you will obtain aA5A5a instead of aA5a5a.
The numpad keys invert the caps lock but do not turn the caps lock light.

So, I changed “Caps_Lock 0×3a capslock” to the initial value “Caps_Lock 0×0 inhibit” and tried the following parameter :
Menu "System - Preferencies - Keyboard", select "Caps Lock invert Caps., affects all the keys" in the options.
It works but now I've got another problem. Using CAPS LOCK and the numerical keypad activates the mouse moving with the numerical keypad, then the numerical doesn't work anymore.

There's no solution to have CAPS LOCK working under Ubuntu in a RDP session? Help!!!!!!!!

Test it under Debian 5.0 and Mandriva 2009.1, with "Caps_Lock 0×0 inhibit" (default configuration) and without "CAPS LOCK inverts Caps." (default configuation of the keyboard" -> I don't have all these problems.

affects: yelp (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Confirmed

This bug is quite old. Can you test in Lucid or Maverick if the issue is still present? Thanks!

affects: ubuntu → rdesktop (Ubuntu)
Changed in rdesktop (Ubuntu):
status: Confirmed → Incomplete

Always the same problem with Lucid Lynx + last updates + tsclient 0.150 :
CAPS LOCK works but as soon as you press a number on the numerical touchpad, the CAPSLOCK doesn't work anymore (but the CAPSLOCK light stays switched on).
No problem after using debian tsclient.

Changed in rdesktop (Ubuntu):
status: Incomplete → Confirmed

No more problem in Ubuntu 10.10. You can close this bug.

Thanks for letting us know! Note that you can change the status of the bug by clicking the yellow icon below "Status".

Changed in rdesktop (Ubuntu):
status: Confirmed → Invalid
Changed in rdesktop (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers