Cannot exit gnome-rdp fullscreen when visual effects are enabled

Bug #153995 reported by daws on 2007-10-18
68
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rdesktop (Ubuntu)
Medium
Domker_
Nominated for Intrepid by Ken Foskey

Bug Description

This happens when I have a gnome-rdp session open in fullscreen, with desktop effects enabled. I press CTRL+ALT+<ENTER> to get out of fullscreen and it goes out for a blink of an eye and then re-maximizes itself so that I am stuck in the session. The only way I can get out is to log out, which is not an option.

WORKAROUND: Install compizconfig-settings-manager and uncheck "Legacy Fullscreen Support" from the Utility -> Workarounds group.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in gnome-rdp.

R S Gill (rsgill) wrote :

Changed this bug from gnome-rdp to tsclient since tsclient is installed by default.

Perhaps it belongs in rdesktop then?

On 10/19/07, R S Gill <email address hidden> wrote:
> Changed this bug from gnome-rdp to tsclient since tsclient is installed
> by default.
>
> ** Changed in: tsclient (Ubuntu)
> Sourcepackagename: gnome-rdp => tsclient
>
> --
> Cannot exit gnome-rdp fullscreen when visual effects are enabled
> https://bugs.launchpad.net/bugs/153995
> You received this bug notification because you are a direct subscriber
> of the bug.
>

R S Gill (rsgill) wrote :

Changed to rdesktop since tsclient is a front end to rdesktop.

daws (dawsdesign) wrote :

Sorry for not assigning it to a package to begin with. I saw that option as I clicked the submit button and afterword I looked for a way to change it, but could not determine how.

Jamie Jackson (jamiejackson) wrote :

This is happening to me, too, starting with my recent upgrade to Gutsy (final) from Feisty. Once I'm in a full-screen RDP session, I can't get back to Ubuntu in any sort of normal manner (CTRL-ALT-ENTER).

"Lossy" workarounds:
 *Log out of remote machine (ends the remote session, retains local session)
 *CTRL-ALT-Backspace (ends local session, retains remote session--once logged back in via RDP)

"Lossless" workaround.
 *This one's weird, but if you hold down CTRL-ALT-ENTER, and keep it down, you'll enter a Twilight Zone where it's rapidly flashing back and forth between Ubuntu and the remote session. While it's in this altered state, hit the Left arrow key and then let go of all four buttons. It's like roulette, so it might take several attempts, but eventually, you'll get to the desktop to the left of the one that's got the RDP session in it.

Using this technique, you would want to start out by opening the RDP session on its own desktop, so it's not obscuring any apps/windows beneath it.

H.E. Pennypacker (pennypacker) wrote :

Can also confirm this bug. Please fix ASAP as it seriously impacts on my ability to do work using Gutsy.

R S Gill (rsgill) on 2007-10-31
Changed in rdesktop:
status: New → Confirmed
Andy V (av-spamtrap) wrote :

I've just installed gutsy and have noticed the same problem. Fortunately, I discovered a decent workaround: start rdesktop at a resolution very slightly smaller then your full-screen resolution. For example, my laptop's resolution is 1280x800, so I start rdesktop like this:

rdesktop -g 1280x799 <hostname>

When rdesktop comes up, it will be in a window, and you will be able to easily switch between fullscreen and windowed mode using Ctrl-Alt-Enter. Of course, your RDP session won't use the bottom row of pixels on your screen, but that seems like a small price to pay. Also, you'll probably have to start rdesktop from the command line, as it doesn't seem that tsclient and grdesktop support passing arbitrary resolutions to rdesktop.

R S Gill (rsgill) on 2007-11-05
Changed in rdesktop:
assignee: nobody → domker2

More workarounds to tide us over until the fix: http://ubuntuforums.org/showthread.php?t=595384

Victor Van Hee (vvanhee) wrote :

The workaround described by Andy V works for me -- thanks. I also created a launcher by right-clicking on the desktop and clicking "create launcher." Then I put 'rdesktop -g 1024x767 <hostname>' in the 'command' line and gave it a name. Now I can just click on the icon that this process created, and CTRL-ALT-ENTER actually works.

Is this going to be fixed more permanently?

davec (david-covell-plus) wrote :

I have just encountered this problem, but curiously only in the last few weeks. I installed gutsy originally, but had problems with my graphics card driver which defaulted to the basic vesa driver. rdesktop behaved perfectly originally, but when I finally fixed my graphics card proprietary ATI driver (fglrx) installation so that all the OpenGL stuff and Compiz effects worked, rdesktop failed to switch with ctrl-alt-enter when I next came to use it.

Don't know whether this was just a coincidence - might have been caused by a package update that I had downloaded in the same period.

i echo davec
was using the roulette method to work-around with Terminal Server Client
had huge issues with dell m65 and restricted drivers and screen resolution, so started using the Envy installation
this "fixed" my difficulty with switching from a full-screen rdesktop or tsc to one of my other ubuntu 7.10 desktops

Alejandro Martínez (zenitram) wrote :

It's some sort of conflict with Compiz. You can make full screen work properly by installing the package compizconfig-settings-manager, running it from System -> Preferences -> Appearance (or ccsm from the command line), going to Workarounds section and disabling "Legacy fullscreen support".

threexk (threexk) wrote :

Bug also exists in Hardy. The Ctrl-Alt-Enter + Ctrl-Alt-Left/Right trick doesn't work; sometimes it'll change the desktop on the local machine, but it will still take me back to the remote machine.

As of today I do not see a bug report on the SourceForge rdesktop project page for this issue.

The workaround I have been using is to disconnect my local PC's network connections, wait for several seconds, reconnect them, then use the Ctrl-Alt-Enter + Ctrl-Alt-Left/Right trick. I have not tried the compizconfig-settings-manager package.

Ken Foskey (foskey) wrote :

Bug occurs in Intrepid as well.

I just found this bug after getting my nvidia drivers to work, I enabled visual effects and went full screen into rdesktop, had to fight it to get out (by holding ctrl+alt+enter while swiftly going to Alt+tab and getting ubuntu's attention)

It is quite annoying, but it isn't "vital" at least, not for me. I think it has something to do with the way visual effect windows "stick" to the sides of the monitor.

ddumont (ddumont) wrote :

What you call a bug, I call a feature. However I think that's only because of the description.

It's not that you can't leave fullscreen, it's that rdesktop is no longer honoring the -K option. It's ignoring the WM keybindings. you definatly can still see the difference between fullscreen and just a large geom rdesktop session. I've gotten my cube to rotate while maximized and see when in fullscreen that the session follows me on to the new face.

However I have not yet been able to get the cube to rotate out of fullscreen mode. I've had to shrink my geom to show the desktop applet and it allows me to rotate.

So again, not stuck in fullscreen, it's just ignoring the WM keybindings.

ddumont (ddumont) wrote :

I think https://bugs.launchpad.net/ubuntu/+source/rdesktop/+bug/270997 is a more accurate report of this bug.

Somewhat echoing ddumont, it happened to me on Hardy Heron after I went to the "performance" tab of the TSClient app and checked the "Enable window manager's key binding" check box. Once I "unchecked" this box, the CTRL-ALT-Enter worked properly again.

Stefan Soriga (sgstefan) wrote :

This bug is still present in Intrepid, the workaround is working though. Thank you Jamie.

Szymon Życiński (zycinski) wrote :

Confirmed, and very annoying in interpid.

Jim Leinweber (jiml-mail) wrote :

It really does seem to be a compiz problem in intrepid; I had it on a Toshiba laptop with an ATI video chip. On an old Compaq presario with an nvidia geforce 440 and the unaccelerated "nv" driver I didn't have the bug. As soon as the binary nvidia driver turned up, with compiz appearance "normal", the bug. Note that an alternative workaround to turning off compiz is to use "rdesktop -g99% ...". You'll have aslightly nasty gray unused "L" border (bottom+right) to your rdesktop session, but you can switch between full screen and windowed mode with Ctrl-Alt-Enter as you could in hardy.

stenzn (stenzn) wrote :

I followed the workaround instructions for Compiz, which fixed the problem, but I have noticed that now when Rhythmbox switches songs and the "Now Playing" tooltip pops up, the remote desktop screen flashes- it's rather annoying.

Michael Rooney (mrooney) wrote :

I'll give this a Medium importance since it can have a severe impact on anyone running RDP in full-screen, which is very useful to do. The solution also may be to disable Legacy Fullscreen Support from compiz by default, which Linux Mint does and as such does not suffer from this issue.

description: updated
Changed in rdesktop (Ubuntu):
importance: Undecided → Medium
threexk (threexk) wrote :

Does this problem still exist with the latest updates in 9.04? It went away for me--rdesktop now minimizes to a window--but I can't remember whether I changed anything. I never installed compizconfig-settings-manager to do the workaround.

Temp fix:
System > Preferences > Appearance > Visual Effects > None > Close

I not sure if this has been fixed yet. I've yet to see a version of Ubuntu that you could run visual effects on without it corrupting some program. 3D games have a hard time running in full screen mode to if you have visual effects enabled.

For example install billard:
sudo apt-get install billard-gl

Great game, but try running it with visual effects turned on!

Joel Oliver (joelol75) wrote :

This is not a rdesktop bug but a compiz one. KDE has an option for desktop effects titled "Disable desktop effects for fullscreen windows" which fixes all problems from games to choppy video playback to this one. Unfortunately it's not checked by default and not in CCSM.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers