./configure --enable-arm needed for ARM events

Bug #1769182 reported by Manoj Iyer on 2018-05-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rasdaemon (Debian)
Fix Released
Unknown
rasdaemon (Ubuntu)
High
dann frazier
Xenial
Undecided
dann frazier
Artful
Undecided
Manoj Iyer
Bionic
Undecided
Manoj Iyer

Bug Description

[Impact]
The UEFI 2.6 spec added support for ARM processor errors and errors
that have unrecognized CPER section types. rasdaemon needs to support ARM kernel trace events. To enable arm events we need to configure rasdaemon package with --enable-arm

[Test]
debian/rules needs --enable-arm to enable arm events. I have a test build of the rasdaemon package in ppa:centriq-team/lp1741978-rasdaemon. I tested this on an a QDF2400 system. Here are the results for bionic, artful and xenial.

--- bionic ---
ubuntu@awrep3:~$ sudo service rasdaemon status
● rasdaemon.service - RAS daemon to log the RAS events
   Loaded: loaded (/lib/systemd/system/rasdaemon.service; enabled; vendor preset
   Active: active (running) since Mon 2018-04-23 15:25:18 UTC; 17s ago
 Main PID: 3369 (rasdaemon)
    Tasks: 1 (limit: 7065)
   CGroup: /system.slice/rasdaemon.service
           └─3369 /usr/sbin/rasdaemon -f -r

Apr 23 15:25:18 awrep3 rasdaemon[3369]: ras:arm_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: Enabled event ras:arm_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: Can't parse /proc/cpuinfo: missing [vend
Apr 23 15:25:18 awrep3 rasdaemon[3369]: Can't register mce handler
Apr 23 15:25:18 awrep3 rasdaemon[3369]: Can't get traces from ras:aer_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording mc_event events
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording aer_event events
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording extlog_event events
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording mce_record events
Apr 23 15:25:19 awrep3 rasdaemon[3369]: rasdaemon: Recording arm_event events

ubuntu@awrep3:~$ grep rasdaemon /var/log/syslog
Apr 23 15:25:18 awrep3 rasdaemon: ras:mc_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon: ras:mc_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: ras:mc_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Enabled event ras:mc_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: ras:aer_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Enabled event ras:aer_event
Apr 23 15:25:18 awrep3 rasdaemon[3370]: rasdaemon: ras:mc_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3370]: rasdaemon: ras:aer_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3370]: rasdaemon: Can't write to set_event
Apr 23 15:25:18 awrep3 rasdaemon[3370]: rasdaemon: Can't write to set_event
Apr 23 15:25:18 awrep3 rasdaemon[3370]: rasdaemon: ras:arm_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon: Enabled event ras:mc_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: ras:arm_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Enabled event ras:arm_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id] [cpu family] [model] [cpu MHz] [flags]
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Can't register mce handler
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Can't get ras:extlog_mem_event traces. Perhaps this feature is not supported on your system.
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Can't get traces from ras:aer_event
Apr 23 15:25:18 awrep3 rasdaemon: ras:aer_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Listening to events for cpus 0 to 45
Apr 23 15:25:18 awrep3 rasdaemon: Can't write to set_event
Apr 23 15:25:18 awrep3 rasdaemon: ras:aer_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon: Enabled event ras:aer_event
Apr 23 15:25:18 awrep3 rasdaemon: Can't write to set_event
Apr 23 15:25:18 awrep3 rasdaemon: ras:arm_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon: ras:arm_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon: Enabled event ras:arm_event
Apr 23 15:25:18 awrep3 rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id] [cpu family] [model] [cpu MHz] [flags]
Apr 23 15:25:18 awrep3 rasdaemon: Can't register mce handler
Apr 23 15:25:18 awrep3 rasdaemon: Can't get traces from ras:aer_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording mc_event events
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording aer_event events
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording extlog_event events
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording mce_record events
Apr 23 15:25:19 awrep3 rasdaemon[3369]: rasdaemon: Recording arm_event events

-- artful --
ubuntu@awrep3:~$ sudo service rasdaemon status
● rasdaemon.service - RAS daemon to log the RAS events
   Loaded: loaded (/lib/systemd/system/rasdaemon.service; enabled; vendor preset
   Active: active (running) since Mon 2018-04-23 15:51:55 UTC; 13s ago
 Main PID: 3683 (rasdaemon)
    Tasks: 1 (limit: 7065)
   Memory: 7.9M
      CPU: 48ms
   CGroup: /system.slice/rasdaemon.service
           └─3683 /usr/sbin/rasdaemon -f -r

Apr 23 15:51:55 awrep3 rasdaemon[3683]: ras:arm_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon[3683]: Enabled event ras:arm_event
Apr 23 15:51:55 awrep3 rasdaemon[3683]: Can't parse /proc/cpuinfo: missing [vend
Apr 23 15:51:55 awrep3 rasdaemon[3683]: Can't register mce handler
Apr 23 15:51:55 awrep3 rasdaemon[3683]: Can't get traces from ras:aer_event
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Recording mc_event events
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Recording aer_event events
Apr 23 15:51:56 awrep3 rasdaemon[3683]: rasdaemon: Recording extlog_event events
Apr 23 15:51:56 awrep3 rasdaemon[3683]: rasdaemon: Recording mce_record events
Apr 23 15:51:56 awrep3 rasdaemon[3683]: rasdaemon: Recording arm_event events

ubuntu@awrep3:~$ grep rasdaemon /var/log/syslog
Apr 23 15:51:55 awrep3 rasdaemon: ras:mc_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon: Enabled event ras:mc_event
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: ras:mc_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Enabled event ras:mc_event
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: ras:aer_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Enabled event ras:aer_event
Apr 23 15:51:55 awrep3 rasdaemon: ras:aer_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon[3684]: rasdaemon: ras:mc_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon[3684]: rasdaemon: ras:aer_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon[3684]: rasdaemon: Can't write to set_event
Apr 23 15:51:55 awrep3 rasdaemon[3684]: rasdaemon: Can't write to set_event
Apr 23 15:51:55 awrep3 rasdaemon[3684]: rasdaemon: ras:arm_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: ras:arm_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Enabled event ras:arm_event
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id] [cpu family] [model] [cpu MHz] [flags]
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Can't register mce handler
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Can't get ras:extlog_mem_event traces. Perhaps this feature is not supported on your system.
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Can't get traces from ras:aer_event
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Listening to events for cpus 0 to 45
Apr 23 15:51:55 awrep3 rasdaemon: Enabled event ras:aer_event
Apr 23 15:51:55 awrep3 rasdaemon: ras:arm_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon: Enabled event ras:arm_event
Apr 23 15:51:55 awrep3 rasdaemon: ras:mc_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon: ras:aer_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon: Can't write to set_event
Apr 23 15:51:55 awrep3 rasdaemon: Can't write to set_event
Apr 23 15:51:55 awrep3 rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id] [cpu family] [model] [cpu MHz] [flags]
Apr 23 15:51:55 awrep3 rasdaemon: Can't register mce handler
Apr 23 15:51:55 awrep3 rasdaemon: Can't get traces from ras:aer_event
Apr 23 15:51:55 awrep3 rasdaemon: ras:arm_event event enabled
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Recording mc_event events
Apr 23 15:51:55 awrep3 rasdaemon[3683]: rasdaemon: Recording aer_event events
Apr 23 15:51:56 awrep3 rasdaemon[3683]: rasdaemon: Recording extlog_event events
Apr 23 15:51:56 awrep3 rasdaemon[3683]: rasdaemon: Recording mce_record events
Apr 23 15:51:56 awrep3 rasdaemon[3683]: rasdaemon: Recording arm_event events

-- xenial --
ubuntu@awrep3:~$ sudo service rasdaemon status
sudo: unable to resolve host awrep3
● rasdaemon.service - RAS daemon to log the RAS events
   Loaded: loaded (/lib/systemd/system/rasdaemon.service; enabled; vendor preset
   Active: active (running) since Mon 2018-04-23 16:05:09 UTC; 13s ago
 Main PID: 4624 (rasdaemon)
    Tasks: 1
   Memory: 8.0M
      CPU: 49ms
   CGroup: /system.slice/rasdaemon.service
           └─4624 /usr/sbin/rasdaemon -f -r

Apr 23 16:05:09 awrep3 rasdaemon[4624]: ras:arm_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon[4624]: Enabled event ras:arm_event
Apr 23 16:05:09 awrep3 rasdaemon[4624]: Can't parse /proc/cpuinfo: missing [vend
Apr 23 16:05:09 awrep3 rasdaemon[4624]: Can't register mce handler
Apr 23 16:05:09 awrep3 rasdaemon[4624]: Can't get traces from ras:aer_event
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Recording mc_event events
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Recording aer_event events
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Recording extlog_event events
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Recording mce_record events
Apr 23 16:05:10 awrep3 rasdaemon[4624]: rasdaemon: Recording arm_event events

ubuntu@awrep3:~$ grep rasdaemon /var/log/syslog
Apr 23 16:05:09 awrep3 rasdaemon: ras:mc_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon: ras:mc_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: ras:mc_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Enabled event ras:mc_event
Apr 23 16:05:09 awrep3 rasdaemon[4625]: rasdaemon: ras:mc_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon[4625]: rasdaemon: ras:aer_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon[4625]: rasdaemon: Can't write to set_event
Apr 23 16:05:09 awrep3 rasdaemon[4625]: rasdaemon: Can't write to set_event
Apr 23 16:05:09 awrep3 rasdaemon[4625]: rasdaemon: ras:arm_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon: Enabled event ras:mc_event
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: ras:aer_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Enabled event ras:aer_event
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: ras:arm_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Enabled event ras:arm_event
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id] [cpu family] [model] [cpu MHz] [flags]
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Can't register mce handler
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Can't get ras:extlog_mem_event traces. Perhaps this feature is not supported on your system.
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Can't get traces from ras:aer_event
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Listening to events for cpus 0 to 45
Apr 23 16:05:09 awrep3 rasdaemon: ras:aer_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon: Can't write to set_event
Apr 23 16:05:09 awrep3 rasdaemon: Can't write to set_event
Apr 23 16:05:09 awrep3 rasdaemon: ras:aer_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon: Enabled event ras:aer_event
Apr 23 16:05:09 awrep3 rasdaemon: ras:arm_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon: ras:arm_event event enabled
Apr 23 16:05:09 awrep3 rasdaemon: Enabled event ras:arm_event
Apr 23 16:05:09 awrep3 rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id] [cpu family] [model] [cpu MHz] [flags]
Apr 23 16:05:09 awrep3 rasdaemon: Can't register mce handler
Apr 23 16:05:09 awrep3 rasdaemon: Can't get traces from ras:aer_event
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Recording mc_event events
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Recording aer_event events
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Recording extlog_event events
Apr 23 16:05:09 awrep3 rasdaemon[4624]: rasdaemon: Recording mce_record events
Apr 23 16:05:10 awrep3 rasdaemon[4624]: rasdaemon: Recording arm_event events

[Regression Potential]
This option is enabled only for target ARM64 in debian/rules.

Manoj Iyer (manjo) wrote :

Patch to enable arm events for aarch64 in bionic

Manoj Iyer (manjo) wrote :

Patch to enable arm events for aarch64 in artful

Manoj Iyer (manjo) wrote :

Patch to enable arm events for aarch64 in xenial

dann frazier (dannf) on 2018-05-04
summary: - [SRU][BIONIC] enable ARM event
+ ./configure --enable-arm needed or ARM events
summary: - ./configure --enable-arm needed or ARM events
+ ./configure --enable-arm needed for ARM events

The attachment "Patch to enable arm events for aarch64 in bionic" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Manoj Iyer (manjo) wrote :

Patch to enable arm events for aarch64 in bionic

dann frazier (dannf) on 2018-05-04
Changed in rasdaemon (Ubuntu Bionic):
status: New → In Progress
Changed in rasdaemon (Ubuntu):
status: New → In Progress
Changed in rasdaemon (Ubuntu Bionic):
assignee: nobody → Manoj Iyer (manjo)
Changed in rasdaemon (Ubuntu):
assignee: nobody → Manoj Iyer (manjo)
dann frazier (dannf) wrote :

Thanks Manoj. Some feedback...

This check is backwards:
ifeq (,$(filter $(DEB_HOST_ARCH),aarch64))

The way it is written, it is checking to see if $(DEB_HOST_ARCH) is *not* in the string "aarch64". We want to this to be true if it is. It's working for you because the $(DEB_HOST_ARCH) and $(DEB_TARGET_ARCH_CPU) will be "arm64", not "aarch64", on an arm64 host so, in fact, arm64 != aarch64. However, neither is amd64, ppc64el, etc - end result is that --enable-arm will be set on every architecture.

btw, the 'filter' function is for searching for a string in a list of words. aarch64 is just one word, so filter is overkill here. I think it'd be easier to understand to just say:
ifeq ($(DEB_HOST_ARCH),arm64)

Also, the ifeq section is currently between a comment and the code it describes - mind moving that up? Thanks! Looking forward to the next version..

Manoj Iyer (manjo) wrote :

[v3] Patch to enable arm events for aarch64 in bionc

Changed in rasdaemon (Debian):
status: Unknown → New
Manoj Iyer (manjo) wrote :

Patch to enable arm events for aarch64 in artful

Manoj Iyer (manjo) wrote :

Patch to enable arm events for aarch64 in xenial

dann frazier (dannf) on 2018-05-09
Changed in rasdaemon (Ubuntu):
status: In Progress → Fix Committed
assignee: Manoj Iyer (manjo) → dann frazier (dannf)
Changed in rasdaemon (Ubuntu Artful):
assignee: nobody → Manoj Iyer (manjo)
Changed in rasdaemon (Ubuntu Xenial):
assignee: nobody → dann frazier (dannf)
Changed in rasdaemon (Ubuntu Artful):
status: New → In Progress
Changed in rasdaemon (Ubuntu Xenial):
status: New → In Progress
Changed in rasdaemon (Debian):
status: New → Fix Released
Timo Aaltonen (tjaalton) wrote :

cosmic got this

Changed in rasdaemon (Ubuntu):
status: Fix Committed → Fix Released
Changed in rasdaemon (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic

Hello Manoj, or anyone else affected,

Accepted rasdaemon into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rasdaemon/0.6.0-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Manoj, or anyone else affected,

Accepted rasdaemon into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rasdaemon/0.5.8-1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in rasdaemon (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed-artful
Changed in rasdaemon (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Manoj, or anyone else affected,

Accepted rasdaemon into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rasdaemon/0.5.6-2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Manoj Iyer (manjo) wrote :
tags: added: verification-done verification-done-artful verification-done-bionic verification-done-xenial
removed: verification-needed verification-needed-artful verification-needed-bionic verification-needed-xenial

The verification of the Stable Release Update for rasdaemon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rasdaemon - 0.6.0-1ubuntu0.1

---------------
rasdaemon (0.6.0-1ubuntu0.1) bionic; urgency=medium

  * debian/rules: Enable ARM events --enable-arm (LP: #1769182)

 -- Manoj Iyer <email address hidden> Wed, 02 May 2018 15:01:16 -0500

Changed in rasdaemon (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rasdaemon - 0.5.6-2ubuntu1.1

---------------
rasdaemon (0.5.6-2ubuntu1.1) xenial; urgency=medium

  * debian/rules: Enable ARM events --enable-arm (LP: #1769182)

rasdaemon (0.5.6-2ubuntu1) xenial; urgency=medium

  * Cherrypick upstream patches to support ARM kernel trace events.
    LP: #1741978

 -- Manoj Iyer <email address hidden> Wed, 09 May 2018 14:54:44 -0500

Changed in rasdaemon (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rasdaemon - 0.5.8-1ubuntu2.1

---------------
rasdaemon (0.5.8-1ubuntu2.1) artful; urgency=medium

  * debian/rules: Enable ARM events --enable-arm (LP: #1769182)

rasdaemon (0.5.8-1ubuntu2) artful; urgency=medium

  * Cherrypick upstream patches to support ARM kernel trace events.
    LP: #1741978

 -- Manoj Iyer <email address hidden> Wed, 09 May 2018 14:45:57 -0500

Changed in rasdaemon (Ubuntu Artful):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.