Add support for ARM events

Bug #1741978 reported by Manoj Iyer on 2018-01-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rasdaemon (Debian)
Fix Released
Unknown
rasdaemon (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
High
Unassigned

Bug Description

[IMPACT]
The UEFI 2.6 spec added support for ARM processor errors and errors
that have unrecognized CPER section types. rasdaemon needs to support ARM kernel trace events.

[FIX]
The following patches add support for ARM events to rasdaemon:

rasdaemon: add support for non standard CPER section events
rasdaemon: add support for ARM events

ARM support was added to rasdaemon in version 0.6.0 release.

[TESTING]
The patches were applied to rasdaemon 0.5.8 and 0.5.6 versions and tested on Artful and Xenial. Test results are attached to comments below.

[REGRESSION POTENTIAL]
None.

Manoj Iyer (manjo) wrote :
Manoj Iyer (manjo) wrote :

These patches were test on Artful on ARM64 system and found to work as expected. The built in test from the package was used to test rasdaemon after the patches were applied.

The attachment "rasdaemon-0.5.8 debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
dann frazier (dannf) on 2018-01-08
Changed in rasdaemon (Ubuntu):
status: New → Fix Released
summary: - [Artful/Zesty/Xenial] Add support for ARM events
+ Add support for ARM events
Manoj Iyer (manjo) wrote :

debdiff for Xenial rasdaemon-0.5.6

Manoj Iyer (manjo) wrote :

These patches were test on Xenial on ARM64 system and found to work as expected. The built in test from the package was used to test rasdaemon-0.5.6 after the patches were applied.

Changed in rasdaemon (Debian):
status: Unknown → Fix Released

Al,

I am reaching out to you to see if you could please review+apply the
debdiff for rasdaemon package, cherry-picked from upstream, and available
in debian and bionic (0.6).
https://bugs.launchpad.net/ubuntu/+source/rasdaemon/+bug/1741978 (Add
support for ARM events ). The diffs apply to 0.5.8 (Artful/Zesty) and
0.5.6 (Xenial) versions of rasdaemon.

Thanks
--
============================
Manoj Iyer
Ubuntu/Canonical
ARM Servers - Cloud
============================

Manoj Iyer (manjo) on 2018-01-19
description: updated
Manoj Iyer (manjo) wrote :

debdiff for Artful (0.5.8).

Manoj Iyer (manjo) wrote :

debdiff for Xenial (0.5.6)

Changed in rasdaemon (Ubuntu Zesty):
status: New → Won't Fix
dann frazier (dannf) wrote :

@Manoj: For the xenial one, note that you need to run 'updatemaintainer' on the package when you add the initial ubuntu1 to the version.

Manoj Iyer (manjo) wrote :

Please review the attached patch for rasdaemon 0.5.6 with changes requested by dannf.

dann frazier (dannf) on 2018-01-23
Changed in rasdaemon (Ubuntu Xenial):
status: New → In Progress
Changed in rasdaemon (Ubuntu Artful):
status: New → In Progress

Hello Manoj, or anyone else affected,

Accepted rasdaemon into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rasdaemon/0.5.6-2ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in rasdaemon (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Changed in rasdaemon (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed-artful
Chris J Arges (arges) wrote :

Hello Manoj, or anyone else affected,

Accepted rasdaemon into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rasdaemon/0.5.8-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Manoj Iyer (manjo) wrote :

Test results for -proposed testing for Xenial.

Manoj Iyer (manjo) wrote :

Test results for -proposed testing for Artful.

tags: added: verification-done verification-done-artful verification-done-xenial
removed: verification-needed verification-needed-artful verification-needed-xenial
Brian Murray (brian-murray) wrote :

I don't see a test case in the bug report so I'm not really certain what behavior this was adding or fixing, subsequently I'm not certain how to evaluate the testing attachments. Could some additional details be provided so I can feel confident about releasing this?

Robie Basak (racb) wrote :

This is blocked on a reply to Brian's comment. Please reset the tags again when done.

tags: added: verification-needed verification-needed-artful verification-needed-xenial
removed: verification-done verification-done-artful verification-done-xenial
Manoj Iyer (manjo) wrote :

The testcase used was a built in testcase (edac-fake-inject) in the package (zesty version also works on bionic and artful). Without these patches the default behavior is not to log anything, you would not see the output I posted in syslogs.

Jeffrey Hugo (jhugo-o) wrote :
Download full text (7.6 KiB)

Verification of the package in -proposed failed. Run with Linux ubuntu 4.14.14 #11 SMP Mon Feb 26 17:06:57 EST 2018 aarch64 aarch64 aarch64 GNU/Linux

From our tester -

I did the testing you asked and it appears that Canonical is not enabling the ARM event support in rasdaemon when they are building it. Without it enabled I can’t verify that it works.

root@ubuntu:/home/ubuntu# dpkg -l | grep rasdaemon
ii rasdaemon 0.5.6-2ubuntu1 arm64 utility to receive RAS error tracings
root@ubuntu:/home/ubuntu# rasdaemon -f
overriding event (830) ras:mc_event with new print handler
rasdaemon: ras:mc_event event enabled
rasdaemon: Enabled event ras:mc_event
overriding event (827) ras:aer_event with new print handler
rasdaemon: ras:aer_event event enabled
rasdaemon: Enabled event ras:aer_event
rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id] [cpu family] [model] [cpu MHz] [flags]
rasdaemon: Can't register mce handler
rasdaemon: Can't get ras:extlog_mem_event traces. Perhaps this feature is not supported on your system.
rasdaemon: Can't get traces from ras:aer_event
rasdaemon: Listening to events for cpus 0 to 45

It appears I have the correct rasdaemon executable as the package is tagged with version 0.5.6-2ubuntu1. When running rasdaemon, mc_event and aer_event are enabled properly but arm_event is missing. I’ve also verified that mc_event and aer_event reporting works, but arm_event reporting is missing when triggering errors (see below).

They will need to compile the rasdaemon executable with the configuration “--enable-arm” similar to how they must be configuring for AER with “--enable-aer”.

------

Feb 27 10:12:43 ubuntu kernel: [72120.868869] {4}[Hardware Error]: Hardware error from APEI Generic Hardware Error Source: 1
Feb 27 10:12:43 ubuntu kernel: [72120.876193] {4}[Hardware Error]: event severity: recoverable
Feb 27 10:12:43 ubuntu kernel: [72120.881818] {4}[Hardware Error]: precise tstamp: 2018-02-27 18:12:41
Feb 27 10:12:43 ubuntu kernel: [72120.888258] {4}[Hardware Error]: Error 0, type: recoverable
Feb 27 10:12:43 ubuntu kernel: [72120.893897] {4}[Hardware Error]: section_type: memory error
Feb 27 10:12:43 ubuntu kernel: [72120.899612] {4}[Hardware Error]: error_status: 0x00000000000c0400
Feb 27 10:12:43 ubuntu kernel: [72120.905874] {4}[Hardware Error]: physical_address: 0x0000000010097570
Feb 27 10:12:43 ubuntu kernel: [72120.912458] {4}[Hardware Error]: physical_address_mask: 0x00000fffffffffff
Feb 27 10:12:43 ubuntu kernel: [72120.919505] {4}[Hardware Error]: node: 0 card: 5 module: 0 rank: 0 bank: 0 device: 0 row: 342 column: 1006
Feb 27 10:12:43 ubuntu kernel: [72120.929397] {4}[Hardware Error]: error_type: 3, multi-bit ECC
Feb 27 10:12:43 ubuntu kernel: [72120.935330] EDAC MC0: 1 UE Multi-bit ECC on unknown label (node:0 card:5 module:0 rank:0 bank:0 row:342 col:1006 page:0x10097 offset:0x570 grain:-4096 - status(0x00000000000c0400): Storage error in DRAM memory)
Feb 27 10:12:43 ubuntu rasdaemon[24088]: overriding event (830) ras:mc_event with new print handler
Feb 27 10:12:43 ubuntu rasdaemon[24088]: overriding event (827) ras:aer_event with new...

Read more...

tags: added: verification-failed-xenial
removed: verification-needed-xenial
Manoj Iyer (manjo) wrote :
Download full text (4.5 KiB)

--- bionic ---
debian/rules needs --enable-arm to enable arm events. I have a test build of the rasdaemon package in ppa:centriq-team/lp1741978-rasdaemon. I tested this on an ARM64 system and confirmed QTI that the output is as expected.

ubuntu@boomer:~$ sudo service rasdaemon status
● rasdaemon.service - RAS daemon to log the RAS events
   Loaded: loaded (/lib/systemd/system/rasdaemon.service; enabled; vendor preset
   Active: active (running) since Thu 2018-04-19 19:21:55 UTC; 26s ago
 Main PID: 4899 (rasdaemon)
    Tasks: 1 (limit: 34406)
   CGroup: /system.slice/rasdaemon.service
           └─4899 /usr/sbin/rasdaemon -f -r

Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Can't get ras:extlog_mem_even
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Can't get traces from ras:aer
Apr 19 19:21:55 boomer rasdaemon[4899]: Can't register mce handler
Apr 19 19:21:55 boomer rasdaemon[4899]: Can't get traces from ras:aer_event
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Listening to events for cpus
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Recording mc_event events
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Recording aer_event events
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Recording extlog_event events
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Recording mce_record events
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Recording arm_event events

-- syslog --
Apr 19 19:21:47 boomer systemd[1]: Starting RAS daemon to log the RAS events...
Apr 19 19:21:55 boomer rasdaemon: ras:mc_event event enabled
Apr 19 19:21:55 boomer rasdaemon: ras:mc_event event enabled
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: ras:mc_event event enabled
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Enabled event ras:mc_event
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: ras:aer_event event enabled
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Enabled event ras:aer_event
Apr 19 19:21:55 boomer rasdaemon[4900]: rasdaemon: ras:mc_event event enabled
Apr 19 19:21:55 boomer rasdaemon[4900]: rasdaemon: ras:aer_event event enabled
Apr 19 19:21:55 boomer rasdaemon[4900]: rasdaemon: Can't write to set_event
Apr 19 19:21:55 boomer rasdaemon[4900]: rasdaemon: Can't write to set_event
Apr 19 19:21:55 boomer rasdaemon[4900]: rasdaemon: ras:arm_event event enabled
Apr 19 19:21:55 boomer rasdaemon: Enabled event ras:mc_event
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: ras:arm_event event enabled
Apr 19 19:21:55 boomer rasdaemon[4899]: rasdaemon: Enabled event ras:arm_event
Apr 19 19:21:55 boomer systemd[1]: Started RAS daemon to log the RAS events.
Apr 19 19:21:55 boomer rasdaemon: ras:aer_event event enabled
Apr 19 19:21:55 boomer rasdaemon: Can't write to set_event
Apr 19 19:21:55 boomer rasdaemon: ras:aer_event event enabled
Apr 19 19:21:55 boomer rasdaemon: Enabled event ras:aer_event
Apr 19 19:21:55 boomer rasdaemon: Can't write to set_event
Apr 19 19:21:55 boomer rasdaemon: ras:arm_event event enabled
Apr 19 19:21:55 boomer rasdaemon: ras:arm_event event enabled
Apr 19 19:21:55 boomer rasdaemon: Enabled event ras:arm_event
Apr 19 19:21:55 boomer rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id...

Read more...

Manoj Iyer (manjo) wrote :
Download full text (4.1 KiB)

--- artful ---
debian/rules needs --enable-arm to enable arm events. I have a test build of the rasdaemon package in ppa:centriq-team/lp1741978-rasdaemon. I tested this on an ARM64 system and confirmed with QTI that the output is as expected.

ubuntu@boomer:~$ sudo service rasdaemon status
● rasdaemon.service - RAS daemon to log the RAS events
   Loaded: loaded (/lib/systemd/system/rasdaemon.service; enabled; vendor preset
   Active: active (running) since Thu 2018-04-19 23:35:08 UTC; 25s ago
 Main PID: 5002 (rasdaemon)
    Tasks: 1 (limit: 34406)
   Memory: 9.3M
      CPU: 65ms
   CGroup: /system.slice/rasdaemon.service
           └─5002 /usr/sbin/rasdaemon -f -r

Apr 19 23:35:08 boomer rasdaemon[5002]: ras:arm_event event enabled
Apr 19 23:35:08 boomer rasdaemon[5002]: Enabled event ras:arm_event
Apr 19 23:35:08 boomer rasdaemon[5002]: Can't parse /proc/cpuinfo: missing [vend
Apr 19 23:35:08 boomer rasdaemon[5002]: Can't register mce handler
Apr 19 23:35:08 boomer rasdaemon[5002]: Can't get traces from ras:aer_event
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Recording mc_event events
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Recording aer_event events
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Recording extlog_event events
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Recording mce_record events
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Recording arm_event events

ubuntu@boomer:~$ grep rasdaemon /var/log/syslog
Apr 19 23:35:08 boomer rasdaemon: ras:mc_event event enabled
Apr 19 23:35:08 boomer rasdaemon: ras:aer_event event enabled
Apr 19 23:35:08 boomer rasdaemon[5003]: rasdaemon: ras:mc_event event enabled
Apr 19 23:35:08 boomer rasdaemon[5003]: rasdaemon: ras:aer_event event enabled
Apr 19 23:35:08 boomer rasdaemon[5003]: rasdaemon: Can't write to set_event
Apr 19 23:35:08 boomer rasdaemon[5003]: rasdaemon: Can't write to set_event
Apr 19 23:35:08 boomer rasdaemon[5003]: rasdaemon: ras:arm_event event enabled
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: ras:mc_event event enabled
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Enabled event ras:mc_event
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: ras:aer_event event enabled
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Enabled event ras:aer_event
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: ras:arm_event event enabled
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Enabled event ras:arm_event
Apr 19 23:35:08 boomer rasdaemon: Can't write to set_event
Apr 19 23:35:08 boomer rasdaemon: Can't write to set_event
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id] [cpu family] [model] [cpu MHz] [flags]
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Can't register mce handler
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Can't get ras:extlog_mem_event traces. Perhaps this feature is not supported on your system.
Apr 19 23:35:08 boomer rasdaemon[5002]: rasdaemon: Can't get traces from ras:aer_event
Apr 19 23:35:08 boomer rasdaemon: ras:mc_event event enabled
Apr 19 23:35:08 boomer rasdaemon: Enabled event ras:mc_event
Apr 19 23:35:08 boomer rasdaemon: ras:arm_event event ...

Read more...

Manoj Iyer (manjo) wrote :
Download full text (4.2 KiB)

--- xenial ---
debian/rules needs --enable-arm to enable arm events. I have a test build of the rasdaemon package in ppa:centriq-team/lp1741978-rasdaemon. I tested this on an ARM64 system and confirmed with QTI that the output is as expected. The patches tracked in this bug are already fix-committed for xenial.

ubuntu@boomer:~$ sudo service rasdaemon status
sudo: unable to resolve host boomer
● rasdaemon.service - RAS daemon to log the RAS events
   Loaded: loaded (/lib/systemd/system/rasdaemon.service; enabled; vendor preset
   Active: active (running) since Fri 2018-04-20 01:57:04 UTC; 7s ago
 Main PID: 6391 (rasdaemon)
    Tasks: 1
   Memory: 9.3M
      CPU: 62ms
   CGroup: /system.slice/rasdaemon.service
           └─6391 /usr/sbin/rasdaemon -f -r

Apr 20 01:57:04 boomer rasdaemon[6391]: Enabled event ras:arm_event
Apr 20 01:57:04 boomer rasdaemon[6391]: Can't parse /proc/cpuinfo: missing [vend
Apr 20 01:57:04 boomer rasdaemon[6391]: Can't register mce handler
Apr 20 01:57:04 boomer rasdaemon[6391]: Can't get traces from ras:aer_event
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Listening to events for cpus
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Recording mc_event events
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Recording aer_event events
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Recording extlog_event events
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Recording mce_record events
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Recording arm_event events

ubuntu@boomer:~$ grep rasdaemon /var/log/syslog
Apr 20 01:57:04 boomer rasdaemon: ras:mc_event event enabled
Apr 20 01:57:04 boomer rasdaemon: ras:mc_event event enabled
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: ras:mc_event event enabled
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Enabled event ras:mc_event
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: ras:aer_event event enabled
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Enabled event ras:aer_event
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: ras:arm_event event enabled
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Enabled event ras:arm_event
Apr 20 01:57:04 boomer rasdaemon[6392]: rasdaemon: ras:mc_event event enabled
Apr 20 01:57:04 boomer rasdaemon[6392]: rasdaemon: ras:aer_event event enabled
Apr 20 01:57:04 boomer rasdaemon[6392]: rasdaemon: Can't write to set_event
Apr 20 01:57:04 boomer rasdaemon[6392]: rasdaemon: Can't write to set_event
Apr 20 01:57:04 boomer rasdaemon[6392]: rasdaemon: ras:arm_event event enabled
Apr 20 01:57:04 boomer rasdaemon: Enabled event ras:mc_event
Apr 20 01:57:04 boomer rasdaemon: ras:aer_event event enabled
Apr 20 01:57:04 boomer rasdaemon: Can't write to set_event
Apr 20 01:57:04 boomer rasdaemon: Can't write to set_event
Apr 20 01:57:04 boomer rasdaemon: ras:aer_event event enabled
Apr 20 01:57:04 boomer rasdaemon: Enabled event ras:aer_event
Apr 20 01:57:04 boomer rasdaemon: ras:arm_event event enabled
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id] [cpu family] [model] [cpu MHz] [flags]
Apr 20 01:57:04 boomer rasdaemon[6391]: rasdaemon: Can't register mce han...

Read more...

Manoj Iyer (manjo) wrote :

The patches tracked in this bug are already fix-committed for xenial and artful, we need those packages rebuilt with --enable-arm in debian/rules. Bionic already has these patches and the package for bionic needs to be rebuilt with --enable-arm in debian/rules.

Manoj Iyer (manjo) wrote :
Download full text (11.8 KiB)

debian/rules needs --enable-arm to enable arm events. I have a test build of the rasdaemon package in ppa:centriq-team/lp1741978-rasdaemon. I tested this on an a QDF2400 system. Here are the results for bionic, artful and xenial.

--- bionic ---
ubuntu@awrep3:~$ sudo service rasdaemon status
● rasdaemon.service - RAS daemon to log the RAS events
   Loaded: loaded (/lib/systemd/system/rasdaemon.service; enabled; vendor preset
   Active: active (running) since Mon 2018-04-23 15:25:18 UTC; 17s ago
 Main PID: 3369 (rasdaemon)
    Tasks: 1 (limit: 7065)
   CGroup: /system.slice/rasdaemon.service
           └─3369 /usr/sbin/rasdaemon -f -r

Apr 23 15:25:18 awrep3 rasdaemon[3369]: ras:arm_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: Enabled event ras:arm_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: Can't parse /proc/cpuinfo: missing [vend
Apr 23 15:25:18 awrep3 rasdaemon[3369]: Can't register mce handler
Apr 23 15:25:18 awrep3 rasdaemon[3369]: Can't get traces from ras:aer_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording mc_event events
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording aer_event events
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording extlog_event events
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Recording mce_record events
Apr 23 15:25:19 awrep3 rasdaemon[3369]: rasdaemon: Recording arm_event events

ubuntu@awrep3:~$ grep rasdaemon /var/log/syslog
Apr 23 15:25:18 awrep3 rasdaemon: ras:mc_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon: ras:mc_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: ras:mc_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Enabled event ras:mc_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: ras:aer_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Enabled event ras:aer_event
Apr 23 15:25:18 awrep3 rasdaemon[3370]: rasdaemon: ras:mc_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3370]: rasdaemon: ras:aer_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3370]: rasdaemon: Can't write to set_event
Apr 23 15:25:18 awrep3 rasdaemon[3370]: rasdaemon: Can't write to set_event
Apr 23 15:25:18 awrep3 rasdaemon[3370]: rasdaemon: ras:arm_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon: Enabled event ras:mc_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: ras:arm_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Enabled event ras:arm_event
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Can't parse /proc/cpuinfo: missing [vendor_id] [cpu family] [model] [cpu MHz] [flags]
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Can't register mce handler
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Can't get ras:extlog_mem_event traces. Perhaps this feature is not supported on your system.
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Can't get traces from ras:aer_event
Apr 23 15:25:18 awrep3 rasdaemon: ras:aer_event event enabled
Apr 23 15:25:18 awrep3 rasdaemon[3369]: rasdaemon: Listening to events for cpus 0 to 45
Apr 23 15:25:18 awrep3 rasdaemon: Can't write to set_event
Apr 23 15:25:18 awrep3 rasdaemon: ras:aer_event event en...

Manoj Iyer (manjo) wrote :

Based on the results, rasdaemon needs to reuploaded to -proposed with --enable-arm in debian/rules.

Manoj Iyer (manjo) wrote :

Patch to enable arm events for aarch64 in xenial

Manoj Iyer (manjo) wrote :

Patch to enable arm events for aarch64 in artful

Manoj Iyer (manjo) wrote :

Patch to enable arm events for aarch64 in bionic

Brian Murray (brian-murray) wrote :

Hello Manoj, or anyone else affected,

Accepted rasdaemon into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rasdaemon/0.5.8-1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-xenial
removed: verification-failed-xenial
Brian Murray (brian-murray) wrote :

Hello Manoj, or anyone else affected,

Accepted rasdaemon into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rasdaemon/0.5.6-2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Manoj Iyer (manjo) wrote :
Download full text (5.1 KiB)

-- verification xenial --
ubuntu@awrep2:~$ sudo apt install rasdaemon
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  sqlite3
Suggested packages:
  sqlite3-doc
The following NEW packages will be installed:
  rasdaemon sqlite3
0 upgraded, 2 newly installed, 0 to remove and 23 not upgraded.
Need to get 492 kB of archives.
After this operation, 1,932 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://ports.ubuntu.com/ubuntu-ports xenial/main arm64 sqlite3 arm64 3.11.0-1ubuntu1 [428 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports xenial-proposed/universe arm64 rasdaemon arm64 0.5.6-2ubuntu1.1 [64.1 kB]
Fetched 492 kB in 0s (1,205 kB/s)
Selecting previously unselected package sqlite3.
(Reading database ... 62682 files and directories currently installed.)
Preparing to unpack .../sqlite3_3.11.0-1ubuntu1_arm64.deb ...
Unpacking sqlite3 (3.11.0-1ubuntu1) ...
Selecting previously unselected package rasdaemon.
Preparing to unpack .../rasdaemon_0.5.6-2ubuntu1.1_arm64.deb ...
Unpacking rasdaemon (0.5.6-2ubuntu1.1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up sqlite3 (3.11.0-1ubuntu1) ...
Setting up rasdaemon (0.5.6-2ubuntu1.1) ...
ubuntu@awrep2:~$ sudo service rasdaemon status
● rasdaemon.service - RAS daemon to log the RAS events
   Loaded: loaded (/lib/systemd/system/rasdaemon.service; enabled; vendor preset
   Active: active (running) since Wed 2018-05-23 17:40:03 UTC; 1min 1s ago
 Main PID: 4572 (rasdaemon)
    Tasks: 1
   Memory: 7.8M
      CPU: 55ms
   CGroup: /system.slice/rasdaemon.service
           └─4572 /usr/sbin/rasdaemon -f -r

May 23 17:40:03 awrep2 rasdaemon[4572]: ras:arm_event event enabled
May 23 17:40:03 awrep2 rasdaemon[4572]: Enabled event ras:arm_event
May 23 17:40:03 awrep2 rasdaemon[4572]: Can't parse /proc/cpuinfo: missing [vend
May 23 17:40:03 awrep2 rasdaemon[4572]: Can't register mce handler
May 23 17:40:03 awrep2 rasdaemon[4572]: Can't get traces from ras:aer_event
May 23 17:40:03 awrep2 rasdaemon[4572]: rasdaemon: Recording mc_event events
May 23 17:40:03 awrep2 rasdaemon[4572]: rasdaemon: Recording aer_event events
May 23 17:40:03 awrep2 rasdaemon[4572]: rasdaemon: Recording extlog_event events
May 23 17:40:03 awrep2 rasdaemon[4572]: rasdaemon: Recording mce_record events
May 23 17:40:03 awrep2 rasdaemon[4572]: rasdaemon: Recording arm_event events

ubuntu@awrep2:~$
ubuntu@awrep2:~$ grep rasdaemon /var/log/syslog
May 23 17:40:03 awrep2 rasdaemon: ras:mc_event event enabled
May 23 17:40:03 awrep2 rasdaemon[4573]: rasdaemon: ras:mc_event event enabled
May 23 17:40:03 awrep2 rasdaemon[4573]: rasdaemon: ras:aer_event event enabled
May 23 17:40:03 awrep2 rasdaemon[4573]: rasdaemon: Can't write to set_event
May 23 17:40:03 awrep2 rasdaemon[4573]: rasdaemon: Can't write to set_event
May 23 17:40:03 awrep2 rasdaemon[4573]: rasdaemon: ras:arm_event event enabled
May 23 17:40:03 awrep2 rasdaemon[4572]: rasdaemon: ras:mc_event event enabled
May 23 17:40:03 awrep2 rasdaemon[4572]: rasdaemon: Enabled event ras:mc_event
May 23 17:40:03 awrep2 rasdaemon[4572]: rasdaemon: ras:aer_ev...

Read more...

tags: added: verification-done-xenial
removed: verification-needed-xenial
Manoj Iyer (manjo) wrote :
Download full text (5.3 KiB)

-- Artful verification --
ubuntu@awrep2:~$ sudo apt install rasdaemon
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  sqlite3
Suggested packages:
  sqlite3-doc
The following NEW packages will be installed:
  rasdaemon sqlite3
0 upgraded, 2 newly installed, 0 to remove and 26 not upgraded.
Need to get 651 kB of archives.
After this operation, 2356 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://ports.ubuntu.com/ubuntu-ports artful/main arm64 sqlite3 arm64 3.19.3-3 [583 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports artful-proposed/universe arm64 rasdaemon arm64 0.5.8-1ubuntu2.1 [68.3 kB]
Fetched 651 kB in 0s (1553 kB/s)
Selecting previously unselected package sqlite3.
(Reading database ... 63686 files and directories currently installed.)
Preparing to unpack .../sqlite3_3.19.3-3_arm64.deb ...
Unpacking sqlite3 (3.19.3-3) ...
Selecting previously unselected package rasdaemon.
Preparing to unpack .../rasdaemon_0.5.8-1ubuntu2.1_arm64.deb ...
Unpacking rasdaemon (0.5.8-1ubuntu2.1) ...
Setting up sqlite3 (3.19.3-3) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up rasdaemon (0.5.8-1ubuntu2.1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/rasdaemon.service → /lib/systemd/system/rasdaemon.service.
Created symlink /etc/systemd/system/multi-user.target.wants/ras-mc-ctl.service → /lib/systemd/system/ras-mc-ctl.service.
ubuntu@awrep2:~$ sudo service rasdaemon status
● rasdaemon.service - RAS daemon to log the RAS events
   Loaded: loaded (/lib/systemd/system/rasdaemon.service; enabled; vendor preset
   Active: active (running) since Wed 2018-05-23 18:06:59 UTC; 11s ago
 Main PID: 3417 (rasdaemon)
    Tasks: 1 (limit: 7065)
   Memory: 7.9M
      CPU: 53ms
   CGroup: /system.slice/rasdaemon.service
           └─3417 /usr/sbin/rasdaemon -f -r

May 23 18:06:59 awrep2 rasdaemon[3417]: ras:arm_event event enabled
May 23 18:06:59 awrep2 rasdaemon[3417]: Enabled event ras:arm_event
May 23 18:06:59 awrep2 rasdaemon[3417]: Can't parse /proc/cpuinfo: missing [vend
May 23 18:06:59 awrep2 rasdaemon[3417]: Can't register mce handler
May 23 18:06:59 awrep2 rasdaemon[3417]: Can't get traces from ras:aer_event
May 23 18:06:59 awrep2 rasdaemon[3417]: rasdaemon: Recording mc_event events
May 23 18:06:59 awrep2 rasdaemon[3417]: rasdaemon: Recording aer_event events
May 23 18:06:59 awrep2 rasdaemon[3417]: rasdaemon: Recording extlog_event events
May 23 18:06:59 awrep2 rasdaemon[3417]: rasdaemon: Recording mce_record events
May 23 18:07:00 awrep2 rasdaemon[3417]: rasdaemon: Recording arm_event events

ubuntu@awrep2:~$ grep rasdaemon /var/log/syslog
May 23 18:06:59 awrep2 rasdaemon: ras:mc_event event enabled
May 23 18:06:59 awrep2 rasdaemon[3417]: rasdaemon: ras:mc_event event enabled
May 23 18:06:59 awrep2 rasdaemon[3417]: rasdaemon: Enabled event ras:mc_event
May 23 18:06:59 awrep2 rasdaemon[3417]: rasdaemon: ras:aer_event event enabled
May 23 18:06:59 awrep2 rasdaemon[3417]: rasdaemon: Enabled event ras:aer_event
May 23 18:06:59 awrep2 rasdaemon[3417]: rasdaemon: ras:arm_event event enabled
May 23 18...

Read more...

tags: added: verification-done-artful
removed: verification-needed-artful
Manoj Iyer (manjo) wrote :
Download full text (6.0 KiB)

-- bionic verification --
ubuntu@awrep2:~$ sudo apt install -y rasdaemon
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libdbd-sqlite3-perl libdbi-perl sqlite3
Suggested packages:
  libclone-perl libmldbm-perl libnet-daemon-perl libsql-statement-perl
  sqlite3-doc
The following NEW packages will be installed:
  libdbd-sqlite3-perl libdbi-perl rasdaemon sqlite3
0 upgraded, 4 newly installed, 0 to remove and 25 not upgraded.
Need to get 1553 kB of archives.
After this operation, 4981 kB of additional disk space will be used.
Get:1 http://ports.ubuntu.com/ubuntu-ports bionic/main arm64 libdbi-perl arm64 1.640-1 [716 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports bionic/universe arm64 libdbd-sqlite3-perl arm64 1.56-1 [135 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports bionic/main arm64 sqlite3 arm64 3.22.0-1 [634 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports bionic-proposed/universe arm64 rasdaemon arm64 0.6.0-1ubuntu0.1 [68.3 kB]
Fetched 1553 kB in 1s (2224 kB/s)
Selecting previously unselected package libdbi-perl.
(Reading database ... 28570 files and directories currently installed.)
Preparing to unpack .../libdbi-perl_1.640-1_arm64.deb ...
Unpacking libdbi-perl (1.640-1) ...
Selecting previously unselected package libdbd-sqlite3-perl.
Preparing to unpack .../libdbd-sqlite3-perl_1.56-1_arm64.deb ...
Unpacking libdbd-sqlite3-perl (1.56-1) ...
Selecting previously unselected package sqlite3.
Preparing to unpack .../sqlite3_3.22.0-1_arm64.deb ...
Unpacking sqlite3 (3.22.0-1) ...
Selecting previously unselected package rasdaemon.
Preparing to unpack .../rasdaemon_0.6.0-1ubuntu0.1_arm64.deb ...
Unpacking rasdaemon (0.6.0-1ubuntu0.1) ...
Setting up sqlite3 (3.22.0-1) ...
Processing triggers for man-db (2.8.3-2) ...
Setting up libdbi-perl (1.640-1) ...
Setting up libdbd-sqlite3-perl (1.56-1) ...
Setting up rasdaemon (0.6.0-1ubuntu0.1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/rasdaemon.service → /lib/systemd/system/rasdaemon.service.
Created symlink /etc/systemd/system/multi-user.target.wants/ras-mc-ctl.service → /lib/systemd/system/ras-mc-ctl.service.
ubuntu@awrep2:~$ sudo service rasdaemon status
● rasdaemon.service - RAS daemon to log the RAS events
   Loaded: loaded (/lib/systemd/system/rasdaemon.service; enabled; vendor preset
   Active: active (running) since Wed 2018-05-23 18:15:05 UTC; 12s ago
 Main PID: 14212 (rasdaemon)
    Tasks: 1 (limit: 7065)
   CGroup: /system.slice/rasdaemon.service
           └─14212 /usr/sbin/rasdaemon -f -r

May 23 18:15:05 awrep2 rasdaemon[14212]: ras:arm_event event enabled
May 23 18:15:05 awrep2 rasdaemon[14212]: Enabled event ras:arm_event
May 23 18:15:05 awrep2 rasdaemon[14212]: Can't parse /proc/cpuinfo: missing [ven
May 23 18:15:05 awrep2 rasdaemon[14212]: Can't register mce handler
May 23 18:15:05 awrep2 rasdaemon[14212]: Can't get traces from ras:aer_event
May 23 18:15:05 awrep2 rasdaemon[14212]: rasdaemon: Recording mc_event events
May 23 18:15:05 awrep2 rasdaemon[14212]: rasdaemon: Recording aer_event events
May 23 18:15:05 awrep2 rasdaemon[14212]: rasdaemon: Recording extlog_eve...

Read more...

tags: added: verification-done-bionic
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rasdaemon - 0.5.6-2ubuntu1.1

---------------
rasdaemon (0.5.6-2ubuntu1.1) xenial; urgency=medium

  * debian/rules: Enable ARM events --enable-arm (LP: #1769182)

rasdaemon (0.5.6-2ubuntu1) xenial; urgency=medium

  * Cherrypick upstream patches to support ARM kernel trace events.
    LP: #1741978

 -- Manoj Iyer <email address hidden> Wed, 09 May 2018 14:54:44 -0500

Changed in rasdaemon (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for rasdaemon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rasdaemon - 0.5.8-1ubuntu2.1

---------------
rasdaemon (0.5.8-1ubuntu2.1) artful; urgency=medium

  * debian/rules: Enable ARM events --enable-arm (LP: #1769182)

rasdaemon (0.5.8-1ubuntu2) artful; urgency=medium

  * Cherrypick upstream patches to support ARM kernel trace events.
    LP: #1741978

 -- Manoj Iyer <email address hidden> Wed, 09 May 2018 14:45:57 -0500

Changed in rasdaemon (Ubuntu Artful):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.