axis2c.log is full of spurious (and full of typos) errors

Bug #456099 reported by Thierry Carrez on 2009-10-20
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Eucalyptus
Invalid
Undecided
Unassigned
Nominated for 1.6.2 by Laurie Byrum
rampart (Ubuntu)
Low
Unassigned

Bug Description

Every 5 seconds, the following error is logged to /var/log/eucalyptus/axis2c.log 16 times:

[Tue Oct 20 09:53:30 2009] [error] error.c(94) OXS ERROR [x509.c:287 in openssl_x509_get_subject_key_identifier] oxs defualt error , The extenension index of NID_subject_key_identifier is not valid

This is both noisy and distracting, since Eucalyptus seems to work alright.

Thierry Carrez (ttx) on 2009-10-20
Changed in eucalyptus (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Thierry Carrez (ttx) wrote :

It's possible to set Axis2LogLevel to "critical" instead of "error" but that doesn't sound like a good idea. Fixing the root cause of the spurious error would be a better way to fix this.

Thierry Carrez (ttx) on 2009-10-26
Changed in eucalyptus (Ubuntu):
status: Confirmed → Triaged
Dustin Kirkland  (kirkland) wrote :

Moving this over to axis2c, as this isn't something Dan says can be solved in Eucalyptus itself.

affects: eucalyptus (Ubuntu) → axis2c (Ubuntu)
Thierry Carrez (ttx) on 2010-04-11
summary: - axis2c.log is full of spurious errors
+ axis2c.log is full of spurious (and full of typos) errors
Thierry Carrez (ttx) wrote :

This is actually a

affects: axis2c (Ubuntu) → rampart (Ubuntu)
Thierry Carrez (ttx) wrote :

... a rampart issue.

Thierry Carrez (ttx) wrote :

It's possible to suppress that specific error message by patching it out in
./src/omxmlsec/openssl/x509.c:

oxs_error(env, OXS_ERROR_LOCATION, OXS_ERROR_DEFAULT,
                  "The extenension index of NID_subject_key_identifier is not valid");

However I suspect this is a valid error so I'd rather fix the underlying reason. It's difficult to check with rampart upstream since their source code repository at https://svn.apache.org/repos/asf/webservices/rampart/trunk/c is now dead.

Some more explanation of why Eucalyptus's use of rampart triggers that error message could be handy.

Neil Soman (neilsoman) on 2010-10-12
Changed in eucalyptus:
status: New → Won't Fix
status: Won't Fix → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers