radiotray crashed with SIGABRT in gtk_main()

Bug #1344043 reported by dino99 on 2014-07-18
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
radiotray (Ubuntu)
Undecided
Unassigned

Bug Description

That crash now happen since libglib2.0-0 has been upgraded to 2.41.2-1~ubuntu1. Was working fine before that upgrade.
Get the crash at the very beginning, before getting the icon.

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: radiotray 0.7.3-1ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-4.9-generic 3.16.0-rc5
Uname: Linux 3.16.0-4-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.14.4-0ubuntu2
Architecture: i386
CurrentDesktop: GNOME
Date: Fri Jul 18 15:47:07 2014
ExecutablePath: /usr/bin/radiotray
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/radiotray
Signal: 6
SourcePackage: radiotray
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0
 gtk_main () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
 ?? () from /usr/lib/python2.7/dist-packages/gtk-2.0/gtk/_gtk.so
 PyEval_EvalFrameEx ()
Title: radiotray crashed with SIGABRT in gtk_main()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lp lpadmin plugdev sambashare sudo

dino99 (9d9) wrote :
information type: Private → Public

StacktraceTop: ?? () from /tmp/apport_sandbox_Mp8g01/lib/i386-linux-gnu/libglib-2.0.so.0

Changed in radiotray (Ubuntu):
status: New → Invalid
Download full text (3.4 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1 version 1:4.9.1-1ubuntu3 required, but 1:4.9.0-11ubuntu1 is available
libx264-142 version 2:0.142.2431+gita5831aa-1 required, but 2:0.142.2389+git956c8d8-5 is available
no debug symbol package found for libx264-142
no debug symbol package found for libjack-jackd2-0
no debug symbol package found for libv4l-0
libcups2 version 1.7.4-1 required, but 1.7.3-1 is available
no debug symbol package found for perl
libgl1-mesa-glx version 10.3~git1407180730.f14d21~gd~t required, but 10.2.3-0ubuntu1 is available
no debug symbol package found for libplymouth4
multiarch-support version 2.19-4ubuntu2 required, but 2.19-4ubuntu1 is available
no debug symbol package found for klibc-utils
outdated debug symbol package for libxshmfence1: package version 1.1-3 dbgsym version 1.1-2
libdrm-nouveau2 version 2.4.54+git1407160630.c0b34d~gd~t required, but 2.4.54-1 is available
no debug symbol package found for dmsetup
libglib2.0-0 version 2.41.2-1~ubuntu1 required, but 2.41.1-2 is available
libdrm-intel1 version 2.4.54+git1407160630.c0b34d~gd~t required, but 2.4.54-1 is available
no debug symbol package found for libklibc
libglib2.0-data version 2.41.2-1~ubuntu1 required, but 2.41.1-2 is available
no debug symbol package found for libv4lconvert0
outdated debug symbol package for plymouth-theme-ubuntu-text: package version 0.9.0-0ubuntu2 dbgsym version 0.8.8-0ubuntu17
libglapi-mesa version 10.3~git1407180730.f14d21~gd~t required, but 10.2.3-0ubuntu1 is available
no debug symbol package found for cpio
no debug symbol package found for sed
glib-networking version 2.40.1-2 required, but 2.40.1-1 is available
glib-networking-common version 2.40.1-2 required, but 2.40.1-1 is available
no debug symbol package found for libdevmapper1.02.1
no debug symbol package found for gir1.2-glib-2.0
glib-networking-services version 2.40.1-2 required, but 2.40.1-1 is available
outdated debug symbol package for upstart: package version 1.13.1-0ubuntu1 dbgsym version 1.12.1-0ubuntu4
gcc-4.9-base version 4.9.1-1ubuntu3 required, but 4.9.0-11ubuntu1 is available
no debug symbol package found for gcc-4.9-base
package libgnutls-deb0-28 does not exist, ignoring
libstdc++6 version 4.9.1-1ubuntu3 required, but 4.9.0-11ubuntu1 is available
libc6 version 2.19-4ubuntu2 required, but 2.19-4ubuntu1 is available
no debug symbol package found for libtag1c2a
no debug symbol package found for iproute2
no debug symbol package found for libmad0
libgl1-mesa-dri version 10.3~git1407180730.f14d21~gd~t required, but 10.2.3-0ubuntu1 is available
no debug symbol package found for debianutils
no debug symbol package found for libmp3lame0
outdated debug symbol package for plymouth: package version 0.9.0-0ubuntu2 dbgsym version 0.8.8-0ubuntu17
libdrm-radeon1 version 2.4.54+git1407160630.c0b34d~gd~t required, but 2.4.54-1 is available
no debug symbol package found for libgdbm3
libdrm2 version 2.4.54+git1407160630.c0b34d~gd~t required...

Read more...

tags: removed: need-i386-retrace
dino99 (9d9) wrote :

Ok, here is the terminal output:

oem@dev32:~$ radiotray
/usr/lib/python2.7/dist-packages/radiotray/AudioPlayerGStreamer.py:51: FutureWarning: The behavior of this method will change in future versions. Use specific 'len(elem)' or 'elem is not None' test instead.
  if(cfg_provider._settingExists("buffer_size")):
Sleep Timer, Stops playing after a predefined time, SleepTimerPlugin.py, Carlos Ribeiro
HelloWorld, This is a test plugin, HelloWorld.py, Carlos Ribeiro
started
Notifications, Shows message notifications on the desktop, NotificationPlugin.py, Carlos Ribeiro
Mate Media Keys, Controls Radio Tray through keyboard multimedia keys, MateMediaKeysPlugin.py, Ken
Gnome Media Keys, Controls Radio Tray through keyboard multimedia keys, GnomeMediaKeysPlugin.py, Carlos Ribeiro
History, Shows song history, HistoryPlugin.py, Carlos Ribeiro
Attempt to unlock mutex that was not locked
Abandon (core dumped)

Hopes it can be fixed as it seems some functions have changed.

Changed in radiotray (Ubuntu):
status: Invalid → Confirmed
dino99 (9d9) wrote :

note2: it is only failing with Utopic, continue to work fine with Trusty, ....

dino99 (9d9) wrote :

Try to get something similar playing inside Utopic, like zradio, but also get a crash:

zradio crashed with signal 5 in g_cclosure_marshal_VOID_POINTERv() from /usr/lib/i386-linux-gnu/libgobject-2.0-so.0

(matthias-zartmann utopic ppa)

I can confirm the same problem with my completely updated Utopic, starting in the same timeframe. I have the same console output as dino99.

Xavier Guillot (valeryan-24) wrote :

I also get the same bug with Ubuntu 14.10, Radiotray and the last updates, unable to report automatically as system tells me there are outdated libs, here is a screenshot.

In the same time, I have a similar problem with psensor:
https://bugs.launchpad.net/ubuntu/+source/psensor/+bug/1358656

jeh (herrando) wrote :

I have the same problem running radiotray in Utopic in two computers..
I get the same terminal output as dino99.

Is there anything else we can provide to assist with troubleshooting this? My utopic installs are fully up to date, and this is the only app having any issues (and is showing the issue on multiple machines).

Strace info:
...
mmap(NULL, 280771, PROT_READ, MAP_PRIVATE, 13, 0) = 0x7f7f9015c000
close(13) = 0
access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/liblzma.so.2", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/liblzma.so.2", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/lib/liblzma.so.2", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/liblzma.so.2", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
munmap(0x7f7f9015c000, 280771) = 0
read(5, "<nada>\n</nada>\n\n", 8192) = 16
read(5, "", 8176) = 0
close(5) = 0
mmap(NULL, 8392704, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS|MAP_STACK, -1, 0) = 0x7f7f833f1000
mprotect(0x7f7f833f1000, 4096, PROT_NONE) = 0
clone(child_stack=0x7f7f83bf0fb0, flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND|CLONE_THREAD|CLONE_SYSVSEM|CLONE_SETTLS|CLONE_PARENT_SETTID|CLONE_CHILD_CLEARTID, parent_tidptr=0x7f7f83bf19d0, tls=0x7f7f83bf1700, child_tidptr=0x7f7f83bf19d0) = 15342
futex(0x224ca50, FUTEX_WAIT_PRIVATE, 0, NULL) = 0
futex(0x1bf8f20, FUTEX_WAIT_PRIVATE, 0, NULL) = -1 EAGAIN (Resource temporarily unavailable)
pipe([5, 13]) = 0
fcntl(13, F_GETFL) = 0x1 (flags O_WRONLY)
fcntl(13, F_SETFL, O_WRONLY|O_NONBLOCK) = 0
write(8, "\1\0\0\0\0\0\0\0", 8) = 8
write(2, "Attempt to unlock mutex that was"..., 44Attempt to unlock mutex that was not locked
) = 44
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(15331, 15331, SIGABRT) = 0
--- SIGABRT {si_signo=SIGABRT, si_code=SI_TKILL, si_pid=15331, si_uid=1000} ---
+++ killed by SIGABRT (core dumped) +++
Aborted (core dumped)

dino99 (9d9) wrote :

@3vi1

what i see with your post is: lot of " no such file or directory", which might explain some issues i suppose.

But an other report have pointed out an incompatibility with the latest glic:

https://bugs.launchpad.net/ubuntu/+source/radiotray/+bug/1359564 (see #7)
(a possible patch as a workaround is attached)

I commented out the call to gtk.gdk.threads_init() in SysTray.py of radiotray, per https://bugs.launchpad.net/ubuntu/+source/radiotray/+bug/1359564/comments/10 and it now works fine.

dino99 (9d9) wrote :

@3vi1

many thanks for pointing out the solution

confirm on Utopic that commenting the line 185 into that file does the trick.

( sudo gedit /usr/lib/python2.7/dist-packages/radiotray/SysTray.py )

Benoit THIBAUD (frombenny) wrote :

I installed it from a Xubuntu Core Utopic beta release. Doesn't launch it at all...

Benoit THIBAUD (frombenny) wrote :

I've made the fix as said by dino99 :
sudo geany /usr/lib/python2.7/dist-packages/radiotray/SysTray.py

Comment the line 185 : gtk.gdk.threads_init()

and save.

It's working fine and better than in Trusty : the launch of it is very fast !!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers