Kit creation fails because schroot isn't installed as a dependency

Bug #1404672 reported by Michael Sheldon on 2014-12-21
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
click (Ubuntu)
Critical
Michael Vogt
qtcreator-plugin-ubuntu (Ubuntu)
Critical
Zoltan Balogh
Vivid
Undecided
Unassigned

Bug Description

On a fresh install of Utopic using the Ubuntu SDK from the SDK team ppa the initial click kit creation fails with the error:

click chroot: error: schroot not installed and configured; install click-dev and schroot

Presumably schroot should be added as a dependency for either the qtcreator-plugin-ubuntu or ubuntu-sdk package so that users aren't faced with errors when first attempting to create kits. (Despite the error message click-dev is already installed, this has schroot as a recommended package, but not a dependency).

Related branches

Zoltan Balogh (bzoltan) on 2014-12-22
Changed in click (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → Critical
Changed in qtcreator-plugin-ubuntu (Ubuntu):
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in click (Ubuntu):
status: New → Confirmed
Changed in qtcreator-plugin-ubuntu (Ubuntu):
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

The error message is also wrongly shown in case of bug #1436835

Changed in qtcreator-plugin-ubuntu (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtcreator-plugin-ubuntu - 3.1.1+15.10.20150507-0ubuntu1

---------------
qtcreator-plugin-ubuntu (3.1.1+15.10.20150507-0ubuntu1) wily; urgency=medium

  [ Alexandre Abreu ]
  * Add autopilot and unit tests templates for HTML5 simple application

  [ Benjamin Zeller ]
  * Fix Bug lp:1402484 "A typo in the scope template readme file" Fix
    bug lp:1427138 and lp:1404672, add schroot to the deps Fix Bug
    lp:1450477 "Typo in initial startup wizard" (LP: #1404672, #1427138,
    #1402484, #1450477)
  * Remove either unused or dangerous functions and scripts. (LP:
    #1324008, #1366785, #1388655)
  * Show Desktop Kit in chroot setup page ( lp:1366934 lp:1369828) Fix
    Bug lp:1400842 "devices panel: text says refresh but button is
    redetect" (LP: #1400842, #1369828, #1366934)

  [ CI Train Bot ]
  * New rebuild forced.

  [ Zoltán Balogh ]
  * Set the title of the tamplate apps to the app name. Fixes LP:
    #1365309 (LP: #1365309)
  * removed obsolate patch
  * removed obsolate patch removed: debian/patches/
    debian/patches/series debian/patches/u-d-f_syntax.diff

 -- CI Train Bot <email address hidden> Thu, 07 May 2015 06:26:00 +0000

Changed in qtcreator-plugin-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers