konsole crashes on closing due to kuniqueapplication

Bug #1436973 reported by Jonathan Riddell on 2015-03-26
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
High
qtbase-opensource-src (Ubuntu)
High
Timo Jyrinki
Vivid
High
Unassigned
Wily
High
Unassigned

KUniqueApplication seems to cause a crash on close.

I reported this as bug
https://bugs.kde.org/show_bug.cgi?id=344918

This is Kubuntu 15.04 beta with kf5 5.7 and qt 5.4.0

Muon moved away from it today (2015-03-06).

Application: konsole (konsole), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6 0x00007f4b8af05233 in QString::~QString (this=0x2068278, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qstring.h:992
#7 0x00007f4b8aefa8b2 in QDBusConnectionPrivate::~QDBusConnectionPrivate (this=this@entry=0x2068260, __in_chrg=<optimized out>) at qdbusintegrator.cpp:1046
#8 0x00007f4b8aefab70 in ~QDBusConnectionPrivate (this=0x2068260, __in_chrg=<optimized out>) at qdbusintegrator.cpp:1064
#9 QDBusConnectionPrivate::deleteYourself (this=0x2068260) at qdbusintegrator.cpp:1076
#10 0x00007f4b8aeeed95 in QDBusConnectionManager::~QDBusConnectionManager (this=0x7f4b8af5ace0 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>, __in_chrg=<optimized out>) at qdbusconnection.cpp:98
#11 0x00007f4b8aeeee49 in (anonymous namespace)::Q_QGS__q_manager::innerFunction()::Holder::~Holder() () at qdbusconnection.cpp:59
#12 0x00007f4b8a8596a9 in __run_exit_handlers (status=0, listp=0x7f4b8abdd6c8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#13 0x00007f4b8a8596f5 in __GI_exit (status=<optimized out>) at exit.c:104
#14 0x00007f4b8a840ecc in __libc_start_main (main=0x400828 <main>, argc=1, argv=0x7fffa80447f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa80447e8) at libc-start.c:321
#15 0x0000000000400739 in _start ()

Reproducible: Always

Steps to Reproduce:
1.run konsole
2.close konsole
3.crash

Jonathan Riddell (jr) on 2015-03-26
Changed in konsole (Ubuntu):
milestone: none → ubuntu-15.04
tags: added: kubuntu
Changed in kde-baseapps:
importance: Unknown → High
status: Unknown → New
Martin Pitt (pitti) on 2015-04-20
Changed in konsole (Ubuntu):
milestone: ubuntu-15.04 → vivid-updates
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in konsole (Ubuntu):
status: New → Confirmed

Fixed qtbase/041fae00351164fbd72763e4bd947fdeb9956a5d

Changed in kde-baseapps:
status: New → Fix Released
Changed in konsole (Ubuntu):
milestone: vivid-updates → none
importance: Undecided → Medium
Changed in konsole (Ubuntu Vivid):
importance: Undecided → Medium
Changed in konsole (Ubuntu Wily):
importance: Undecided → Medium
affects: konsole (Ubuntu) → qtbase-opensource-src (Ubuntu)
Changed in qtbase-opensource-src (Ubuntu):
importance: Medium → High
milestone: none → vivid-updates
milestone: vivid-updates → none
Changed in qtbase-opensource-src (Ubuntu Wily):
milestone: ubuntu-15.10 → wily-updates
Changed in qtbase-opensource-src (Ubuntu Vivid):
importance: Medium → High
Changed in qtbase-opensource-src (Ubuntu Wily):
importance: Medium → High
Changed in qtbase-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.5.1+dfsg-6ubuntu4

---------------
qtbase-opensource-src (5.5.1+dfsg-6ubuntu4) xenial; urgency=medium

  * Update symbols for s390x.

 -- Timo Jyrinki <email address hidden> Tue, 08 Dec 2015 13:35:46 +0000

Changed in qtbase-opensource-src (Ubuntu):
status: Confirmed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

qtbase-opensource-src (5.5.1+dfsg-6ubuntu3) xenial; urgency=medium

  * debian/patches/enable-tests.patch:
    - Replace the non-DFSG-free RFC files with public domain content.
    - Adjust tests to the new files.
    (LP: #1522442)
  * debian/copyright: mention the replacement.
  * Switch to opt-in for architectures to run tests on.

 -- Timo Jyrinki <email address hidden> Mon, 07 Dec 2015 14:02:11 +0000

qtbase-opensource-src (5.5.1+dfsg-6ubuntu2) xenial; urgency=high

  * Skip largefile test on s390x too, in addition to amd64.
  * Make tests to keep going till the end with -k.

 -- Dimitri John Ledkov <email address hidden> Fri, 04 Dec 2015 16:54:28 +0000

qtbase-opensource-src (5.5.1+dfsg-6ubuntu1) xenial; urgency=medium

  * New upstream release. (LP: #1437206) (LP: #1450137) (LP: #1474313)
    (LP: #1470700) (LP: #1504631) (LP: #1423659) (LP: #1474775) (LP: #1508945)
  * Replace load_testability_from_env_var.patch with upstreamed
    Add-environment-variable-support-for-testability-lib.patch
  * Drop patches in upstream:
    - Correct-typo-in-the-Gujarati-openType-identififer.patch
  * Rebase enable-tests.patch. Disable one failing QtWidgets test.
  * Build depend on GStreamer 1.0 and add a configure option for it.
  * Update symbols.
  * Mark/unmark private symbols.
  * Replace two Ubuntu patches with upstreamed patches:
    - Drop disable-generic-plugin-when-others-available.patch, replace with
      Add-an-option-to-skip-the-generic-bearer-engine.patch
    - Drop qopenglframebufferobject_powervrworkaround.patch, replace with
      Blacklist-PowerVR-Rogue-G6200-v1.3-from-supporting-B.patch
  * debian/patches/Make-sure-networkAccessibilityChanged-is-emitted.patch:
    - Include a network fix from Qt 5.5 branch (merged after 5.5.1)
      (LP: #1470700)
  * debian/patches/Use-Node-name-if-Node-logicalModuleName-is-empty-for.patch:
    - Fix a qdoc issue (LP: #1447182)
  * Remove disable_overlay_scrollbars.diff as overlay scrollbars were dropped.
  * debian/patches/Prefer-QT_PLUGIN_PATH-over-compiled-in-paths.patch:
    - Backport. Prefer QT_PLUGIN_PATH over compiled-in paths (LP: #1519927)
  * debian/patches/Fix-crash-on-exit-caused-by-QStringLiterals.patch
    - Backport. Fix a crasher on exit (LP: #1436973)
  * Replace our workaround for font rendering with new backported upstream
    patches:
    - Add debian/patches/Fix-falsely-reported-style-for-fallback-font.patch
    - Add debian/patches/Remove-historical-4-padding-in-QFontEngine-alphaMapF.patch
    - Remove debian/patches/enable_fonts_always_smoothly.patch
      (LP: #1475205)

 -- Timo Jyrinki <email address hidden> Tue, 01 Dec 2015 06:16:35 +0000

Changed in qtbase-opensource-src (Ubuntu Vivid):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.