Okular crashes at opening of print dialog

Bug #788141 reported by Marius B. Kotsbak
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KDE Graphics
Won't Fix
High
Qt
Fix Released
Undecided
Unassigned
qt4-x11 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdegraphics

Backtrace:

Application: Okular (okular), signal: Segmentation fault
[Current thread is 1 (Thread 0xb52db710 (LWP 11132))]

Thread 4 (Thread 0xae7cfb70 (LWP 11133)):
#0 0xb56f1d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1 0xb6357dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2 qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3 0xb64244f2 in updateCurrentTime (this=0x98fa334, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4 QTimerInfoList::timerWait (this=0x98fa334, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5 0xb6422d32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae7cf0dc) at kernel/qeventdispatcher_glib.cpp:136
#6 0xb6422dcd in timerSourcePrepare (source=0x98fa300, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7 0xb5899fd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8 0xb589ae63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9 0xb589b524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6423577 in QEventDispatcherGlib::processEvents (this=0x9739270, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb63f5289 in QEventLoop::processEvents (this=0xae7cf290, flags=...) at kernel/qeventloop.cpp:149
#12 0xb63f5522 in QEventLoop::exec (this=0xae7cf290, flags=...) at kernel/qeventloop.cpp:201
#13 0xb62ff2a0 in QThread::exec (this=0x96efe40) at thread/qthread.cpp:492
#14 0xb63d6fdb in QInotifyFileSystemWatcherEngine::run (this=0x96efe40) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6301da2 in QThreadPrivate::start (arg=0x96efe40) at thread/qthread_unix.cpp:320
#16 0xb594ee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb60ad73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xaddc4b70 (LWP 11421)):
#0 0xb7888424 in __kernel_vsyscall ()
#1 0xb595348c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2 0xb60bb3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3 0xb6302467 in wait (this=0x98d03a0, mutex=0x98d039c, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4 QWaitCondition::wait (this=0x98d03a0, mutex=0x98d039c, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5 0xb6e2ca62 in QFileInfoGatherer::run (this=0x98d0394) at dialogs/qfileinfogatherer.cpp:214
#6 0xb6301da2 in QThreadPrivate::start (arg=0x98d0394) at thread/qthread_unix.cpp:320
#7 0xb594ee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8 0xb60ad73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xad3ffb70 (LWP 11424)):
#0 0xb7888424 in __kernel_vsyscall ()
#1 0xb609ef76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2 0xb58ab84b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3 0xb589b1af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4 0xb589b524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5 0xb6423577 in QEventDispatcherGlib::processEvents (this=0x9af8128, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6 0xb63f5289 in QEventLoop::processEvents (this=0xad3ff290, flags=...) at kernel/qeventloop.cpp:149
#7 0xb63f5522 in QEventLoop::exec (this=0xad3ff290, flags=...) at kernel/qeventloop.cpp:201
#8 0xb62ff2a0 in QThread::exec (this=0x9b3eee8) at thread/qthread.cpp:492
#9 0xb63d6fdb in QInotifyFileSystemWatcherEngine::run (this=0x9b3eee8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6301da2 in QThreadPrivate::start (arg=0x9b3eee8) at thread/qthread_unix.cpp:320
#11 0xb594ee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb60ad73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb52db710 (LWP 11132)):
[KCrash Handler]
#7 0xb6b04b35 in QCUPSSupport::printerOption (this=0x9b43640, key=...) at painting/qcups.cpp:251
#8 0xb6dd8524 in QUnixPrintWidgetPrivate::_q_printerChanged (this=0x9bc67c8, index=0) at dialogs/qprintdialog_unix.cpp:804
#9 0xb6dd91bb in QUnixPrintWidgetPrivate::QUnixPrintWidgetPrivate (this=0x9bc67c8, p=0x9b521d8) at dialogs/qprintdialog_unix.cpp:711
#10 0xb6dd9507 in QUnixPrintWidget::QUnixPrintWidget (this=0x9b521d8, printer=0x0, parent=0x9a54c18) at dialogs/qprintdialog_unix.cpp:1036
#11 0xb6dd958d in QPrintDialogPrivate::init (this=0x94e4b30) at dialogs/qprintdialog_unix.cpp:386
#12 0xb6dd9e3e in QPrintDialog::QPrintDialog (this=0x9a54c18, printer=0xbfc6b190, parent=0x9586a90) at dialogs/qprintdialog_unix.cpp:591
#13 0xb753a4d8 in KdePrint::createPrintDialog (printer=0xbfc6b190, pageSelectPolicy=KdePrint::ApplicationSelectsPages, customTabs=..., parent=0x9586a90) at ../../kdeui/dialogs/kdeprintdialog.cpp:44
#14 0xb753a7d3 in KdePrint::createPrintDialog (printer=0xbfc6b190, customTabs=..., parent=0x9586a90) at ../../kdeui/dialogs/kdeprintdialog.cpp:81
#15 0xb1e7ec6b in Okular::Part::slotPrint (this=0x9581cd8) at ../../okular/part.cpp:2016
#16 0xb1e7f330 in Okular::Part::qt_metacall (this=0x9581cd8, _c=QMetaObject::InvokeMetaMethod, _id=54, _a=0xbfc6b2e8) at ./part.moc:240
#17 0xb63fc6ba in QMetaObject::metacall (object=0x9581cd8, cl=QMetaObject::InvokeMetaMethod, idx=69, argv=0xbfc6b2e8) at kernel/qmetaobject.cpp:237
#18 0xb640c4ff in QMetaObject::activate (sender=0x9892dc0, m=0xb72033f8, local_signal_index=1, argv=0xbfc6b2e8) at kernel/qobject.cpp:3287
#19 0xb68cb8d9 in QAction::triggered (this=0x9892dc0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#20 0xb68cbb38 in QAction::activate (this=0x9892dc0, event=QAction::Trigger) at kernel/qaction.cpp:1257
#21 0xb6d5d8ad in QMenuPrivate::activateCausedStack (this=0x98bb960, causedStack=..., action=0x9892dc0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:993
#22 0xb6d6416b in QMenuPrivate::activateAction (this=0x98bb960, action=0x9892dc0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1085
#23 0xb6d64ffe in QMenu::mouseReleaseEvent (this=0x98a4128, e=0xbfc6bb84) at widgets/qmenu.cpp:2306
#24 0xb74e1cf4 in KMenu::mouseReleaseEvent (this=0x98a4128, e=0xbfc6bb84) at ../../kdeui/widgets/kmenu.cpp:458
#25 0xb692b13a in QWidget::event (this=0x98a4128, event=0xbfc6bb84) at kernel/qwidget.cpp:8259
#26 0xb6d654d7 in QMenu::event (this=0x98a4128, e=0xbfc6bb84) at widgets/qmenu.cpp:2415
#27 0xb68d2d24 in QApplicationPrivate::notify_helper (this=0x94a1a90, receiver=0x98a4128, e=0xbfc6bb84) at kernel/qapplication.cpp:4462
#28 0xb68d8201 in QApplication::notify (this=0xbfc6c4dc, receiver=0x98a4128, e=0xbfc6bb84) at kernel/qapplication.cpp:4023
#29 0xb74043ca in KApplication::notify (this=0xbfc6c4dc, receiver=0x98a4128, event=0xbfc6bb84) at ../../kdeui/kernel/kapplication.cpp:311
#30 0xb63f60bb in QCoreApplication::notifyInternal (this=0xbfc6c4dc, receiver=0x98a4128, event=0xbfc6bb84) at kernel/qcoreapplication.cpp:731
#31 0xb68d3c3b in sendSpontaneousEvent (receiver=0x98a4128, event=0xbfc6bb84, alienWidget=0x0, nativeWidget=0x98a4128, buttonDown=0xb721fc60, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#32 QApplicationPrivate::sendMouseEvent (receiver=0x98a4128, event=0xbfc6bb84, alienWidget=0x0, nativeWidget=0x98a4128, buttonDown=0xb721fc60, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3120
#33 0xb695d4c3 in QETWidget::translateMouseEvent (this=0x98a4128, event=0xbfc6c0ac) at kernel/qapplication_x11.cpp:4490
#34 0xb695b746 in QApplication::x11ProcessEvent (this=0xbfc6c4dc, event=0xbfc6c0ac) at kernel/qapplication_x11.cpp:3678
#35 0xb6986b84 in x11EventSourceDispatch (s=0x94a4740, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#36 0xb589aaa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0xb589b270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb589b524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb642353c in QEventDispatcherGlib::processEvents (this=0x9469ac0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#40 0xb6986775 in QGuiEventDispatcherGlib::processEvents (this=0x9469ac0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0xb63f5289 in QEventLoop::processEvents (this=0xbfc6c374, flags=...) at kernel/qeventloop.cpp:149
#42 0xb63f5522 in QEventLoop::exec (this=0xbfc6c374, flags=...) at kernel/qeventloop.cpp:201
#43 0xb63f9ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#44 0xb68d08e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#45 0x0804e6d8 in main (argc=) at ../../../okular/shell/main.cpp:85

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: okular 4:4.6.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic-pae 2.6.38.4
Uname: Linux 2.6.38-9-generic-pae i686
Architecture: i386
Date: Wed May 25 16:12:03 2011
ProcEnviron:
 LANGUAGE=nb_NO:nb:no_NO:no:nn_NO:nn:en
 PATH=(custom, user)
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
SourcePackage: kdegraphics
UpgradeStatus: Upgraded to natty on 2011-04-29 (26 days ago)

Revision history for this message
In , Jnelson-kde (jnelson-kde) wrote :
Download full text (6.4 KiB)

Application that crashed: okular
Version of the application: 0.8.90
KDE Version: 4.2.95 (KDE 4.2.95 (KDE 4.3 RC1)) "release 139"
Qt Version: 4.5.2
Operating System: Linux 2.6.27.23-0.1-default x86_64
Distribution: "openSUSE 11.1 (x86_64)"

What I was doing when the application crashed:
I tried to print, it hung (unresponsive) after control-p with no dialog.
I restarted cups and that is when it crashed.

 -- Backtrace:
Application: Okular (okular), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6874db5750 (LWP 4272))]

Thread 3 (Thread 0x7f6863043950 (LWP 4347)):
#0 0x00007f68729ddd59 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1 0x00007f6872c4ee19 in QWaitCondition::wait (this=0xc26bd8, mutex=0xc26bd0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2 0x00007f687247165e in QFileInfoGatherer::run (this=0xc26bc0) at dialogs/qfileinfogatherer.cpp:207
#3 0x00007f6872c4de65 in QThreadPrivate::start (arg=0xc26bc0) at thread/qthread_unix.cpp:188
#4 0x00007f68729da070 in start_thread () from /lib64/libpthread.so.0
#5 0x00007f687141d10d in clone () from /lib64/libc.so.6
#6 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6860cce950 (LWP 4348)):
#0 0x00007f6871414386 in poll () from /lib64/libc.so.6
#1 0x00007f686e99a768 in ?? () from /usr/lib64/libglib-2.0.so.0
#2 0x00007f686e99aa8b in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3 0x00007f6872d60d3f in QEventDispatcherGlib::processEvents (this=0x8733a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#4 0x00007f6872d361d2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 1624039424}) at kernel/qeventloop.cpp:149
#5 0x00007f6872d365a4 in QEventLoop::exec (this=0x7f6860cce040, flags={i = 1624039504}) at kernel/qeventloop.cpp:201
#6 0x00007f6872c4aed8 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7 0x00007f6872d199b8 in QInotifyFileSystemWatcherEngine::run (this=0xc278b0) at io/qfilesystemwatcher_inotify.cpp:214
#8 0x00007f6872c4de65 in QThreadPrivate::start (arg=0xc278b0) at thread/qthread_unix.cpp:188
#9 0x00007f68729da070 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f687141d10d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6874db5750 (LWP 4272)):
[KCrash Handler]
#5 0x00007f687218ff9e in QCUPSSupport::printerOption (this=0xc26780, key=@0x7fff7cdecf30) at painting/qcups.cpp:251
#6 0x00007f687241c239 in QUnixPrintWidgetPrivate::_q_printerChanged (this=0xc19100, index=<value optimized out>) at dialogs/qprintdialog_unix.cpp:795
#7 0x00007f687241cf2f in QUnixPrintWidgetPrivate (this=0xc19100, p=<value optimized out>) at dialogs/qprintdialog_unix.cpp:702
#8 0x00007f687241d2dc in QUnixPrintWidget (this=0xc18cb0, printer=0x0, parent=<value optimized out>) at dialogs/qprintdialog_unix.cpp:995
#9 0x00007f687241d350 in QPrintDialogPrivate::init (this=0xc16c80) at dialogs/qprintdialog_unix.cpp:384
#10 0x00007f687241d929 in QPrintDialog (this=0xbdd050, printer=0x7fff7cded360, parent=0x7c7e20) at dialogs/qprintdialog_unix.cpp:580
#11 0x00007f6873ae5840 in KdePrint::createPrintDialog(QPrinter*, QList<QWi...

Read more...

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 233890 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

This probably is http://bugreports.qt.nokia.com/browse/QTBUG-10512 and should be fixed in Qt 4.6.3. If you can still reproduce with that version, please file a bug report to http://bugreports.qt.nokia.com/

Revision history for this message
In , Christian Trippe (christiandehne) wrote :

JFYI: Bug 242472 which in the end was marked as duplicate of this bug happened for me with Qt 4.6.3. I filled an upstream bug report at http://bugreports.qt.nokia.com/browse/QTBUG-12748

Revision history for this message
In , Dario Andres (andresbajotierra) wrote :

[Comment from a bug triager]
Bug 257816 is also happening with Qt 4.6.3

Revision history for this message
In , Dario Andres (andresbajotierra) wrote :

*** Bug 257816 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Dario Andres (andresbajotierra) wrote :

*** Bug 223767 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Dario Andres (andresbajotierra) wrote :

*** Bug 258945 has been marked as a duplicate of this bug. ***

Revision history for this message
Marius B. Kotsbak (mariusko) wrote :
Changed in qt:
status: New → Fix Released
Revision history for this message
Marius B. Kotsbak (mariusko) wrote :

Upstream Qt bug: http://bugreports.qt.nokia.com/browse/QTBUG-10512

Seems like it is fixed in Qt 4.6.3. Hmm, it seems like I have Qt 4.7.2. Maybe some old libs there after upgrade.

Changed in kdegraphics:
importance: Unknown → High
status: Unknown → Won't Fix
Revision history for this message
Harald Sitter (apachelogger) wrote :

Indeed... Please check that libqtgui4 is actually on 4.7.2

The function in question:

> const cups_option_t* QCUPSSupport::printerOption(const QString &key) const
> {
> for (int i = 0; i < printers[currPrinterIndex].num_options; ++i) {
> if (QLatin1String(printers[currPrinterIndex].options[i].name) == key)
> return &printers[currPrinterIndex].options[i];
> }
> return 0;
> }

Crash happens in first line.

Both variables there are members of qcups:
> cups_dest_t *printers;
> int currPrinterIndex;

Both initialized to 0:
> printers(0),
> currPrinterIndex(0),

Printers apparently is only set once (in the ctor of qcups).

The _q_printerChanged slot essentially adds this on top:
> cups->setCurrentPrinter(index);
> const cups_option_t *opt = cups->printerOption(QString::fromLatin1("printer-location"));

So, from the bt we know that the index there is sane (0), leaving us with the following causes:
a) printers points to invalid mem (which should not be the case as cups internally sets this, unless of course something went horribly wrong in cups)
b) printer points to an array of nil size

So all together the issue is rather weird as I suppose if there is no printer the printerChanged slot ought not be called:
> QObject::connect(widget.printers, SIGNAL(currentIndexChanged(int)),
> parent, SLOT(_q_printerChanged(int)));
i.e. if there is no printer the printer widget (or rather the dropdown with printers) should be disabled an thus not emit the signal. This means that no matter what, something is not quite right about this whole thing in both cases from above there should be no printers reported, so the widget.printers should be disabled. Very odd.

I suppose something that could help in addition to known whether libqtgui4 is actually up-to-date is whether you actually have any printers installed? If you have, that would suggest a bug in CUPS itself (wrongly assigning the pointer address or somesuch).

affects: kdegraphics (Ubuntu) → qt4-x11 (Ubuntu)
Changed in qt4-x11 (Ubuntu):
status: New → Incomplete
Revision history for this message
Marius B. Kotsbak (mariusko) wrote :

libqtgui4 is 4:4.7.2-0ubuntu6.1.
2 printers are installed (and working when this does not happen).

Changed in qt4-x11 (Ubuntu):
status: Incomplete → New
Revision history for this message
In , Cgiboudeaux (cgiboudeaux) wrote :

*** Bug 295138 has been marked as a duplicate of this bug. ***

Revision history for this message
In , DA (adawit) wrote :

*** Bug 298276 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Albert Astals Cid (aacid) wrote :

*** Bug 312049 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Albert Astals Cid (aacid) wrote :

*** Bug 315842 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Paul Leopardi (paul-leopardi-iinet) wrote :
Download full text (4.9 KiB)

I experienced a very similar crash with Okular Version 0.16.2
Using KDE Development Platform 4.10.2. Should I file a new report, or ask for this one to be re-opened?

Thread 1 (Thread 0x7fdb07b7f780 (LWP 17842)):
[KCrash Handler]
#6 0x00007fdb0612cefe in QCUPSSupport::printerOption (this=0x22677c0, key=...) at painting/qcups.cpp:251
#7 0x00007fdb063c9335 in QUnixPrintWidgetPrivate::_q_printerChanged (this=0x2279370, index=0) at dialogs/qprintdialog_unix.cpp:830
#8 0x00007fdb063c9f42 in QUnixPrintWidgetPrivate::QUnixPrintWidgetPrivate (this=0x2279370, p=<optimized out>) at dialogs/qprintdialog_unix.cpp:737
#9 0x00007fdb063ca22b in QUnixPrintWidget::QUnixPrintWidget (this=0x22a9e30, printer=0x0, parent=<optimized out>) at dialogs/qprintdialog_unix.cpp:1062
#10 0x00007fdb063ca2ae in QPrintDialogPrivate::init (this=0x22e8e10) at dialogs/qprintdialog_unix.cpp:386
#11 0x00007fdb063ca7f8 in QPrintDialog::QPrintDialog (this=0x295b650, printer=0x7fffdb5ac1a0, parent=0x1b8a0e0) at dialogs/qprintdialog_unix.cpp:617
#12 0x00007fdb06d6e902 in KdePrint::createPrintDialog (printer=0x7fffdb5ac1a0, pageSelectPolicy=KdePrint::ApplicationSelectsPages, customTabs=..., parent=0x1b8a0e0) at ../../kdeui/dialogs/kdeprintdialog.cpp:44
#13 0x00007fdaf638ada8 in ?? () from /usr/lib/kde4/okularpart.so
#14 0x00007fdaf638b93a in ?? () from /usr/lib/kde4/okularpart.so
#15 0x00007fdb05525781 in QMetaObject::activate (sender=0x1f939d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffdb5ac390) at kernel/qobject.cpp:3547
#16 0x00007fdb05f08072 in QAction::triggered (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#17 0x00007fdb05f0825f in QAction::activate (this=0x1f939d0, event=<optimized out>) at kernel/qaction.cpp:1257
#18 0x00007fdb0635a5e9 in QMenuPrivate::activateCausedStack (this=0x1af2db0, causedStack=..., action=0x1f939d0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1028
#19 0x00007fdb06360742 in QMenuPrivate::activateAction (this=0x1af2db0, action=0x1f939d0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1120
#20 0x00007fdb06d0ac90 in KMenu::mouseReleaseEvent (this=0x1fb0e60, e=0x7fffdb5acf60) at ../../kdeui/widgets/kmenu.cpp:464
#21 0x00007fdb05f5efb4 in QWidget::event (this=0x1fb0e60, event=0x7fffdb5acf60) at kernel/qwidget.cpp:8371
#22 0x00007fdb06361cdb in QMenu::event (this=0x1fb0e60, e=0x7fffdb5acf60) at widgets/qmenu.cpp:2469
#23 0x00007fdb05f0e7b4 in notify_helper (e=0x7fffdb5acf60, receiver=0x1fb0e60, this=0x1959ad0) at kernel/qapplication.cpp:4556
#24 QApplicationPrivate::notify_helper (this=0x1959ad0, receiver=0x1fb0e60, e=0x7fffdb5acf60) at kernel/qapplication.cpp:4528
#25 0x00007fdb05f13f2f in QApplication::notify (this=<optimized out>, receiver=0x1fb0e60, e=0x7fffdb5acf60) at kernel/qapplication.cpp:4099
#26 0x00007fdb06c4a006 in KApplication::notify (this=0x7fffdb5adc50, receiver=0x1fb0e60, event=0x7fffdb5acf60) at ../../kdeui/kernel/kapplication.cpp:311
#27 0x00007fdb0551132c in QCoreApplication::notifyInternal (this=0x7fffdb5adc50, receiver=0x1fb0e60, event=0x7fffdb5acf60) at kernel/qcoreapplication.cpp:915
#28 0x00007fdb05f0f782 in sendEvent (event=<optimized out>, receiver...

Read more...

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

Paul, if this bug is reproducible, and you can provide exact steps to reproduce this crash, please report it to Qt developers via https://bugreports.qt-project.org/

Revision history for this message
In , adaptee (adaptee) wrote :

*** Bug 318268 has been marked as a duplicate of this bug. ***

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qt4-x11 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.