Ubuntu

No icons on buttons

Reported by GamePad64 on 2013-05-14
76
This bug affects 13 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
High
Dmitry Shachnev
Raring
High
Dmitry Shachnev

Bug Description

== Impact ==
All Qt 4 apps that use icon themes do not show any icons in default Ubuntu 13.04 installation. (Some apps ship their own fallback icons, an example of app that doesn't is retext).

== Development Fix ==
Fixed in saucy-proposed (currently FTBFS because of some toolchain changes in saucy, a fix is in progress).

== Test case ==
0. Use Ubuntu desktop 13.04 (default flavour, not GNOME).
1. Install and run retext from raring repositories.
2. Check that it has icons.

As an alternative, run Qt assistant or a text editor from Qt examples and verify that they use icons from icon theme.

== Regression Potential ==
Should not cause any regressions.

== Original Description ==
I use Ubuntu 13.04.
Problem: There are no icons on buttons in retext since 4-th version. The buttons appear and they are clickable, but there are no pictures on them. It looks like:

GamePad64 (gamepad64) wrote :
description: updated
Dmitry Shachnev (mitya57) wrote :

Thanks for the report.

This is a bug in Qt, already fixed in dev branch. I'll look if we can do something for Ubuntu.

Changed in retext:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Dmitry Shachnev (mitya57)
Dmitry Shachnev (mitya57) wrote :

Work-around:

$ mkdir -p "~/.config/ReText project/"
$ echo "iconTheme=Humanity" >> "~/.config/ReText project/ReText.conf"

GamePad64 (gamepad64) wrote :

Okay, this workaround seems working, thanks.

affects: retext (Ubuntu) → qt4-x11 (Ubuntu)
Changed in qt4-x11 (Ubuntu):
assignee: nobody → Dmitry Shachnev (mitya57)
importance: Undecided → High
status: New → In Progress
Changed in qt4-x11 (Ubuntu Raring):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Dmitry Shachnev (mitya57)
no longer affects: retext
Dimitri John Ledkov (xnox) wrote :

Before uploading this as an SRU for Raring, please update the bug description as per:
https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.4+dfsg-0ubuntu11

---------------
qt4-x11 (4:4.8.4+dfsg-0ubuntu11) saucy; urgency=low

  * debian/rules: build with -no-pch on armhf and powerpc (fixes FTBFS).
 -- Dmitry Shachnev <email address hidden> Tue, 28 May 2013 16:07:22 +0400

Changed in qt4-x11 (Ubuntu):
status: In Progress → Fix Released
Dmitry Shachnev (mitya57) wrote :

Subscribing ubuntu-sponsors, as I would still like the fix to be uploaded to raring (the branch is linked).

Sebastien Bacher (seb128) wrote :

Thanks Dmitry, I'm going to sponsor that one

Hello GamePad64, or anyone else affected,

Accepted into raring-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in qt4-x11 (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Dmitry Shachnev (mitya57) wrote :

GamePad64: any chance you can test the version in raring-proposed?

GamePad64 (gamepad64) wrote :

Yes, I have tested it now on a fresh Ubuntu installation with raring-proposed enabled. Everything works like expected, icons display normally.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.4+dfsg-0ubuntu9.1

---------------
qt4-x11 (4:4.8.4+dfsg-0ubuntu9.1) raring; urgency=low

  * debian/patches/kubuntu_42_fix_icon_themes.diff:
    fix icon themes not working on a default Ubuntu install by using
    GtkSettings where appropriate (LP: #1180067).
 -- Dmitry Shachnev <email address hidden> Sun, 19 May 2013 19:18:58 +0400

Changed in qt4-x11 (Ubuntu Raring):
status: Fix Committed → Fix Released
Philip Muškovac (yofel) wrote :

Dmitry: this fix seems to have a rather bad side effect on KDE applications that throw X errors while running, which affects at least kile (bug 1195007), kdevelop and amarok
http://ubuntuforums.org/showthread.php?t=2157427

Could gdk_x_error() be somehow disabled or changed to not "exit(1);" on errors?

Jonathan Riddell (jr) wrote :

Uploaded qt4-x11_4.8.4+dfsg-0ubuntu9.2 to raring-proposed without the patch

Scott Kitterman (kitterman) wrote :

Reopened for raring. Due to the regression in many KDE apps this particular attempt at fixing this issue has been reverted. Another fix is in progress.

Changed in qt4-x11 (Ubuntu Raring):
status: Fix Released → Confirmed
Dmitry Shachnev (mitya57) wrote :

Looks like one needs to run KDE apps in non-KDE environment to reproduce the crash — I didn't test my patch in this configuration, sorry.

Upstream patch (which is identical to what's now in bzr) doesn't have the issue. Can anybody please upload the fixed version of the patch to raring instead of reverting the fix?

The revert is already accepted and building. Once the correct fix is in saucy,
we can redo the raring SRU with the correct fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.4+dfsg-0ubuntu9.2

---------------
qt4-x11 (4:4.8.4+dfsg-0ubuntu9.2) raring-proposed; urgency=low

  * Drop kubuntu_42_fix_icon_themes.diff fix regression in running
    KDE applications on Unity, LP: #1180067
 -- Jonathan Riddell <email address hidden> Mon, 08 Jul 2013 14:23:48 +0100

Changed in qt4-x11 (Ubuntu Raring):
status: Confirmed → Fix Released
Scott Kitterman (kitterman) wrote :

The revert for this is now released for raring, so it will show up again until the new fix is available.

Changed in qt4-x11 (Ubuntu Raring):
status: Fix Released → Confirmed
Dmitry Shachnev (mitya57) wrote :

Updated debdiff for raring with the X handling fix included. This now exactly matches what was committed upstream in ceaa577a03.

Dmitry Shachnev (mitya57) wrote :

Can anybody please sponsor the new version? This bug is getting more duplicates…

Tommy Stanton (tommystanton) wrote :

The work-around stated previously should use "$HOME" instead of "~" (tilde in quotes translates to literal tilde):

$ mkdir -p "$HOME/.config/ReText project/"
$ echo "iconTheme=Humanity" >> "$HOME/.config/ReText project/ReText.conf"

Otherwise, thanks for the work-around! :)

Scott Kitterman (kitterman) wrote :

Sorry for the last comment. Wrong bug.

Changed in qt4-x11 (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Dmitry Shachnev (mitya57) wrote :

Rebased on top of the current version in raring-proposed.

Changed in qt4-x11 (Ubuntu Raring):
status: Fix Committed → Triaged
Changed in qt4-x11 (Ubuntu Raring):
status: Triaged → Fix Committed
Scott Kitterman (kitterman) wrote :

There's already a SRU in -proposed. Please don't upload this one until that one is in -updates.

Changed in qt4-x11 (Ubuntu Raring):
status: Fix Committed → Triaged
Scott Kitterman (kitterman) wrote :

The previous SRU has been released, so this one can be uploaded now.

Scott Kitterman (kitterman) wrote :

Hello GamePad64, or anyone else affected,

Accepted into raring-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in qt4-x11 (Ubuntu Raring):
status: Triaged → Fix Committed
Dmitry Shachnev (mitya57) wrote :

Actually the fix is mostly the same as in ubuntu9.1, and still works here. Based on that fact and comment #11, marking as verification-done.

tags: added: verification-done
removed: verification-needed

Did you verify the regression that cause 9.1 to get reverted is not present?

Dmitry Shachnev (mitya57) wrote :

Kate launches fine in Ubuntu GNOME and correctly uses Oxygen icon theme (screenshot attached).

Dmitry Shachnev (mitya57) wrote :

The same for Krusader.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.4+dfsg-0ubuntu9.4

---------------
qt4-x11 (4:4.8.4+dfsg-0ubuntu9.4) raring-proposed; urgency=low

  * Update kubuntu_42_fix_icon_themes.diff to fix the regression,
    and re-enable it (LP: #1180067).
 -- Dmitry Shachnev <email address hidden> Sun, 25 Aug 2013 10:16:48 +0400

Changed in qt4-x11 (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers