Ubuntu

Scribus crashes when populating an image frame

Reported by Joe Mooring on 2012-04-04
This bug report is a duplicate of:  Bug #891681: Scribus crashes due to Signal #6. Edit Remove
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Scribus
Fix Released
Unknown
qt-at-spi (Ubuntu)
Undecided
Unassigned
scribus (Ubuntu)
Undecided
Unassigned

Bug Description

Scribus version: 1.4.1.svn (6 Feb 2012, Build ID C-C-T-F-C1.10.2-64bit

Ubuntu release: 12.04 (fully updated as of 4 Apr 2012) 64-bit)

Steps to reproduce problem:
1. Launch Scribus
2. In the New Document dialog, use the defaults and press OK
3. From the main menu choose Insert > Insert Image Frame
4. Draw an image frame of any size in any location on the page
5. Right-click on the image frame and choose Get Image
6. The open dialog appears, with Look In set to /home/username
7. Click on the Pictures folder -- bam.

A dialog appears:
Title: Scribus Crash
Text: Scribus crashes due to Signal #6

description: updated
Joe Mooring (toomanypets) wrote :

This does not occur if I start scribus with 'gksudo scribus'.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in scribus (Ubuntu):
status: New → Confirmed
Rudi von Staden (rudi) wrote :

It seems to be related to the file chooser dialogue. I can also get the same error by going to New Document > Open Existing Document > Click on any folder displayed.

Rudi von Staden (rudi) wrote :

Output running from command line:

Interface is not valid
ASSERT failure in : "Got an update for an invalid inteface. Investigate this.", file atspiadaptor.cpp, line 899
Scribus Crash
-------------
Scribus crashes due to Signal #6
Calling Emergency Save

I am having exactly the same problem. Some files with .JPG extension can be imported without problem!

Same problem by open a existing file
Ubuntu 12.04 64bit Unity
~$ scribus
Got bus address: "unix:abstract=/tmp/dbus-eA0CCLI967,guid=88a909d90d777407419890ec00000042"
Connected to accessibility bus at: "unix:abstract=/tmp/dbus-eA0CCLI967,guid=88a909d90d777407419890ec00000042"
Registered DEC: true
Registered event listener change listener: true
QSpiAccessible::accessibleEvent not handled: "8008" obj: QObject(0x0) " invalid interface!"
QSpiAccessible::accessibleEvent not handled: "8008" obj: QSidebar(0x3863a70, name = "sidebar") "sidebar"
FIXME: handle dialog start.
FIXME: handle dialog start.
Interface is not valid
ASSERT failure in : "Got an update for an invalid inteface. Investigate this.", file atspiadaptor.cpp, line 899
Scribus Crash
-------------
Scribus crashes due to Signal #6
QSpiAccessible::accessibleEvent not handled: "2" obj: QMessageBox(0x7fffc4768300) ""
FIXME: handle dialog start.
FIXME: handle dialog end.
Calling Emergency Save

This "bug" seems to be resolved by removing the qt-at-spi package.

Eric Hanuise (ehanuise) wrote :

"This "bug" seems to be resolved by removing the qt-at-spi package."
I can confirm this #7 fix does work.
Before, clicking on any folder in the file dialog would crash scribus (signal 6). Removing qt-ap-spi fixed the issue.

Inherited this bug when I updated from 11.10 to 12.04.
qt-ap-spi removal worked for me.

Thomas Kluyver (takluyver) wrote :

Also seeing this on 12.04 - removing qt-at-spi sorted it.

Sebastian Kubat (s-kubat) wrote :

Ok, i have the same problem and imagine i'm a total Linux beginner.
How to remove the qt-ap-spi and what the heck does that mean?

Thanks

Thomas Kluyver (takluyver) wrote :

Sebastian: qt-at-spi is a package. You can go to Ubuntu software centre, search for qt-at-spi and click Remove. Or from a command line, run "sudo apt-get remove qt-at-spi" (without the quotation marks). Note that it's installed for a reason: it's part of the accessibility framework that lets visually impaired users use the computer. So removing it might break things if anyone uses a screen reader on your computer.

Joe Mooring (toomanypets) wrote :

@ s-kubat:

To remove:

$ sudo apt-get remove qt-ap-spi

What it means:

According to http://packages.ubuntu.com/precise/qt-at-spi, qt-ap-spi is an accessibility plugin for Qt. As I understand it, this plugin allows screen readers (for users who are visually impaired) to work with applications build with the Qt application framework. You can learn more about Qt here: http://en.wikipedia.org/wiki/Qt_%28framework%29

Summary:

If you or any other user on your system does not use a screen reader, removing qt-ap-spi should be sage.

Thomas Kluyver (takluyver) wrote :

The bug was reported to Scribus (see link above), and they say it is a bug in qt-at-spi, and hence beyond their control. I've marked it as affecting qt-at-spi as well.

Sebastian Kubat (s-kubat) wrote :

Thank you very mutch! That helped a lot and fixed my problem :D Keep up the great work!

Changed in scribus:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qt-at-spi (Ubuntu):
status: New → Confirmed
Hoper (denispal) wrote :

After remove:
$ sudo apt-get remove qt-ap-spi
all work

Hoper (denispal) wrote :

Sorry
After remove:
$ sudo apt-get remove qt-at-spi
all work

oxman (mohair) wrote :

My latest update/upgrade for 12.04 causes this crash to start. Did not have a problem with it until then. It was associated with hdtemp package I had hoped to install. Doing > $ sudo apt-get remove qt-at-spi solved the problem but crashed hdtemp app.

There are lots of bugs reported about this problem - I think we should mark this bug is a duplicate of bug #998012 (librecad, qtiplot (among others) crash with "ASSERT failure in : "Got an update for an invalid inteface. Investigate this.", file atspiadaptor.cpp) or bug #946956 (lyx crashes in open/save file dialog)
QGIS (and other QT applications) crash bugs can be solved by simply removing qt-at-spi package 0.2.0+git20120411-0ubuntu1 (from Ubuntu 12.04 LTS)!

Realramnit (realramnit) wrote :

same here. ubuntu 12.04 (64bit) feat. Gnome-Shell.
Removing qt-at-spi solved the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.