[FFE] Build qemu-kvm with RBD support

Bug #904834 reported by Wido den Hollander on 2011-12-15
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
High
Clint Byrum
Precise
High
Clint Byrum

Bug Description

The current Qemu code included in Ubuntu has support for RBD (RADOS Block Device), part of the Ceph distributed filesystem.

Although Qemu supports RBD, Ubuntu doesn't build it with --with-rbd support, while librbd already available in Ubuntu.

It would be nice if the upcoming Ubuntu release (12.04) could ship with a Qemu version which has RBD support enabled.

Since librbd is available in the Ubuntu repositories it doesn't seem that hard to enable RBD support while building Qemu.

Some information about RBD: http://ceph.newdream.net/wiki/QEMU-RBD

Serge Hallyn (serge-hallyn) wrote :

Thanks for submitting this bug.

We can't currently build with rbd because librbd-dev is in universe. It needs to go into main first.

However, pulling it into main as well as building qemu against it are planned for this cycle. Hopefully soon.

Changed in qemu-kvm (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Wido den Hollander (wido) wrote :

Has there been any progress on this? I see that librbd is still in universe?

You might want to take a look at: https://bugs.launchpad.net/ubuntu/+source/ceph/+bug/837667/

Currently version 0.38 is in Ubuntu, but the Ceph project is going pretty fast, I suggest that another pull of the Ceph code is done before freezing the packages.

James Troup (elmo) on 2012-03-05
tags: added: canonistack
Clint Byrum (clint-fewbar) wrote :

Test rebuild commencing, but wanted to get this on the radar, sorry it is so late, the CEPH MIR got lost in the fray and is arriving a bit late.

summary: - Build qemu-kvm with RBD support
+ [FFE] Build qemu-kvm with RBD support
Changed in qemu-kvm (Ubuntu Precise):
importance: Medium → High
status: Triaged → In Progress
assignee: nobody → Clint Byrum (clint-fewbar)
Clint Byrum (clint-fewbar) wrote :

Test build finished. VERY minimal impact to the packages at a high level. Running smoke tests right now on my machine, nothing has failed yet with regular kvm usage.

File lists identical (after any substitutions)

Control files: lines which differ (wdiff format)
------------------------------------------------
Source: qemu-kvm [-(1.0+noroms-0ubuntu12)-] {+(1.0+noroms-0ubuntu13)+}
Version: [-1:84+dfsg-0ubuntu16+1.0+noroms+0ubuntu12-] {+1:84+dfsg-0ubuntu16+1.0+noroms+0ubuntu13+}
File lists identical (after any substitutions)

Control files: lines which differ (wdiff format)
------------------------------------------------
Version: [-1.0+noroms-0ubuntu12-] {+1.0+noroms-0ubuntu13+}
File lists identical (after any substitutions)

Control files: lines which differ (wdiff format)
------------------------------------------------
Version: [-1.0+noroms-0ubuntu12-] {+1.0+noroms-0ubuntu13+}
File lists identical (after any substitutions)

Control files: lines which differ (wdiff format)
------------------------------------------------
Depends: iproute, python, qemu-common (>= [-1.0+noroms-0ubuntu12),-] {+1.0+noroms-0ubuntu13),+} qemu-utils (>= [-1.0+noroms-0ubuntu12),-] {+1.0+noroms-0ubuntu13),+} upstart-job, libaio1 (>= 0.3.93), libasound2 (>= 1.0.23), libc6 (>= 2.15), libcurl3-gnutls (>= 7.16.2-1), libglib2.0-0 (>= 2.24.0), libgnutls26 (>= 2.12.6.1-0), libncurses5 (>= 5.5-5~), libpng12-0 (>= 1.2.13-4), libpulse0 (>= 1:0.99.1), {+librados2, librbd1,+} libsasl2-2, libsdl1.2debian (>= 1.2.10-1), libtinfo5, libuuid1 (>= 2.16), libx11-6, zlib1g (>= 1:1.1.4)
Installed-Size: [-12912-] {+12942+}
Version: [-1.0+noroms-0ubuntu12-] {+1.0+noroms-0ubuntu13+}
File lists identical (after any substitutions)

Control files: lines which differ (wdiff format)
------------------------------------------------
Depends: libaio1 (>= 0.3.93), libc6 (>= 2.15), libcurl3-gnutls (>= 7.16.2-1), libglib2.0-0 (>= 2.12.0), {+librados2, librbd1,+} libuuid1 (>= 2.16), zlib1g (>= 1:1.1.4)
Installed-Size: [-781-] {+799+}
Version: [-1.0+noroms-0ubuntu12-] {+1.0+noroms-0ubuntu13+}

Clint Byrum (clint-fewbar) wrote :
Clint Byrum (clint-fewbar) wrote :

Attaching successful build log showing building/linking RBD

Changed in qemu-kvm (Ubuntu Precise):
status: In Progress → Fix Committed
milestone: none → ubuntu-12.04
Clint Byrum (clint-fewbar) wrote :

This is now blocked on the MIR bug 932898 for CEPH, which is blocked on the FFE bug 932896

Serge Hallyn (serge-hallyn) wrote :

qa-regression-tests for test-qemu.py and test-libvirt.py both passed (minus the USB hostdev failure which was pre-existing). A guest install with the new kvm is going fine.

No objections from me on the patch, no apparent regressions.

Thanks, Clint.

Steve Langasek (vorlon) wrote :

Since this is already regression-tested, no objections. FFe approved.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu-kvm - 1.0+noroms-0ubuntu13

---------------
qemu-kvm (1.0+noroms-0ubuntu13) precise; urgency=low

  * d/rules,d/control: Enable RADOS block device (RBD) (LP: #904834)
 -- Clint Byrum <email address hidden> Thu, 12 Apr 2012 08:58:11 -0700

Changed in qemu-kvm (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers