qemu-kvm daemon fails: exit 1

Bug #559896 reported by Gerben on 2010-04-10
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
Critical
Dustin Kirkland 
Lucid
Critical
Dustin Kirkland 

Bug Description

Binary package hint: qemu-kvm

10.04 server beta2 amd-64

ii qemu-kvm 0.12.3+noroms-0ubuntu5

kvm hypervisor to be running (so virt-manager can use kvm in stead of qemu)

kvm hypervisor did not start
# start qemu-kvm
start: Job failed to start

RESOLUTION:
uncomment line "#SLEEP_MILLISECS=2000" in file /etc/default/qemu-kvm

I don't know what this sleep is for, it looks to me a process is too speedy for another process to complete.

When still commented, the following logs were written in /var/log/*:
(kernel modules kvm* would not have been loaded)
==> daemon.log <==
Apr 10 11:22:56 kvm-02 init: qemu-kvm pre-start process (5904) terminated with status 1

==> kern.log <==
Apr 10 11:22:56 kvm-02 kernel: [ 4375.839967] kvm: Nested Virtualization enabled
Apr 10 11:22:56 kvm-02 kernel: [ 4375.839975] kvm: Nested Paging enabled

==> messages <==
Apr 10 11:22:56 kvm-02 kernel: [ 4375.839967] kvm: Nested Virtualization enabled
Apr 10 11:22:56 kvm-02 kernel: [ 4375.839975] kvm: Nested Paging enabled

==> syslog <==
Apr 10 11:22:56 kvm-02 kernel: [ 4375.839967] kvm: Nested Virtualization enabled
Apr 10 11:22:56 kvm-02 kernel: [ 4375.839975] kvm: Nested Paging enabled
Apr 10 11:22:56 kvm-02 init: qemu-kvm pre-start process (5904) terminated with status 1

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: qemu-kvm 0.12.3+noroms-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Uname: Linux 2.6.32-16-generic x86_64
Architecture: amd64
Date: Sat Apr 10 11:13:21 2010
InstallationMedia: Ubuntu-Server 10.04 "Lucid Lynx" - Beta amd64 (20100317)
KvmCmdLine:
 UID PID PPID C SZ RSS PSR STIME TTY TIME CMD
 root 4707 1 55 201859 538228 0 11:09 ? 00:02:13 /usr/bin/kvm -S -M pc-0.12 -enable-kvm -m 512 -smp 1 -name test-1004 -uuid ff2e7e05-2697-3db6-5f3d-44c8dee08315 -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/test-1004.monitor,server,nowait -monitor chardev:monitor -no-reboot -boot d -drive file=/mnt/data/kvm/test-1004/sda.img,if=virtio,index=0 -drive file=/mnt/data/iso/ubuntu-10.04-beta2-server-i386.iso,if=ide,media=cdrom,index=2 -net nic,macaddr=52:54:00:3c:c5:fb,vlan=0,model=virtio,name=virtio.0 -net tap,fd=44,vlan=0,name=tap.0 -chardev pty,id=serial0 -serial chardev:serial0 -parallel none -usb -vnc 127.0.0.1:0 -vga cirrus -soundhw es1370
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System manufacturer System Product Name
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=9e6c4a89-df23-4cda-be81-fc678c696646 ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: qemu-kvm
dmi.bios.date: 10/09/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M3N78 PRO ACPI BIOS Revision 1301
dmi.board.name: M3N78 PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM3N78PROACPIBIOSRevision1301:bd10/09/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM3N78PRO:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Related branches

Gerben (gerbgeus) wrote :
Changed in qemu-kvm (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Dustin Kirkland (kirkland)
milestone: none → ubuntu-10.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu-kvm - 0.12.3+noroms-0ubuntu6

---------------
qemu-kvm (0.12.3+noroms-0ubuntu6) lucid; urgency=low

  * debian/qemu-kvm.upstart: fix logic that was preventing upstart
    job from starting properly, LP: #559896
 -- Dustin Kirkland <email address hidden> Sat, 10 Apr 2010 11:06:47 -0500

Changed in qemu-kvm (Ubuntu Lucid):
status: In Progress → Fix Released
Dustin Kirkland  (kirkland) wrote :

@Gerben-

Thanks for the report!

@James-

This is the issue you showed me yesterday. I was able to reproduce it as soon as I reinstalled from scratch. Minor logic error in the upstart job. My fault. Fix uploaded. Please mark any other bug you might have opened a dupe against this one.

Changed in qemu-kvm (Ubuntu Lucid):
status: Fix Released → Fix Committed
Carlo Pires (carlopires) wrote :

I confirm this. Uncommenting SLEEP_MILLISECS in /etc/default/qemu-kvm solved the problem and saved my day. My vms are alive again :)

Thierry Carrez (ttx) on 2010-04-12
Changed in qemu-kvm (Ubuntu Lucid):
status: Fix Committed → Fix Released

I've qemu-kvm (0.12.3+noroms-0ubuntu6) installed on Ubuntu 10.04.3 but this problem still persist. I thought it were solved on 0.12.3....

Serge Hallyn (serge-hallyn) wrote :

@Wainer,

please file a new bug describing your symptoms, using 'ubuntu-bug qemu-kvm' if possible, and mentioning that you think it looks like this bug (but 559896).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers