oosplash.bin crashed with SIGSEGV in splash_create_window() under KVM

Bug #273930 reported by Michael Vogt on 2008-09-24
148
This bug affects 25 people
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: openoffice.org

Happend when I started the writer after a hardy to intrepid upgrade. It looks similar to #85613. Video driver is "cirrus" (not sure if that is relevant).

ProblemType: Crash
Architecture: i386
CrashCounter: 1
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/lib/openoffice/program/oosplash.bin
Package: openoffice.org-core 1:2.4.1-9ubuntu1
ProcAttrCurrent: unconfined
ProcCmdline: /usr/lib/openoffice/program/oosplash.bin -writer
ProcEnviron:
 PATH=/usr/lib/openoffice/program:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: openoffice.org
Stacktrace:
 #0 0x0804b0c9 in splash_create_window ()
 #1 0x0804cd5b in main ()
StacktraceTop:
 splash_create_window ()
 main ()
Title: oosplash.bin crashed with SIGSEGV in splash_create_window()
Uname: Linux 2.6.27-4-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy plugdev scanner video

Michael Vogt (mvo) wrote :

StacktraceTop:splash_create_window ()
main ()

Changed in openoffice.org:
importance: Undecided → Medium
Chris Cheney (ccheney) on 2008-10-13
Changed in openoffice.org:
importance: Medium → Undecided
status: New → Invalid
Chris Cheney (ccheney) on 2008-10-22
Changed in openoffice.org:
status: Invalid → New

Can anyone still reproduce this bug? I can't reproduce this on i386 or amd64.

Thanks,

Chris Cheney

Changed in openoffice.org:
status: New → Incomplete
Chris Cheney (ccheney) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in openoffice.org:
status: Incomplete → Invalid
Sebastien Bacher (seb128) wrote :

that's still an issue in current jaunty alpha6 cds

Changed in openoffice.org:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

to trigger the crash easily:

* boot a jaunty CD in a virtual installation
* double click on one openoffice example in the desktop directory
* you get the apport crash dialog

seems to happen every time you open an example

Chris Cheney (ccheney) on 2009-03-19
Changed in openoffice.org (Ubuntu):
status: New → Confirmed
Chris Cheney (ccheney) wrote :

I'll try testing this again once the live cd's work, currently nautilus blows up constantly for me as noted in bug 325973.

Cam Cope (ccope) wrote :

I just got this in a virtual machine as well.
Jaunty, fully updated. QEMU 0.10.1 + KVM 84. Host is Gentoo 2.6.28 x86.

Chris Cheney (ccheney) wrote :

I still can't reproduce this problem with the Ubuntu 9.04 live cd while running under VMware 6.5.2. Perhaps this only shows up under Qemu?

Changed in openoffice.org (Ubuntu):
status: Confirmed → Incomplete
Chris Cheney (ccheney) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in openoffice.org (Ubuntu):
status: Incomplete → Invalid
Ivan Baldo (ibaldo) wrote :

Happened to me with Ubuntu 9.10 Beta Live CD running under KVM.

Tuomas Heino (iheino+ub) wrote :

Happened to me as well on first startup with Ubuntu 9.10 Beta Live DVD running under KVM.
On second try it managed to start, go figure.

Chris Cheney (ccheney) wrote :

This appears to be some sort of KVM issue, or at least it isn't reproducible anywhere else.

summary: - oosplash.bin crashed with SIGSEGV in splash_create_window()
+ oosplash.bin crashed with SIGSEGV in splash_create_window() under KVM
affects: openoffice.org (Ubuntu) → kvm (Ubuntu)
Changed in kvm (Ubuntu):
status: Invalid → New
Mathias Gug (mathiaz) on 2009-10-19
affects: kvm (Ubuntu) → qemu-kvm (Ubuntu)
Changed in qemu-kvm (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Matt Zimmerman (mdz) wrote :

I just confirmed this on karmic-desktop-i386.iso build 20091020.3:

1. Boot in KVM
2. Select "Try..."
3. Open the Examples folder using the shortcut on the desktop
4. Double-click Presenting_Ubuntu.odp

The document opens successfully, but a crash report appears for oosplash.bin.

Changed in qemu-kvm (Ubuntu):
status: Confirmed → Triaged
importance: Low → Medium
tags: added: iso-testing
sam tygier (samtygier) wrote :

still an issue in lucid, using todays livecd amd64 in testdrive (kvm)

Dustin Kirkland  (kirkland) wrote :

Hi Sam (or anyone else)-

Could you try it again today, using an up-to-data Lucid system?

I'm running today's latest:
 * lucid-desktop-amd64.iso 2010-03-01 af73e2b6f258bca70a2485af0f5496d1
 * qemu-kvm 0.12.3-0ubuntu2
 * linux 2.6.32-14-generic

I booted the live cd (using testdrive), tried-without-installing, double-clicked all examples, and everything opened and ran as expected. Attaching a screencast, and closing this bug as fix-released for now.

If you can reproduce this bug, please reopen it with specific instructions and program versions.

Changed in qemu-kvm (Ubuntu):
status: Triaged → Confirmed
Dustin Kirkland  (kirkland) wrote :

Hmm, well, actually...

A few minutes after closing all of those windows, I did end up with a /var/crash/_usr_lib_openoffice_program_oosplash.bin.999.crash file.

Loïc Minier (lool) on 2010-03-01
Changed in qemu-kvm (Ubuntu):
status: Confirmed → Triaged
Dustin Kirkland  (kirkland) wrote :

Hi Loic-

You marked this bug triaged... Do you know what's actually causing the error, or where to begin debugging this?

Dustin Kirkland  (kirkland) wrote :

Interestingly, I could not reproduce this in virtualbox (just another datapoint...)

Dustin Kirkland  (kirkland) wrote :

I'm going to down this from Triaged->Confirmed, but Loic, if you can tell me exactly where the bug is and how to fix it, please promote it to Triaged again. Thanks!

Changed in qemu-kvm (Ubuntu):
status: Triaged → Confirmed
sam tygier (samtygier) wrote :

still crashing for me when running lucid daily in testdrive (qemu kvm).

Loïc Minier (lool) wrote :

I thought you had managed to crash it and had gathered a .crash file, so that it could move back to Triaged from where it was before you said you couldn't reproduce.

Dustin Kirkland  (kirkland) wrote :

Well, it is true that I have a crash file. But I have no idea how to fix it ;-) Moving back to triaged, I suppose.

Changed in qemu-kvm (Ubuntu):
status: Confirmed → Triaged

Can you please try to reproduce with an upstream qemu-kvm?

Hrm, I tried, but upstream qemu (compiled from git head) froze up.
I'll try against upstream 0.12.3.

Jérôme (jerome-bouat) wrote :

I had the crash detection too with i386 lucid alpha3 release (and all updates) over KVM on karmic amd64.

Harald (hdmuell) wrote :

I had the crash today with Ubuntu Netbook (lucid-i386; 2010-03-18 02:05:29). I updated the ISO today. I started a power-point presentation.
I run the ISO in qemu/KVM on Karmic.

Harald (hdmuell) wrote :

I had the crash with Ubuntu Desktop (lucid-i386; 2010-03-21 09:13:40) on the same computer with qemu/KVM on Karmic, too.

David Ayers (ayers) wrote :

I can confirm this bug still exists with a Lucid host (virt-manager/libvirt/KVM) and a Maverick alpha 3 guest.

Confirmed in Ubuntu 11.04 virt-manager guest, LibreOffice Calc, in a Ubuntu 10.10 host. The impact is minimal as the Calc file opens fine anyways, despite the crash.

WORKAROUND: Run Calc from the Terminal with the -nologo switch:
localc -nologo (FILE)

md5sum natty-desktop-i386.iso
3185a6c65bc6a197dddc8bbcb8a7e3a6

Guest:

lsb_release -rd
Description: Ubuntu natty (development branch)
Release: 11.04

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.0-1ubuntu1
  Candidate: 1:3.3.0-1ubuntu1
  Version table:
 *** 1:3.3.0-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

Host:

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy virt-manager
virt-manager:
  Installed: 0.8.4-7ubuntu1.1
  Candidate: 0.8.4-7ubuntu1.1
  Version table:
 *** 0.8.4-7ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.8.4-7ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

apt-cache policy qemu-kvm
qemu-kvm:
  Installed: 0.12.5+noroms-0ubuntu7.1
  Candidate: 0.12.5+noroms-0ubuntu7.1
  Version table:
 *** 0.12.5+noroms-0ubuntu7.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.12.5+noroms-0ubuntu7 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers