Selecting spice and qxl mode results in blank screen

Bug #970234 reported by Troels Liebe Bentsen on 2012-03-31
184
This bug affects 36 people
Affects Status Importance Assigned to Milestone
qemu-kvm-spice (Ubuntu)
Medium
Unassigned

Bug Description

Steps to reproduce is:

1. Create new vm in virt-manager
2. Select video mode qxl and display spice

Results is a blank screen on vm startup and 100% cpu.

Serge Hallyn (serge-hallyn) wrote :

Hi,

thanks for reporting this bug. Can you tell me exactly which .iso you were booting from? I've noticed the alternate installer reproduces this behavior for me, but the desktop cd (from http://cdimage.ubuntu.com/daily-live/current/) seems fine.

Changed in qemu-kvm (Ubuntu):
status: New → Confirmed
affects: qemu-kvm (Ubuntu) → qemu-kvm-spice (Ubuntu)
Changed in qemu-kvm-spice (Ubuntu):
importance: Undecided → Medium
Troels Liebe Bentsen (tlbdk) wrote :

I ran in to the problems with a Windows XP guest domain, but have reproduced it just trying to do a pxe boot via the bios, using splice works so long as I don't set it to qxl.

Serge Hallyn (serge-hallyn) wrote :

actually for my own case specifying -boot d works for me.

Serge Hallyn (serge-hallyn) wrote :

The 100%cpu and black screen also happens when grub waits for input. So if you have an unclean shutdown, and grub waits indefinately for input before booting, you're stuck.

A workaround is to temporarily work over vnc, get a clean shutdown, then you can boot over spice.

Obviously this is not nice.

Troels Liebe Bentsen (tlbdk) wrote :

The guest machines in testing with is running windows so I don't have that problem, but it seems it the seabios that has a problem.

summary: - Selecting splice and qxl mode results in blank screen
+ Selecting spice and qxl mode results in blank screen
MatthewHawn (steamraven) wrote :

This happend to me when switching from kvm to kvm-spice emulator. With KVM-spice, the only video mode that works is cirrus.

Serge Hallyn (serge-hallyn) wrote :

@Troels,

can you tell me exactly which installer iso you are using?

The live desktop installer works for me with spice. The alternate installer does not. I'd like to make sure that you are seeing the same thing i am.

Lincoln Smith (dagdamor) wrote :

+1 for WinXP guest blank screen and 100% cpu when trying to boot with spice+qxl.

My install is an amd64 upgrade from 11.10. Happy to provide more details/testing if needed.

lequeux1 (elequeux) wrote :

+1 for WinXP for 100% cpu when booting with spice+qxl.

Ubuntu 12.05 fresh install

avdhoot (avdhooth) wrote :

Any soulution for this problem. when we will get fix??? :)

Same problem with up2date Ubuntu 12.04 and a Windows XP VM created with aqemu.

I had the same problem yesterday on Ubuntu server 12.04 x86_64. The problem remains even when adding spice guest tools to the windows VM. Works only with "-vga cirrus".

Joseph (joenmtl) wrote :

After upgrading to 12.10 amd64, I was able to run my virtual machine using spice. So the issue seems to be resolved in newer version of qemu-kvm-spice 1.2.

winmasta (winmasta) wrote :

where can i get 1.2 version for ubuntu 12.04 ?

In ubuntu 13.04 all work.
brain@brain-ThinkPad-X230:~$ dpkg -s qemu-kvm-spice | grep Version
Version: 1.2.0-2012.09-0ubuntu2

Stuart Longland (redhatter) wrote :

I've noticed this myself.

For what it's worth, a lot of people here are experiencing it with Windows VMs. I tried booting a Zentyal system with a qxl emulated card and got the same result.

root@bneprdcn0:/var/lib/libvirt/images# dpkg -l qemu-kvm*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-======================-======================-============================================================
ii qemu-kvm 1.0+noroms-0ubuntu14.7 Full virtualization on i386 and amd64 hardware
ii qemu-kvm-extras 1.0.50-2012.03-0ubuntu QEMU system and user mode emulation (transitional package)
ii qemu-kvm-spice 1.0.50-2012.03-0ubuntu Full virtualization on amd64 hardware

This is on a Ubuntu 12.04 AMD64 server, installed via PXEboot. The workaround for the first VM was to just use VNC, since it's only Zentyal and I'll only be using the console for getting networking going (something I have done; simple as blasting away the udev network naming rules).

For the second VM on that host, it'll be Windows Server 2008r2, where the graphical console is much more important.

In 1.2 all fixed

Changed in qemu-kvm-spice (Ubuntu):
status: Confirmed → Fix Committed

In 13.04 qemu-kvm-spice is dropped.
Use qemu-kvm and python-spice-client-gtk for SPICE.

qemu (1.3.0+dfsg-5expubuntu3) raring; urgency=low

  * Now that qemu provides spice support, and qemu-kvm-spice is removed from
    the archive, have qemu-kvm (which qemu-kvm-spice always depended on)
    P/C/R qemu-kvm-spice.

 -- Serge Hallyn <email address hidden> Thu, 14 Feb 2013 13:43:27 -0600

tags: added: precise
Ryan Daly (daly-ctcnet) wrote :

I can confirm 1.2 fixes things, too.

Is there any chance of these packages making their way into the 12.04 repositories? I grabbed mine through a PPA...

Tomas Herfert (herfik) wrote :

Is it going to be fixed in 12.04 as well?
Thanks

Coenraad Loubser (dagelf) wrote :

I'm on 12.04.4 and a simple apt-get install qemu-kvm-spice gave me the qemu-system-x86_64-spice which worked fine. I also got a black screen after installing the guest tools, and the QNX driver, upon first boot in QNX mode... but just gave it a few minutes to detect and install the driver - it's very slow before that gets enabled. Links here: http://askubuntu.com/questions/202067/libvirt-with-spice-on-12-04-amd64/511043#511043

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions