[Regression] Caffeine can't connect to display in Ubuntu 14.04.3 & 14.04.4 w/ HWE stack

Bug #1549798 reported by Tarik on 2016-02-25
36
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Caffeine
Undecided
Unassigned
python-xlib (Ubuntu)
Undecided
Unassigned

Bug Description

* Expected to happen:
Run caffeine

* Actual behaviour:
Crash with the following error

Traceback (most recent call last):
  File "/usr/bin/caffeine", line 36, in <module>
    ewmh = EWMH()
  File "/usr/lib/python3/dist-packages/ewmh.py", line 50, in __init__
    self.display = _display or display.Display()
  File "/usr/lib/python3/dist-packages/Xlib/display.py", line 80, in __init__
    self.display = _BaseDisplay(display)
  File "/usr/lib/python3/dist-packages/Xlib/display.py", line 62, in __init__
    display.Display.__init__(*(self, ) + args, **keys)
  File "/usr/lib/python3/dist-packages/Xlib/protocol/display.py", line 129, in __init__
    raise error.DisplayConnectionError(self.display_name, r.reason)
Xlib.error.DisplayConnectionError: Can't connect to display ":0": b'Invalid MIT-MAGIC-COOKIE-1 key'

Python-xlib version is 0.14+20091101-1ubuntu3~trusty

Ubuntu version: Ubuntu 14.04.4 LTS

The same bug was reported and reportedly solved before: https://bugs.launchpad.net/ubuntu/+source/python-xlib/+bug/1482844, but I started experiencing the same issue a few days ago. The same error occurs running caffeine-plus.

Tarik (tarik-causevic) on 2016-02-25
description: updated
description: updated
Reuben Thomas (rrt) wrote :

This is not a Caffeine bug: it's a bug in python-xlib.

Changed in caffeine:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-xlib (Ubuntu):
status: New → Confirmed
summary: - caffeine can't connect to display (regression-update)
+ [Regression] Caffeine can't connect to display in Ubuntu 14.04.3 &
+ 14.04.4 w/ HWE stack
tags: added: regression-update trusty
Tarik (tarik-causevic) wrote :

Something like 2-3 weeks after the initial bug report my laptop was asleep for a longer duration and after waking up the caffeine and other python-xlib related stuff worked as it should. Upon reboot it stopped working again.

Some time after that the problems just stopped and ever since then (it's been a month approximately) everything has been working without any issues. I have been waiting to see if the bug would reappear, but until today nothing has happened. I have not followed all the updates precisely so I do not know what caused the fix. I can run some tests on my machine if you need any.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers