Missing dependencies in Ubuntu 18.04

Bug #1763923 reported by Fuel on 2018-04-14
60
This bug affects 14 people
Affects Status Importance Assigned to Milestone
apt-btrfs-snapshot
New
Undecided
Unassigned
apt-btrfs-snapshot (Ubuntu)
Undecided
Unassigned
python-stem (Debian)
Fix Released
Unknown
python-stem (Ubuntu)
Undecided
Unassigned

Bug Description

After installing apt-btrfs-snapshot in Ubuntu 18.04 I got following error messages:

Traceback (most recent call last):
  File "/usr/bin/apt-btrfs-snapshot", line 33, in <module>
    from apt_btrfs_snapshot import AptBtrfsSnapshot
  File "/usr/lib/python3/dist-packages/apt_btrfs_snapshot.py", line 28, in <module>
    from distutils.spawn import find_executable
ModuleNotFoundError: No module named 'distutils.spawn'

This was resolved by manually installing 'python3-distutils'.

The dependency should be added to the package.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt-btrfs-snapshot (Ubuntu):
status: New → Confirmed
tags: added: bionic packaging
Changed in python-stem (Ubuntu):
status: New → Confirmed
Changed in python-stem (Debian):
status: Unknown → Fix Released

I have installed apt-btrfs-snapshot 3.5.1 today but the dependencies was not installed automatically.

I still need to install 'python3-distutils' manually.

S.L.R. (stever1978666) on 2019-04-01
Changed in apt-btrfs-snapshot (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Chris (liny-odell) wrote :

This also affects 19.10 so I'm guessing this is waiting on a fix from Debian? The noted debbug is for a similar issue, missing this same depends, but it is for a different package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.