python-scipy uninstallable (needs gfortran transition)

Bug #187004 reported by der_vegi on 2008-01-29
26
Affects Status Importance Assigned to Milestone
python-numpy (Ubuntu)
Undecided
Unassigned
python-scipy (Debian)
Fix Released
Unknown
python-scipy (Ubuntu)
High
William Grant

Bug Description

I cannot install python-scipy because it depends on python-numpy. But somehow, it seems to conflict with python-numpy at the same time. Only works, if I do 'dpkg --force-conflicts'. The not very instructive error in Synaptic is 'python-scipy:'. Apt-get says ' python-scipy: depends on: python-numpy (>= 1:1.0.2) but should not be installed' (translated from the German output).

I am using Hardy amd64 with all updates installed until today, python-scipy is 0.6.0-5ubuntu1, python-numpy is 1:1.0.4-5ubuntu2.

der_vegi (m-may) on 2008-01-29
description: updated
Matthias Klose (doko) wrote :

right, has to be updated to build with gfortran, plus it should be tested before upload.

Changed in python-scipy:
status: New → Confirmed
William Grant (wgrant) on 2008-02-08
Changed in python-numpy:
status: New → Invalid
Changed in python-scipy:
importance: Undecided → High
status: Confirmed → Triaged
William Grant (wgrant) wrote :

This will need the new suitesparse from unstable, which will require a FFe.

Changed in python-scipy:
assignee: nobody → fujitsu
Changed in python-scipy:
status: Unknown → New
Changed in python-scipy:
status: New → Fix Released

Fixed in debian now.

Changed in python-scipy:
milestone: none → ubuntu-8.04-beta
William Grant (wgrant) wrote :

A fixed version is now being tested in my PPA.

Changed in python-scipy:
status: Triaged → In Progress
Yosef (yosefm) wrote :

The PPA packages solve the dependency problems for me. I also ran today a 3 hour long simulation with scipy/numpy and done analysis with your version of Matplotlib without any breakage.

Thanks.

der_vegi (m-may) wrote :

Installs for me as well. The basic things, I have tested so far, work without a problem.

William Grant (wgrant) wrote :

Thanks for the testing! I'm confident that everything works, but I can't upload it all to Hardy yet, as it requires a suitesparse transition, and one of suitesparse's reverse dependencies (petsc) now FTBFS. Once that's sorted out, I'll upload them all to Hardy.

William Grant (wgrant) wrote :

The petsc FTBFS is bug #199256.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-scipy - 0.6.0-8ubuntu1

---------------
python-scipy (0.6.0-8ubuntu1) hardy; urgency=low

  * Sync from Debian unstable.
    - Builds with gfortran, so is installable again. (LP: #187004)
  * debian/rules: Fix a few FTBFSes (LP: #199031):
    - Don't remove LICENSE.txt, or python-central gets angry.
    - Make sed look for stuff in /usr/share/pyshared, rather than the old
      python-central directory.
    - Unset {LD,F}FLAGS, as it FTBFS otherwise due to a braindead distutils.
  * debian/control: Comply with DebianMaintainerField.

python-scipy (0.6.0-8) unstable; urgency=low

  * Build depend on libsuitesparse (>= 3.1.0-3)
  * Build depends fixed to use gfortran based lapack and blas (Closes: #466868)

python-scipy (0.6.0-7) unstable; urgency=low

  * Bumped the version, because python-numpy conflicts with python-scipy (<=
    0.6.0-6). This compiles against the old suitesparse, but it makes the
    package installable and working again.

python-scipy (0.6.0-6) UNRELEASED; urgency=low

  * debian/control
    - uniforming both Vcs-Svn and Vcs-Browser fields

 -- William Grant <email address hidden> Sat, 08 Mar 2008 12:16:04 +1100

Changed in python-scipy:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.