jockey-kde crashed with SIGSEGV in QWidget::metric() on kubuntu 9.04 startup

Bug #349419 reported by Lorenzo on 2009-03-27
278
This bug affects 19 people
Affects Status Importance Assigned to Milestone
python-qt4 (Ubuntu)
Medium
Unassigned

Bug Description

I dont' know ho to reproduce this bug

this problem after loggin in and loading kde
1)
Description: Ubuntu jaunty (development branch)
Release: 9.04
2)
jockey-kde:
  Installato: 0.5-0ubuntu5
  Candidato: 0.5-0ubuntu5
  Tabella versione:
 *** 0.5-0ubuntu5 0
        500 http://it.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

3) I don't know

4) nothing..

thank you

ProblemType: Crash
Architecture: i386
CurrentDmesg:
 [ 23.972829] r8169: eth0: link up
 [ 34.288065] eth0: no IPv6 routers present
 [ 45.580709] Marking TSC unstable due to cpufreq changes
 [ 46.084029] Clocksource tsc unstable (delta = -277800430 ns)
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/jockey-kde
InterpreterPath: /usr/bin/python2.6
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Acer Aspire 1520
Package: jockey-kde 0.5-0ubuntu5
PackageArchitecture: all
ProcCmdLine: root=UUID=9bac72d2-abf1-4a62-9c44-ba9a4b6a8066 ro quiet splash
ProcCmdline: /usr/bin/python /usr/bin/jockey-kde
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-11.37-generic
Signal: 11
SourcePackage: jockey
StacktraceTop:
 QWidget::metric () from /usr/lib/libQtGui.so.4
 QFont::QFont () from /usr/lib/libQtGui.so.4
 QWidgetPrivate::updateFont () from /usr/lib/libQtGui.so.4
 QWidgetPrivate::resolveFont () from /usr/lib/libQtGui.so.4
 QWidget::setParent () from /usr/lib/libQtGui.so.4
Title: jockey-kde crashed with SIGSEGV in QWidget::metric()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf:

Lorenzo (tecnicop) wrote :

StacktraceTop:QWidget::metric (this=0x9431c88, m=QPaintDevice::PdmDpiY)
QFont (this=0xbfc3770c, font=@0xbfc3774c, pd=0x9431c90)
QWidgetPrivate::updateFont (this=0x943ee38,
QWidgetPrivate::resolveFont (this=0x943ee38)
QWidget::setParent (this=0x9431c88, parent=0x0, f=

Jonathan Thomas (echidnaman) wrote :

Either a Qt or PyQt/KDE bug.

visibility: private → public
affects: jockey (Ubuntu) → qt4-x11 (Ubuntu)
Changed in qt4-x11 (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed

My bug 428810 was considered a duplicate of this one.

I am on Karmic Koala Kubuntu and trying to activate proprietary fglrx driver in Karmic Koala. It just hangs and never activates. So I cannot get the Catalyst 9.10 driver installed.

Marc Schwarz (slick666-gmx) wrote :

Use jockey-gtk to install it in Kubuntu.

user@computer:~$ sudo apt-get install jockey-gtk
Confirm
user@computer:~$ sudo jockey-gtk
Install the Driver and be lucky;)

tags: added: iso-testing
Tyler Burton (tylerburtonca) wrote :

If you use jockey-text you can enable the driver without installing jockey-gtk. Just run:

$ sudo jockey-text -u
[will update the driver list]

$ sudo jockey-text -c
[will check for new usable drivers]

$ sudo jockey-text -l
[will list all available drivers for your system]

$sudo jockey-text -e [driver]
[will enable driver for your system. for example on my machine I used 'sudo jockey-text -e xorg:fglrx' to enable my ATI drivers]

Jonathan Thomas (echidnaman) wrote :

Fixed in Kubuntu 10.04.

affects: qt4-x11 (Ubuntu) → python-qt4 (Ubuntu)
Changed in python-qt4 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.