Ubuntu

Volume too loud

Reported by Taylor "Ripps" LeMasurier-Wren on 2009-08-09
216
This bug affects 38 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Medium
Luke Yelavich

Bug Description

Binary package hint: pulseaudio

The latest pulseaudio_0.9.16~test4-0ubuntu4 in karmic is ramping the volume up way too high on my sblive! 5.1. The previous version was perfect, but now it's seems to moving the mixers around illogically and causing the the pcm volume to go straight to 80% even when the pa volume is only at 5%. This is much loud.

I don't know why things were changed from the last version, it was working great yesterday, now I can't even listen with my headphones without causing hearing damage.

ProblemType: Bug
Architecture: i386
Card0.Amixer.info:
 Card hw:0 'Live'/'SB Live! 5.1 (rev.7, serial:0x80641102) at 0xc000, irq 16'
   Mixer name : 'eMicro EM28028'
   Components : 'AC97a:454d4328'
   Controls : 216
   Simple ctrls : 38
Card1.Amixer.info:
 Card hw:1 'CX8801'/'Conexant CX8801 at 0xeb000000'
   Mixer name : 'CX88'
   Components : ''
   Controls : 3
   Simple ctrls : 2
Date: Sun Aug 9 01:22:01 2009
DistroRelease: Ubuntu 9.10
Package: pulseaudio 1:0.9.16~test4-0ubuntu4
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SourcePackage: pulseaudio
Uname: Linux 2.6.31-5-generic i686

Florian Schweikert (kelvan) wrote :

I had similar problems, at the moment it seems to work.
BUT, when I change Output from Speaker to HDMI or otherwise, sound controls jump to zero. If I enhance volume it immediately jumps back to zero -> unusable.

Hmm... I've made some observations on the volume-control's behaviour by watching alsamixer:
At mute (0% system volume), Master is 0%, PCM is 0%, and Surround is 0%.
System volume goes above 0%, PCM goes straight to 75% and than the Surround Slider.
System volume goes above 10%, Surround is at 100% and than the Master slider starts increasing.
System volume goes above 60%, Master is at 100% and than the PCM slider starts increasing.

Now, I have couple issues with this:
Why does PCM go straight to 75%, shouldn't it ease up there slowly right after mute?
Why is only the Surround slider moving between 0-10%. It doesn't have any affect on normal volume control. In fact, I think it's only used when the digital 5.1 audio is being used, which is not a normal use case.

Both PCM and surround should be going up gradually throughtout the entire volume control process, not just jumping around illogically and annoyingly.

Okay, I've determined that the Surround slider controls the volume of the rear speaker port, while Master only control the front. It seems that Surround should move identical to Master, but instead, it's moving to highest volume at only 10%. Just wrong.

Andres Mujica (andres.mujica) wrote :

I'm having the same issue.

In fact, i blew out the right speaker of my laptop thanks to the multiple volume controls available and the oddly behaviour explained below.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
phenest (steve-clark) wrote :

Karmic alpha 4
I'm finding the same as Taylor. I have a Dell Precision M90 laptop with an LFE channel (sub-woofer). Watching alsamixer, I see that PCM goes up first, followed by LFE, followed by Master. I won't allow anything else. Using the volume hotkeys gives the same results. This means my sub-woofer is at full volume before the main speakers start to do anything.

A fresh install of Karmic alpha 3 shows all the channels working independently in alsamixer. So there has been an update since then that has broken it.

Andrea Caminiti (nrayever) wrote :

Hi guys:

i'm having issues with pulseaudio too. I own a laptop Dell 9400 inspiron. It has a sub-woofer and it is controlled by LFE, master is the front speakers and pcm was typically the real control, so i only had to adjust one volume bar. With this new approach in 9.10 alpha 4 everything is a big mess!

it's kind of cool, because know each application has independent volume control. but it is harder to choose the volume control from the sound card. i believe this is a bug, or maybe a misconception of how pulseaudio should be integrated. there is no way the user can choose which volume bar has the control. Hope that this solved pretty soon.

Is there any way i can provide you more information, just let me know.

Regards Andrea.

PS. I installed karmic 9.10 fresh new, i wiped out my hd to install it.

neuromancer (neuromancer) wrote :

I've installed yesterday karmic koala alpha 4 in my inspiron 9400 (same as #7) and the audio isn't working correctly.
The behaviour is the same of #6.
The volume is too high. If I try to reduce it silence...

In pulseaudio volume controller the harware device is setted to analog stereo output (digital stereo duplex doesn't reproduce any sound).
If I launch from shell the alsamixer, i see that my sigmatel has a PCM, Master and LFE and that PCM is setted to 100%, LFE also and Master is about 15%. If I try to reduce one of this volume I see that they are related in the same order of phenest (first PCM, then LFE and only when they are at 100% the Master start to increase but obviously the volume is now too high and disturbed).

Timo Saloranta (timo-saloranta) wrote :

I can also confirm #6 on my Compaq 6715s laptop.

Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium
Albert Einstein (spideryzarc) wrote :

I have the same problem, dell inspiron 9400 with LFE channel

Card: HDA Intel │
Chip: SigmaTel STAC9200

Similar problem - my audio doesn't start playing until 30% (in any sound app) and 50% in Flash under Firefox. From there it scales to 100%, but over a smaller interval so it's very hard to finely control it, not to mention being frustrating to play at low levels.

Daniel Lee (longinus00) wrote :

I have a laptop with only stereo out and the the pcm volume jumps straight to 74% right away. The master catches up when the volume slider is only at around 20% so 74% of max volume is compressed into only 20% of the volume slider.

neuromancer (neuromancer) wrote :

Just a link http://ubuntuforums.org/showthread.php?t=1234894&page=2 with analogue discussion in the Ubuntu Forum and a little workaround meanwhile we expecting fix.

I should mention that in my case (Dell Inspiron 9400 with Intel 82801G (Ich7) HDA (rev 01)) the volume (especially of LFE) can be controlled seperatly again so I can set the same values to master, pcm and lfe manually. That's better than nothing.

But if I try to control the volume via laptop-keys or gnome-volume-control, the problem still exists.

Using ubuntu karmic.

Sorry for being unclear: I should have written: The seperate control is possible via alsamixer (in my case).

Okay, the latest pulseaudio in the ubunu-audio-dev ppa works a little better, but I had to change the gconf app/gnome_settings_daemon/volume step to 1 to have decent control over volume, as the highest I'd want my headphones with this volume scheme is about 30%.

The only remaining issue is that it still maxes surround early on, when it should follow the same movement master does with my soundcard.

Also, pulseaudio output is actually broken at the moment because it causes nothing but static, but alsa output still works fine and volume control affects alsa output as well. But this bug is unrelated to this one and I've filed it at https://bugs.edge.launchpad.net/ubuntu/+source/pulseaudio/+bug/432506

phenest (steve-clark) wrote :

I have a "fix" based on someone else's idea:
Open /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf and change the LFE and Master sections so 'volume = ignore'. Then open alsamixer in a terminal, and set Master and LFE to 100%. You should now find that the volume hotkeys now control just PCM.

Pedro Villavicencio (pedro) wrote :

Luke, may you have a look into the report? Thanks in advance.

Changed in pulseaudio (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
Captain Nemo (danslenautilus) wrote :

The fix proposed by phenest is OK for me ! (Dell Inspiron 9400)

jomtois (jomtois) wrote :

The fix by phenest also works for me (Dell Inspiron E1705), however, I must re-do it every time I reboot the computer. The speakers blast loud as possible when logging into Gnome. The headphone jack seems to work properly.

doclist (dclist) wrote :

The default volume sounds loud enough to damage my speakers and my hearing.

00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)

Jason Houston (jason-houston) wrote :

I also have a Dell E1705, and a similar problem...my LFE volume is maxed on boot up. After login, I can reduce the LFE volume with ALSA mixer but it returns to max on reboot.

softzilla (softzilla) wrote :

Confirm problem with Dell Inspiron 9400 & HDA Intel.

phenest (steve-clark) wrote :

Here ya go!

jomtois (jomtois) wrote :
Qualidafial (matthall) wrote :

Confirmed a huge jump in volume at about 25% when using the hardware volume buttons.

neuromancer (neuromancer) wrote :

Another one verbose log.
Inspiron 9400.

Soundblaster Live! 5.1
The log probably shows me switching from a custom sink I made that swaps my front and rear.

Note: I don't get the overdriven sound when I swap my front and rear, in fact, it seems that pulseaudio isn't using alsa mixers to change volume when I do that... kinda strange.

phenest (steve-clark) wrote :

I'm not sure what the purpose of these logs are. I mean, everyone knows what the problem is: the alsa mixer tracks are increasing asynchronously instead of the previous approach which was to select what tracks you want the volume to control, thus having a selection of tracks moving synchronously (or one track only). This is a bug as the current method has undesirable effects. Put simply (and I'm sure all here will agree), can we have the old method as found in Jaunty so the user can decide?

Daniel T Chen (crimsun) wrote :

The previous approach is non-intuitive for many people. Please google
for flat volume and see how other operating systems approach the
issue.

Also, you're incorrect that having overdriven audio is a PulseAudio
problem. It's both a hardware bug (broken hardware!) and a linux bug
(not exposing correct dB information!). It needs to be fixed
everywhere, but hardware is much hardware to fix after-the-fact...

phenest (steve-clark) wrote :

If the change was to make it more intuitive, might I suggest to keep this as default but include a switch so users can use the old method if they want.

realmrealm (realmrealm) wrote :

Also have E1705 (9400)

Sound just about woke the house the first time I booted up into 9.10

I also noticed that volume all the way down = no sound at all

Volume at 1 tick up = full blast

-AndyS-

I have the same problem as realmrealm, but only with headphones in. I have an "82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller" (according to lshw). I'll try to get a log for you in the next few days.

mac.ryan (macryan) wrote :

Verbose log, as per request.

Hades_6_6_6 (mguillemenet) wrote :

same here on fresh 9.10 install on Dell Inspiron 1501.

Zeratul2k (zeratul2k) wrote :

Having the same problem here. Mine is a Gateway MT3707 updated to Karmic from Jaunty. Also, after replacing "merge" with "ignore" in analog-output.conf there's a nasty clicking sound instead of the expected sound in the first two steps. For example, starting as muted I begin playing an MP3, then step up the sound once and I hear some clicking. Step up again and the clicking gets worse. Step up again and the clicking disappears and the music finally starts coming through. Had to undo changes to analog-output.conf because of that.

Daniel T Chen (crimsun) wrote :

@Zeratul2k There are two additional ways. You can:

* Pass ignore_dB=1 to module-udev-detect in /etc/pulse/default.pa (or
~/.pulse/default.pa)
* Pass control=foo, where foo is the amixer element name, to
module-alsa-sink in /etc/pulse/default.pa (or ~/.pulse/default.pa)

Zeratul2k (zeratul2k) wrote :

Passing ignore_dB=1 to module-udev-detect worked wonders. Thanks Daniel!

mac.ryan (macryan) wrote :

@Zeratul maybe you are the missing link between this bug and this other one?
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/301755

Also, reviewing the other open bugs for pulseaudio, I would candidate this to be prioritised as "high" and not "medium". It actually makes sound totally unusable... who decide about priorities indeed!?

Daniel T Chen (crimsun) wrote :

@mac.ryan Please note that if there is an easily applicable
workaround, the Importance of a bug tends *not* to be any more
critical than High. Also, with this specific symptom, the bug is in
*linux* not pulseaudio.

mac.ryan (macryan) wrote :

@Daniel T Chen - Will try the latest suggestions posted in the thread tomorrow, but so far the "easily applicable workaround" did not work out for me. However my comment was not coming out of frustration (for the moment I am happy sticking with headphones) but out of love for ubuntu! :)

As an ubuntu enthusiast and evangelist - indeed - I still think that a bug that makes sound unusable with standard hardware installed on mainstream computers (Dell is #1 computer vendor in the world) would call for immediate action and a priority of *at least* "high". This is totally a show-stopper for somebody new to ubuntu, inviting somebody to try out ubuntu under these conditions would be like inviting him to learn to skydive promising that the parachute will be delivered to him (probably) sometimes mid-air...

Honestly: we are not speaking of the flickering of a toolbar icon in an application for fractal computation in reverse polish notation under an obscure legacy graphic toolkit ported from solaris. We are speaking of the possibility to watch a video on youtube or BBC, listen to a CD, watch a movie, etc... :(

wolfie2x (wolfie2x) wrote :

Same here on fresh 9.10 install on Dell Inspiron 9400. (I assume attaching another verbose log wouldn't make a difference)

I love Ubuntu and honestly hope something more than the typical finger pointing ("the bug is in *linux* not pulseaudio") will be done *soon*. How many average users would be capable of googling the problem, finding this bug report, reading through 40+ posts and pick the workaround, and actually do terminal stuff to apply the "easily applicable workaround"!?

Daniel T Chen (crimsun) wrote :

@wolfie2x I agree that it's a problem that needs to be fixed [in
linux]. For what it's worth, I have blogged about it[0] and linked to
it in ubuntuforums[1]. I expect that some people will be quite
frustrated and give up, and obviously that's why it needs to be fixed
[in linux].

Patches are welcome. I am not employed to work on Ubuntu, so every
minute where someone's contributions can be merged is a win for
everyone.

[0] http://drowninginbugs.blogspot.com/2009/10/caveats-for-audio-in-910.html
[1] http://ubuntuforums.org/showthread.php?t=1307019

phenest (steve-clark) wrote :

@Daniel: When you say "linux" do you mean the kernel? I was under the impression that this change was due to the old method being non-intuitive. That kinda made me think it was an Ubuntu issue.

Daniel T Chen (crimsun) wrote :

@phenest linux is the name of the source package, so yes, it refers to
the kernel.

Artsaypunk (artsaypunk) wrote :

Maybe this is common knowledge, but maybe it'll help someone out.

I have a Dell Inspiron 9300, and for me to get the "merge-ignore" fix to work, I had to modify the "analog-output-lfe-on-mono.conf" file instead of the ones mentioned here. So if you have a "multimedia" laptop that uses the "Master-Mono" channel for the subwoofer, give it a try.

Clownfishy (clownfishy) wrote :

Same problem as above with DELL Precision M90. My sound is unusable and have muted it so not to blow the speakers up!

Daniel T Chen (crimsun) wrote :

@Take Life Easy
Try passing ignore_dB=1 to module-udev-detect in /etc/pulse/default.pa
(or ~/.pulse/default.pa).

Clownfishy (clownfishy) wrote :

@Daniel T Chen,

Within Sound Preferences, I have now set the master output volume as low as it will go and then adjusted each applications volume down to an acceptable level so I now have sounds again.

Many thanks for your help though.

Daniel T Chen:
I'd like to try your tip, but I'm not sure what it means to "pass ignore_dB=1 to module-udev-detect in /etc/pulse/default.pa". Can you give more detailed instructions for a beginner?

Daniel T Chen (crimsun) wrote :

@Matthew Pirocchi
Open /etc/pulse/default.pa with an editor. Keep in mind that it
requires root privileges to be modified. On line 54, change:

load-module module-udev-detect

to:

load-module module-udev-detect ignore_dB=1

Save the file, and in a Terminal, use:

killall pulseaudio

PA will respawn automatically.

Thanks Daniel, that fixed my audio.

Martin Hollis (mhollis22) wrote :

Daniel, that fix worked for me as well. Is there a way to make the volume keys change PCM as opposed to master? I know this is the old behavior, but it's very useful for keeping the sound levels the same for my laptop between my laptop speakers, headphones, and external speakers. Thank you.

mac.ryan (macryan) wrote :

@Daniel T Chen - I can confirm that the fix you proposed does *not* work for DELL XPS M1710. If it might be useful, I have already uploaded the verbose log in this same thread.

RIco (rico-rootscore) wrote :

@mac.ryan
I have a DELL XPS M1710 as well. I didn't try Daniel T Chen fix, but #17 (master and LFE to ignore, then set set them to 100% in alsamixer , then volume will be controled through PCE) solved part of the problem, i can now controll the volume with the front keys and it's not blowing the speakers on startup. At ~15% though it still goes to 0 with some weird noises.

Daniel T Chen (crimsun) wrote :

@mac.ryan
First of all, ignore_dB=1 *isn't* a fix. This is hardware issue that
can be worked around in linux or pulseaudio, but the proper place to
do it is in linux -- the sound driver.

Second, ignore_dB=1 is a rather poor universal workaround. This is the
problem with bug reports: people see a comment and assume it applies
to everyone's hardware. Wrong. In your specific case, you want to use
the control parameter, which is passed to module-alsa-sink and
module-alsa-source in /etc/pulse/default.pa (or ~/.pulse/default.pa),
e.g.,

load-module module-alsa-sink control=PCM

At that point, PA only controls your PCM mixer control and ignores the
others. That's very different from ignore_dB=1, which simply tells PA
to ignore what linux tells it for the hardware volume range but
continues to adjust all the mixer controls.

While passing ignore_dB=1 makes my volume level reasonable, it is no longer possible to adjust it (from my laptop keys or the volume applet). Is there any workaround for this?

Daniel T Chen (crimsun) wrote :

@Matthew See what I wrote to mac.ryan above.

On Nov 9, 2009 4:06 PM, "Matthew Pirocchi" <email address hidden>
wrote:

While passing ignore_dB=1 makes my volume level reasonable, it is no
longer possible to adjust it (from my laptop keys or the volume applet).
Is there any workaround for this?

-- Volume too loud https://bugs.launchpad.net/bugs/410948 You received this
bug notification becau...

Status in “pulseaudio” package in Ubuntu: Confirmed Bug description:

Binary package hint: pulseaudio The latest pulseaudio_0.9.16~test4-0ubuntu4
in karmic is ramping th...

mac.ryan (macryan) wrote :

@Rico , @Daniel

Thanks for the advices guys. Seems that #17 fixed for me! :)
[Happy man]

Fred W. Schwinn (fred-schwinn) wrote :

I have the same problem on a Dell Precision M90. Volume is either mute or full blast. Very little in between. I appreciate all your efforts in finding a swift fix for this show-stopper.

eof (eric-odier-fink) wrote :

Have the same problem. Dell Inspiron 710m. #17 workaround helps (thank you phenest), but I think the new system is a bad idea.

Jonathon James (isamaranga) wrote :

For me this bug (I assume it is the same) affects headphones only. I have a Dell Inspiron 700m, ubuntu 9.10 x386. I tried both workarounds and neither works.

Pavol Klačanský (pavolzetor) wrote :

I have that card

description: Audio device
product: 82801H (ICH8 Family) HD Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=HDA Intel latency=0
resources: irq:22 memory:fc400000-fc403fff

and volume is too loud in Karmic

I've fixed it by that
sudo gedit /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common

change

[Element PCM]
switch = mute
volume = merge

to

volume = ignore

than set pcm in alsamixer to cca. 50%

Daniel T Chen (crimsun) wrote :

On Tue, Dec 22, 2009 at 1:38 PM, pavolzetor wrote:
> description: Audio device
> product: 82801H (ICH8 Family) HD Audio Controller

Unfortunately that doesn't contain any necessary information to fix
the bug. Please file a new bug using "ubuntu-bug alsa-base".

Pavol Klačanský (pavolzetor) wrote :

I have reported it, Bug #502151

krisman18 (kris-55) wrote :

same as @neuromancer wrote on 2009-08-21: #8

Daniel T Chen (crimsun) wrote :

You should add volume=ignore stanzas for the appropriate mixer elements.

Changed in pulseaudio (Ubuntu):
status: Confirmed → Won't Fix
phenest (steve-clark) wrote :

@Daniel - Status is "Won't Fix". I guess by that you mean you can't fix it. Should we take this up with the PulseAudio devs directly?

Derek (bugs-m8y) wrote :

Having same issue w/ master volume that seems to only have values for mute and ear blasting.

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
Chip: SigmaTel STAC9227

Tried the replacing merge with ignore trick in alsa conf, didn't seem to help (well, maybe there was a slight variation in volume, could be my imagination).

ignore_dB=1 in pa didn't help either.

attempting control=PCM had interesting effect - it seemed volume adjusted more correctly, but it kind of skipped and stuttered as I adjusted it, and the application I was using (mplayer) hung completely for a while, then skipped a bit, so I removed it.

FWIW, playing around in alsamixer, seems that, at least when using PA, master does nothing. PCM or "Speaker 3" do seem to control volume correctly.

Daniel T Chen (crimsun) wrote :

Derek, please file a separate bug against alsa-driver for your hw using
ubuntu-bug.

On May 8, 2010 6:26 PM, "Derek" <email address hidden> wrote:

Having same issue w/ master volume that seems to only have values for
mute and ear blasting.

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio
Controller (rev 02)
Chip: SigmaTel STAC9227

Tried the replacing merge with ignore trick in alsa conf, didn't seem to
help (well, maybe there was a slight variation in volume, could be my
imagination).

ignore_dB=1 in pa didn't help either.

attempting control=PCM had interesting effect - it seemed volume
adjusted more correctly, but it kind of skipped and stuttered as I
adjusted it, and the application I was using (mplayer) hung completely
for a while, then skipped a bit, so I removed it.

FWIW, playing around in alsamixer, seems that, at least when using PA,
master does nothing. PCM or "Speaker 3" do seem to control volume correctly.

--
Volume too loud
https://bugs.launchpad.net/bugs/410948
You received this bug notification becau...

Status in “pulseaudio” package in Ubuntu: Won't Fix

Bug description:

Binary package hint: pulseaudio

The latest pulseaudio_0.9.16~test4-0ubuntu4 in karmic is ramping th...

Derek (bugs-m8y) wrote :

Wow. Nothing like getting my ears blasted by ubuntu-bug after picking the least-worst of the radio buttons that was lacking an "other category". Guided support fail...
Oh well. Going ahead with that.

Stefan Goldmann (ingo-knietow) wrote :

Hi there.

I wonder why no more comments have been posted for over two weeks now. As far as I am concerned, the problem is still in place, and none of the workarounds proposed above (using a pure PCM-control; passing ignore_dB=yes to the module(s)) have worked out for me.

Anyway, I found another workaround which up to now works good for me. A more comprehensive description can be found here (http://ubuntuforums.org/showpost.php?p=9363330&postcount=30). In summary:
1. Edit /etc/pulse/default.pa
2. In there, uncomment any autodetection modules (modules module-udev-detect, module-hal-detect, module-detect)
3. Add a line "load-module module-alsa-sink device=surround40:0". Replace "surround40:0" with whatever matches your configuration.
4. Open alsamixer and adjust the hardware controls to match the maximum output volume desired by you.
5. Restart pulseaudio via running "killall pulseaudio" within a terminal.

==> PulseAudio now does the volume control in software now, in a way the user would expect, and leaves the hardware controls alone, i.e., as you adjusted them.

I hope this does help some of you. I would be glad to get some feedback.

Best wishes,
-- Stefan

Stefan Goldmann (ingo-knietow) wrote :

NOTE: In the post above, substitute "uncomment" by "outcomment" (step 2).

Sorry,
-- Stefan

BTW: Please nobody get me wrong. PA's idea of simplifying controls is absolutely right. As soon as the original issue is fixed, I recommend to immediately switch back to PA controlling the hardware volume.

Lee Braiden (lee-braiden) wrote :

Also affecting me.

I don't know if others are seeing slightly different symptoms, or have misinterpreted. For me, the problem is simply:

* surround and LFE seem to be equivalent, at least in that they both adjust up the sub-woofer volume.
* the LFE and Surround volume levels are maximised by default
* If I set these to lower levels in alsamixer, then everything sounds great. However, adjusting the volume control in gnome's panel immediately ramps these right up to 100% again, as if someone made the assumption that you'd always want pumping basslines, even if you turn the overall volume down.

Setting a sane surround and LFE volume by default, saving volume levels across reboots, and setting surround and LFE to volume = ignore in the aforementioned config file is all I really need to fix this. Slightly better would be for the gnome volume to move LFE and surround proportionally to the main volume. Ideal would be for ALSA to present these levels relative to the main volume, rather than as absolute values.

Also, some have suggested that gnome's volume control should adjust the PCM volume. I think that would be broken. My expectation of the gnome volume control, when only one slider is presented, is that it adjusts the master volume, and (although it fails in this), there would be an "advanced" option where individual sliders/toggles/etc. could be accessed.

Note that I'm running an Asus P7P55D-E LX mobo, with a Logitech 5.1 surround speaker system, though I haven't bothered connecting the surround speakers.

Lee Braiden (lee-braiden) wrote :

I just realised that Daniel T. Chen tagged this Won't fix?! Frankly, that's INSANE. Just because there's a way to fix it manually, it does not mean that ubuntu should not work to fix it by default. The current behavior is ILLOGICAL, UNEXPECTED, INTERFERING, and ANNOYING.

This is the most annoying bug in ubuntu for me right now, which means I have to go back to text-based alsamixer just to watch videos with reasonable volume levels. I have to LEAVE it open, too, because the stupid default GUI controls reset everything against my explicit settings.

This is a BIG usability problem, which many people above are also experiencing. If I demo'd Ubuntu to a new potential user, thsi would probably be the kind of flaw that would make them think Ubuntu was too buggy to use. Please take it seriously and get it sorted out. Frankly it's embarrassing that Ubuntu hasn't already released an update to fix this.

Daniel T Chen (crimsun) wrote :

@Lee That's because we shouldn't work around it in PulseAudio. It
needs to be fixed at the driver level. Have you filed a separate bug
report against alsa-driver? (`ubuntu-bug alsa-base`)

xvegan88x (yatc1-me-ngeef) wrote :

It's 2011 and still audio under linux is a mess :(

Farran (farran) wrote :

I can't contribute anything to this in the way of help, but I also have this issue with my headphones - I can provide any hardware and bug information you need to sort this out.
I've just upgraded to Oneiric on my mum's computer, and now we're having this volume problem with the headphones (possibly with the main speaker output as well, although I can't test this right now), rendering her headphones totally unusable.

As with several other people who have commented on here, I can get perfect volume with the alsamixer control, but when I change the volume with the volume keys (or through the pulseaudio mixer), the volume levels go all over the place. In fact, watching them change in alsamixer is really weird - none of the changes seem to make sense.

If an actual fix is found (even if only for my soundcard 'ICH7 82801G'), could someone please post it to http://askubuntu.com/questions/65565/headphone-output-is-far-too-loud as well?

To post a comment you must log in.