Ubuntu

Crackling noise after update to pulseaudio

Reported by Ulrik Mikaelsson on 2008-11-24
260
This bug affects 42 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: pulseaudio

After upgrading to Jaunty, when listening to audio through Pulseaudio, I get a crackling sound, that seems to be bound to system load. Not necessarily CPU load, the CPU load is well below 50% at all times, but I.E. harddisk access seems to provoke the crackling extra.

When disabling Pulseaudio, running directly towards ALSA, the crackling disappear.

My soundcard according to lspci: nVidia Corporation CK804 AC'97 Audio Controller (rev a2). (Motherboard built-in)

Matteo Settenvini (tchernobog) wrote :

Confirming also for my pretty standard Intel AC'97 integrated sound card.
Some applications heavily affected:
* wesnoth
* scummvm
* dosbox
* firefox (e.g. on youtube.com) using swfdec
* pretty much anything using SDL or ALSA directly.

Daniel T Chen (crimsun) wrote :

Adjust default-fragments and default-fragment-size-msec in /etc/pulse/daemon.conf.

Changed in pulseaudio:
importance: Undecided → Low
status: New → Confirmed
Tom Jaeger (thjaeger) wrote :

Adjusting default-fragments and default-fragment-size-msec doesn't seem to have any effect for me.

David Henningsson (diwic) wrote :

Jaunty has a new version of PulseAudio. The below is taken from "https://fedoraproject.org/wiki/Features/GlitchFreeAudio", perhaps you can report back if this helped you or not.

The PulseAudio sound server has been rewritten to use timer-based audio scheduling instead of the traditional interrupt-driven approach. Timer-based scheduling may expose issues in some Alsa drivers. To turn timer-based scheduling off, replace the line

load-module module-hal-detect

in /etc/pulse/default.pa by

load-module module-hal-detect tsched=0

Matteo Settenvini (tchernobog) wrote :

Thanks, I already tried that (tsched=0). But unfortunately, it doesn't make any difference.

sq2cet (sq2cet) wrote :

Confirmed. I have the same symptoms. tsched=0 working form me. Sound card HDA Intel (Alsa mixer) in Asus EEE 900.

Anton Kraus (done) wrote :

I also suffer from this bug.
The tsched=0 workaround doesn't change anything.

This bug appeared on both of my PCs after upgrading to Jaunty. Intrepid's Pulseaudio was fine.

Brad Davis (champamp) wrote :

Worked for me....NVIDIA Nforce2 ALC650F

Daniel T Chen (crimsun) on 2009-02-14
Changed in pulseaudio:
status: Confirmed → Fix Committed
Brad Davis (champamp) wrote :

So what does "fix committed" mean? I can remove the tsched=0 argument after receiving this update? Is the update eminent?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.14-0ubuntu6

---------------
pulseaudio (0.9.14-0ubuntu6) jaunty; urgency=low

  * 0004_disable_autospawn.patch: Disable this patch. Doing so
    allows the daemon to spawn if not already running, which
    works around LP: #191027, #204272
  * 0012_clarify_driver_error_redirect_to_alsa_devs.patch:
    - Only log POLL* being set if tsched is used so that syslog
      isn't filled with innocuous messages when we set tsched=0
      (see 0030 below) (LP: #323712),
    - Hint 'linux' source package instead of 'alsa-driver' for
      Launchpad bug reports,
    - The debug-specific portion is only applicable to 0.9.14;
      0.9.15 enables a rate limiting module by default to work
      around this (and other) issues
  * 0029_fix_suspend_on_idle_null_race.patch: Handle sink case,
    too
  * 0030_set_tsched0.patch: Work around a shedload of (driver)
    bugs by falling back to interrupt-based buffer semantics
    (LP: #190754, #292880, #295519, #298494, #301755, #302964,
     LP: #319118, #323976, #324103, #326205, #326864)
  * Backport fixes from git HEAD:
    - 0031_fix_6chan_map.patch,
    - 0032_reinit_proplist.patch,
    - 0033_fix_pa-gcc-packedmalloc.patch,
    - 0034_bt_fixes.patch
  * Make invoking the stop target in the initscript not fail an
    upgrade (LP: #317921)
  * Previous upload (0.9.14-0ubuntu3) fixed LP: #321357
  * 01PulseAudio: use sudo -H to ensure that $HOME is, in fact,
    the user's when invoking pacmd for suspend/resume

 -- Daniel T Chen <email address hidden> Sun, 15 Feb 2009 02:35:26 -0500

Changed in pulseaudio:
status: Fix Committed → Fix Released

Removing the tsched=0 results in the return of crackling....so the fix just
addressed the logging issue when tsched=0 was enabled.

On Sun, Feb 15, 2009 at 4:35 PM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package pulseaudio - 0.9.14-0ubuntu6
>
> ---------------
> pulseaudio (0.9.14-0ubuntu6) jaunty; urgency=low
>
> * 0004_disable_autospawn.patch: Disable this patch. Doing so
> allows the daemon to spawn if not already running, which
> works around LP: #191027, #204272
> * 0012_clarify_driver_error_redirect_to_alsa_devs.patch:
> - Only log POLL* being set if tsched is used so that syslog
> isn't filled with innocuous messages when we set tsched=0
> (see 0030 below) (LP: #323712),
> - Hint 'linux' source package instead of 'alsa-driver' for
> Launchpad bug reports,
> - The debug-specific portion is only applicable to 0.9.14;
> 0.9.15 enables a rate limiting module by default to work
> around this (and other) issues
> * 0029_fix_suspend_on_idle_null_race.patch: Handle sink case,
> too
> * 0030_set_tsched0.patch: Work around a shedload of (driver)
> bugs by falling back to interrupt-based buffer semantics
> (LP: #190754, #292880, #295519, #298494, #301755, #302964,
> LP: #319118, #323976, #324103, #326205, #326864)
> * Backport fixes from git HEAD:
> - 0031_fix_6chan_map.patch,
> - 0032_reinit_proplist.patch,
> - 0033_fix_pa-gcc-packedmalloc.patch,
> - 0034_bt_fixes.patch
> * Make invoking the stop target in the initscript not fail an
> upgrade (LP: #317921)
> * Previous upload (0.9.14-0ubuntu3) fixed LP: #321357
> * 01PulseAudio: use sudo -H to ensure that $HOME is, in fact,
> the user's when invoking pacmd for suspend/resume
>
> -- Daniel T Chen <email address hidden> Sun, 15 Feb 2009 02:35:26 -0500
>
> ** Changed in: pulseaudio (Ubuntu)
> Status: Fix Committed => Fix Released
>
> --
> Crackling noise after update to pulseaudio
> https://bugs.launchpad.net/bugs/301755
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
-Brad

This update fixed it for me. Thanks!

Paul O'Keefe (pbokeefe) wrote :

Cross posting from 335955:

Still seeing buzz/static click using pulseaudio (0.9.14-0ubuntu11). Mostly for me with web streaming media. System sounds always clear, along with Rhythmbox, but can hear static sound right now at idle with no media playing just by moving the mouse around.

Device:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

On current update of Jaunty.

Download full text (12.6 KiB)

I am still having problems even after the update. My lspci -vvnn is
00:00.0 RAM memory [0500]: nVidia Corporation MCP78S [GeForce 8200] Memory Controller [10de:0754] (rev a2)
 Subsystem: Hewlett-Packard Company Device [103c:360a]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Capabilities: <access denied>

00:01.0 ISA bridge [0601]: nVidia Corporation Device [10de:075e] (rev a2)
 Subsystem: Hewlett-Packard Company Device [103c:360a]
 Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Region 0: I/O ports at 1a00 [size=256]

00:01.1 SMBus [0c05]: nVidia Corporation MCP78S [GeForce 8200] SMBus [10de:0752] (rev a1)
 Subsystem: Hewlett-Packard Company Device [103c:360a]
 Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Interrupt: pin A routed to IRQ 10
 Region 0: I/O ports at 3080 [size=64]
 Region 4: I/O ports at 3040 [size=64]
 Region 5: I/O ports at 3000 [size=64]
 Capabilities: <access denied>

00:01.3 Co-processor [0b40]: nVidia Corporation MCP78S [GeForce 8200] Co-Processor [10de:0753] (rev a2)
 Subsystem: Hewlett-Packard Company Device [103c:360a]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0 (750ns min, 250ns max)
 Interrupt: pin B routed to IRQ 11
 Region 0: Memory at c0080000 (32-bit, non-prefetchable) [size=512K]

00:01.4 RAM memory [0500]: nVidia Corporation MCP78S [GeForce 8200] Memory Controller [10de:0568] (rev a1)
 Subsystem: Hewlett-Packard Company Device [103c:360a]
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

00:02.0 USB Controller [0c03]: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller [10de:077b] (rev a1) (prog-if 10)
 Subsystem: Hewlett-Packard Company Device [103c:360a]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0 (750ns min, 250ns max)
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at c0006000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: <access denied>
 Kernel driver in use: ohci_hcd
 Kernel modules: ohci-hcd

00:02.1 USB Controller [0c03]: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller [10de:077c] (rev a1) (prog-if 20)
 Subsystem: Hewlett-Packard Company Device [103c:360a]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UD...

Eugene (kukachik) wrote :

when i try to watch a movie, i get

 PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 9716 eugene 20 0 214m 5240 3724 S 90 0.3 0:02.76 pulseaudio
 9703 eugene 20 0 345m 27m 15m S 6 1.4 0:00.33 mplayer
in syslog

Mar 21 12:50:09 eugene-desktop pulseaudio[9647]: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
Mar 21 12:50:09 eugene-desktop pulseaudio[9647]: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
Mar 21 12:50:09 eugene-desktop pulseaudio[9647]: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Mar 21 12:50:19 eugene-desktop pulseaudio[9650]: cpulimit.c: Received request to terminate due to CPU overload.

eugene@eugene-desktop:~$ sudo lspci
00:00.0 RAM memory: nVidia Corporation MCP65 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation MCP65 LPC Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation MCP65 SMBus (rev a1)
00:01.2 RAM memory: nVidia Corporation MCP65 Memory Controller (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP65 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP65 USB Controller (rev a3)
00:06.0 Ethernet controller: nVidia Corporation MCP65 Ethernet (rev a3)
00:07.0 Audio device: nVidia Corporation MCP65 High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP65 PCI bridge (rev a1)
00:09.0 IDE interface: nVidia Corporation MCP65 IDE (rev a1)
00:0a.0 SATA controller: nVidia Corporation MCP65 AHCI Controller (rev a3)
00:0d.0 PCI bridge: nVidia Corporation MCP65 PCI Express bridge (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
02:00.0 VGA compatible controller: nVidia Corporation GeForce 9800 GT (rev a2)

eugene@eugene-desktop:~$ uname -a
Linux eugene-desktop 2.6.28-10-generic #33-Ubuntu SMP Mon Mar 16 23:49:27 UTC 2009 x86_64 GNU/Linux

last update - 21/03

when i change audio output to alsa in mplayer all works fine to me

Audio still crackly. When it happens the only way to fix it is to kill pulseaudio in system monitor and then starting pulseaudio back up. All updates installed.

Daniel T Chen (crimsun) wrote :

On Sat, 21 Mar 2009, shane fagan wrote:

> Audio still crackly. When it happens the only way to fix it is to kill
> pulseaudio in system monitor and then starting pulseaudio back up. All
> updates installed.

Try the appropriate kernel at http://kernel.ubuntu.com/~dtchen/ .

Ill give it a go and give back my results.

Problem solved thanks Daniel T Chen.

Paul O'Keefe (pbokeefe) wrote :

On Sat, 2009-03-21 at 17:45 +0000, Daniel T Chen wrote:
> On Sat, 21 Mar 2009, shane fagan wrote:
>
> > Audio still crackly. When it happens the only way to fix it is to kill
> > pulseaudio in system monitor and then starting pulseaudio back up. All
> > updates installed.
>
> Try the appropriate kernel at http://kernel.ubuntu.com/~dtchen/ .
>

Daniel: Reduced crackle with your updated kernel, but still there.

Clear when playing any media through:

 Preferences --> Sound
 Rhythmbox
 Firefox --> MP3
 Firefox --> WAV
 Firefox --> RealPlayer File
 Firefox --> Quicktime
 Firefox --> Flash

However, it appears that after I load any Flash media that I then get
static on just idle mouse movements. Not able to consistently reproduce
and the kernel change has reduced the crackle a lot.

But not clear when playing

Ara Pulido (apulido) wrote :

I am still affected by this bug (Jaunty updated March 31st)

00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)
 Subsystem: Lenovo ThinkPad T61 [17aa:20ac]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin B routed to IRQ 17
 Region 0: Memory at fe220000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Changed in pulseaudio:
assignee: nobody → ubuntu-foundations
importance: Low → High
Ara Pulido (apulido) wrote :

Find my alsa_info.sh output attached.

Ara Pulido (apulido) wrote :

Raising 'Master' and lowering 'PCM' didn't help. I still get the noises.

Robbie Williamson (robbiew) wrote :

Moving back to "In Progress" as the released fix doesn't apparently FIX the issue for everyone.

Changed in pulseaudio:
status: Fix Released → In Progress
Changed in pulseaudio (Ubuntu):
assignee: ubuntu-foundations → themuso
Luke Yelavich (themuso) wrote :

Could you please attach /etc/pulse/default.pa so I can determine whether you are using glitch free or not?

Thanks.

Ara Pulido (apulido) wrote :

Please, find a attached all the PA configuration files.

Ara Pulido (apulido) wrote :

Hello,

Today I tested with the latest kernel that Daniel provided and I still get the crackling noise.

I was listening to MP3 audio with rhythmbox. When pidgin generated an event (a buddy logged in), I got the noise :-(

ara@sushirider:~$ uname -a
Linux sushirider 2.6.28-12-generic #42~crimsun1lp345627 SMP Sat Apr 11 06:42:19 UTC 2009 i686 GNU/Linux

Hi,
I'm experiencing crackling sound too, in fact I hear only crackling, no sound or music.
This is the output of alsa_info.sh: http://www.alsa-project.org/db/?f=486580c016bbb473d5945f92354d6e85cd85daff
Attached also there's my /etc/pulse/default.pa.

Thanks.

Oh, forgot to say: I'm using crimsun's kernel packages.

Iriiko (aderach) wrote :

Hi!

I had this problem BUT i found a solution:

File "default.pa" (in ~/.pulse usually), add "tsched=0" to the modules
module-alsa-sink and module-hal-detect (at least, to module-hal-detect):

#here: The sink is used for me, for the module module-ladspa-sink, to equalized the sound)
load-module module-alsa-sink device=hw:0,0 sink_name=alsa_out tsched=0
load-module module-ladspa-sink sink_name=ladspa_out master=alsa_out plugin=mbeq_1197 label=mbeq control=-15,-15,-10,-1,-5,-1,-1,0,0,0,0,0,0,0,0
...
load-module module-hal-detect tsched=0
...

AND, if you got problem like pulseaudio crash when changing the musique in Amarok for example, I think I found the solution:
File "demon.conf" (in ~/.pulse usually), I uncomment and increase default-fragment-size-msec:

default-sample-channels = 2
high-priority = yes
default-fragments = 8
default-fragment-size-msec = 25

It seems to work fine with me.

Ps: Do not forget to kill pulseaudio
#pulseaudio -k
Then relaunch it
#pulseaudio -D

See you!

Daniel T Chen (crimsun) wrote :

On Fri, 17 Apr 2009, Iriiko wrote:

> File "default.pa" (in ~/.pulse usually), add "tsched=0" to the modules
> module-alsa-sink and module-hal-detect (at least, to module-hal-detect):

Default jaunty already ships with tsched=0. That parameter is passed to
module-alsa-sink and module-alsa-source from module-hal-detect.

> default-fragments = 8
> default-fragment-size-msec = 25

Changing to these values will not work across all codecs and controllers.

> Ps: Do not forget to kill pulseaudio
> #pulseaudio -k
> Then relaunch it
> #pulseaudio -D

The proper way is to use `start-pulseaudio-x11'.

Montblanc (montblanc) wrote :

I upgraded to Jaunty, today, and got choppy sound from pulseaudio (0.9.14-0ubuntu20). I added Luke Yelavich's PPA to my sources.list to upgrade it to 0.9.15-0ubuntu1~ppa4 and now I've got choppy *and* crackling sound. The tsched=0 workaround didn't work for me. I've got a Creative Sound Blaster X-Fi Platinum; here's my lspci -v:

02:11.0 Multimedia audio controller: Creative Labs SB X-Fi
        Subsystem: Creative Labs Device 0023
        Flags: bus master, medium devsel, latency 64, IRQ 18
        I/O ports at e800 [size=32]
        Memory at cee00000 (64-bit, non-prefetchable) [size=2M]
        Memory at c8000000 (64-bit, non-prefetchable) [size=64M]
        Capabilities: <access denied>
        Kernel driver in use: CTALSA
        Kernel modules: ctxfi

Iriiko (aderach) wrote :

Hi!

Since the 0.9.15, I had to reduce the number of fragment in alsa-sink but keeping tshed=0 (alsa crash if =1):
   load-module module-alsa-sink device=hw:0,0 sink_name=alsa_out fragments=8 fragment_size=2048 tsched=0

But, I did not put tshed=0 on hal detect:
   load-module module-hal-detect

Do not forget to use now the default.pa of the 0.9.15 version: If you used ~/.pulse/default.pa, replace its contents by the file in /etc/pulse because there are few changes.

See u.

Montblanc (montblanc) wrote :

Thanks for your hints, Iriiko.
I tried applying the changes to alsa-sink, but not so much has
changed. I guess I'm turning back to alsa, hoping next pulseaudio
release will fix this annoying issue.

2009/4/24 Iriiko <email address hidden>:
> Hi!
>
> Since the 0.9.15, I had to reduce the number of fragment in alsa-sink but keeping tshed=0 (alsa crash if =1):
>   load-module module-alsa-sink device=hw:0,0 sink_name=alsa_out fragments=8 fragment_size=2048 tsched=0
>
> But, I did not put tshed=0 on hal detect:
>   load-module module-hal-detect
>
> Do not forget to use now the default.pa of the 0.9.15 version: If you
> used ~/.pulse/default.pa, replace its contents by the file in /etc/pulse
> because there are few changes.
>
> See u.
>
> --
> Crackling noise after update to pulseaudio
> https://bugs.launchpad.net/bugs/301755
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Iriiko (aderach) wrote :

Why there is my mail on your reply??

I use only pulse because of the equalizer, and the fact that you can control each program volume.

Montblanc (montblanc) wrote :

Yeah, it's the same to me.
P.S.: Maybe it's because I'm replying from gmail?

2009/4/25 Iriiko <email address hidden>:
> Why there is my mail on your reply??
>
> I use only pulse because of the equalizer, and the fact that you can
> control each program volume.
>
> --
> Crackling noise after update to pulseaudio
> https://bugs.launchpad.net/bugs/301755
> You received this bug notification because you are a direct subscriber
> of the bug.
>

bordaigorl (bordaigorl+lpbug) wrote :

I have the same crackling sound since I upgraded from Ubuntu Intrepid to Jaunty.
I have a Realtek ALC861 sound card which worked fine in Intrepid after some tweaking.

Now I can play sounds without problems but there is a periodic crackling noise (every 60 sec) that comes with a small cpu load (5%) caused by ath5k_pci....disabling the wireless from NetworkManager made the noise disappear.

Any fix?

Daniel T Chen (crimsun) wrote :

Has anyone besides Ara actually tested the appropriate updated kernel at http://kernel.ubuntu.com/~dtchen/ ?

There are at least two issues at play for these symptoms. You need to be testing the above kernel, and you need to be running stock jaunty PulseAudio. Most importantly, we need to know which codec you have. You can provide this information via "apport-collect -p alsa-base 301755", or you can download and run http://www.alsa-project.org/alsa-info.sh as a bash script.

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rincewind 4794 F.... mixer_applet2
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xd7000000 irq 18'
   Mixer name : 'Realtek ALC861-VD'
   Components : 'HDA:10ec0862,103c30bf,00100001 HDA:10573055,103c30bf,00100700'
   Controls : 22
   Simple ctrls : 13
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev users video

Jens (jeeloo) wrote :
62 comments hidden view all 140 comments

Just thought I should add that I had the same problem with crackling sound and high CPU usage by pulseaudio after update to jaunty, until I removed the tsched=0 line which fixed the problem.

My soundcard is a Via VT1708/A in an MSI laptop.

Let me know if you would like any more info about my system to help understand what was the problem.

ag3r (ag3r) wrote :

Hello, i`m having troubles with my Fatality X-fi like another person here

 "Ara Pulido says :
I was listening to MP3 audio with rhythmbox. When pidgin generated an event (a buddy logged in), I got the noise :-("

I got the crackling noise only when emesene generate an event (a buddy logs in & out or something like that) and i'm listening to mp3's with rythmbox, there's no cracling sounds when i play stream video/audio with firefox or something like that.

I own an Abit's motherboard that has the same chipset as She, a Nvidia CK804.

ls pci -v

05:0a.0 Multimedia audio controller: Creative Labs SB X-Fi
 Subsystem: Creative Labs Device 0023
 Flags: bus master, medium devsel, latency 32, IRQ 18
 I/O ports at 9800 [size=32]
 Memory at dfc00000 (64-bit, non-prefetchable) [size=2M]
 Memory at d8000000 (64-bit, non-prefetchable) [size=64M]
 Capabilities: <access denied>
 Kernel driver in use: CTALSA
 Kernel modules: ctxfi

pd: please help, sorry for my english i'm from spain :D

ag3r, I actually gave up on pulseaudio but I'm aware many people tried
different settings and got it working. In fact, it's a matter of
settings. I'll give it some tries when I'll have some spare time and
hope we'll have our X-Fi working soon with pulse! :P

I resolved the issue by adding the ppa for the most recent release then:

apt-get remove pulseaudio

rm -rf /etc/pulse*

rm ~/.pulse*

apt-get install pulseaudio ubuntu-desktop

2009/6/3 TotoKid <email address hidden>

> ag3r, I actually gave up on pulseaudio but I'm aware many people tried
> different settings and got it working. In fact, it's a matter of
> settings. I'll give it some tries when I'll have some spare time and
> hope we'll have our X-Fi working soon with pulse! :P
>
> --
> Crackling noise after update to pulseaudio
> https://bugs.launchpad.net/bugs/301755
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Montblanc (montblanc) wrote :

Ok, it seems Iiriko's workaround worked for my X-Fi. The only thing I had to do before reinstalling pulseaudio and applying the fixes was removing pulse folders:

sudo rm -rf /etc/pulse
sudo rm -rf ~/.pulse

The only trouble I have after this is sound in Skype...

$ apt-cache policy pulseaudio:
pulseaudio:
  Installato: 1:0.9.15-1ubuntu2~ppa1
  Candidato: 1:0.9.15-1ubuntu2~ppa1
  Tabella versione:
 *** 1:0.9.15-1ubuntu2~ppa1 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status
     1:0.9.14-0ubuntu20.1 0
        500 http://it.archive.ubuntu.com jaunty-proposed/main Packages
     1:0.9.14-0ubuntu20 0
        500 http://it.archive.ubuntu.com jaunty/main Packages

Montblanc (montblanc) wrote :

I mean I had to set it to CreativeX-Fi instead of pulse, I assume it's the same thing with Farsight options in aMSN.
I'm extremely sorry for double-commenting. Hope my info helps.

Montblanc (montblanc) wrote :

I'm ashamed, I spoke too early. A reboot brought back crackling and/or choppy sound, I give up (again). :( I really hope a decent xfi driver will be released soon.

Montblanc (montblanc) wrote :

Coming again with good news: I finally made my Sound Blaster Creative X-Fi work fine with pulseaudio! Here are all steps:
1) Install latest dtchen's test kernel (2.6.28-13-generic #44~lp345627~crimsun1, at the moment) from here: http://kernel.ubuntu.com/~dtchen/
2) Add Luke Yelavich's PPA is in your /etc/apt/sources.list:

deb http://ppa.launchpad.net/themuso/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/themuso/ppa/ubuntu jaunty main

3) Obviously compile the crappy xfi drivers against the new kernel -.-
4) Purge pulseaudio from system:

sudo apt-get purge pulseaudio
sudo rm -rf /etc/pulse
rm -rf ~.pulse

5) Reinstall pulseaudio, you should now get v0.9.15-1ubuntu2~ppa1:

sudo apt-get install pulseaudio

6) *KDE ONLY* Add your user to pulseaudio groups (replace myusername with your user):

sudo adduser myusername pulse-access
sudo adduser myusername pulse-rt

7) *KDE ONLY* Let pulseaudio run at startup:

cp /usr/bin/pulse-session ~/.kde/env/pulse-session.sh

then edit /etc/default/pulseaudio so that its variables should look like these:

PULSEAUDIO_SYSTEM_START=1
DISALLOW_MODULE_LOADING=0

8) Edit /etc/pulse/daemon.conf either uncommenting and/or modifying these values:

high-priority = yes
nice-level = -15
realtime-scheduling = yes
realtime-priority = 5
default-fragments = 7
default-fragment-size-msec = 3
resample-method = speex-float-10

You may need different values according to your system, but remember it will suck more CPU (I'm using an Athlon64-X2 4200+, and both me and top don't notice any difference, anyway ;) )

9) Tell your system and your apps such as skype to use pulseaudio.
10) Reboot!
11) Forgive me for spamming your inbox! :P

Luke Yelavich (themuso) on 2009-06-17
Changed in pulseaudio (Ubuntu):
assignee: Luke Yelavich (themuso) → nobody

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dmy 4644 F.... mixer_applet2
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xffe00000 irq 2300'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,14620110,00100101'
   Controls : 31
   Simple ctrls : 17
DistroRelease: Ubuntu 9.04
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
Uname: Linux 2.6.28-13-generic i686
UserGroups: adm admin cdrom dialout disk lpadmin plugdev sambashare vboxusers

9 comments hidden view all 140 comments
Daniel T Chen (crimsun) wrote :

This symptom should be resolved in karmic when rtkit is usabled (waiting on merge of FIFO linux patch). In the meantime, one can modify /etc/security/limits.conf (add the rt-relevant bits; see the ubuntu studio site).

Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Committed
Florian Schweikert (kelvan) wrote :

I've similar problem with karmic when streaming over network.
Sometimes it works, if there is no other sound playing on server.

Dave V (mindkeep) wrote :

I understand a fix seems to already be in the works, and maybe I'll try again when Karmic is released, but I wanted to add that when getting this crackling, pulseaudio cpu usage goes through the roof (a detail I didn't see mentioned).
On my eeepc 900, playing openarena, pulse audio would occassionally spike to ~50% cpu utilization and would cause the crackling to occur. Obviously, thee eeepc has limited resources, but I would experience similar (maybe even worse) problems on my Dual AMD64 6000+ box. "sudo apt-get remove -purge pulseaudio" is a much easier fix than any of the above hacks IMHO. Unfortunately this removes ubuntu-desktop also, but well... oh well.

On Wed, 2009-09-16 at 18:05 +0000, mindkeep wrote:

> Unfortunately this removes ubuntu-desktop also, but well... oh well.
>

Thats just a metapackage.

Dave V (mindkeep) wrote :

I think the important bit is that "/etc/X11/Xsession.d/70pulseaudio" is removed and hence pulseaudio is not started with the session. However, I think I also tried to rm this file (without removing the package) and found pulseaudio running again.

"sudo apt-get remove -purge pulseaudio" will remove "/etc/X11/Xsession.d/70pulseaudio". "sudo apt-get remove pulseaudio" will not. My knowledge of apt is sketchy at best (I'm an ex-gentoo user), so I'm not exactly sure where to look to truly figure out what else apt is doing.

Jason Tackaberry (tack) wrote :

linux-image-2.6.28.15.20 and pulseaudio-1:0.9.14-0ubuntu20.2 here, with the crackling audio (on a Thinkpad T61p).

The fix that seemed to work for me -- and in fact the only one needed at all -- was Jonathan's suggestion of adding the position_fix=1 option to snd_hda_intel.

Vladislav Muravyev (rex-lux) wrote :

Also seemed to work for me. Audio device according to lspci is:
01:00.1 Audio device: ATI Technologies Inc R700 Audio Device [Radeon HD 4000 Series]
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

Tom Vijlbrief (tvijlbrief) wrote :

My samsung NC20 after upgrade from 9.04 to 9.10 beta had the same problem (booting 9.10beta from a life USB-stick was ok).

I removed all the .pulse* files from my home directory and sound was fully ok after a reboot...

Kimiko Koopman (kimiko) wrote :

Any version of Pulseaudio after 0.9.15-4ubuntu3 (i.e. 0.9.16 and above) has this problem for me. Regular desktop sounds are about half-half crackly noise, and MPlayer doesn't play proper sound at all. Downgrading back to 0.9.15 solves it.

Karmic's official release is awfully close. You'd better do something about this problem quickly. Pulseaudio is a rather important part of the current desktop.

Mark Falcey (mfalcey) wrote :

I have crackling sound with both Jaunty and Karmic but only in my usb headset and only when the pulseaudio volume control is not active. If i have the pulseaudio volume control active or even minimized the crackling goes away. When I close it the crackling comes back gradually over about 10 seconds. This does not effect either my hda-intel on board sound chip or my c-media pci card.

The gnome volume control has no effect at all on this problem in either Jaunty or Karmic.

It seems to me that opening the pulseaudio volume control changes the scheduling parameter or something, why would it need to do that?

Daniel T Chen (crimsun) wrote :

@Mark Falcey
Does using PULSE_NO_SIMD=1 help?

jglass (b0arder753) wrote :

Has this been solved?
I'm still experiencing problems. Should I take pulseaudio back to a previous release?

David Henningsson (diwic) wrote :

@jglass: please file a separate bug and include relevant information with this terminal command: "ubuntu-bug -p pulseaudio"

Luisgmarine (luisgmarine) wrote :

Having the same problem on Ubuntu 9.10 (64-bit) using the nVidia Corporation CK804 AC'97 Audio Controller (rev a2). I've spent the last several days looking at this bug report post by post and trying every fix recommended and I'm still getting cracks and pops through my speakers. Do I need to file my own bug report for it, or try to continue monitoring this one and hope that after a year or so it can be fixed?

Daniel T Chen (crimsun) wrote :

On Thu, Jan 7, 2010 at 11:46 PM, Luisgmarine wrote:
> Having the same problem on Ubuntu 9.10 (64-bit) using the nVidia
> Corporation CK804 AC'97 Audio Controller (rev a2). I've spent the last

Spindoctor (m2m) wrote :

I have the same problem in Ubuntu 9.10 (32bit) and my ASUS A7n8x Deluxe. I wanted to try the "/etc/pulse/default.pa"-hack, but "load-module module-hal-detect" is nowhere in this file.

What should I do? Make my own bug-report?

David Henningsson (diwic) wrote :

As a general recommendation, if you have different hardware, the cause of the bugs can be different, so go through the list at https://wiki.ubuntu.com/DebuggingSoundProblems/KarmicCaveats and see if anything applies to your situation. If that doesn't help, file a separate bug using the "ubuntu-bug -p pulseaudio" terminal command. Also, if you have time to check whether it is fixed in the latest development snapshot (i e Lucid, currently), that will be most helpful. Thank you!

Spindoctor (m2m) wrote :
Daniel T Chen (crimsun) wrote :

Resolved in lucid

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
Displaying first 40 and last 40 comments. View all 140 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers